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Chapter 1. Introduction

1. Introduction

nShield® Monitor is a monitoring solution delivered in a virtual appliance
environment. Designed to be both cost-effective and scalable, it delivers the level
of security assurance expected of a Hardware Security Module (HSM) accessory
supporting application.

Users connect to the nShield Monitor server via HTTP(s) using a configured IP
address or through a user-friendly name. This is achieved using a standard web-
browser (Internet Explorer, Chrome or Firefox). nShield Monitor provides a secure,
authenticated connection allowing easy access to all monitored information.

nShield Monitor provides the following features:

e Able to monitor of estates composed of the nShield HSMs and client hosts
* Operates automatically in the background without human involvement

» Alerts users when investigation or intervention may be required

* Provides information relevant to each user based upon role and groups

* nShield Monitor provides the following benefits to an organization:

« Removes the need to pro-actively inspect each device to determine status on
a regular basis

» Suitable to operate in "dark” data centers or in environments where physical
access to devices is not possible

* Rapid and automatic notification of potential security issues

* Ability to respond to device hardware failures. For example, a failed power
power supply unit.

* Notification of unexpected changes to device configurations
* Immediate alerting of device overload

* General reporting of security, configuration, health and utilization of the estate
of devices to support audit requirements

After the initial network setup and installation, the virtualized nShield Monitor
server monitors HSMs and client hosts.

nShield Monitor provides a central repository of all information collected from
your estate of devices and monitors information directly from the HSMs including
device utilization, command information and HSM health. nShield Monitor also
provides alarm and event notification (via syslog, SNMP, and email) as well as
event logging and report generation from predefined templates.
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Chapter 2. Requirements

2. Requirements

2.1. General requirements
nShield Monitor is delivered in the following formats:

* Open Virtual Appliance (OVA)
* Microsoft Hyper-V

Both formats include:

* A 64-bit Linux-based OS
* Open VMware Tools (OVT)

By default, OVT service is DISABLED. A system administrator
0 can choose to ENABLE OVT from the CLI. For details, refer to
Service Commands.

2.1.1. Hypervisor compatibility
The OVA can be installed on the following virtual platforms:

* vSphere ESXi 6.0

* vSphere ESXi 6.5

* VMware Workstation 12
* VMware Workstation 14
* VMware Fusion 10

* Oracle VirtualBox 6.0

The Hyper-V image can be installed on the following virtual platforms:

e Microsoft Hyper-V

e Microsoft Azure

2.1.2. Server requirements

* Must support 64 bit OS
e CPU: 2 cores of 2.0GHz multicore CPU (can be increased as needed)

* Memory: 8GB dedicated memory for nShield Monitor (can be increased)
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* Network: Single network attached interface to bridged or physical network
Size on disk:

» Thin provisioned: 2.3 GB (OVA) / 3.3 GB (Hyper-V)
e Thick provisioned: 326.0 GB (OVA)

2.1.3. nShield compatibility

nShield Monitor is compatible with the following nShield HSM models and
software versions:

* nShield Edge, Solo+, Solo XC, Connect+, and Connect XC
* Security World software v12.40 and higher

2.2. Centralized monitoring

When monitoring an estate of HSMs (that is, more than one HSM), reduce data
duplication by keeping your data in as few places as possible.

Multiple instances of your data may be required due to your
organization’s external requirements. For example, due to
regulatory issues.

2.3. Client workstation

The client workstation is any Apple or Microsoft Windows workstation that has
network connections to nShield Monitor. A supported browser (WebUI access) or
SSH client (CLI access) that can access nShield Monitor is required.

The client workstation can perform various configuration, administrative tasks or
group management tasks based upon defined roles.

2.4. Role based access

nShield Monitor supports role-based access.

Each nShield Monitor user role is associated with a predefined set of tasks. This
ensures that a user with a specific role can perform only those tasks that are
allowed by that role. For example, if a user is assigned the role of group manager,
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the user cannot perform administrative tasks, such as creating users. Role-based
access adds a level of security to the configuration and administration of nShield
Monitor.

The following credential schemes are supported:

* nShield Monitor’s own credential scheme, see Creating Users.

* Active Directory credentials, see Active Directory authentication.

Active Directory authentication is set up by mapping Active Directory groups
to nShield Monitor roles.

For users whose credentials were imported from Active
Directory, Configuration > Security shows their own credentials
o in and for nShield Monitor. Changes made to passwords in
nShield Monitor are not ported back automatically to the Active
Directory server.

Users who are Active Directory administrators have no access or
o visibility to the credentials of other Active Directory users
through Configuration > Security.

2.4.1. User roles
The nShield Monitor role based administration model has the following role type:

e Auditor
e Administrator

* Group Manager

Users can be assigned to more that one role. For example, a user could be both
am Administration and as a Group Manager. This user is then able to perform tasks
related to both an the administrator role and a group manager role.

For example, you could create users with the following combinations of
permissions:

* User #1: administrator and group permissions
e User #2: auditor only

e User #3: group manager only

The nShield Monitor Ul is role sensitive, and the pages displayed are dependent
upon the role of the user.
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2.41.1. Auditor

Auditors have complete visibility into nShield Monitor; however, they cannot
modify any setting in nShield Monitor or on the HSMs.

o ‘ Auditors cannot be Administrators or Group Managers.

The auditor role is for visibility purposes.

2.4.1.2. Administrator

Administrators are required to have sufficient knowledge of

o networks, various operating systems, and general system
administration tasks such as configuring IP addresses, backing
up systems, and using the console interface.

The Administrator is responsible for:

* User management, including creating new users, and deleting users who do
not have any roles assigned to them

* Assigning administrator or group manager roles to users
* Network configuration

» System configuration

* Upgrading the system

* License management

» Security configuration

* Group management

* Event notification (syslog, SNMP and email) management

* Enabling the Open VMware Tools Service

2.4.1.3. Group Manager
Group Managers are required to have sufficient knowledge and understanding of:

* The importance of the data and devices that they manage
» Corporate policies with respect to data dissemination

» Corporate policies with respect to problem resolution

The Group manager is responsible for monitoring and understanding the
following:
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* The command instruction usage

* HSM utilization

* HSM health

e Event triggers in assigned groups

 Event logging and report generation in assigned groups

e Configuring event notification via email in assigned group

2.5. Accessing the User Guide

Online Help is available to all user role types.

o While Online Help is enabled, you cannot perform any actions on
the GUI.

1. Log on as Administrator, Group Manager, or Auditor.

2. Locate the toggle switch in the upper right corner of the screen.

auditor | System Auditor ), Jan 11,2017 20:37 @

% Log Cut

3. Slide the toggle switch to the right.
Online Help is enabled.

Fields surrounded by a colored box contain help.

auditon | System Auditor ). Jan 11, 2017 2040 @

. Log Cut

4. Click a field to open the help text pop-up window. For example:
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I:::dminl [ Systermn Administr

User Profile

A description of the user roles assigned
to you is provided in parenthesis next
to your user name. Clicking your
usemame opens the profile information
page. You can edit the following
settings on this page:

- name

- description

- email

- password

- auto-logout duration by moving

the slider

Save or Cancel your changes.
You can change the date and time
formatting from the options in the drop-
down list:
= MNone (default): if you do not
select a format the default is
used: Month, DD, YYYY, HH:MM
= UTC
Month/Day/Year
Day/Month/Year
Custom: you can enter a custom
format in the text box provided,
use the example as a reference

L]

L]
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3. License Installation

3.1. Overview

nShield Monitor is shipped with an evaluation license. This license allows for the
Virtual Appliance to enroll and monitor up to eight devices for up to 30 days.
After 30 days,the product automatically stops device monitoring and restricts user
access to the administrator role only.

There are multiple license options available.

Contact Entrust Sales/Sales Support for prices and availability.
Please have the serial number of the deployed nShield Monitor
o available in order to obtain a license. The serial number can be
found on the dashboard page under the nShield Monitor Status
tab.

nShield Monitor Status ~

R
[ Serial Number : Tkig 7y 1P n7 5Y 9x 8X-c M LX O9 Iz yvD Ly FY
Software version : 2.5.4 (build 002%) ’
License : Evaluation, Remaining Days: 27
System Uptime : 20 hours, 27 minutes
Disk Space Used : 2%
Services ! OK, running 18 of 18

3.2. Installing a license

1. Download the license, provided by Entrust, to the local machine that is
currently being used to access the nShield Monitor WebUI.

Log in as an Administrator.

Navigate to: Configuration > License
Click Choose File.

Browse to the license file.

Click Open.

N O g A~ NN

Click Install License.
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Chapter 3. License Installation

The license installs and details are viewable under the Current License(s) tab:

Current License(s)

Licenze Category Licenze Type Max No. of Devices Purchasze Order
Standard Device 200 5009
o In addition to choosing the file, it is also possible to copy
and paste the license code directly into the text box.

The Virtual Appliance is now ready to enroll and monitor devices up to the
quantity of devices licensed.

Monitor v2.9.7 Install and User Guide
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4. Setup Wizard

4. Overview

nShield Monitor is delivered as an Open Virtual Appliance, OVA, format. The OVA
includes a 64 bit Linux based OS. The nShield Monitor system can be accessed
with a web browser.

Supported web browsers include:

* Firefox (Version 44 or higher)
* Internet Explorer (Version 11 or higher)

e Chrome (v 55.0)

4.2. Wizard

The initial setup of nShield Monitor upon first boot and login is done via a setup
wizard. This setup wizard can be run both from the WebUI or the Command Line
Interface (CLI). It is recommended that you use the WebUI Setup Wizard for initial
setup of nShield Monitor.

o ‘ See nShield CLI Commands for details on how to setup using the
CLI.

1. Access the Virtual Appliance from your Internet browser, go to:

https://XXX. XXX. XXX. XXX

(Use the IP address assigned in the CLI during the installation process.)

2. If the password was not changed during an initial OVA installation via the CLI:
o Enter the default admin username and password.
o Enter a new password.

3. Click Change Password.

Once your password has changed (either using the CLI or the WebUI), the nShield
Monitor Setup Wizard loads.

o ‘ The Wizard prompts you through each tab.
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1. Click Start.

The EULA page displays In order to continue to setup, you must accept the
terms of the End User license Agreement (EULA) provided with the Virtual
Appliance. If you decline the EULA, you will be automatically logged off.

2. Read through the entire EULA and then select | Accept.
The Email Setup page displays.

3. Enter the email associated with the default user (admin).

4. Enter the email a second time to confirm and then click Next Step.

The Create Administrators page opens.

4.2.1. Creating Administrators

nShield Monitor requires at least two Administrators. During the
setup, the system prompts to create two new Administrators (in
addition to the default administrator which cannot be deleted
0 during setup). The best practice recommendation is to come
back and delete the default administrator, after you have
successfully created your two official administrators, as

described in the procedure below.

1. On the Create Administrators page, enter the User Name (for example,
Adminl) and Email (and confirm email) for each Administrator.

2. Select Next Step.

The Create Administrators page displays:

Create Administrators

User Name : User Nome :

Email Email :

Confirm Email : Confirm Email :

3. Complete the fields and then select Next Step.

The Network Settings page opens:
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« Welcome + EULA « Email o System Administrators Network

Key Generation Date and Time Ready to Sefup

Network Settings

IP Address :

| 10.1.7.124 ‘

Subnet Mask :

| 255.255.248.0 ‘

Gateway :

| 10.1.1.20 ‘

Hostname:

| localhast ‘

Domain {optional} :

Primary DNS (optional) :

Secondary DNS [optional) :

Mail Host [optional) :

[Cnail Host Credenfials (eptional)

4.3. Setting up the network

To use nShield Monitor, you must setup a network.

o Please do not change the following parameters without
assistance from your IT support/infrastructure organization.

* I[P Address

e Subnet

* Gateway

* Hostname

* Domain (optional)

* Primary DNS (optional)

e Secondary DNS (optional)
e Mail Host (optional)
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* Master Key Generation

Mail Host Credentials are optional. Should you select the
o Mail Host Credentials box, a window opens prompting for
Mail Host User Name and Mail Host Password.

1. On the Network Settings page, select Next Step.

The Master Key Generation page opens.

« Welcome « EULA ' Emnail « System Administrators o Network

Key Generafion Date and Time Ready fo Setup

Master Key Generation

Passphrase One

Passphrase :

Confirm Passphrase @

Passphrase Two

Passphrase :

Confirm Passphrase @

4.4. Master Key Generation

The master key consists of an AES256 wrapping key and an HMAC-SHA-512 hash
key that is used as the root of protection.

The master key is derived by using the two passphrases, using PBKDF2, that are
input during the wizard configuration after the first boot and after every reboot.

The master key is never stored in persistent storage.

Please note to record each passphrase in a secure location as you will re-enter
them when nShield Monitor reboots.

1. On the Master Key Generation page, enter Passphrase One and Passphrase
Two, and then re-enter both for confirmation.

2. Record both phrases before continuing to the next step.

3. Select Next Step.
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The Date/Time Settings page opens.

+ Key Generation Date and Time Ready to Setup

Date/Time Settings |

NIP Enable  « NIP Disable

Time :

19:42

Date :

02/10/2017

Time Zone :

| |GMT -05:00] Eastern Time (U & Canada) ‘

Next Step

4.5. Date/Time

The Network Time Protocol (NTP) is an Internet standard protocol that
synchronizes computer clock times on your network. NTP servers transmit time to
their client systems.

NTP Disable is the default setting. If you select NTP Enable, a
o new window opens and you are prompted to enter the NTP

Server Address(es). You have the option of entering multiple

servers, as long as you separate the entries with commas.

451. NTP Disabled

1. On the Date/Time Settings page, select NTP Disable.

2. Enter Time, Date and Time Zone.
The default setting is:
GMT Greenwich Mean Time.

3. Select Next Step.
The Ready to Setup page opens.

4. Continue to Ready to Setup.
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45.2. NTP Enabled

If NTP is enabled, you must indicate the NTP server that you want to use in the
NTP Server Address field.

o You can enter multiple servers, as long as you separate them
using commas.

1. On the Date/Time Settings page, use the drop down arrow to open the Time
Zone drop down menu.

2. Select the appropriate Time Zone.

3. Select Next Step.

The Ready to Setup page opens.

4.6. Ready to Setup

1. Select Initialize.

The initialization status page opens and tracks the process. For example:

Inifializing System

Initiglization Task Status Result

Generaling Master key v Iaster key generated an|
Set Default User email address v Email changed CK.
Create user 'adminl’ v User created OK.

Assign System Administrator role to ‘adminl’ v Role assigned QK.
Create user ‘admin2’ v User created OK.

Assign System Administrator role to "admin' v Role assigned OK

Setting Date/Time/NTP/Network values and rebooting [v]

nShield Monitor reboots.

4.7. Log In

1. Enter your User ID and Password.

2. Select Log In.

The Master Key needs to be reloaded every time that nShield Monitor is
rebooted. After rebooting, you are prompted to enter the Master Key
passphrase.
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@ Master key has been generated, but has not been loaded. You must load the
Master key for monitoring operations.

™

3. Select the message to initiate the Master Key load.

The Master Key / SSL Certificate and the User Interface SSL/TLS Options
windows open.

4. Enter Passphrase One and Passphrase Two.

5. Select Load Master Key.

The GUI session disconnects and the a pop-up reports:

Connection to nShield Monitor has been lost.

If you have updated SSL Certificate, change the IP address or Hostname of nShield Monitor.
You will need to open a new browser window to correct address.

Attempting to reconnect.

6. After the system reconnects, log back on to the system.

The system is now ready to use.
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5. Configuration Logged in as
Administrator

5.1. Overview

After setting up nShield Monitor, Administrators can modify the system setup via
the Configuration tab.

o To see the options available to a Group Manager, see
Configuration Logged in as Group Manager.

The Administrator is able to set date and time, events, create groups, update
licenses, configure the network, reboot the system, set up security, perform
upgrades, and set up users.

5.2. First-time setup

In order to begin using nShield Monitor, several steps must be taken. These
include:

* HSM configuration - verifying that the HSMs to be monitored are enabled for
SNMP

* Installing the appropriate nShield Monitor License
* Creating groups and users in the nShield Monitor Virtual Appliance

* Enrolling devices to appropriate groups

e Please note that a device can be assigned to one group or
to many separate groups.

* Open firewall port settings

5.2.1. Configuring the nShield/client host

In order to manage your HSM estate with nShield Monitor, you must perform the
following on each device:

e Enable SNMP and add SNMPv3 users

e Enable the collection of utilization data
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* Set the period over which utilization statistics are to be collected to 60
seconds

» Enable the collection of health check counts
These tasks can be performed via the appropriate commands as follows:

UTILCFG Sets the period over which utilization statistics are
collected. Must be set for 60 seconds.

UTILENABLE Enables the collection of utilization data.

HEALTHENABLE Enables the collection of health check counts.

SNMP Enable provisioning of utilization and health check data
via SNMP.
SNMPADD Adds an SNMP community or user.

5.2.2. Configuring the nShield HSM

For instructions, see the SNMP monitoring agent appendix in the User Guide for
your HSM(s).

5.2.3. Step 1. Create groups

In order to begin monitoring, the first required item is to create groups that will
contain the monitored devices.

o ‘ You must be logged in as an Administrator.

1. Navigate to Configuration > Groups.

2. Select Add New Group.

The Group Setup page opens.

Group Setup

New Group Name :

New Group Description (optional) :

Cancel Changes
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3. Enter the New Group Name along with an optional description.

4, Select Create Group.

It is a best practice to never create more groups than the

0 number required to manage the number of devices that you
have.
o ‘ nShield Monitor can support up to 32 groups.

5.2.4. Step 2: Configure the Group Manager role

Once you have created your groups, you will need to configure one or more users
with the Group Manager role.

0 This procedure also includes how to associate a Group Manager
with a group.

1. Navigate to: Configuration > Users.
The Manage Users page opens.
2. Select Create User.
The Create a New User page opens.
3. Enter the new user data.

e You select the Auto-Logout Duration by sliding the circle to
the right to increase the length of time.

Auto-Logout Duration :

5 minutes

5 mirm\ 60 minutes

4. Complete the open fields appropriately and under Assign Role(s) for this
User, select Group Manager.

The Assign User to Groups window opens.

5. Associate the user to groups by selecting the group name (for example,
Group 1).

6. When clicking on a Group name in the Available groups list, the group name
moves to the Member of list.
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7. Select Create User.
The User is created.

The one-time password is displayed on the screen and is emailed to the user.

5.2.5. Step 3: Group Manager enroll managed entities to groups

The Group Manager can add devices (that is, enroll entities) to be monitored into
the groups. See Configuration Logged in as Group Manager.

A Group Manager can be configured to access one group, a subset of all the
groups or all of the groups in nShield Monitor.

Based on your current environment, the persons responsible for the day to day
operations of the monitored devices are usually the appropriate persons to assign

to this role.
It is possible to assign a user to both Administrator and Group
Manager roles. In doing so, operations and functions of both user
o roles can be performed. You should refer to your organization’s
policy on whether a user with multiple roles is allowed to exist
within your security management system.

5.3. Edit Profile page

The Edit Profile page is accessed by selecting your User ID located in the top right
corner of the page. For example:

l adminl{ System Administrator ), Jan 8, 2018 11:24:10 (GMT-10:00] @

. Log Out

From this page, you can perform the following actions:

» Add a description

* Update the email address

Change the password

Set the Auto-Log duration

e Select a custom date format

When you select a custom date format, the chosen format is associated with your
user ID giving each user the option of selecting their preferred format. Once the
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format has been selected, it is consistently displayed in accordance with your
selection.

The only date format that will not change is the date in the User ID line, as shown
below:

admin { System Administrator ]{Jcm 8, 2018 11:24:10 (GMT -10:00] I9
. Log Qut

o You can select Use Browser Timezone for Exporting Events,
based on your preference.

nShield Monitor keeps track of things such as table column sort
e order, which sections of a page are collapsed/expanded, chart
settings, and so on, as part of your GUI Persistence Profile.

To restore Custom Date/Time Format settings to the default, select the admin’s
GUI Persistence Profile tab, and then the Reset to GUI Default option.

5.3.1. Changing your password and email and set the auto-logout
duration

1. Click on the <user name> on the upper right hand corner of main screen (for
example, click on admin).

admin]( System Administrator |, Jan 8, 2018 11:24:10 [GMT-10:00) @

. Log Out

The Edit Profile window displays:
2. To change the password:

Enter the old password in the Change Password field. As you type, the system
will prompt.

As prompted, enter the new password once, and then again, to confirm.
3. To change your email:

Enter the new email in the Email field.
4. The Auto-Logout Duration is set to 60 seconds by default.

Use the slide to adjust this setting.
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5. Select Save User.

5.3.2. Formatting the admin date and time

1. Select the Custom Date/Time Format drop down arrow.

admin's Date/Time Formatting :

Custom Date/Time Format :

MNone (default) l

| yyyy-MM-ddTHH:mm:ss.ss57

[ Example: )

[ Use Browser Timezone for Exporting Events

Save Date Format setting

The drop down menu opens.

2. Select your preferred format.

3. Select Use Browser Timezone for Exporting Events to export logs/alarms
using the same Date/Time format as that displayed on the web page.

Date/Time on all web pages display in the format configured in the User
Profile.

By default, exported logs/alarms show Date/Time in GMT format.

4. Select Save Date Format setting.

5.3.3. Resetting the admin GUI persistence profile

nShield Monitor keeps track of things like table column sort order, which sections
of a page are collapsed/expanded, and chart settings, and so on.

nShield Monitor also provides you with the means to reset Custom Date/Time
Format settings for your profile.

Selecting the Reset to Factory Default option does not affect
nShield Monitor Configuration settings, but it does reset Custom
Date/Time Format settings in your profile.

To return to the default for the Date/Time format:
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* Select Reset to GUI Default.
A confirmation message appears.

For more information, see Managed entities.

5.4. Configuration tab tasks

The nShield Monitor main menu page contains a Configuration tab. This tab
provides quick links to individual pages. The following sections provide a brief
discussion of actions available via the quick links.

For display purposes, the parameters displayed in this section

e are those found on the Configuration tab for the Administrator
user type.

5.4.1. Active Directory authentication

Active Directory authentication is set up by mapping Active Directory groups to
nShield Monitor roles.

Features of the integration between Active Directory and nShield Monitor:

* Auto-logout is set to five minutes for Active Directory users. This setting
cannot be modified.

Active Directory users under the nSMUsers hierarchy are tagged to nSMGroups.

By default, three roles exist in nSMGroups. These roles map directly to the
nShield Monitor user roles:

Active Directory nShield Monitor

nSMAdministrator Administrator
nSMGroup Group Manager
nSMAuditor Auditor

* The content of the mail field of Active Directory user profiles must be
populated. nShield Monitor does not use the field. However, if it is empty when
the user is imported from Active Directory to nShield Monitor, the user will not
be able to log into nShield Monitor with their AD credentials.

* |f a new user is created in the nSMUsers hierarchy in Active Directory, the user
must log in to the Active Directory domain first, before being able to use the

Monitor v2.9.7 Install and User Guide 23/205



Chapter 5. Configuration Logged in as Administrator

Active Directory credentials in nShield Monitor.

* When Active Directory authentication is enabled in nShield Monitor, user
management is fully switched over to Active Directory:

- nShield Monitor generated credentials, that is, non Active Directory
credentials, cannot be used.

o User creation and user editing is disabled in nShield Monitor.

o Passwords cannot be updated from nShield Monitor. Passwords must be
updated in Active Directory and the Forget password link is disabled in
the nShield Monitor UI.

5.4.1.1. Configuring Credentials for Active Directory
To configure credentials for Active Directory:

1. Login as Administrator.
2. Navigate to: Configuration > Active Directory > Credentials Settings.

3. On the Credentials settings tab, enter the following details:
Host or IP The hostname or IP address of the AD server.

Port The port on the AD server. Typically, port 389 is used
for LDAP connections, and port 636 is used for
secure LDAP.

Base DN The point from where a server will search for users.
For example: dc=ivqqg,dc=com.

Username The AD Administrator Bind DN. This enables the
LDAP connection to gain access into the Active
Directory. For example: nSMserv.

Password The credentials to use with AD Administrator Bind
DN.

AD Domain Name The name of the AD domain. For example: ivgg.com.

4. If a secure LDAP connection is required:
a. Select Use Secure LDAP.

b. Ensure that a secure Port is selected. Typically, for secure LDAP
connections, port 636 is used.

c. Under Choose certificate file, click Choose file and select the required
certificate file.
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Alternatively, paste the certificate text (in PEM format) into the window
below the button. A valid AD Server Certificate starts with ----- BEGIN
CERTIFICATE----- and ends with ----- END CERTIFICATE----- :

d. Under Choose key file, click Choose file and select the required key file.

Alternatively, paste the key (in PEM format) into the window below the
button. A valid valid AD Server Key starts with ----- BEGIN PRIVATE
KEY----- and ends with ----- END PRIVATE KEY----- .

5. Select Save.

A confirmation message appears.

5.4.1.2. Enable Active Directory authentication

1. Navigate to: Configuration > Active Directory > Enable AD Authentication.
2. Select Use AD for Authentication, then select Save.

3. Confirm the change.

The nShield Monitor Ul restarts and Active Directory credentials can now be used
for authentication.

5.4.1.3. Disable Active Directory authentication
To switch back to nShield Monitor’s own authentication scheme:

1. Navigate to: Configuration > Active Directory > Enable AD Authentication.
2. Clear Use AD for Authentication, then select Save.

3. Confirm the change.

The nShield Monitor Ul restarts and Active Directory credentials cannot be used
for authentication. The nShield Monitor user management scheme is restored,
including the ability to create, update, or delete users in nShield Monitor.

5.4.2. Date/Time

Navigate to: Configuration > Date/Time.

The Date/Time Settings window opens.

5.4.2.1. Date/Time - NTP Disabled
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Most operating systems, including Windows, OS X, Linux, have an option to
automatically synchronize the system clock periodically using a network time
protocol (NTP) server. With nShield Monitor, you can toggle this option between
disabled (off) and enabled (on).

This allows either manual configuration or setting up an NTP server to adjust time
as needed.

1. Select NTP Disabled.

2. Enter data appropriately and select your Time Zone from the drop down
menu.

0 The default Time Zone on nShield Monitor is GMT. Change it
appropriately to match your organization’s Time Zone.

3. Select Save.

5.4.2.2. Date/Time - NTP Enabled

o ‘ Changing date, time, or NTP options will reboot nShield Monitor.

If NTP is enabled, you must indicate the NTP server that you want to use in the
NTP Server Address field.

You can enter multiple servers, as long as you separate them using commas.

1. Select NTP Enabled.
2. Enter the NTP Server Addresses (separated by commas).

3. Select the Time Zone drop down arrow to open your selections.

e When NTP is enabled, the time and date field are already
populated. You are not able to change them.

The default setting is;: GMT Greenwich Mean Time.
4, Select your time zone.
The system prompts for confirmation:

o ‘ Changing date, time or NTP options will reboot nShield Monitor.

1. Select Save.
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5.4.3. Events
nShield Monitor provides the capability for event notification via:

» Syslog
* SNMP and SNMP trap receiver

 Email

o ‘ nShield Monitor can support up to 5 Syslog/SNMP servers at a
time.

Navigate to: Configuration > Events.

The Event Management page opens.

Event Management

« Syslog  SNMP  Email

Add Syslog Server

Host or IP Port
Notification Policy: Remote Syslog
Policy Category Info Nofification Warning Error  Critical Alert Emergency
Monitor-Specific Security Events O | Od O [} [l ™
Device-Group Specific Events O O O O O O [
Monitor-Specific General Events O O O O O O O

Save Settings

5.4.3.1. Adding a syslog server

=Y

Navigate to: Configuration > Events > Syslog.
Click Add Syslog Server.

Enter the Host or IP of the syslog server.
Enter the Port number.

Click Save new Server.

o A NN

Once the Syslog Server is configured, select the policy category and severity
combination that you would like reported to the Syslog Server.

7. Select Save Settings.

5.4.3.2. Deleting a syslog server
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1. Select the check box next to the HP or IP address of the Syslog server to be
deleted.

The Delete Server(s) tab activates.
2. Select Delete Server(s).
A confirmation page opens.

3. Select Confirm Delete.

5.4.3.3. Download MIBs

1. Navigate to: Configuration > Events > SNMP.
2. Select Download MIBs.

The system prompts with the option to Open, Save, or Cancel.

3. Select your preference.

5.4.3.4. Support for nCSNMP traps

The nShield Monitor user interface provides event notifications for supported
nCipher SNMP (nCSNMP) traps on the Dashboard, Logs, and Alarms pages.

» Policies can be set about the notification level, for example warning or
emergency, for SNMP traps in general. These policies are managed by
Administrators, Assign Notification Policies for SNMP.

* Group Managers can associate these notification policies with device groups
and trap groups:

o Assign SNMP Notification Policies for Groups.
- Assign SNMP Notification Policies for Trap Groups.

The following SNMP traps are supported:

Trap ID Name Severity Trigger Event
hardserverAlert Hard Server ERROR The nShield host-side
Failure module control software
failed
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Trap ID

hardserverUnAlert

moduleAlert

moduleUnAlert

psuAlert

psuUnAlert

fanfailureAlert

fanfailureUnAlert

memoryUsageHighAlert

memoryUsageOkAlert

5.4.3.4.1. Assign Notification Policies for SNMP

Name

Hard Server
Restart

Module Failure

Module Restart

PSU Failure

PSU Restart

Fan Failure

Fan Restart

Memory Usage

High

Memory Usage
Normal

1. Sign in as Administrator.

Severity

NOTIFICATION

ERROR

NOTIFICATION

ERROR

NOTIFICATION

ERROR

NOTIFICATION

ERROR

NOTIFICATION

2. Navigate to: Configuration > Events > SNMP.

3. Select your preferences for the Policy Categories.

Trigger Event

The nShield host-side
module control software
restarted after a previous
failure event.

The nShield hardware
failed.

The nShield hardware
restarted after a previous
failure event.

The power supply to an
nShield Connect failed.

The power supply to an
nShield Connect is now
operational, after a
previous failure event.

The speed of an individual
fan on the nShield
Connect is zero.

Fan speed is now non-
zero, after a previous
failure event.

The HSM memory usage
high threshold has been
reached.

The memory usage is
below the HSM memory
usage ok threshold.
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Notification Policy: SNMP

Category

Monitor- O O O O
Ipecific
Security Events

Device-Group | [ O O O
Specific Events

Monitor- O 0O O O
Jpecific

General

Events

Policy Info  Mofification  Warning Emor  Critical

O

d O

Alert Emergency

4. Select Save Settings.

5.4.3.4.2. Assign SNMP Trap Settings

1. Log in as Administrator.

devices.

2. Navigate to: Configuration > Events > SNMP.

The settings need to match the SNMP trap settings on the

3. Select the SNMP TRAP Enabled box. The SNMP Trap Setting page opens.
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SNMP TRAP Receiver v2/v3 Credentials Settings

SNMF TRAF Enabled:

Usermname :
Please enter a valid SNMP TRAP user name. Mininum & and
maximum 32 characters, no special characters are allowed.

Authentication Algorithm :

Authentication Password :

Privacy Algorithm :
AE3-256 v

Privacy Fossword :

SMMPY2 TRAP Enabled: [

4, Populate the following data fields: Username, Authentication Password, and
Privacy Password.

5. Select your Authentication Algorithm from the list.

6. Select your Privacy Algorithm from the list.

o ‘ Client Hosts only support AES.

7. By default, SNMP traps are supported only for SNMP v3. Therefore, option
SNMPv2 Enabled is not enabled by default.

8. Select Save SNMP Trap Settings.

5.4.3.4.3. Configure SNMPV3 traps on the SNMP daemon

trapsess [SNMPCMD_ARGS] HOST defines the configuration for a trap. This is the only
way to define SNMPv3traps. SNMPCMD_ARGS are arguments that would be used for an
equivalent snmptrap command. For example to send a SNMPv3trap as USM user
userl with authentication and encryption, use -v3 -u user1 -1 priv. For example:

trapsess -v3 -u user1 -1 authpriv IP-address:port

To configure SNMPv3 traps on the SNMP daemon:
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1. Navigate to the snmp folder:
a. Linux: /opt/nfast/etc/snmp
b. Windows: c:\program files\nCipher\nfast\etc\snmp
2. Stop the SNMP daemon:
a. Linux: run /etc/init.d/nc_ncsnmpd stop
b. Windows: via Services, the name of the service is nCipher SNMP Agent

3. Add the trapsess to the snmpd.conf file. Replace <userRW>, <userRO>,
<trapreceiver/P>, and port with your values.

trapsess -v3 -u <userRW> -1 authpriv <trapreceiverIP>:<port>
trapsess -v3 -u <userR0O> -1 authNopriv <trapreceiverIP>:<port>

1. Restart the SNMP server:
a. Linux: /etc/init.d/nc_ncsnmpd start

b. Windows: via Services, the name of the service is nCipher SNMP Agent

5.4.3.4.4. Delete SNMP Trap Credentials Settings

1. Navigate to: Configuration > Events > SNMP > SNMP Trap Receiver v2/v3
Credentials Settings.

2. Select Delete SNMP Trap Credentials Settings.

The system response confirms the deletion.

5.4.3.4.5. Add SNMP Trapsink
1. Navigate to: Configuration > Events > SNMP > Add SNMP Trapsink.

Two options are displayed, one for SNMP V2, and one for SNMP V3. By
default, SNMP V2 is selected, and the SNMP V2 settings are shown. To load
the SNMP V3 settings, select SNMP V3.

2. Configure the Trapsink:

For SNMP V2: Enter the Host or IP address of the SNMP device, the port
number (default: 162), and the community.

For SNMP V3: Enter all properties.

3. Select Save new Trapsink.

Monitor v2.9.7 Install and User Guide 32/205



Chapter 5. Configuration Logged in as Administrator

5.4.3.4.6. Delete the SNMP trap

1. Navigate to: Configuration > Events > SNMP
2. Select Delete Trapsink(s).

3. Select the appropriate SNMP trap to delete.
4. Select Save Settings.

5.4.3.5. Request email notification

1. Navigate to: Configuration > Events > Email.
2. Select Email Notification Enabled.
3. Select the Policy Category and severity combination.

4, Select Save Settings.

5.4.4. Groups
Groups can be added, deleted, and sorted.
1. Navigate to: Configuration > Groups.

The Group Management page opens.

Group Management

Add New Group
Q Search:
A Group Name Descripfion Status
Group 1 Unit test Group 1 | Managed by user. Devices enrolled.
Group 2 This is Group 2 Managed by user. Devices enrolled.
Group 3 This is Group 3 Managed by user. Devices enrolled.
Group & Managed by user. Devices enrolled.

5.4.41. Add a new group
1. Select Add New Group.
The Group Setup window opens.

2. Enter a New Group Name and optionally, a description.

3. Select Create Group.
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5.4.4.2. Delete groups
You can only delete a group if its status is empty. That is:

* the group is not managed by another user
* the group does not contain any enrolled devices

* there are no scheduled reports associated with this group.

5.4.5. License

From the License tab, users can:

* View general license data including license count
* Add licenses
* Install licenses

1. Navigate to: Configuration > License.

The System License page opens.

System License

Serial Number: Tkig 7y 1P n7 5Y 9x 8X-kc M LX OP Iz yD Ly Fo
Total Licensed Device Count: 8
Used licensed Device Count: & nShields

Unused Licensed Device Count: Q

Cumrent License(s)

License Type Max Mo. of Devices Remaining Days

evaluation 8 29

5.4.5]1. Add a license
1. Select Choose File.
The file browser window opens.

2. Navigate to the file location and select the file.

3. Select Install License.

5.4.5.2. License warning banner

When the number of enrolled devices exceeds the maximum number of managed
devices, a warning banner displays on the top of the web page.
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The highlighted message instructs you to reduce the number of managed devices.

5.4.6. Mail host

From here you can configure your nShield Monitor’s outgoing email address (that
is, your "from" address) and you can send a test email.

o ‘ A mail host may be required in order to enable email.

1. Navigate to: Configuration > Mail Host.
The Email and Messaging page opens.

Enter your Mail Host.

Enter your Email sender address.

Select Save.

Enter your Email ID for Sending Test Email.

Select Send Test e-mail.

N O g b~ D

Locate the test email in your email In-box.

5.4.7. Network

The base network configuration including IP address, subnet mask and default
gateway can all be changed via the Network Settings page.

Changing any one of these settings requires that you close your
0 browser and reconnect approximately 15 seconds after you save

the new settings. If you change the IP address, you will have to

redirect your web browser to the new IP address or host name.

1. Navigate to: Configuration > Network.

The Network Settings page opens.
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Network Settings

+ DHCP  Static

IP Address : Domain [optional) :

| 10.3.202.202 | | ncipher.com

Subnet Mask: Primary DNS (optional) :

| 255.255.0.0 | | 10.3.110.104

Gateway: Secondary DNS (optional) :
| 10.3.30.254 | |

Hostnarne:

| nshisld-only |

Cancel Changes

2. Select your preference:
a. Dynamic Host Configuration Protocol (DHCP) IP addressing or
b. Static IP addressing

3. Select Save.

5.4.8. Reboot

Users with System Administrator privileges are able to reboot the nShield Monitor
virtual appliance.

1. Navigate to: Configuration > Reboot.
The System Reboot page opens.
2. Select Reboot Now.
The system prompts for confirmation prior to initiating the reboot.

3. Select Yes, reboot now to continue the process.

5.4.9. Security
1. Navigate to: Configuration > Security.

The Security page opens.
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Master key

+ Master key is cumently loaded.

Destroy Master key

SSL Certificate

« View Certificate cen el e Certificate Request Install Signed Cerfificate

Country -

state:

ity :
Company/Organization
Department :

Common Name -

Email -

Country :

state:

Ciry
Company/Organization
Department :

Common Name -

Email -

valid From :

Valid To :

User Interface SSL/TLS Options

Denied Protocols:

EfssLvz

Change Pending Approval:

EssLva
Hrsw
Omnswia
Onswiz

For users whose credentials were imported from Active
Directory, Configuration > Security shows their own credentials
o in and for nShield Monitor. Changes made to passwords in
nShield Monitor are not ported back automatically to the Active
Directory server.

Users who are Active Directory administrators have no access or
o visibility to the credentials of other Active Directory users
through this dialog.

5.4.9.1. Master key

The master key consists of an AES256 wrapping key and an HMAC-SHA-512 hash
key that is used as the root of protection.
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The master key is derived by using the two passphrases using PBKDF2, that are
input during the wizard configuration after the first boot and after every reboot.
The master key is never stored in persistent storage.

Two passphrases are required for generation of the key. Enter be entering each
passphrase twice.

Please note to record each passphrase in a secure location as
0 they are required to be reentered when nShield Monitor is
rebooted.

To destroy a Master Key:

0 The Master Key can only be destroyed if all of the enrolled
devices have been deleted.

1. Select Destroy Master Key.
2. Select Yes, destroy it.

Please note that destroying the master key stops all device
0 monitoring and renders all device credentials invalid. The system
must be reset after this operation.

To generate a new master key, enter the two passphrases as before.

5.4.9.2. View the SSL certificate

By viewing the current SSL certificate, the administrator can determine what type
of certificate is currently installed in the system.

By default, the system installs a self-signed SSL certificate with fixed values for
common name, country state, city, and so on.
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Generate Cerfificate Request

Country : Us
State : CA
City

Company/Crganizafion

Department :

Common Mame :

Errvail -

Issued To

Country - us
State : CA
City :

Company/Crganizafion :

Department :

Common Name :

Email -
Walid From :
Valid To -
As a best practice, it is recommended that at least a new self-
o signed certificate be generated using the appropriate values. The

default SSL certificate is valid for 30 days.

5.4.9.3. Generate a self-signed certificate

With a self-signed certificate, you can customize certificate information by
entering information that applies to your nShield Monitor deployment.

1. Select Generate Self-Signed Certificate.

2. Enter the requested data to complete each field.

o The default value for the field Certificate Validity in Days is
730 (2 years).

3. Select Generate Certificate.

This action requires the web services to restart so the new certificate can take
effect.
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4. Re-login into the WebUI.
The following message displays:

Self-Signed Certificate successfully created. System is restarting the web
service, please log in again.

5.4.9.4. Generate SSL certificate request

When a certificate must be signed by an organization’s own Certificate Authority
(CA) or a third party trusted CA, you must generate a ertificate signing request.

The only difference between the fields in a self-signed certificate
0 and a certificate signing request are the number of days of
validity which will be determined by the signing CA.

1. Select Generate Certificate Request.
2. Enter the requested data to complete each field.

3. Select Generate Certificate Request.

The system prompts you to save a file that you will provide to your PKI team
or third party CA provider to sign and return.

e ‘ Private keys are not exported as part of the signing request.

5.4.9.5. Install Signed SSL Certificate

Once your PKI team or third party CA provider returns your signed certificate, you
will need to install it in one of two fashions.

It is recommended that you ensure that the returned signed
certificate includes the full chain of signers (that is, nShield
Monitor certificate, signing CA, root CA).

The chain should consist of at least two certificates: * nShield Monitor certificate *
Signing CA certificate.

The chain can have as many as seven certificates, including: * nShield Monitor
certificate * Signing intermediate CA * Intermediate CAs between signing CA and
the root CA.

o If you receive the file via email be sure to save it to a location
where you can find it.
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—_

. Select Install Signed Certificate.

2. Select Choose file and browse to locate the file that contains the signed
certificate and the associated signing chain.

3. Open the file and include the contents in the window.
4, Select Install Certificate. The signed certificate is installed.

5. Close your browser session (logout and close the tab) in order to connect
using the new certificate.

0 ‘ You will be prompted to login again when you do so.

5.4.9.6. User Interface SSL/TLS Options

On this page, you can configure which protocols and cipher mechanisms nShield
Monitor accepts.

This feature requires a quorum approval from a second
o administrator before changes made by the first administrator
can be applied.

* By default, SSL v2 & v3, and TLS v1 protocols are disabled.
* By default, the AES256-SHA cipher suite is disabled.

User Interface SSL/TLS Options

Disabled Protocols:

550 v2
BssLva
ETLS vl
OTs vl
Onswviz

Disabled Cipher Suites:

AES256-3HA -
O DHE-DSS-AES 128-GCM-SHA256

O DHE-DSS-AES 128-SHA256

0 DHE-DSS-AES 256-GCM-SHA384

O DHE-DES-AES254-3HAZ5S

[ DHE-RSA-AES 128-GOM-SHAZS6

[ DHE-RSA-AES125-35A256

O DHE-RSA-AES256-GOMSHAZEL

[ DHE-RSA-AE3254-3HA254

[ ECDH-ECDSA-AES 1 26-GCM-3HA254
0 ECDH-ECDSA-AES 128-5HA256

0 ECDH-ECDSA-AES256-GTM-SHA3S 4

Save Optlions

To change which protocols and cipher mechanisms are allowed:
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1. Navigate to: Configuration > Security.
2. Select the protocols that the GUI server should deny.

3. Select Save Options.

This generates a warning that lists the protocol option changes that require
approval.

e There are protections that make sure at least one option is
left unchecked (which means unblocked).

4, When a quorum approval is pending, one of three actions can happen next:

a. The first administrator can cancel the quorum request by selecting Cancel
Change and the system remains unchanged.

b. The second administrator can deny the change by selecting Reject
Change. This generates a log message indicating that a change was
denied.

c. The second administrator can approve the change by electing Approve
Change. This generates a log message indicating that a change was
approved, and the GUI server is restarted.

5. A restart is required for the new settings to take effect.

This is not a reboot, only a restart of the GUI server.
However, any users that are logged on are sent back to the
login page. They will need to log back in to the system.

5.4.9.7. Password settings
1. Navigate to: Configuration > Security.
You may need to scroll down.

2. Set the parameters based on your organization’s security policy.

3. Select Save Password Settings.

5.4.10. Upgrade
nShield Monitor has the capability to be upgraded via a file provided by Entrust.

0 We recommend taking a backup before upgrading, see nShield
Monitor Backup and Restore.
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5.4.10.1. Upgrade from 1.1.X

The same firmware upgrade file works for all your nShield
o Monitor appliances. Additionally, the upgrade requires a
password, or upgrade key.

The process to obtain an upgrade file for your virtual appliance follows.

1. Send an email to Entrust nShield Support, https:/nshieldsupport.entrust.com,
and request an upgrade.

Support forwards a firmware upgrade file (with a .cmf file extension) along
with the upgrade key password.

2. Save the .cmf file to a convenient location. You are now ready to apply the
upgrade.

3. Navigate to:
Configuration > Upgrade

The Upgrade System page opens:

Upgrade System

Choose file to upload :

Select file for upload

Upgrade Key :

Automatically reboot after upgrade : [

Start Owver

Version History

This version of nShield Monitor is 2.5.4 (0029).

From Version To Version Upgrade date/time

2.5.4.0022 2.5.4.0029 Fri Dec 07 2018 09:46:41 GMT-0800 (PST)

4. Click Select file for upload.
5. Navigate to the upgrade file.

6. Select, and open the upgrade file that you just saved.
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7. Enter the password, provided by Support, under Upgrade Key.

At this point, you can choose to have the system

automatically reboot when the upgrade is complete by

e selecting Automatically reboot after upgrade. Otherwise,
you will need to manually trigger a reboot once the upgrade

process has completed. Either way, the system must be

rebooted to complete the upgrade process.

8. Select Automatically reboot after upgrade.

If Automatically reboot after upgrade is not selected, you
will need to manually trigger a reboot once the upgrade
process has completed.

9. Select Upload and Perform Upgrade.
The system displays progress meters to indicate the status.

Please do not navigate away from the Upload page during
6 the upload process. Should you navigate away, the upgrade
automatically cancels.

If the system does not automatically reboot, select Reboot Now button and then
confirm the action with a second click.

When the process completes, the system will either reboot automatically or you
will need to select Reboot Now button and then confirm the action with a second

click.

o After the system reboots, the new software version is displayed
on the Dashboard page, in the nShield Monitor Status window.

5.4.11. Creating users

o ‘ nShield Monitor can support up to 64 users.
0 ‘ A user with no role is not allowed to login.
o ‘ After three failed login attempts, the account is locked

To unlock an account, select Forgot your Password on the login page, enter your
username, and then select Request New Password. An email containing a reset
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link will be sent to the email address associated with the username. The link will

prompt the user to change the password before accessing their account.

o | The reset link expires after 15 minutes.

1. Navigate to: Configuration > Users.

The Manage Users page opens.

Manage Users

Create User
Q Search:

A Login Full Name Email
ID

O admin Default System admi...

Administrator

O | adminl admi...

0O | admin2 admi...

O | auditor afa

O group aEag

Password

Expirafion

MNewer

MNewer

MNewer

30 days

MNewer

Auto
Logout

1 hours

rminutes

minufes

minutes

1 hours

Assigned
Roles

System
Administrator

System
Administrator

System
Administrator

System Auditor

Group
Manager

2. Select Create User.

3. Complete the open fields appropriately.

0 When creating a user with the Group Manager role, available

groups must be assigned to the user.

e At least one group must be assigned to all users assigned a

4, After you have made your selections, select Create User.

5.4.12. Editing users

Group Manager role.

1. Navigate to: Configuration > Users.

The Manage Users page opens.

2. Select the Login ID associated with the user to edit. The Edit this user page

opens.
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When you are updating a user with the Group Manager role, available groups
must be assigned to the user.

0 At least one group must be assigned to all users assigned a
Group Manager role.

3. Under Assign Roles for this User, select the role to associate with the user,
then select Save User.

5.4.13. Deleting users
1. Navigate to: Configuration > Users.
The Manage Users page opens.

o ‘ Only those users who have no role assigned can be deleted.

2. Select the Login ID associated with the user to be deleted. The Edit this user
page opens.
3. Under Assign Roles for this User, select No Role.

4. Select Save User.
The Manage Users page opens.

5. Select the box associated with the user.

6. Select Delete User(s).
The system prompts requesting a confirmation of the deletion.

7. Confirm the deletion.
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6. Configuration Logged in as Group
Manager

6.1. Overview

The Group Manager role is responsible for:

* The configuration of devices that are to be monitored.

* The day to day monitoring of health and statistics down to an individual HSM
device level.

Group Managers are able to enroll devices, set group alarm thresholds, and
configure group event notifications via email.

6.2. Edit Profile page

Both the Administrator and the Group Manager are able to edit their own profiles.

The Edit Profile page is accessed by selecting your User ID located in the top right
corner of the page.

Group Manager ), May 24, 2017 0457 @

. Log Ot

From this page, you can perform the following actions:

» Add a description
* Update the email address

* Change the password

Set the auto-log duration

e Select a custom date format.

0 When selecting a custom date format, you can also select: Use
Browser Timezone for Exporting Events.

When you select a custom date format, the chosen format is associated with your
user ID giving each user the option of selecting their preferred format. Once the
format has been selected, it is consistently displayed in accordance with your
selection.
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The only date format that will not change is the date in the User ID line, as shown
below:

group | Group Monager )| May 24, 2017 0457 | @

. Log Ot

e Reset the GUI Persistence Profile.

6.3. Managed entities

Logged on as a Group Manager, the Configuration tab displays the following:

Configuration = Logs

Group Alarm Thresholds

Group Event Motification

Manoged Entities

6.3.1. Enrolling devices/entities

To enroll a device/entity, you must be logged on as a Group
0 Manager. For enrolling a device you must configure SNMPV3 on

the device with an authentication algorithm and a privacy

algorithm, and use the same during device enrollment.

1. Navigate to: Configuration > Managed Entities.
The Manage Entity Settings page opens.

2. Select Enroll Managed Entities
The Entity Enrollment options are displayed.

You can choose to enroll an entity one at a time or you can use a Batch file.
The default is set to enroll a Single Entity.

3. Select the required Managed Entity Type from the drop down menu.
4. Enter Device Details, SNMP Details, and Group Membership details.
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Entity Enrollment

« Single Entity  Batch

Device Details : SNMP Details :

Managed Enfity Type : Username -
2 |
Hostname/IP Address - Port -
| | ‘ 141
Marne (optional) - Authentication Algorithm :
| |
Description {opfional) - Authentication Possword -
Location {optional) : Privacy Algorithm © [Client hosts only support
AES)
| -
Stats Timeout
Privacy Possword -

| | |
Adrrin Timeout :
E |

Group Membership :

Member of Available Groups

| Filter groups: ‘ ‘ Flter groups: ‘

| ‘ P { Managed Groups ~

o Both the Authentication Algorithm and the Privacy
Algorithm require a selection from a drop down.

9 ‘ Client hosts only support AES Privacy Algorithms.

5. Click Enroll Device to complete the enrollment process:
6. Select Yes, test connection to test the connection.
- |f you would like to skip the test, select No, skip Test.

- |f you would like to cancel the data that you just entered, select Cancel
Changes.

o |f you choose to test your connection and the test is successful are
returned to the Managed Entities page.
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If you test the connection and the test is not successful,
you Wwill receive an error message. Correct the error
condition and re-enter the device information.

ATTENTION: Devices/entities can be assigned to multiple groups.

« A device/entity can be assigned to groups not associated with the current
manager role; however, this is a one way function.

» In order to make changes or delete a device/entity in a group, the user must
be a Group Manager for that group.

« A device/entity can be associated into multiple groups during enrollment.

« The same device/entity can be associated to more groups by editing the
device.

ATTENTION: All HSMs being monitored must be configured to support SNMPv3
with nShield Monitor.

6.3.2. Option: Enrolling using a batch file
1. From the Entity Enrollment page, select Batch.
The Entity Enrollment page opens.

o To see a sample batch file, select Download Sample Batch
Enroll File.

2. Select either Choose File or Download Sample Batch Enroll File.

- Enrolling multiple devices at one time requires a comma separated
variable (CSV) file containing all the device information and SNMP
information.

> You can create a file without passwords, but you will need to still leave a
space where the passwords would go in the file.

Devices can be assigned to multiple groups. A device

can be assigned to groups not associated with the

current manager role; however, this is a one way

o function. In order to make changes or delete a device in
a group, the user must be the Group Manager. A device

can be associated into multiple groups during

enrollment. The same device can be associated to more

groups by editing the device.
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Device/Entity Batch Entry CSV Fields

CSV File Field Name Notes

Group Name Required (string) [multiple groups in square
brackets]

Device Host name Optional if IP address present (string)

Device IP address Optional if hostname present (IPv4 address -

123.45.67.89)

Device Name Optional (string)
Description Optional (string)
Location Optional (string - cannot use commas to separate

city from state)

SNMP User Name Required (string)

SNMP Authentication Algorithm Required (one of [MD5 SHAD)

SNMP Authentication Password Required (string)

SNMP Privacy Algorithm Required (one of [DES AES 3DES AES-192 AES-
2560

SNMP Privacy Password Required (string)

SNMP Port Optional (string) default is 161

Device type Optional (string)

Admin Timeout Optional (string)

Stats Timeout Optional (string)

- Each entity must be listed in a single row and all fields must be separated
by commas.

o For the optional fields, if you do not want to specify a value, leave the
field blank. Both blank lines and comment lines are ignored.

- Example with all fields specified:

Group1, Devicel, 192.168.18.101, Device 1, Device description 1,Location
1,User1,SHA, authpassword1,DES, privacypassword1

- Example with optional fields not specified - Note that those field are left
empty:
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Group2,,192.168.18.102,Device 2, , ,User2,SHA,authpassword2,DES,privacypassword2

- Example with optional fields not specified - Note that those field are left
empty:

Group2,,192.168.18.102,Device 2, , ,User2,SHA,authpassword2,DES,privacypassword2

3. After loading the batch file, select Enroll Devices.
4, Select Yes, test connection to test the connection.
- |f you would like to skip the test, select No, skip Test.

- |f you would like to cancel the data that you just entered, select Cancel
Changes.

> |f you choose to test your connection and the test is successful, you are
returned to the Device Listing page.

If you test the connection and the test is not successful,
you Wwill receive an error message. Correct the error
condition and re-enter the device information.

6.3.2.1. Deleting enrolled devices

You can only delete devices from groups that you have been
assigned the manager role. When a device is associated with
multiple groups, deleting a device from a group removes the
0 association of the device from that group only. The device does
not get deleted from other groups that it is associated with. A
device gets deleted from nShield Monitor only when it does not

have any association with any other group.

1. Navigate to: Configuration > Managed Entities.

2. Select the check box next to the device to be deleted.

e Selecting the check box at the header level automatically
selects all the devices in the Group.

3. Select Delete <device>.

6.3.2.2. Editing enrolled devices
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1. Single click on <device name> of the device to be edited.
The Edit Device Details page opens.

The Group Membership window displays two assignments:
Member of and Available Group. You are able to toggle
membership between the two.

2. Enter the changes/make your selections.

3. Select Save Changes.

6.3.2.3. Starting and stopping device monitoring
1. Navigate to: Configuration > Managed Entities.
The Managed Entity Setting page opens.

2. Select the box associated with the device to have monitoring started/stopped.

O A Name IF Address Monitoring Description Location
] Faisal 3W2 CHI 192.168.18.32 m
O Faisal SW2 CH2 192.168.17.141

New action buttons appear:

Bnrcll Managed Enfifies Stop Monitoring Client Hosts Delete Client Hosts

The Start Monitoring <device> is a toggle with Stop

0 Monitoring <device>. When the device is being monitored,
the Stop Monitor option is available. When the device is not

being monitored, the Start Monitor option is available.

0 All selected devices must be either enrolled or unenrolled
for the button to be enabled.

3. Select <Stop><Start> Monitoring <device/entity>.

6.4. Group Alarm Thresholds

The Group Manager role can view and set alarm thresholds.
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manager [ Group Manager ) JFeb 22, 2018 8:01:27 [GMT-08:00) @

. Log Out

1. Navigate to: Configuration > Group Alarm Thresholds.

The Group Alarm Thresholds page opens:

Group Alarm Thresholds

Group nShield nShield nShield nShield nShield nShield
Name Warning Crifical Feak Feak Object Object
Level Level Level Duration Count Count
Warning Crifical
Level Level
nShield | 40 &7 39 15 minutes | 540 7500

nShield High
Object
Count
Durafion

15 minutes

2. Select the Group that you would like to set.
3. Use the slide bars to set the thresholds.

4, Set the values in the nShield High Object Count fields based on your

preferences.

5. Select Save Thresholds.

Alarms must be enabled to receive alerts, and must be programmed for each

group you wish to see alerts for.

Utilization overload thresholds have two levels:

e The first level is a Warning Threshold used to generate a Warning Severity

Event.

e The second level is Critical Threshold used to detect a Critical Severity Event.

When the group utilization overload alarm is enabled, and both thresholds are

configured:

e Every 10 minutes the alert detection will compute the previous 10-minute

nShield utilization for each device in the group.

e If the utilization is over the Critical Threshold, a critical event is generated.

 If the utilization is less than the Critical Threshold, but over the Warning

Threshold, a warning event is generated.

e Otherwise, there is no alert event.

The Utilization Peak Event provides a warning level threshold if the utilization
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peaked above a selected percentage during a pre-configured amount of time in
minutes.

Both sets of alerts are disabled by default.

6.5. Group Event Notification

The group manager role has the capability to view and set group event
notification via email.

1. Navigate to: Configuration > Group Event Notification.

Group Event Nofification

Group Email Info  Mofification Warning Ewor Crifical Alert Emergency
Name Enabled

2. Select the Group for notification.

The Notification Warning message displays.

Group Event Nofification : Group 1

O Email Nofification Enabled

Warning: Email Nofification i disabled.
Policy Category Info  Mofification Warning Emor Critical Alert  Emergency
Device-Group Specific o 4 | [} O O O
Events

Save Policy Cancel changes

3. Select Email Notification Enabled.
4, Select the alert type.

5. Select Save Policy.

0 If a device is enrolled in multiple groups, the Group Manager
receives event notification emails for all groups to which the
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device is enrolled and to which the manager has been assigned
the Group Manager role.

6.5.1. Assign SNMP notification policies for groups

Group Managers manage which email addresses are sent notifications when a trap
event occurs in the device group. For instructions on how to enable notifications
by trap groups, see Assign SNMP Notification Policies for Trap Groups.

To assign Notification Policies for device groups:

1. Navigate to: Configuration > Group Trap Settings.

2. In the Group Name column, select the hyperlink of the device group for which
you want to configure email notifications.

Group Trap Event Notification
‘ F

Group Name Email Enabled Info Notfification Warning

3. Select your preferences for the Group Trap Event policy categories and
configure the trap emails for the group.

Group Trap Event Notification : Group 1

Nofification Enabled
Email Noftification is disabled.

Policy Category Info Notfification Warning

Device-Group Specific Events =

Cancel changes
Add Trap Event Nofification Emails

Add emails

Save Emails Cancel changes

a. To enable email notification, select the Enable Email Notification Enabled
option.

b. To specify for which trap events to send email notifications, select the
relevant options.

c. Select Save Policy.

The Group Trap Event Notification page is displayed.
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4. Configure the email notifications.

a. In the Group Name column, select the link of the group for which you
want to configure email notifications.

b. Add the email addresses to which the notifications should be sent when a
trap event occurs. There is no limit on the number of emails that you can
add to the list.

c. Select Save Emails.

6.5.2. Assign SNMP Notification Policies for Trap Groups

Group Managers create, edit, and manage trap groups that contain traps and a list
of email addresses where notifications are sent when a trap event occurs.

For instructions on how to enable notifications by device groups, see Assign
SNMP notification policies for groups.

To assign notification policies for trap groups:
1. Navigate to: Configuration > Trap Settings.

The Trap Configuration page is displayed.

Traps Configuration

Group Name Descripfion (opfional)

2. Select Add New Trap Group.

The Group Details page is displayed.
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Group Details

Group Nome :

Description (optional) :

Click a group in either selection box to move it to the other one.

Curently Selected

Add emails

Any changes made will not be saved until you click the Save changes button.

Available Traps for configuration

Select the available fraps to configure

Fan Failure Fon Faled Eror
Fan Restart ~on Resfart Succass
Hard Server Failure Hard Server Failed Eror

Hard Server Restart Hord Server Restart
Success

Memory Usage High High memory usage eror

Memory Usage Normal Memory usage & less
than threshold

Adaddete Pailima Sioiooroioar

Add Trap Event Notification Emails

3. Enter a name for the new trap group.

4, Select traps from the list of Available traps. For traps supported in nShield
Monitor, see Support for nCSNMP traps.

5. Add the email addresses to which the notifications should be sent when a trap
event occurs. There is no limit on the number of emails that you can add to

the list.
6. Select Create Group.

The Trap Configuration page is displayed.
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/. Logs

The logging capability of nShield Monitor provides a view of all ongoing events
that occur in the system. Organizations can track all activities pertaining to their
estate of HSMs and clients, and pro-actively evaluate a preventative maintenance
strategy.

@ CIPHER A Dashboard Views - Reports~ Configuration ~ Logs  Alams

o ‘ The default sorting is by sequence number.

7.]. Logs available to Group Managers

When logged in as a Group Manager, the logs tab provides the ability to view, sort
device and filter group logs.

manager [ Group Manager ) JFeb 22, 2018 8:01:27 [GMT-08:00) @

. Log Ot
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+" Device/Group Log

Q Search:
A
18] Date Time Severity Messoge
4237 | 201705 [ nFo | The connection status is now SNMP
ZETIP 47147441 accessible for nShield module,
SerialNumber: D2EC-DE03-6D97 in
group: Group 1
4234 | 2017-05 The connection status is now
ZATIF46011.1247 unreachable for Faisal 3W2 CH1 -
192.145.18.32 in group: Group 2
4235 2017-05 The connectfion status is now
Z3TI9-4411.1237 unreachable for Foisal SW2 CH1 -
192.168.18.32 in group: Group 1
4234 | 2017-05 The connection status is now
23TI9-4411.107L unreachakle for nShisld module,
SefialNumber: D2EC-DE03-6D97 in
group: Group 1
4233 201705 [ nFo | The connection status is now SNMP
ZITI9:4411 0347 accessible for Faisal SW2 CHI -

192.148.18.32 in group: Group 2

rows per page.
First Page | o ' 2| 3| n| Lost Page

177 Total rows . Poge | 1 of 34,

Export Log (C5V)]

Logs can be exported via CSV format for further analysis.

7.2. Logs available to Administrators

When logged in as an Administrator, the Logs tab on the main menu bar enables
you to:

* View and sort system event logs

* View and sort security logs

* Export logs.

admin [ Systermn Administrator ), reo 22 2018 8:04:24 [GMT-08:00) @

. Log Out
By default, the system sorts logs based on sequence. Clicking on
o the colored text (such as ID or Date/Time) toggles the order that

Monitor v2.9.7 Install and User Guide 60/205



Chapter 7. Logs

| the data is displayed.

Q Search:

D Date/Time

4199 2017-05
23T16:23:29. 4192

4198 2017-05
23T16:23:20.5607

4197 | 201705
FIM&:2208.796F

4196 2017-05
23M6:21:02.3842

P‘DWS oer Doge.

First Poge o

Export Log [C3Y]

Export Support Data/Debug Logs

o Systern Event Log ~ Security Log

&
E E E E g
N
=

2

Message

Adrninistrator admin has rejected an
351 opficn changs.

Adrninistrator admin has requested
quorurm approval for an 551 option
change.

Administrator admin has rejected an
S5L opficn change.

Administrator admin has requested
queorurm approval for an 550 option
change.

3| n | Lost Poge

2978 Total rows . P::ge| ! |of 504,

Support Data/Debug Logs

7.3. Log sorting

nShield Monitor provides the ability to filter logs by ID, date/time, severity, and

message.

1. Click on the sort condition. For example, Date/Time.
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" Device/Group Log

Q Jearch:
AlD Da'e,.-'@e Severity Message
58 2007-04 m Group: "Group 3", User kory has enrclled device: Faisal CH 1A

26113:37:04 9571

59 | 2017-D4- KX}  Group: Group 1", User kory has enrclled device: Faisal CH2

The sorting icon displays as the content is sorted.

A Date/Time

20704~
2871535704 9571

2017-04-
28T13:3705.5701

2017-04-
28T15:37:05.6302

7.4. Log functionality

o | You are logged in as Administrator.

admin [ Systermn Administrator ), reo 22 2018 8:04:24 [GMT-08:00) @

. Log Out

7.4.1. System event log

The system event log provides events that correspond to non-security related
system events for nShield Monitor.
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o Systern Event Log ~ Security Log

Q Search:

14} Date,/ Time Severity Message

4199 | 2017-05- m Administrator admin has rejected an 3L option change.
23N 4:23:29. 4192

4198 | 2017-05 )  Adminisirator admin has requested quonum approval for an
2311 6:23:20.560Z 35L opfion change.

4197 2017-05 EIE) | Adminisirator admin has rejected an S5L option change.
23N 4:22:08.796

4194 2017-05- m Adrministratcr admin has requested gquonsm approval for an
23T 4211023847 33L opficn change.

7.4.2. Security log

The security log shows events that are related to system level security events.
Events such as master key password entry, master key destruction, certificate
changes, and changes to other system level security information are noted.

o | The default for sorting is by sequence number.

SystemEventlog — «* Security Log

Q Search:

AlD Date,/Time Severity Message

3 2017-04-26T13:20:55.6571 I}  useradminioggedin.

4 2017-04-28T1 32102 0277 = User admin has changed password.

5 201 7-04-28T1 3-23:07 6427 = Master key generafed by user: admin

8 2017-04-26T1323:07 7251 m User admin has created new user: admin
7 2017-04-26T13:23:08.3617 B  Roles have changed for user: admin]

7.4.3. Device/group log

o | You are logged on as Group Manager.
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manager [ Group Manager ) JFeb 22, 2018 8:01:27 [GMT-08:00) @

. Log Out

The device/group log lists events and alerts that relate to the groups for which a

group manager has management rights. Group event entries are displayed in

sequential order from newest to oldest.

Q

103

72

" Device/Group Log

Search:

Date,Time

2018-02-

2071 540042 40427
2018-02-

2071 5:40:38. 40387
2018-02-
20T08:57:04.5947

2018-02-
270443034332

2018-02-
21T08:59-00.590F

Sewverity Message

The monitcring status is now enable;

192.168.18.101 in group. groupl by

The monitcring status is now disable
192.168.18.101 in group. group] by

Error log count increased to 544 for
192.158.18.101 in group: group |

Emror log count increased to 863 for
192.188.18.101 in group: group ]

Error log count increased fo 8462 for
192.168.18.101 in group: group ]

7.4.4. Exporting a log.csv file

1. Select Export Log (CSV).

2. Select Open. The log.csv file is imported into Microsoft Excel.

The system prompts to open or save the logs.csv file.

a,_|2017-01-0 4

f A Y B . C [ D . E . F . G
_ﬂTime 1 everity Message
3 |2017-01-0 INFO The connection status is now SNMP accessible for K
112017-01-0 INFO The connection status is now SNMP accessible for K
4 |2017-01-0 INFO The connection status is now SNMP accessible for K
2017-01-0 RITICAL The connection status is now unreachable for Kory

RITICAL The connection status is now unreachable for Kory

o Logs can be exported in their entirety or filtered. This includes both

actions on or by a monitored system. They can also include changes in
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security of a given device as needed such as a tamper, changes to device
SNMP credentials, or the addition of a new device. Changes in the device
contact status are also displayed in the group event log and on the alarms
screen.

- The default for sorting is by sequence number.

- By default, the Time format is Date/Time in GMT format. Refer to
Formatting the Admin Date and Time for additional information regarding
date formatting.

3. Save the Excel file, if needed.

7.4.5. Debug log export and upload

A debug log export may be required to be given to Support for investigating
issues. This log will need to be exported which can take several minutes to
generate and export. Once exported it will need to be sent to Support.

The file does not contain any security information but does contain information
related to actions taken by nShield Monitor such as polling devices, system status
events, and code execution information.

The debug logs are a system for assisting in troubleshooting issues that may arise
with the virtual appliance during day-to-day operation. Logs are provided on a
First in First out (FIFO) basis, so if requested, the logs need to be exported as
soon as possible after an issue has occurred.

Only one user can export the debug log at a time, and only administrators and
auditors have the ability to perform this function.

The debug logs are not readable by users, and are to be sent to
Support for analysis. Exporting large debug files requires that
the auto logout value be set to 60 minutes.
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8. Dashboard

nShield Monitor provides a dashboard view when you first log on to the system.

This view provides a snapshot of what is occurring with your estate and provides
invaluable information for the day-to-day management of all your organization’s
HSMs.

The contents of the dashboard depends upon logon type:

* Logged on as Administrator.

A Dashkoard Views - Configuration = Logs Alarms

Event List »

nShield Monitor Status »

Unacknowledged Alarm Summary »

* Logged in as Group Manager.

A Dashboard Views ~ Reports - Configuration -

Event List »

nShield Performance »

nShield Monitor Status »

Unacknowledged Alarm Summary »

The following table summarizes the views based on log-on type:

Dashboard views based on logon type
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Dashboard

Dashboard Views

Event List

nShield Performance

Users

nShield Monitor Status

Unacknowledged Alarm

Summary

Administrator logon required Group Manager logon required

X X
X
X
X X
X X

The sections that follow examine each of the Dashboard Views

(as identified

8.1. Event List

in the table above).

1. Select the Event List expansion arrow.

Event List -~

| 5 ¥ || Most Recent Unacknowiedged v |

4237

4236

4235

4234

4233

2017-05
ZATNF47 147447

0705 CRITICAL

ZATS4410.1247

20705 CRITICAL
23M19:44:11.1232

2017-05 CRITICAL
Z3AM9:46:11.1072

2017-05
Z3TN9:46:11.0842

The connection status is now SNMP accessible for
nshisld module. SefalNumiber: D2EC-DE03-6D7F in
group: Group 1

Tha connection status is now unreachable for Faisal
SW2 CHIT - 192.188.18.32 in group: Group 2

The connection status is now unreachakle for Faisal
SW2 CHI - 192.148.18.32 in group: Group 1

The connection status is now unreachakle for nshield
medule, SerialMumicer: D2EC-D803-5D7F in group:
Group 1

The connection status is now SNMP accessible for
Faisal SW2 CHI - 192.188.18.32 in group: Group 2

From this window, you can specify the number of events (default value is 5)

displayed and filter according to:

> Most Recent Unacknowledged (default value)

o

o Alarm level (That is, EMERGENCY ONLY, ALERT ONLY, and so on.)

Most Recent Events

2. Select the drop down arrow to expand your choices for number of events

disp

layed.
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Event List -~

| CRMCTAL only

4

2017-05-
23T19:44:11.1242

4235 | 201705
Z3AN441.1232

The connection status is now unreachable for Faisa
SW2 CH1 - 192.148.18.32 in group: Group 2

The connection status is now unreachable for Faisa
SW2 CHI - 192.148.18.32 in group: Group 1

4234

2017-05

[l Yl  The connection status is now unreachable for NShield

3. Select your preference.

4. Select the drop down arrow to expand your choices for event types.

Most Recent Unacknowledged

Most Recent Evenits

EMERGENCY only

- ALERT only

5w

ERROR only L\\?

WARNING cnly

NOTIFICATION cnly

4236 || INFO only

he connection status is now unreachable for Faisal

& -3, R T

4235  2017-05
Z3Te44601.0231

SW2 CH1 - 192.148.18.32 in group: Group 2

The connection status is now unreachable for Faisal
SW2 CH1 - 192.148.18.32in group: Group |1

5. Select your preference (for example, CRITICAL only.)

6. Select the event by clicking on the event type. For example:

Event List ~

| 5w || CRMCAL only

|

4236 201705
23T19:46:11.1242
4235 | 2017-0%
23T19:46:11.1232
—— —

The connection status is now unreachable for Faisa
SW2 CH1 - 192.168.18.32 in group: Group 2

The connection status is now unreachable for Faisa
SW2 CH1 - 192.148.18.32in group: Group 1

Tho -—ni-di = chob s e o ! hnl—hf rn"‘!—'id

The Acknowledge Alarm page opens:
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eemcar ACknowledge Alarm

Alarm Date/fTime:

‘ 2017-05-23T19:46:11.1242 ‘

Alarm ID:

‘ AVwETCIqURvIxMATUAL ‘

Alarm Message:

‘ The connection status is now unreachable for Faisal SW2 CHI - 192.148.18.32 in group: Group 2

Acknowledgement Comments | Opticnal )

Acknowledge Alarm Cancel

7. Enter Acknowledgment Comments, if needed.

8. Select Acknowledge Alarm.

o | Selecting Cancel returns you to the Dashboard.

8.2. nShield Performance

o | You are logged in as a Group Manager.

manager [ Group Manager ) JFel 22, 2018 8:01:27 [GMT-08:00) @

. Log Cwut

1. Select the nShield Performance expansion arrow.
Two windows open:

- nShield Performance

- Top 5 Client Hosts by Command Count
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nShield Performance ~

nShield Commands Count, Last Hour

100

a0

* . -—— — — -
&0
-4~ mShiald

0

Commands count

20

o
ﬂ 17:00 1710 17:20 17:30 17:40 17:50 18:00

5 mins
H | Lost Howr | ° P -
15 mins 1 min
Top 5 Client Hosts by Commands Count
Naome IP Address Security World Commands Count
1017212 17212 07 8c7d5i5fed417038778e34c48cobacar 5727d 250

8.2.1. nShield performance window
The performance window provides a customizable graph.

This section provides a basic overview on how to use the customization options.
Refer to Client Host Detail Page for greater detail.

8.2.1.1. Navigate to a group’s Detail page

At any time, you can open a specific group’s Detail page. A color key on the right
side of the graph contains Group color line assignments. For example, the
"nShield" group, circled in red above.
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nShield Perfformance -

nShield Commands Count, Last 24 Hours

(-

i IFMI ulm ,.J [ /'

M | _
?E l |h|'l| I I“I \ J'I l _In;!! L |i|fmh Fltl f, || J!i_||‘- :I;J'I'.k'{I:'JLﬂ__II | \_h!_llf"ll\\lll_ . T
|
ke 20:00 8. Dac 04:00 08:00 12:00 16:00
5 mins
B ceroaasss——— I o
& hours 5 mins

Clicking on Group 1s graph contents opens the Group Detail For: Group 1 page.

nShield Object Count, Last 7 Days

5. Dac 12:00 6. Dac 12:00 7. Dac 12-00 . Duc 12:00
15 mins
aa = 5]
2 days 15 mins

Refer to Group Details for a full description of the Group Details page.

8.2.2. Top 5 Client Hosts by Commands Count

This window also contains a live count down until the next refresh. In the example
below, the data will refresh in 24 seconds.
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Top 5 Client Hosts by Commands Count

Name IP Address Securty World ‘Commands Count
10,0722 1017212 c07 6cTd5f5fed417c387 T3a34c48cabaca? 572d 214

1. Select an entry in the name list to navigate to additional windows of data.
The Client Host Detail page opens.

2. Select the Performance expansion arrow.

Client Host Detail for: 10.1.7.212

IP Address/Host Mame : "10.1.7.212°

Performance -

10.1.7.212 Command Count, 2018-11-28T18:21:51.2151Z - 2018-12-08T18:21:51.2151Z =

200

200

150

Commands count

100

50

16:00 20:00 8. Daz 0400 0B-00 12-00 16:00 ﬂ

2018-11-28T18:21:51.21512 | | 2018-12-08T1&:21:51.21512

Done

| 201 8-11-

The Start Date and End Date selection boxes appear when the custom date
option is selected.

3. Scroll down and click on the Health expansion arrow.
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Client Host Detail for : 10.1.7.212

IP Address/Host Mame : "10.1.7.212"

Performance »

Hardserver Stotus: m

Number Of HSMs: &

Applicafions With Active Connection Te Hardserver: 11

Modules Failed:

Hardserver Version: 12.400

Hardserver Port: FO04

Hardserver Upfime: %8 Doys - 23 Hours © 21 Minutes : 14 Seconds

4. Scroll down and click on the Applications with Active Connection to
Hardserver expansion arrow.

Applications with Active Connection fo Hardserver -

Q search: Add
Connecfion Upfime Command Reply Remote IP Process Process Total Objed
HNumber Count Count Address [1s] Name Count
7 98 Days : 23 Hours : 21 [ o] 0.0.00 0 o]

Minutes : 14 Seconds

11 98 Days - 23 Hours : 21
Minutes : 02 Seconds

ﬂ 0.0.0.0 0 legacyl
12 P8 Days : 23 Hours : 21
Minutes : 02 feconds

12 98 Days : 23 Hours : 21
Minutes : 02 Seconds

a
ﬂ 0.0.0.0 0 legacyl ﬂ
B 0.0.00 0 fegacy] [0 ]
o | o]

15 98 Days - 23 Hours : 21
Minutes : 02 Seconds

0000 a [legocy]

5. Scroll down and click on the Security World Info expansion arrow.

Secunty World Info ~

Security World Name: 7 6cTd5iEfel41 703877 Bel34c4dcobacal 552fd
Security World State:

hashKN5O: 07 6cTd5iEfel4 193877 8el4c48coboca 572d
hashkM: 111d43def3fc341 222443771 P41 0ol 342128

6. Scroll down and click on the nShield HSMs expansion arrow.
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nshield H3Ms ~

Q Search:
Serial No. Type Mode Commands Last Hr.
0305-02E0-DF 47 CONMECT XC

=
2R05-02E0-DF47 CONNECT XC [ FaiLep |
£599-74B4-30FF CONNECT
SFFF-T4BF-4278 CONNECT
BS4A-21CH-TAF2 CONNECT

7. Scroll down and click on the nShield Card Sets expansion arrow.

nshield Card Sefs ~

Q Search:

et Naome Client Host Couwnt Generafion Time
crnocil 1 2014-09-148T23:47:30.45302
ocl 1 20146-03-15T1 871207122
oc2 1 2014-03-15T23:07:15.715L

8. Scroll down and click on the nShield Keys expansion arrow.

nshield Keys -

Q Search: Add

Key Identifier/Name Key Hash Key Application  Chent
Name Hosts

Zo4c351 432805001 378247 1 29077 abETidE0 1 S Defdo7ETcfddeT 404521649201 601 42122231505 embed 1

427556015747 2oBb4a3d 251 SeafeSicPbdatd- 1f3c2f423118fe07b3b31ecd1454451b83eca2d? | embed 1

CO0o000

2fd31935720b3b47 obe | 4527 ecd badET dbaTiets 429c21220090507cb082a447755 1 2d61f1812317  embed 1

ffl 7386cc17beay37dSPdISANT 45207 ¢ bdSedff simple 1

livd bdbfdfo4197154820292d82384560007 4908ddee | simple 1

6 ‘ At any time, you can select Back to Previous Page.

8.3. Users

o ‘ You are logged in as an Administrator.
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admin|( System Administrator ), Jan 8, 2018 11:24:10 (GMT-10:00) @

. Log Out

1. Click the Users expansion arrow.

2. Select the drop down arrow to open the filtering options.

| Systemn Administrat: s o4

Cnline admin System Administrator 2018-12-08T15:465:57 46571
Cffiine sUper System Administrator, Group Monager 2018-12-07T14:55:48 55451
Cffiine adl System Administrator
Cffiine ad3 System Administrator

3. Select your preferred view. Filters include:
o System Administrators
o Group Managers
o System Auditors
o Last 5 login
- Locked Out

The display reflects your selected filter option.

8.4. nShield Monitor Status

0 ‘ You are logged in as an Administrator.

1. Select the nShield Monitor Status expansion arrow.

The status data is displayed.

8.5. Unacknowledged Alarm Summary

o ‘ You are logged in as an Administrator.

1. Select the nUnacknowledged Alarm Summary expansion arrow.
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Unacknowledged Alarm Summary -

°
[ Aeer: | °
2
[EE=] B
[ wannme : °
[ | 2
[ wro - | D

2. Select the alarm type. For example, click on CRITICAL. The Current

Unacknowledged Alarms detail page opens.

Cumrent Unacknowledged Alarms

Date,Time Severity
Q7T Z:47:48.47451

047T13:30:2£.30261

Message

Master key hos been gensrated but net loaded. You must lead master key for manitering
operations

Master key has been generated but not loaded. You must load master key for monitoring
cperations

3. Select the alarm for acknowledgment.

4. Enter Acknowledgment Comments, if required.

5. Select Acknowledge Alarm.

From the Current Unacknowledged Alarms window, you can

e also click on the severity type (for example, click on
CRITICAL), to open the Acknowledge Alarm window.

cemcar Acknowledge Alarm

Alarm Date/Timea:

| 2018-12-07T1 2:47:43 A7 481

Adarm I0:

| AWelyF_Lz3MLgex-_ojD

Alarm Massage:

| Master key has been generoted but not loaded. You must load master key for monitoring operations

Acknowledgement Comments | Cptional )

owledge Alam Conceal
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9. Views

User login type determines which options are displayed.

9.1. Logged in as Administrator
1. Navigate to Views > Groups > Group List

The Group Summary page opens.

Group Summary

A Group Name nshield Overload Alarm nShield Chient Hosts Descripfion

! (oisasieo | gooo 0 0
10 (o a00c0 oo 0 :
> ooe 0 0
3 oo ooo 0 0

On this page, you can sort the display order of the Group Name column and
the Description column.

Refer to View > Group > Group List for additional information on Administrator
options under Group List.

9.2. Logged in as Group Manager

Logged on as Group Manager provides the following navigational options:

%v Reports =

I Groups 4 l
Hihs r
Client Hosts ¥
k.eys 4
Card Sets k

Security Worlds ¢
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9.2.1. View > Groups

View Groups drop down has three destinations:

* Group List. Refer to View > Group > Group List, for additional information on

Group Manager options under Group List.

* HSMs By Group
» Client Hosts By Group

View > Groups > Group List
Group Summary page
Navigational links:
Group Name > Group Detail page
Alarm count > Current Unacknowledged Alarms page
nShield > HSMs By Group page
Client Hosts > HSMs By Group page
View > Group > HSMs By Group
Group <n> There are <n> nShields in this group page
Expand the pane:
nShield HSMs
Navigational links:
Serial No. > HSM Detail page
Alarm count > Current Unacknowledged Alarms page
Security World > Security World Detail page
Client Host Count > Client Hosts By HSM page
View > Group > Client Hosts By Group
Group <n> There are <n> client host(s) in this group page
Expand the pane:
Navigational links:
Name > Client Host Detail page
HSM count > HSMs By Client Host page
Alarm count > Unacknowledged Alarms page

Secunty World > Secunty World Detail page

9.2.2. View > HSMs

View HSMs drop down has two destinations:

* HSM List
e Client Hosts By HSM
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View > HSMs > HSM List
HSM Summary page
nShield HSMs
Navigational links:
Serial No. » HSM Detail page
Alarm count > Current Unacknowledged Alarms page
Security World > Security World Detail page
Client Host(s) count > Client Hosts By HSM page
View > HSMs > Client Hosts By HSMs
There are <n> client host(s) in this nShield page
Expand the pane:
Navigational links:
Name > Client Host Detail page
HSMs count > HSMs By Client Host page
Alarm count > Current Unacknowledged Alarms page

Security World > Security Waorld Detail page

9.2.3. View > Client Hosts
View Client Hosts has two destinations:

e Client Host List
« HSMs By Client Hosts

View > Client Hosts > Client Hosts List
Client Host Summary page
Navigational links:
Name > Client Host Detail page
HSMs count > HSMs By Client Host page
Alarm count > Unacknowledged Alarms page
Security World > Security World Detail page
View > Client Hosts > HSMs By Client Hosts
There are <n> nShield(s) in this client host page
Expand the pane:
Navigational links:
Serial No. > HSM Detail page
Alarm count > Current Unacknowledged Alarm page
Security World > Security World Detaill page
Client Host(s) count > Client Hosts By HSM page

9.2.4. View > Keys
View Keys has two destinations:

* Key List
* Client Hosts By Key
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View > Keys > Key List
Key Summary page
Navigational links:
Key Name/ldentifier > Key Detail page
Client Hosts > Client Hosts By Key page
View > Keys > Client Hosts By Key
Key Summary page
There are <n> client host(s) with this key page
Expand the pane:
Navigational links:
Name > Client Host Detail page
HSMs > HSMs by Client Host page
Alarm count > Current Unacknowledged Alarms page

Security Waorld > Security World Detail page

9.2.5. View > Card Sets

View Card Sets has two destinations:

» Card Set List
e Client Hosts By Card Set

View > Card Sets > Card Set List
Card Set Summary page
Navigational links:
Set Name > Card Set Detail page
Client Host count > Client Hosts By Card Set page
View > Card Sets > Client Hosts By Card Set
There are <n> client host(s) with this cardset page
Expand the pane:
Navigational links:
Name > Client Host Detail page
HSMs > HSMs By Client Host page
Alarm count > Current Unacknowledged Alarms page

Securnty World > Secunty World Detall page

9.2.6. View > Security Worlds

View Security Worlds has five destinations:

Security World List
HSMs By Security World
Client Hosts By Security World

» Keys By Security World
Card Sets By Security World
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View > Security Worlds > Security World List

Security World Summary page
Navigational links:
Name > Security World Detail page
HashKNSO > Secunty World Detail page
Client Hosts count > Client Hosts By Security World page
nShield count > HSMs By Security World page
View > Security Worlds > HSMs By Security World
There are <n> nShields in this security world page
Expand the pane:
Navigational links:
Serial No. > HSM Detail page
Alarm count = Current Unacknowledged Alarms page
Client Host(s) count > Client Hosts By HSM page
View > Security Worlds > Client Hosts By Security World

There are <n> client host(s) in this security world page
Expand the pane:

Navigational links:

Name > Client Host Detail page

HSMs count » HSMs By Client Host page

Alarm count = Unacknowledged Alarms page

View > Security Worlds > Keys By Security World

There are <n> keys(s) in this security world page
Expand the pane:
Navigational links:
Key Name/ldentifier > Key Detail page
Client Hosts count > Client Hosts By Key page
View > Security Worlds > Card Sets By Security World

There are <n> card set(s) in this security world page
Expand the pane:
Navigational links:

Set Name = Card Set Detail page

Client Hosts count > Client Hosts By Card Set page

9.3. View > Group > Group List

From the View tab, whether logged in as an Administrator or as a Group Manager
(or Auditor), you are able to navigate to the Group List page.

The Group List page provides:

* A group summary listing of groups configured in the virtual appliance

Utilization information

e Host command information

Overload information
* Alarm information

» Descriptive information.

o When logged on as a Group Manager, you can navigate through
the View menu to acknowledge alarms.

Monitor v2.9.7 Install and User Guide 81/205



Chapter 9. Views

The options provided in the View drop down menu is directly tied to your logon.

e Administrator
e Group Manager

e Auditor

The Auditor has the same views (that is, menu drop downs) as the Group Manager.
However, the auditor has no ability to perform any actions. For example, an
Auditor can not acknowledge alarms or enter comments, and so on.

9.3.1. Group List > Group Summary - Administrator

The Group Summary page provides an easy to use view that updates every 60
seconds as information is polled.

1. Navigate to:
Views > Groups > Group List

The Group Summary page opens.

When logged in as an Administrator, you can only view all
o groups. You cannot perform any other actions on these
groups.

Group Summary

A Group Name nshield Overlood Alarm nShield Client Hosts Descripfion

[izaneo | s [1]4]:] 0 °

0 [ pisasieo | [+ [ 1] ° 1
z [ Disasteo | 1 [2]2] ° °
3 [ oisasieo ] ooo ° o
4 [ pisasieo | ] o

As an Administrator, you are able to sort the data displayed.

Blue column headers indicate that the contents of the
0 column can be sorted. Black column headers indicate that
the contents of the column cannot be sorted.
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Group Summary

¥ Groyp Name nshield Overload Alarm nshield Client Hosts Description
Test u{t') 0 ]
= 0% | 45 [+ ]2]30] § !
[orsnateo ] o o
aoo 0 0
[ o1sanieo | [+ [2]2] E o

2. Toggle the sort, if needed.

3. Hover over an alarm total in the Alarm column to view the severity pop-up.

Group Summary

Q Search:
¥ Group Name nShield Overload nShield Client Hosts Description
e o= | & 1
[oisnsieo | 0 o
s [oisasieo | 0 o
D ° o

9.3.2. Group List > Group Summary - Group Manager
When logged in as Group Manager, all groups assigned to you are listed.
1. Navigate to:
Views > Groups > Group List

The Group Summary page opens.

Group Summary

Q Search:

¥ Group Name nshield Overload Alarm nshield Client Hosts Description
Test Vps [ Disasien | 0 0

= @oamo : 1

‘ [oisanieo | ° o

3 [oisasieo | oon ° °

- [+ [2]2] E °

9.3.3. Group Summary page - Navigation options

The Group Summary contains three navigation points.
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Selecting any one of the following opens a new page:

* A specific Group Name

¥ Group Name nShield Overlood Alarm nShield Client Hosts Descripfion
[osanio ] o 0
a @ooo ‘ 1
[osamieo ] o 0

The Group Detail page opens.

evious Page

Group Detail For : Test Vp$

nShield HSMs »

» A specific Alarm

¥ Group Name nShield Overload Alarm nShield Client Hosts Description

Test Vp3 [ pisasiep | 0 o

sz [0 ] 2] s0] ¢ !
i ci o o

:  oisasteo | ‘aoD ° °

The Current Unacknowledged Alarms page opens.

Current Unacknowledged Alarms

Q Severty: CRMCAL @ JEEC: T S T

O  Date/Time Severity Message

' 2018-12-08T10:07:1 65167 The connection status i now unreachoble for nShisld medule, 10.1.3.78 in group: nihisld
L]

2018-12-08T10:07:16.516L The connecfion status is now unreachable for nShield module, 10.1.3.72 in group: nShield
O 2018-12-08T10:07:16.5162 The connection status is now unreachoble for 10.1.7.212- 10.1.7.212 in group: nShield
O  2018-12-08T10:08:14.9162 The connection status i now unreachable for nshisld medule, 10.1.3.77 in group: nShisld

O | 201812-08T10:07:16.5161 The connection status 5 now unreachable for nshisld module, 101371 in group: nShisld

rows per page. First Poge | & n 23 = lostPoge 45 Total rows . Fagel:l of 9.

Acknowledgement Comments | Optional |:

Acknowledge Alorm  [EeETRE ]

You can acknowledge the alarm by checking the box to open the
Acknowledge Alarm page.

* A specific entity
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Group Summary

Q Search:
4 Group Name nShield Overload Alarm nShield Client Hosts Descripfion
[ pisanien | (o [1]2]5] 0 :
[ pisasieo | [+ [ °
[ pisasteo | oaa 0
3  Disastep | oon 0 ®
[ oisaeieo | 0 o

The Client Hosts By Group page opens.

Client Hosts By Group

Q CELAlLc) Seorch:

10 ~ There are 1 client host(s) in this group.

Q Search:

Name Monitoring Hardserver Commands HiMs Alarm A Last Security HSMs
Status Last Hr. Update Locafion = World Failed

ecevee | (NG OGN @ aoo

9.3.3.1. Alarms Acknowledgment Views
1. Navigate to:
View > Groups > Group List

The Group Summary page opens.

Group Summary

Q Search
A Group Nome nShield Overlood Alorm nShield Client Hosts Descripfion
=) aooa 0 °
[ oisasteo | oo 0 1
- [ oisasieo | [+ [2]2] 0 °
: [ Disasieo | Doo ° °
4 [ oisasien | 0 o

2. Select any number in the Alarm column.

3. After Current Unacknowledged Alarms page opens, optionally enter a
comment and then select Acknowledge Alarm.
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Current Unacknowledged Alarms

a search

O  Date/Time Severity Message

O  2018-12-06T1£:09:10.5107 The connaction status is now unreochable for testastdevice? - 152.168.114.113 in group: |
B 2018-12-04T14:07:50.7502 The connection status is now unreachable for testdevice ] - 192.168.122.121 in group: 1
[m]

201 8-12-05T14:34:28 34287 The connection status is now unreachable for 192.168.17.188 - 192.148.17.188 in group: 1

£ inowiedgement Camments | Opfional |:

Acknowledge Alam Concel

e Selecting multiple boxes allows you to simultaneously
acknowledge multiple alarms.

o If you click directly on the Alarm Severity (for example, click
directly on CRITICAL), the Acknowledge Alarm page opens.

acsmear ACknowledge Alarm

Alarm Date/Time:

| 2017-05-24T15:08:37 4611 |

Alarm 1D

| AVWTSGDnCRVDaMATZEH |

Alarm Message:

| The connection status is now unreachable for nShield mod

Acknowledgement Comments | Opticnal ):

Acknowledge Alarm Cancel

4. Enter comments (optionally) and then select Acknowledge Alarm.

9.3.3.2. Navigating to the Group Detail page
1. To get to the Group Detail page, navigate to:
View > Groups > Group List

The Group Summary page opens.
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Group Listw®  HEMs By Group <
Group Summary
=3 search: . Add
A payshield payshield payshield nshield Alarm payshield nshield client
Group  Utilization Host Overload oOverload Hosts  Descripfion
Name Command
con = 0@ B3 B @@ - P P
1 Group 1
con o @ (@ @ @O0 s 1 mes
2 Group 2
cor  »  (E3 (@ (@ 0OO@ - o 1 mes
3 Group 3

2. From the Group Name column, select a group. The Group Detail page for the
selected group appears. For example:

Group Detail For : 1

nshield H3Ms »

9.3.3.3. Filtering Group Detail - Group Average, Top 10, or Custom

Each window on the Group Detail page can be filtered based on Group Average,
Top 10, or based on a Custom list of devices. For example:

nshield HSMs »

Each of these views shows the average of the data collected for the interval
period selected (5 minutes, 15 minutes, and so on).

Line colors in the chart are used to designate a specific device.
o Click on the items in the color index, (for example, specifically on
"MAX", and/or on "Group 1") to toggle the display options.

nShield Monitor can provide the maximum data point that
o occurred in a selected interval period. The utilization chart
provides a red line to show a maximum data point as well as a

time stamp to show when that maximum utilization occurred.

» Select the drop down arrow on the time period bar to modify the time period
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being viewed.

0 ‘ The Custom Range selections are in the

e Use the sliding mechanism to change the intervals.

5 mins

E | i il | —.—o—.—o—o . .

15 miinz 1 min

Example of Custom:

Group Detail For: 10

Group Averoge

Customize the Device list

Click o device in either selection box to mowve it fo the other one_

Any changes made wil not take efect untifyou cick the Apply button.

Ielected devices Available devices

testdevicel

[2]

10 nShield Commands Count, Last Hour

Select in the selection box to move it from one box to t
Select Apply to confirm the change.
Select Close to return the to Group Detail page.

Select the expansion arrow to open a Group Detail pag

UTC time zone.

he other.

e, as needed.
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Client Hosts =

Group 1 Command Count, Last Hour

125k

——————

Cemmands count

Ok
1415 14:20 14:45 15:00
B (- |

15 rmins 1 min

Q Search: m

Commands Alarm Security World
Name  Last Hr. Description
Faisal [1]2] COT6CTA5Sfes419C38778e34c48cabact]

rosal (@ @om
W2
CH1

6 ‘ Each graph can be printed or exported in CSV.

Print chiart

Downlood S8V

9.3.3.4. Group Detail page - Client Hosts

The Client Hosts window displays:

e Graphed command count based on command count per time block:
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Group Detail For : 10

Selected devices

Any changes made wil nat foke effect unfl you click the Apply button.

‘Customnize the Device list

Click a device in either selection box to move it to the other one.

Avoiloble devices

tesidevicel

H | Last 24 Hours

Client Hosfs =

10 nShield Commands Count, Last 24 Hours

Commands Last Hr.

5 mins
|
& hours 5 mins
Alarm 4 Descripfion Security World

apa seszimton

* Clicking on the device name opens the Client Host Detail page for that

device.

9.3.3.5. Client Host Detail page - Overview

Select the expansion arrow to open the windows.
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Client Host Detail for : Faisal CH 2

IP Address/Host Name : "10.1.7.212"

Performance »

Health »

Applications with Active Connection to Hardserver »

Security World Info »

nShield HSMs »

nShield Card Sets »

nShield Keys »

9.3.3.6. Client Host - Performance window

Performance «

Faisal CH 2 Command Count, Last Hour

400k

200k

Commands count
5
=
H

100k

Ok
n 17:10 17:15 17:20 17:25
H | Last Hour | -.—.—.—.—o . .

15 mins 1 min

9.3.3.7. Client Host - Health window
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nonitoring:

Status:

Hardserver status:

Mumber Of HEMs:

Applicotions With Acfive Connecfion To Hardserver:
nedules Failed:

Hardserver Version:

Hardserver Port:

Hardserver Upfime:

[unninG ]

L

-4

2921
F004

46 Days : 13 Hours © 34 Minutes : 06 Seconds

9.3.3.8. Client Host - Applications with Active Connection window

Apphcations with Active Connection to Hardserver -

Q, search:
connection upfime Command Reply
Number Count Count

46 Days 13 [ 0 | 167495531

Houwrs : 36
Minutes 2 08
Taconds

4 45 Days < 15 [ o0 | [ o |

Hours : 36
Minutes 06
E=aconds

5 46 Days 15 [ o | [ o ]

Houwrs : 38
Minutes 2 08
Zaconds

[

Remaote Frocess | Frocess Tohal

IF Address | ID Mame Object
Count

0.0.0.0 ]

0.0.0.0 o llegacy]

0.0.0.0 o llegacy]

e Click on the blue columns to reverse the sort order, based on preference.

» Select a specific Connection Number to open a the connection’s Application

Details page.
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Application Details for :

Application Connection Mumber : "3"

connection Number: 0 Days : 00 Howrs : 00 Minutes : 05 Seconds
Uptime: A0D4447

Command Count: n

Reply Count:

Remote IF Address: 0.0.0.0

Process |D: o

Process Name:

Total Object Count:

nShields ~

(o} search:
Serial Type Mode mMonitoring Module Object Count
£577-7 4B4-30FF CONNECT OPERATIONAL Enm B
F9P-745F-4255 CONNECT OPERATIONAL Ex [ o]

¢ Select a specific Serial number to open the HSM Detail page.

SM Detail fo 74B4-30FF
Managed By Groupls) : "Group 1, Group 2" IP Address :"10.1.3.71"

Performance »

Configuration »

Health »

Secunty World Info »

Client Hosts »

Applications with Active Connection to Hardserver »

9.3.3.9. Client Host - Security World Info window

Securty World Info -

Security World Nome: cO76cTa5f5fetd 1P 36T TEeddc doabacar 57 2fd
security World State:

hashKNsO: cOFacTdsisiesd 19 o3ETFEeSdcLBoabacar 57 2fd
hashkmm: 111d30ef3fo341 2e20637F 721761 40001 362126
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e Select the Security World identifier to open the Security World Detail page.

urity World Detail For : c076c7dd

Edit Security World Name

Health »

Security World Quorum »

Client Hosts »

nShield H3Ms »

Keys »

Card Sets »

9.3.3.10. Client Host - nShield HSMs window

nShield H5Ms ~
Q search: Add
Serial No. Type Mode Commands Last Hr.
S67F-T 4E4-30FF CONNECT OPERATIONAL
£FP0-T4EF-4008 CONNECT CPERATIONAL [ 5025 |

¢ Select a specific Serial Number to open the HSM Detail page.

HSM Detail for : 9FC6-3000-53C9
Managed By Group(s) : "Group 3" Senal Mumber : "3FCé
Performance »
Configuration »
Health »
Secunty World Info »

Client Hosts »

Applications with Active Connection to Hardserver »

9.3.3.11. Client Host - nShield Card Sets window
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nShield Card Sets ~

Q Search: Add
set Nome Client Host Count Generation Time
cmocdl z 2016-07-16T23:47:30.4730L
ool ] 2016-05-15TIB1 7207128

» Select a specific Set Name to open the Card Set Detail page.

Card Set Detail for : ffocl

Guorum Count (k):

2016-08-24T1905:11.811

Securty World Info »

nShield Keys Protected By This Card Set »

Client Hosts »

9.3.3.12. Client Host - nShield Keys window

nShield Keys -

Q search: Add

Key applicafion Client
Nome Haosts

Key identifier/Nome Key Hash

fic27 556011747 20804050251 Seafe 53crs4efa 1i3c2fezsifeledTbIba 1 ecd 1456651 bEbecaZdR =mioed ES
3193590003047 cbel 45e7ecdbeds7anariess | 42Pce 1820080507 cb0EEe64P5512d411812317 | embed 3
Ll 7386CC17DCAYS7 asFafseli7 4166207l Dadeafi simpie 3
fiz baofafad 157154820278052584560007 s708adee | simple 3

« Select a specific Key Identifier/Name to open the Key Detail page.

Key Detail for : 6ffc2 b4a3d2515eafe

Ediit key Name

Key Application Name :
Key Identifier/Name :
Key Hash

Key Protecfion

Key Recovery

Time Limit :

Generafing Module ESN :

Frotecting Cardset Hash ©

Secunty World Info »

Client Hosts »

Fre-authenficafion Use Time Limit -

emoed

&fic2r 556011747 2cE04a3d|

1fscxfszs1fafenrbsnsiecyd

MODULE

ENABLED

]

]

Not availabie

9.4. Additional Views available to the Group Manager
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The View drop down menu provides several additional options that are not offered
to the Administrator:

Groups
HSMs
Client Hosts

* Keys
Card Sets

Security Worlds

9.4.1. Groups

1. Navigate to View > Groups > Client Hosts By Group

2. Select Client Hosts By Groups.

The Client Hosts By Groups page opens.

Client Hosts By Group

a Search
" Monitoring Hardserver Commands  HsMs Alarm  Lost Security World
Name status Last Hr. Update | Location
O3 @@ @ O o
OIm a : @ e
o MEEDD S O 2 [2]
<

Group 2, There are 2 client host(s) in this group.

The Client Hosts By Group page contains three navigation points. Selecting any
one of the following opens a new page:

* A specific device name.

The Client Host Detail page opens.
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Client Host Detail for : Faisal CH 2

IP Address/Host Name - "10.1.7.212"

Performance »

Health »

Applications with Active Connection to Hardserver »

Secunty World Info »

nShigld H5Ms »

nShield Card Sets »

nShield Keys »

* A specific Alarm

Alarm

%?n
[ 1182 |

‘aa

The Current Unacknowledged Alarms page opens.

ent Unacknowledged Alarms

a severty: CRMCAL E) JECR S

Date/Time severity Messoge
2017-01-31T01:23:34 4771 [y The connection stafus E now wnreachable fl

() 2017-01-10T21:13:13.5502 [Ny | The connection status & now unreachable fl

» A specific Security World

Security World
cc.‘.fc.‘ﬁ"e&1?:56.‘"EaE-i:aE:c::—::lc::l,'-E'P:"c:
07 sc7dmsietd | Po38778a34c 48cabocar 5P 2fd

The Security World Detail page opens.
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Security World Detail For : c076c7d515fe841

Edit Security World Name

Health »

Security World Quorum »

Client Hosts »

nShield H5Ms »

Keys »

Card Sefs »

9.4.2. View > HSMs > HSM List

1. Navigate to Views > HSMs > HSM List.
2. Select HSM List.

The HSMs Summary page opens.

With the HSM Summary page open, you can toggle between views by selecting
Client Hosts by HSM. See the upper right hand corner of the screen.

H3M Summary

nshield HiMs

& Serial No. Type Monitoring Commands Last Alarms Security World Chent Host Lost
= o o

(=)

0305-02E0-DF47 | CONMECT

Mode
[0 ] 07 6cTa5tSfeB4 190387 B2 4gd5cabocaTSeRd | 1 Curent
pL=3
2805-02E0-DF4MA, CONNECT B a [+ [1] 07 Sc7di5H5feB419 287 TEe 3 4c 45cabo oo MG Curent
6695-TABA-30FF | COMMECT [ 14| ED BIDD  -07ic7oststeEa190387 7B 4 B abocaT50Rd | 1 Cument
EFP9-TABF-4298  COMMECT [ 14] [ 3217 ] BB -07sc7astsi=6419o367 T834c48cabosal 5920 | 1 Curent
B564-61C5- CONMNECT a [ 2737 | [« [1] cO74cTaSiSfeB417c387TontdcdBcabocaTsiRid | | Cument

7IF2

On this screen:

* A colored column heading indicates that filtering is available.
¢ A blue icon or blue text indicates that an action is available.

¢ You can select individual devices to open new windows.

For example, select a security world to display the Security World Detail page.
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Security World Detail For : c076c7d

Edit Security World Name

Health »

Security World Guorum »

Client Hosts »

nShield HSMs »

Keys »

Card Sets »

9.4.3. View > HSMs > Client Hosts by HSM
1. Navigate to Views > HSMs > Client Hosts by HSM.
The Client Host by HSM page opens.

2. When hovering over the text turns the text blue, click to expand.

[ on e oo oty i e e

A details window opens:

HSMList  Ciient Hosts By HSMv?

Client Hosts By HSM

Q Search: Add
A Name Monitoring Hardserver Commands Last ~ HSMs  Alarm Last Update Security World  HSMs

Status Hr. Location Failed
om o s CIEDE o home  Secuttyvord Fobe
Simulator 20717:21:29.7371 one

This detail window has 4 navigation links as summarized in the following

table.
Links on the Details window
Clicking Opens this page Notes
Name See Client Host Detail page
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HSMs count nShield HSMs page. The nShield HSMs page also
This page lists all the HSMs by contains a link under the
Serial Number Security World column. Clicking

on the Security World identifier
opens the Security World Detail

page.
Alarm Current Unacknowledged Alarm Select the box associated with
(hover over the colored alarm the alarm to open the
total box in the Alarm column, Acknowledge Alarm window.
then click.)
Security World (name or Security World Detail page.
HashKNSO)

9.4.3.1. Client Host Detail page

Select the expansion arrows to open additional windows.

Client Host Detail for : Faisal CH 2

IP Address/Host Name - "10.1.7.212"

Perfermance »

Applications with Active Connection to Hardserver »

Secunty World Infa »

nShigld H3Ms »

nshield Card Setfs »

n5hield Keys »

Performance window:
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Performance ~

Faizal CH 2 Command Count, Last 30 Days

Commands count

ok e —
E. Mar 13. Mar Z0. Mar 27. Mar

E | Last 30 Doys |

1 howr

1 wesk

1 howr

Health window:

Moniforing:

sttus: [avaiiswur

Hardserver status: | RUNNING |

Humber OF HEMs: 3

Applicafions with Active Connection To Hardserver: T

Modules Failed:

Hardserver Version: 2.92.1

Hardserver Port: 004

Hardserver Upiime: 48 Days - 17 Hows © 47 Minutes ; 57 Seconds

Applications with Active Connection to Hardserver window:
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Applications with Active Connection to Hardserver =

Q Search: Add
" Upfime Command Reply Remote Process | Tofal Object
‘Connecfion ‘Count Count IF Frocess = Name Count
Number Address | ID
3 ssoayss17 | @ 173857643 JTIT o Hat available

Hours © 49
Minutes - 57
Seconds
4 ELUCER R o | [0 ] 0.00.0 o ===l kot ovaoilobie
Hours : 49
Minutes © 57
Saconds
= LR o | B 0.00.0 o ===l kot ovaoilobie
Hours : 47
Minutes @ 57
Saconds
£ 4B Days: 17 n n 0.00.0 o ==l kot ovailoble
Hours © 47
Minutes - 57
Seconds
72561 seDoys:23 | ([ENELEE) 20478471 0.0.0.0 o Mot ovoiloble
Hours : 27
Minutes - 57
o ——

Security World Info window:

Secunty World Info -

Security World Name: cOT6cTa5f5fed41 o367 76e34c4Beabaca7 572 d
security world state:

hashkMsO: cOrécTosisfesd FosETTERS4c4ECcODaCaTSPEfa
hashKm: 111030bf3fc3d 2e20437e97e1 761 40001 362128

o Clicking on the Security World identifier (for example, cO76cd...
.), opens the Security World Detail page.

nShield HSMs window:

nShield H5Ms ~

Q search:
sernial No. Type Mode Commands Last Hr.
£575-T4B4-30FF CONNECST [ se93 |
£FFD-T4BF-4275 CONNECT [ casa |
F45C-32CE-3E0F CONNECST [ 2195 |
e

nShield Card Sets window:
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nShield Card Sefs ~

Q Search:

set Name Client Host Count Generation Time
cmocdl 2 2071£-07-1 6723473047300
ool 3 201605 15TIB 7217122
oo 3 201405 15T23:07:15.7151

o ‘ Selecting a set name, opens the Card Set Detail page.

Card Set Detail page:

Card Set Detail for : cmocO]

Health »

Securty World Info »

nShield Keys Protected By This Card Set »

Client Hosts »

Select the expansion arrows to open additional windows.

nShield Keys window:

Q Search: Add

Key idenfifier/Name Key Hash Key Applicafion Client
Name Hosts

AHe27 8840117 4720804030251 Seafesicpiiaia 1f3c24423118fe07 D303 1 2ca 145448 1 DBaca2dl amped @

afa3193502003047abel 45eTecabedd?apariess | 429cel200f050TcD0BSed475510a041{1810217 embed 3

i1 7384cc1Tboararasralsdiridsszore i pasaall simple 3

ffa baofafad 197154820 008082354 540007 4Pa8adee | simple 3

ffa 1408400D4309081 00F 0037 4c05440532cD1Pc808 | simpie 3

This window has two navigational links.

Selecting the Key Identifier opens the Key Detail page:

Health »

Secunty World Info »

Client Hosts »
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Selecting the Client Hosts number opens the Client Hosts By Key page.

Client Hosts By Key

. Name- &fc2755401 7747 2080403d25] Seafe53cssdatd @ Secrch:

46ffc275560117472c8b4a3d251 5eales3dc?64eld -~ There are 3 client host(s)
with this key.

Q search: m

A Ci H3Ms  Alarm Last Security World

Mame Status Last Hr. Update  Locafion

Faisal [ rumninc WY 5720 | 2 B Cument c074cT dSSfal419c38778=34

CH1

Faisal [ Runnine QN 13729 | 3 a8 Cument 07407 4553417038778

CH2

Faisal [ runnine [ sse7232 [ EBDED  curent cOT&cT dSISTea417o38778e3
w2

CH1

9.4.3.2. Navigating to the Security World Detail page
1. Select a Security World name.

Security World Detail page opens.

Security World Detail For : c076c7d5fafei

Health »

Securty World Guorum »

Client Hosts »

nShield H5Ms »

Keys »

Caord Sets »

2. Select the Health expansion arrow.

Genenafion Time: 201 6-01-25T00:00:00.002

Genenafing Module ESN: BSEA-E1CP-TIFE

hashkNsC: cOFécTasisie8d] Po3ETTEes4c4Bc0bacar 57
hashkm: 11123dbf3fc3412e2d43729721941 4000 1 342128

3. Select the Security World Quorum expansion arrow.
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Secunty World Guorum -

KNSO Guorum 1
Total Humber OF Admin Cards 3
Module Reprogramming (KM) Guorum 1
Recovery (KR) Guorum 1
Passphrose Recovery (KF) Guorum 1
NVRAM Avthorization [KNV) Guorom 1
RTC Awthorizafion (KRTC) Quorum 1
SEE Debuvgging Avthorization (KDSEE) Guorum 1

Foreign-Token Avthorizafion (KFIF) Guarem 1

4. Select Client Hosts

Chent Hosts =

Q Search:
Mame Hardserver Status Commands Last Hr.
Faisal CH 1 | RUMMING ] 8741
Faisal i 2 [RunbinG | (15002 |
Faisal W2 CH1 [ RUMMING ] [0 ]

The Client Hosts window has one navigational link.
5. Select a name from the Name column (for example, click on Faisal CH 1)

The Client Host Detail page opens:

Client Host Detail for : z

IP AddressfHost Name - *10.1.7.194"

Performance »

Applications with Active Connection to Hardserver »

Security World Info »

nShield HSMs »

nShield Card Sets »

nShield Keys »

9.4.4. View > Keys

9.4.4.1. Key > Key List

1. Navigate to Views > Keys.

2. Select Key List.
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The Key Summary page opens.

Key Summary

Q Search: Add
Key Name/Identifier ¥ Key Hash Eey Application Name Client Hosts
mycintlkeyl fo008ee80db3Bbadcsf?98a5deccc229bd4bdbl0 smple 3
training T002346567eec4 ] 1e4c04 6600208592 77 46e6e ample 3
nirav 237802af?d2eP5ceefbdfabb ] ded1f0533c9ff5a dmple 3
fisimpleffocs =3560ba57b1a1d61dc3070ddPIRssifdybarase smple 1
ffkeysimpleoug242016 ©c13803c17b133fcSbof83a) #72397ae261 Pedis dmple 1

The Key Summary page has two navigation links:

- Key Name/Identifier
> Client Hosts
3. Select a Key Name to open the Key Detail for page.

Key Detdil for : mycintlkeyl

Edit Key Name

Health »

Security World Info »

Client Hosts »

o Should you need to Edit the Key Name, Select Edit Key
Name, rename the key and then select Save.

4. Select the expansion arrows to open the windows.

Blue font indicates that the text is a link. Click on the blue
text to drill deeper. For example, click on Faisal CH 1to open
the Client Host Detail page.

Health:
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Health «

Eey Applicafion Name :

Key Identifier :

Key Hash :

Key Protecfion :

Eey Recovery :

Time Limit :

Fre-authenficafion Use Time Limit :
Generafing Module ESN :

Protecting Cardset Hash :

simple

mycintTkeyl
fo0082e80db38ba3céfPP8a5deccc229bd4bdb10
MCDULE

EMABLED

4]

0

Mot available

Security World Info:

Security World Info -

Security World Name:
Security World State:
hashKNSO:

hashKM:

<07 $c7dSi5fe8419038778e34c48cabacar 592fd

OFERATIONAL

07 6cTd5f5feb419c38778e34c4Bcabaca? 592fd

111d3dbf3fcd4] 2206379721961 4baal 362128

Client Hosts:

Client Hosts =

Q Search:

Name
Faisal CH 1
Faisal CH 2

Faisal 3W2 CHI

Hordserver Status ‘Command Last Hr.
[ezas01s ]
connam |

9.4.4.2. Keys > Client Hosts By Key

1. Select Client Hosts By Key.

The Client Hosts By Key page opens.
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Client Hosts By Key

Q Search:

Client Hosts By Key

Q Search: m
i Monitoring ~ Hardserver  Commands  HSMs  Alarm  Lost Security World

Name Status Last Hr. Update Location

Fasal | ([EIENEEN 2 B Cument cO076cTdSiSfe419c38778234c48car
CHI

Il enacieo M sunminc Qi a2455:c JIE] BBA cuent CO76c7dI5i5feB419c 38778 34c48cat
CH2

2. When hovering over the text turns the text blue, click to expand.

3. Select a device.

A Monitoring  Hardserver Commands HSMs  Alarm Last

Name Status Last Hr. Update = Llocafion
ool [OUEE] COOOCS EX@  : @ Cuen

CH 1

Y o oo s G e

CH2

fool | (CTEY (IS : @0 cwent

SW2

CH1

Security World

c076cTd5f5ieg414

cl76cTdsfsfed419

c076c7d5f5ieg414

The Client Host Detail page opens.

Client Host Detail for : Faisal CH 1

IP Address/Host Name : "10.1.7.154"

Performance »

Applications with Active Connection to Hardserver »

Security World Info »

nshield HSMs »

nsShield Card Seis »

nShield Keys »

4., Select the expansion arrows to open the windows.

Performance:
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Faisal CH 1 Command Count, Last Hour

600k

500k

400k e

200k

Commands count

200k

100k

ok
19:20 15:35 19:40 19:45
H | fot ot | _._._._._o . °

15 ming 1 min

Health:
Mornitoring:
status: [svaiswwe |
Hardserver Status:
Number Of HSMs: 2
Applications With Acfive Connecfion To Hardserver: 5
Modules Failed: [ TRuE |
Hardserver Version: 2921
Hardserver Port: F004
Hardserver Upfime: 45 Days : 20 Howrs - 49 Minutes : 18 Seconds

Applications with Active Connection to Hardserver:

Applications with Active Connection to Hardserver «

Q Search: m
A Uptime: Command  Reply Remote Process Name Total Object
Connection Count Count IF Process Count
Number Address  ID
450as:20 @) 0000 o
Hours : 49
Minutes : 18
Seconds
s ssoov: | @ o 0000 0 | fegacy
Hours : 43
Minutes : 46
Seconds
w5 4ionco GEENES EGEEE) o000 o
Hours - 03
Minutes - 14

Security World Info:
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Security World Info +

Security World Name: <07 o7 dbf5feB419038778234c4Bcabacar 592fd
Secuty Word site:

hashKNSO: cO78c7dofSfeb419c38778e34c46cabacar 572id
hashkKM: 111d23d0f3fc341 22244637 207219461 4bon 1342128

nShield HSMs

nShield HSMs ~
Q Search: . Add
Serial No. Type Mode Commands Last Hr.
9FC4-3000-53C9 S0LO [ 2378 |
F48C-82C8-3E0F COMNECT

nShield Card Sets:

nShield Card Sets «

Q Search:
Set Nome Client Host Count Generafion Time
ffocl 1 2016-08-24T19:08:11.8112
ocl 3 201603-15M 871217122
oc2 3 201603-15T23:07:15.7152

nShield Keys:

nShield Keys ~

Q Search: m
Key Idenfifier/Name Key Hash Key Client
Applicaion | Hosts
Name
&ffc27556017 47 2c8b 4030251 Seafe53cPsdefd 113c2f6231f8fe07b3b31 ecd 1456451 088eca2d2 embed 3
8fd3193592003b47abe 45e7ecdbedd7dbalfe5s | 429ce] 82009a5b7cbi83es4f9551eds1f181e317 | embed 3
il 7386cc17boa?37d5PdiSsfi7 4788207 ¢ 1bdBedif simple 3
ff2 bdbfdfa419715482c298d823845600074908ddes | simple 3
3 16084dabs309081 do%0a374c0544b832cb19c8a8 | simple 3

9.4.5. Card Sets

1. Navigate to Views > Card Sets.
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9.4.51. View > Card Set > List
1. Navigate to Views > Card Sets > Card Set List.

The Card Set Summary page opens.

Cord Set Listy*  Client Hosts By Card Set

Card Set Summary

Q jearch: m

¥ Set Name Client Host Count
oc? 3

ocl 3

ffocl

cmoci] 2

2. Select a Set Name to open a specific Card Set Detail page.

Card Set Detail for : oc2

Health »

Security World Info »

nShield Keys Protected By This Card Set »

Client Hosts »

3. Select the expansion arrow to open the windows.

Health:

hashELTL: S1oabéc4ai?clios?sc2c3df4Bdosd | fic24f804a
Quorum Count (kK): 1
Total Number Of Cards{N): 1
Timeouwt : 0

Generation Time : 201 4-03-15123:07-15.7157

Security World Info:
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Security World Info ~

Security World Name: cO756c7d515feB41 Pc38778e34c48cabacar 592fd
Security World State:

hashKNSO: cO74c7d5i5fef4) 9c38778234c48cobacar 592fd
hashKM: 111d3dbf3ic341 2220437 29721961 40001362128

nShield Keys Protected By This Card Set:

nShield Keys Protected By This Card Set =

@ There are no keys to display.

o ‘ When there are no keys to display, the system indicates such.

Client Hosts:

Client Hosts =
Q Search: : m

Name Hardserver Status Command Last Hr.
Faisal CH 1 [ RUNNING ]

Faisal CH 2 | RUNNING |

Faisal SW2 CH1 [ unminG |

9.4.5.2. View > Card Sets > Client Hosts By Card Set
1. Navigate to Views > Card Sets > Client Hosts By Card Set.

The Client Hosts By Card Set page opens.

Client Hosts By Card Set

Q Search

cmoc01 » There are 2 client host(s) with this cardset.

ffoc1 » There are 1 client hosi(s) with this cardset.

ocl » There are 3 client host(s) with this cardset.

oc2» There are 3 client host(s) with this cardset.

2. When hovering over the text turns the text blue, click to expand.

Monitor v2.9.7 Install and User Guide 112/205



Chapter 9. Views

Client Hosts By Card Set

Search

cmocO0]1 ~ There are 2 client host(s) with this cardset.

'y Monitoring  Hardserver Commands HSMs  Alarm Last Security World HSMs
Name Status Last Hr. Update Locafion Failed
Faisal | runminG | 3 BB curent 74T d5M5ieB4 190387 78e34c48cabaca?592id | False
CH2
Faisal [ runnine Il 1310417 IS B curent ©076c70515/e8419038778e34c48c0baca?592(d | False
SW2
CHI

3. Continue to click on the blue text to drill deeper.

For example, clicking on the Security World identifier opens the Security World
Detail page:

Security World Detail For : c076c7d5fofed41

Edit Security World Name

Health »

Security World Quorum »

Client Hosts »

nShield HSMs »

Keys »

Card Sefs»

9.4.6. Security Worlds

9.4.6.1. Views > Security Worlds > Security World List
1. Navigate to Views > Security Worlds > Security World List.

The Security World Summary page opens.

Security World Summary

Q Search: Add
& Nome HoshKNSO Client nShield Generafion Time Generofing
Hosts Module ESN
c074<7d5F5fe8419c 3677 24c4cabonal S92 | cT4cTdEFH=E419c387 T8 24cibcabacal5P2id | 2 12 01601- BI4A-51C5-
29700:00:00.000Z 7aF2
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2. Click on the blue text to drill deeper.

¥ Name HashKNSQ

<07 6c7d585f28419c38778234c4B8cabocar 592fd | o7 6c7d565fe8419c38778234c48cabaca7 592fd

For example, clicking on the Security World HashKNSO opens the Security
World Detail page.

Security World Detail For : cO76c7d5f5fei

Client Hosfs »

3. Click on the expansion arrows to open additional windows.

9.4.6.2. Security Worlds > HSMs By Security World

1. Navigate to Security Worlds > HSMs By Security World.

The HSMs By Security World page opens.

HSMs By Security Word

Q Search:

c076c7dofofe8419¢c38778e34c48cabaca/592fd ~ There are 4
nShield(s) in this security world.

Q Search: . m
nShield HSMs

s Type Mode Monitori Ci Alarms | Client  Last
Serial Objects = Last Hr. Host Update
No. (s)

s5- | coer | CENETS EXE @ [ T: JERRRE-RS
7484

30FF

& | CONNECT I3 @ B0 : e
74BF-

4298

2. When hovering over the text turns the text blue, click to expand.
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nShield HSMs

A Type Mode Monitoring Commands Alarms  Client  last
Serial Objects = Last Hr. Host Update|
No. )

6675 | CONNECT e m OO 2 e
74B4-

o7 | CONNeCT = @ [T JEREE

T4BF-
4295
o

3. Select a Serial Number to open the HSM Detail page.

HSM Detail for : 6699-74B4-30FF

Managed By Group(s) : "Group 1, Group 2" IP Address

Configuration »

Security World Info »

Client Hosts »

Applications with Active Connection to Hardserver »

4. Select the expansion arrows to open additional windows.

9.4.6.3. Security Worlds > Client Hosts By Security World
1. Navigate to Security Worlds > Client Hosts By Security World.

The Client Hosts By Security World page opens.

2. When hovering over the text, the font turns blue, click to expand.

Client Hosts By Security World

The page expands:
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Client Hosts By Security World

client host(s) in this security world.
Q Search:

Name Monitoring =~ Hardserver Commands HSMs Alarm
Status Last Hr.

Faisal CH RUNNING 4248634 3
JIESERECRE TN P 424554 | [ [2]

2

o [T CcZm : oo

SW2 CH1

fovl o+ | [ | NI : m

Last
Update
Cumrent

Cumrent

Cumrent

Location

c076c/dot5fe8419¢c387 7/8e34c48cabaca/592fd ~ There are 3

A HSMs
Failed

False

False

The blue font indicates that there are two links on this page. That is, data in

the name column, and count total in the HSMs column.
3. Select a specific Name. For example, click on Faisal CH 2.

The Client Host Detail for: Faisal CH 2 page opens.

Client Host Detail for : Faisal CH 1

IP Address/Host Mame - "10.1.7.1.54"

Performance »

Health »

Applications with Active Connection to Hardserver »

Secunty World Info »

nShield HSMs »

nShield Card Sets »

nShield Keys »

4, Select the expansion arrows to open additional windows.

5. Continue to click on the blue text to drill deeper.

9.4.6.4. Security Worlds > Keys By Security World

1. Navigate to Security Worlds > Keys By Security World.

The Keys By Security World page opens.
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Keys By Security World

Q Search:

c076c/d5t5fe8419¢c387/78e34c4Bcabaca/592fd ~ There are 15 key(s) in this

security world.

Q Search: .‘_;f;f
A Key Nome/ldentifier Key Hash Key Applicafion Client
Name Hosts

6ifc27 556011747 2c8b4a3d251 5eafe53cP6 113c2f6231151e0703b31 ecd1 456651088eco2d2 embed

E1d3193592003047abel 4587 ecdbedi7doariess  429ce182a070507 cb0BBes4f?551ed61flg1e317 embed
ffl 7385cc17bca?37 d50 547 4188207 o 1bdBedif simple

ff2 bdbfdfa4] 9715482c298d8238456b0074908ddes | simple

Both the Key Name/Identifier and the Client Host columns

e contain blue font. Blue font indicates an active link. For
example purposes, the following step selects the Key
Name/Identifier.

2. Select the Key Name/Identifier.

4 Key Name/ldentifier K

The Key Detail page opens.

Key Detail for : 6ffc275560117472c8b4a3d

Edit Key Name

Hedlth »

Security World Info »

Client Hosts »

3. Select the expansion arrows to open additional windows.

4, Continue to click on the blue text to drill deeper.

9.4.6.5. Security Worlds > Card Sets By Security World
1. Navigate to View > Security Worlds > Card Sets By Security World.

The Card Sets By Security World page opens.

Monitor v2.9.7 Install and User Guide

17/205



Chapter 9. Views

Card Sets By Security World

Q Search:

c076c7d5f5fed

Q Search:

A Set Name
cmocO]
ffocl

ocl

oc2

19c38778e34c48cabaca/592id

~ There are 4 card set(s) in this security wond.

Client Host Count

2

1

3

3

2. Select a Set Name to open the Card Set Detail page.

Card Set Detail for : cmoc01

Health »

Security World Info »

nihield Keys Protected By This Card Set »

Client Hosts »

3. Select the expansion arrows to open the windows.
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d Set Detail for : cmocO01

Health +

hashELTU: 1417ef??580bb2e1b30045fcddf 1 dié272024644
Quorum Count (k):

Total Number Of Cards(N): 2

Timeout : o

Generation Time : 201 6-09-18T23:49:30. 49307

Security World Info

Security World Name: c0746c7d5i5feB419c38778e34c48cabaca7 592id

Secuty Word site:

hashKNSO: 07 6cFd5f5ieB419c38778e34c48cabacar 572fd

hashkM: 111d3dbf3fc341222d4379721941 4baal 362125

nShield Keys Protected By This Card Set ~

O Theres are no keys to display.

Client Hosts

p |
wa
i
il
B

Name Hardserver Status ‘Command Last Hr.
Faisal CH 2 [aunninc ] =3
FiaiswzcHl (I =

4, Select the Client Host Count (from the Card Sets By Security World page).

Sets By Security World

c0/76c/7d5i5fe8419c387/78e34c48caba
There are 4 card set(s) in this urity word.

A Set Name Client Host Count
cmocOl 2

ffocl {b

ocl 3

oc2 3

The Client Hosts By Card Set page opens.
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Client Hosts By Card Set

Q (EielE)  Search:

cmocO1 ~ There are 2 client host(s) with this cardset.

Q Search

A Monitoring  Hardserver Commands HSMs  Alarm Last Security World

Name Status Last Hr. Update  Locafion

Foisol | ([ENXTEED | 13053 | 3 BB cuent GU76c7d5T5eB419c38778234c48cabacar 5721d
CH2

eIl crasico Qi cunnin | 2 ag curent 0767 d5f5feB419c38778234c48cabacar 502fd
sw2

CH1

HSMs
Failed

Falsz

False

5. Select Name to open the Client Host Detail page.

Client Host Detail for : Faisal CH 2

IP Address/Host Name : "10.1.7.212"

Applications with Active Connection to Hardserver »

Security World Info »

nShield HSMs »

nShield Card Sefs »

nShield Keys »

6. Select the expansion arrows to open the windows.
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10. Reports

With nShield Monitor, you can create pre-generated reports and send them to a
PDF file or export them to a CSV file. These reports can provide valuable
information pertaining to a specific HSM or group in near real time. You can also
schedule a report to periodically track a group or a specific HSM over time.

With the Reports feature you can track device utilization and loading trends, as
well as cross HSM (details per HSM as selected).

10.1. Generate Reports
1. Navigate to: Reports > Generate Reports

The Generate Report page opens.

Generate Report

Groups and Devices

Cancel Changes

2. Select the Groups and Devices drop down arrow.

The down menu opens.
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Generate Report

Groups and Devices -~

Select a Group :

Test VpS k
1

%
2
3 rt type :
4
10 ot Device Report

Cancel Changes

3. Select a Group. (In the example above, the Group is titled "nShield".)

The Group Report and Device Report options display.
o ‘ Follow this link to see the Device Report menus/options:

Device Report.

10.1.1. Group Report

1. Select Group Report
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Generate Report

Groups and Devices -

select a Group :

Shioid 1%

select a report type :

Group Report  Device Report

Cancel Changes

The Generate Report page opens.
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Generate Report

Groups and Devices -~

Select a Group :

nshield W

Select areport type :

Group Report #  Device Report

U (optional) Show Top 10 Devices.

Report Configuration ~

Utilization and Loading Trends Opfions -

Cancel Changes

2. Optionally, select Show Top 10 Devices to limit the report to the top 10

devices.

Group Report #*f  Device Report

B [optional) Show Top 10 Devices.

e You may need to scroll down the screen to access the
expansion arrows.

3. Select the Report Configuration expansion arrows.

The Report Configuration window opens.
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Generate Report

Groups and Devices -

Selecta Group -

slect arsport type :

Group Report »*  Device Report

[optional) Show Top 10 Devices.

Report Configuration -

Enter the report name : slect areport type - Select an output format -

| | | LHilization and Loading Trends
elect a delivery method - Select a report ofientafion |

® Portrait O Landscape

4. Enter a report name.

5. Expand the drop down arrows and use the radio button to set your report’s
specifications.

6. Scroll to the Utilization and Loading Trends Options window.

7. Expand the drop down arrow.
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Utilization and Loading Trends Opfions -~

Client Host Options

High Command Ceount Threshold :

78 ‘

Low Command Count Threshold :
B

nShield Options

High Command Count Threshold :

75 ‘
Low Command Count Threshold :
ENN

High Object Count Threshold :

75 ‘
Low Object Count Threshold :

EN

Cancel Changes

8. Modify the default settings, based on preference.

9. Select Generate Report.

10.1.2. Device Report

1. Select Device Report.
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Generate

select a Group :

nihield

Group Report

Client Hosts

Report

Groups and Devices -

select areport type.:

Device Report v

vicer rt, select a device fype :
For a device report, select a device type

nshields

Report Configuration -~

Cancel Changes

2. Select a device type.

Monitor v2.9.7 Install and User Guide

127/205



Chapter 10. Reports

For a device report, select a device type :

Client Hosts nshields

)

Report Configuration -

Caoncel Changes

o To see the flow for device type Client Hosts, go to: Device
report for client hosts.

The device selection window opens.
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Groups and Devices -

Group Report  Device Report «*

For a device report, select a device type -

Client Hosts  nShields «

Click a device in either selection box to move it to the other one.
Q Search:
Selected Devices Available Devices

Remaining Devices: 15

0305-02E0-D947 (10.1.3.78) (CONNECT XC)

2805-02E0-DP47 (10.1.3.77) (CONNECT XC)
6699-74B4-30FF (10.1.3.71) (CONNECT)
4F99-74BF-4295 (10.1.3.72) (CONNECT)
B56A-81C9-73F2 (10.1.5.49) (CONNECT)

F48C-82C8-3ED? (10.1.3.70) (CONNECT)

Report Configuration -

Loading Trends Options -

p
G

ancel Changes

3. Select, by single clicking, the devices from the Available Devices window for

inclusion in your report.

0 The click will toggle the device between the Selected
Devices window and the Available Devices window.

The selected device moves to the Selected Devices window.
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Client Hosts  nShislds «*

Click a device in either selection box to move it fo the other one.

Q Search:

Selected Devices

Remaining Devices: 14

[DSGS-GEED-D?-‘-!? (10.1.3.78) (CONNECT XC) ]

[added)

Report Configuration -

Loading Trends Opftions -

Available Devices

Asc W

2805-02E0-D947 (10.1.3.77) (CONNECT XC)

6699-74B4-30FF (10.1.3.71) (CONNECT)

GF99-7ABF-4298 (10.1.3.72) (CONNECT)

B56A-B1CY-73F2 (10.1.5.4%) (CONNECT)

F48C-B2C8-3EDY (10.1.3.70) (CONNECT)

Cancel Changes
0 You may need to scroll down to access the expansion arrows
for additional views.

4. Select the expansion arrow to open the Report Configuration window.
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Report Configuration -~

Enter the report name :

select areport type :

Loading Trends v

select an output format :

PDF Vv

Select a delivery method :

save fo Fle v

Select a report crientation :
® Portrait O Landscape

Select a schedule :

Dne-Timse v

select a fime/date range .

Last 24 Hours W

5. Enter the report name and select the drop down arrows to display additional
selections.

6. Select your preferences.

7. Select the expansion arrow to open the Utilization and Loading Trends
Options window.
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Loading Trends Opfions -~

nShield Opfions

High Command Count Threshold :

75 ‘
Low Command Count Threshold :
EN

High Object Count Threshold :

73 ‘
Low Object Count Threshold :

R

Cancel Changes

8. Set your preferences.

9. Select Generate Report.

10.1.3. Device report for client hosts

1. Navigate to: Generate Report > Groups and Devices > Device Report > Client
Hosts
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select a Group :

nshield

Group Report

Generate Report

Groups and Devices ~

select areport type :

Device Report ¥

Client Hosts

For a device report, select a device type :

nshields

The Client Host Cross-HSM device report supports 2,500

nShield keys. That is, the report limits the number of keys to

2,500 even if there are more keys on the client host.

2. Select, by single clicking, the devices in the Available Devices window to

move the device into the Selected Devices window.
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Select a report type :

Group Report Device Report ¢

For a device report, select a device fype :

Client Hosis #f  nShields

Click a device in either selection box to move it to the other one.

Q Search:

Selected Devices Avdilable Devices

Remaining Devices: 15 Serigl V] | ‘ Asc W ‘
Y

|
[ {10.1.7.212)

Report Configuration -~

e The click will toggle the device between the Selected
Devices window and the Available Devices window.

o You may need to scroll down to access the expansion arrows
for additional views.

3. Select the expansion arrows to open the Report Configuration window.
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Report Configuration -

Enter the report name :

select a report type :

Loading Trends v

select an output format :

PDF Vv

Select a delivery method :

Save to File W

Select a report orientation :
@® Portrait O Landscape

Select a schedule :

One-Time %

select g fime/date range :

Last 24 Hours W

Loading Trends Opfions -

4. Enter a report name and select the drop down arrows to display additional
selections.

5. Select your preferences.

6. Select the expansion arrow to open the Loading Trends Options window.
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Loading Trends Options -

Client Host

High Command Count Thresheold -

75

Options

Cancel Changes

7. Set your thresholds.

8. Select Generate Report.

10.2. Scheduled Reports

1. Navigate to: Reports > Scheduled Reports

Reports - Configura

| Zenerate Reports l

Scheduled Reports

The Scheduled Reports page opens.

2. Select the report name.
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Scheduled Reports

Q Search:

O A

Enabled Name

O ™ CH-R
=

O ch-uit
0O ™ devl
O ™ grpl

Group  Last Run
nShield 2018-12-
11T18:00:00.00Z

nshield 2018-12-
11T18:00:00.00Z

nShield 2018-12-
117T18:00:00.00Z

nshield  2018-12-
11T18:00:00.00Z

Next Run

2018-12-

11719:00:00.002

2018-12-
11719:00:00.00Z

2018-12-
11719:00:00.00Z

2018-12-
11719:00:00.007

Frequency

HOURLY

HOURLY

HOURLY

HOURLY

File

Type

PDF

PDF

PDF

PDF

The report page opens.

Download All
Q Search:
O A Ran At Download Type Status
O 2018-12-04T719:00:00.00Z Download Report PDF SUCCESS
O 2018-12-04720:00:00.00Z Download Report PDF SUCCESS
O 2018-12-04721:00:00.00Z Download Report PDF SUCCESS
O 2018-12-04722:00:00.00Z Download Report PDF SUCCESS
[} 2018-12-04723:00:00.00Z PDF FAILED |[No active devices found for this report)
[1 2018 12-.08T00-00-00 Q07 PDE EANED (Mo active devicae fonind for this renaort!]

10.2.1. Downloading individual reports

The report page also provides download links.
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Q Search:

Ol A Ran At Download Type Status
] 2018-12-04T19:00:00.00Z Download Report FDF SUCCESS
] 2018-12-04720:00:00.00Z Cownload Report FDF SUCCESS
] 2018-12-04721:00:00.007 Download Report FDF SUCCESS

1. Select Download Report.

The system prompts:

170104180001+0000--1.PDF (68.5 KB) 10.1.7.124

Open Save = Cancel

2. Select Open or Save.

When Save is selected, the system prompts:

The 170104180001 +0000--1 (1).PDF download has completed.

Open i Open folder View downloads

3. Select your preference.

10.2.2. Downloading reports in bulk
Selecting Bulk Download uses a toggle:

1. Select the check box of the first report to download.

Monitor v2.9.7 Install and User Guide

138/205



Chapter 10. Reports

The Bulk Download and Delete Report tabs activate as soon as you have
selected a report.

Bulk Download Delete Report(s)

Q Search:

@ A Ran At Download Type Status
[+] 2018-12-04T19:00:00.,00Z Download Report PDF SUCCESS
[+] 2018-12-04T20:00:00.007 Download Report PO SUCCESS
[v] 2018-12-04T21:00:00.00Z Download Report PO SUCCESS
vl 2018-12-04T722:00:00.00Z Download Report FDF SUCCESS
—
[1 2018-12-04723:00.00.00Z FDE FAILED (Mo active 4
To activate the Select All feature, select the box at the
0 header. This check box can also be used to clear you
selections.
o Conversely, you can click specific check boxes to customize
the download. The check box selection can be toggled.

2. Select Bulk Download to initiate the download.

The system prompts with (example):

2017-02-13T20_21_18.959Z Sample gro....zip (238 KB) 10.1.7.124

Open Save b Cancel

3. Select your preference.

10.2.3. Delete Reports
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1. Select the report(s) to be deleted.

Delete Report(s)

Q sSearch:

A Ran At

2018-12-04T719:00:00.007

2018-12-04720:00:00.007

2018-12-04721:00:00.007

2018-12-04722:00:00.00Z

2018-12-0472:3:00:00.00Z

I RS R B R S

2018 12 05TO0-00-00 007

Once the check box is selected the Delete Report(s) option activates.
2. Select Delete Report(s).

The system prompts for confirmation.

Download All Confimn Delete

Q, Search:

3. Select Confirm Delete.
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11. Alarms

11.1. General description

Alarms events must be acknowledged before they can be cleared. Until an alarm is
acknowledged it remains reported in the alarm totals.

For example:

Alarm

Alarms can be monitored actively and historically.

Active alarms (unacknowledged alarms) appear on the main menu by clicking on
the icon that looks like an exclamation.

% Dashboaord Wiews = Reports - Configuration = Lo

When there are any active alarms, this icon changes color to indicate the highest
alarm active.

Select the Alarms tab, in the main menu, to view Alarm History.

Alarms can always be exported, by selecting Export Alarm History (CSV) from the
Alarm History page.

11.2. Acknowledging alarms in bulk

1. From any Alarm count column, select the alarm total.
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Alarm

Viarning

The Current Unacknowledged Alarms page opens.

2. Select all the alarms that you want to acknowledge.

Current Unacknowledged Alarms

Date Time Severity
200 7-0N-Z3T A 4111 7182 | WARNING
200 7-0N-23T 41117152 m
201 7-01-23T20 41117112 m
201 7-01-23T 003618 4591 m

200 7-01-23T 038184887 | WARNING

?E]

3. Select Acknowledge Alarm.

Acknowledgement Comments | Optional |:

Acknowledge Alarm Cancel

)

11.3. Acknowledging an individual alarm
1. Navigate to: Alarms > Alarm History
The Alarm History page opens.

2. Select (that is, single click) on the alarms severity level.
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The Acknowledgment Alarm page opens.

iFel AcCknowledge Alarm

Alarm Date/Time:

‘ 2017-03-15T15:05:35.5352 ‘

Alarm 1D:

‘ AvVriglbgxH-kyRY2QB6g ‘

Alarm Message:

‘ The connection status is now SNMP accessible for Enhanced payShie

Acknowledgement Comments | Optional ):

Aclknowledge Alarm Cance

3. Enter any Acknowledgment Comments in, if needed.

4. Select Acknowledge Alarm.
The Alarm History page opens.

5. Select Export Alarm History (CSV). The file can now be saved or opened.
The system prompts asking if you would prefer to Open or Save the .csv file.

6. Select your preference.

Open Save =
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12. nShield CLI Commands

12.1. GUI initialization

Upon the startup of the nShield Monitor Virtual Appliance, the CLI will wait for the
GUI to finish initializing (at the first boot and every reboot). This operation can
take up to 60 seconds. If GUI initialization is not completed by then, the user is
logged out and asked to log back in later.

12.2. Setting a password

If you are using the One Time Password (OTP), you will be asked to change it after
logging in and before accessing any of the CLI| operations.

You are prompted with the following password requirements:

* Length should be between eight and sixteen characters
* Should contain at least two capital letters

* Should contain at least two lower case letter,

* Should contain at least two digits

* Should contain at least two special characters

1. Enter the old password.

2. Enter the new password.

The new password is checked for the requirements above
and compared with the old password. If it fails to comply
o with the requirements or if the new password is the same as
the old one, the user is prompted with the associated error

and/or the requirements and is directed back to step 2.

3. Enter the password confirmation.
The only check that is performed is whether the two passwords match.
If it fails, it will prompt the error and start from step 2 above.

If it is successful, you will proceed to the CLI commands of the wizard.

12.3. Master key status
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After the setup wizard has run and the mandated passwords have been entered, a
status message for the master key may be prompted. This occurs if the master key
needs to be reloaded, or generated and loaded.

12.4. CLI| setup wizard

12.4.1. Log in

1. Connect to the IP address.

2. Login as administrator.

£ 10.1.7.161 - PuTTY
-

admi 1'1.

The CLI Setup Wizard initializes at the first boot. It will only initialize if the entire
wizard setup has not yet run, or if the following steps of the wizard failed: Set User
Email, or Create Administrators.

The wizard prompts you to perform the following operations:

Set the user’'s email

* Create two administrators

» Configure the network

» Configure the date and time

* Set two passwords for system key

Once the user logs in, the CLI verifies if the Virtual Machine (VM) has an IP
address. If it does, it will prompt the user with the IP address and the URL to
launch the wizard from a web browser.

If the Virtual Machine (VM) does not have an IP address, the CLI

o will prompt the user to set the static network configuration
before running the Wizard. Until the IP address is set, the user
will not be able to run the Wizard.

12.5. Welcome
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1. Select y to start the CLI Setup Wizard.

0 ‘ Select n if you need to exit and logout.

12.6. EULA

The EULA is displayed one page at a time.

1. Navigate the EULA:

Scroll up and down the page using up and down arrows
Select Enter to scroll down the page

Enter q to quit EULA at any time

Scroll to the bottom of the page, which will automatically close the EULA

o o A WD

Select y to agree to the terms of the EULA.

o ‘ Select n if your need to exit and logout (after 5 seconds).

The system prompts to set the default user email.

12.7. Set User's Email

SET THE DEFAULT USER'S EMATL

The requirements for an email address are:

e Alphanumeric characters and < - or _ or .>@<alphanumeric characters and < -
or .>

* The two parts before and after the "@" cannot start or end with a non-
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alphanumeric character.

e The email cannot contain successive dots, dashes or underscores.

1. Enter your email address.

2. Re-enter your email address to confirm.

The system prompts to create your Administrators.

12.8. Create Administrators

CREATE ADMINISTRATORS

1. Enter the User Name for Administrator One.

2. Enter the first administrator’'s email address; verify that the email address is
valid.

3. Enter the first administrator’'s email address confirmation; verify that the email
addresses match.

4. Repeat steps 1 through 3 above to create second administrator.

Once the administrators are created, the system prompts for network
configuration.

12.9. Configure network
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ot oo oo oo oo e oo

IUelcome IEULAIEmail ISystem Admins| =Network= |Key Genera

NETWORK SETTING

configuration ..: dhcp

ip 1 192.168.17.197
netmask : 295.255.248.0
gateway : 192.168.16.20
hostname : localhost
primary DNS 1 192.168.17.79
secondary DNS ..: 19Z2.168.17.80
domain name : localdomain
interface.......I ethd

The wizard will show the current network configuration.

1. Select the network configuration.

IWelcome |EULAIEmail ISystem Admins| *Network+= |Key Generationl
NETHORE SETTING

configuration ..: dhcp

ip : 192.168.17.197
netmask : 255.255.248.0
gateway : 192.168.16. 20
hostname : localhost
primary DNS : 192.168.17.79
secondary DNS ..: 192.168.17.80
domain name ....: localdomain
interface.......: etho

Select the type of network configuration.
1) DHCP

2) Static

3) Keep the current configuration

Type number corresponding to configuration type:

2. If DHCP, enter:

> hostname (optional)
> mail host (optional)
> |nterface (optional)

0 ‘ Interface can be skipped by pressing enter (system defaults
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to ethO).

3. If Static, enter:

> hostname (mandatory)

o |P (mandatory)

o netmask (mandatory)

- gateway (mandatory)

o domain (optional)

o primary DNS (optional)

> secondary DNS (optional)
- mail host (optional)

o Interface (optional)

4. To Keep the current configuration, enter: mail host(optional)

Interface can be skipped by pressing enter (system defaults
to ethO).

The system continues with Master Key Generation and prompts you to create
Passphrase One.

12.10. Generate system key
1. Enter Passphrase One and then re-enter to confirm.
The system prompts for Passphrase Two.

2. Enter Passphrase Two and then re-enter to confirm.

The system prompts to configure date and time.
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12.11. Configure date and time

Thu

GMT

n/a

1. Choose between NTP and NTP Disable (manual configuration).
o Enter 1 or 2 based on your preference:

o Enter: 1 for dynamic configuration (NTP enabled)
Follow the prompts to complete the configuration.

2. Enter servers (this is only optional if a server is already configured, otherwise
this is mandatory).
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Welcome |EULA |Email

DATE/TIME SETTINGS

ntp enabled..............: no
Thu 2017-06-08 17:41:59
GMT

n/a

o Check for server regular expression.

o Select timezone (optional).

o Each parameter is checked. If a failure occurs, you are prompted
to re-enter the parameter.

1. Enter 2 for manual configuration (NTP disabled)

DATE-TIME SETTINGS

ntp enabled

date tine : Mon 2017-05-01 18:29:43 GHT
timezone

day light saving status..: n-a

elect type of date and time configuration.
1) NTP (dynamic configuration)
J Manually configure date, time and timezone.

nter number corresponding to configuration type: 2

ate (optional): [YYYY-MM-DDI]

2. Follow the prompts to complete the configuration:
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el

=]

£
T

10} GMT
11) Mountain Time
12) Pacific

- Enter date (optional)
o Enter time (optional)

o Select timezone (optional)

0 Each parameter is checked. If a failure occurs, you are prompted
to re-enter the parameter.

The system now prompts for initialization.

12.12. Initialize

complete,

1. Select y to start performing all operations.
0 ‘ Select n if you need to log out.
The initialization process is performed in the following order:

* Generate and load master key.
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» Set user's email (if this fails, it will log out after five seconds).
» Create administrators (if this fails, it will log out after five seconds).
* Set mailhost.

e Configure network.

Set NTP (on/off). Configure date, time and timezone and/or NTP servers.
If the date-time configuration is successful, a reboot is triggered.
You can log back in and restart the wizard if:

* |nitialization failed

o « |nitialization was interrupted before setting Date/Time and
Network

* You logged out before initialization.

12.13. CLI commands
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netmask Eateway

network

timezone
Set-nip-state

SEt-5ErVErS
traceroute

troubleshoot

power-off
reset-config

master-key

emailqueus

upgradephg

12.14. Network commands
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Action Show current network configuration.

Input > network show

Output Mode (dhcp or static)

IP address
Metmask

Gateway

Host Name
Primary DNS IP
Secondary DNS IP
Comain Name
Mail Host (if any)
Interface (if any)

Action Configure dynamic network.

Input > network configure dhcp hostname

<hcstname> interfacename <interface>

Details Hostname is optional. Interface is optional.

Action Configure static network.

Input > network configure static hostname
<hocstname> ip <ip> netmask <netmask> gateway
<gateway> interfacename <interface>

Details All parameters are mandatory. Interface is optional.
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Action | Add/overwrite DNS parameters.

Input » network configure dns add domain
<dcmain name> primary <primary dns> secondary <secondary
dns> interfacename <interface>

Details | Commands to set domain name and primary DNS/secondary DNS can be
performed separately or together in one command.

Only prompt for secondary if primary is entered to ensure that primary DNS is not
left blank.

Interfacename is optional

Action Remove DNS parameters.

Input > network configure dns remove domain
<dcmain name> primary <primary dns> secondary <secondary
dns> interfacename <interface>

Details | Commands to remove domain name and primary DNS/secondary DNS can be
performed separately or together in one command.

Only prompt for primary if secondary is entered to ensure that primary DNS is not
left blank.

If the domain name is removed, it will be replaced by « localdomain »
Interface name is optional.

12.15. Date-time commands

Date-time configuration triggers system reboot if configuration has succeeded.

Action | Show date and time configuration.

Input > date-time show

Output | NTP enabled : <ves/no=
Date/time

Timezone

Day light saving status : <yes/noz

NTP server list (if any)
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Action | Switch NTP on or off.

Input > date-time configqure ntp set-ntp-state
<on/off>

Details | set-ntp-state is mandatory. Set it to « on * to enable NTP and set it to
« off » to disable NTP.
If enabled, NTP will try synchronizing with NTP servers. If it fails, it will
remain disabled.
Mote: check with « date-time show » command if any servers were
configured.

Action | Set NIP servers.

Input > date-time configure ntp set—3servers <“list
cf servera”»

Details | This command removes all previous servers (if any) sets the new list of
SEervers.
In CLI, provide the list of servers between double guotes. If there is only
one server then there is no need for quotes.
Examples :
date-time configure ntp set-servers us.pool.ntp.org
date-time configure ntp set-servers "us.pool.ntp.org time.nist.gov”

Action | Configure date and time manually.

Input > date-time configure manual date <dater time
<time> timezone <gelect from list>

Details | NTP has to be disabled to perform this operation.

Commands to set date, time and timezone can be performed separately or
together in one command.

12.16.

System commands

Action | Power-off the system.

Input > gystem power—-off
Details | This operation can take up to 60 seconds.
Action | Reboot the system.

Input > ayatem reboot
Details | This operation can take up to 60 seconds.
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Action | Reset the system to factory settings.
Input > aystem reset-config
Details | Stop database services.
Remove data.
This operation can take up to 60 seconds.
Action | Show summary of system information.
Input > ay3tem Jummary
Details | SSH state indicates only the user’s configuration for SSH through the
CLI (=« service ssh enable/disable » command.)
« ‘enable”; if user configured SSH using « service ssh enable »
« ‘disable’; if user configured S5H using « service ssh disable =
Output | Serial Number
Software Version
System Uptime
Disk Usage
Services status
License
Type : Evaluation/Product.
If evaluation then show remaining days.
Uparade history (if any)
S55H state
Web UI state
Action | Belcad Master Hey.
Input > gystem master-key relcad
Details | Reload master key when master key is generated but not loaded.
Master key has to be reloaded after each reboot.
Action | Show current state of debug.
Input > ayatem debug show
Details | Show current state of debug
Action | Enable logging of debug message
Input > ayatem debug confiigure set—debug-state on
Details | Enable debug logging
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Action

Disable logging of debug message

Input

> gystem debug configure set—debug-state off

Details

Disable debug logging

12.17. Email queue commands

Action
Input

Output

Action
Input

Output

Show the out standing emails queued up in the system

> gayatem emailqueue 3tatus

EMAIL QUEUE SUMMARY
Pending mail requests ... I nn

Purge system email queue

> ay3stem emailgqueus purge

EMAIL QUEUE PURGE STATUS

Mail purge status ... .. . SUCCesS

12.18.

Troubleshooting commands

Action | Fing host name or IP addreas

Input > troublesheoot ping <ip address/hostnames>

Action | Tracercute host name cor IP address

Input > troubleshoot tracercute <ip
address/ho3tname>

Details | This operation may take up to 450seconds (7.5min)

Action | Show routing tables.

Input » troublesheoot routedump

Action | Dump traffic on the network to a file.

Input > troubleshoot tcopdump <on/off>

Details | The file is overwritten everytime tcpdump is turned on.
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Action Export debug logs through SCP.

Input > troubleshoot export logs server <IPx»
ugername <name> deat dir <destination path> port
<optional port number:>

Optional | port and debug db date are optional parameters
Details | This command is used to export debug logs using SCP. The users should
have valid access to SCP server with username and deatinaticn directory.
Port number is optional and the default SCP port would be used if not
provided.

User is pormpted to enter correct password after executing the command.

12.19. Service commands

Action | Enable/Disable SSH.

Input > gervice 33h <enable/disable>

Details | By default, it is disabled as well as after each reboot.

Action | Enable/Disable webUI.

Input > gervice webll <enable/disable>

Action | Enable/Disable OVT

Input > gervice open—-vm-tools enable
This will enable Qpen VMware Toocls. Proceed? [v/n]

CLI access is restricted to Administrator accounts only. Manager

accounts cannot access the CLI. A proper error message will be
displayed.
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13. Licensing

13.1. Introduction

The nShield Monitor Virtual Appliance offers several license options as listed

below.

Order Code

License Options

Description

nShield Monitor monitoring software licenses for installation onto customer-supplied workstation or

PC.

NT-SW-V2S

NT-SW-V2D

NT-SW-V2E

NT-LIC-ADD50

nShield Monitor software license - single

nShield Monitor software license - dual

nShield Monitor software license - Enterprise

Adds additional 50 endpoints

nShield (endpoints) to be monitored. A maximum of 500 endpoints per monitoring software license

is available.

NT-LIC-ADDS

NT-LIC-ADD10

NT-LIC-ADD20

NT-LIC-ADD50

NT-LIC-ENTERPRISE

Post-installation upgrades

NT-DVD-V2

NT-LICU-S2D

NT-LICU-S2E

NT-LICU-D2E

nShield Monitor endpoint license - 5 additional

nShield Monitor endpoint license - 10 additional

nShield Monitor endpoint license - 20 additional

nShield Monitor endpoint license - 50 additional

nShield Monitor endpoint license - Enterprise (500 endpoints valid for
NTM 2.5 and later, 300 endpoints for NTM 2.4.1 and earlier)

nShield Monitor installation image on DVD

Upgrade from single to dual license

Upgrade from single to Enterprise license

Upgrade from dual to Enterprise license
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14. Enterprise Firewall Settings

If the nShield Monitor appliance is separated from any of its services or endpoints

by a firewall, you must configure the firewall to allow passage of the appropriate IP

protocols. For example:

e Services, such as NTP, DNS, or SMTP server.

* Endpoints, such as users devices.

The table in this section lists the ports that, at a minimum, you must configure to

support connectivity.

Protocol

Echol

SSH

HTTPS

DNS

NTP

SNMP

SNMP

System Log

SMTP

FTP

HTTP

Echo Reply

Echo Request

Transport
N/A

TCP/UDP

TCP

TCP/UDP

UDP

UDP
UDP
ubP

TCP

TCP

TCP/UDP

Port Configurations

Port
N/A

22

443

53

123

161
162
514

25

21

80

Direction

Both

Inbound

Both

Outbound

Outbound

Outbound

Outbound

Outbound

Outbound

Both

Outbound

Both

Both

Description
Echo/ICMP Pings

nShield Monitor Remote Console
Management

nShield Monitor Web Ul & firmware
upgrade

nShield Monitor Web Ul & firmware
upgrade DNS

nShield Monitor utilization of
Network Time Protocol

Monitoring devices via SNMPV3
SNMPV3 Notification
Remote system log alerts

nShield Monitor sending email
alerts

nShield Monitor firmware upgrade
option

nShield Monitor firmware upgrade
option

ICMP Response (code 0)

ICMP Request (code 8)
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15. Troubleshooting

This appendix describes nShield Monitor troubleshooting information.

15.1. Global Troubleshooting Enhancement feature

15.1.1. Overview

HSMs, nShield Monitor (NM) Servers, and nShield Monitor users can be globally
dispersed crossing multiple time zones. nShield Monitor stores all collected HSM
events in Greenwich Mean Time (also referred to as nShield Monitor Server time).
Users who remotely log into nShield Monitor see NM information displayed in the
local time zone of their browser.

The Global Troubleshooting Enhancement feature allows nShield Monitor users in
various time zones, to select and view nShield Monitor Log and Alarms in a
common Timezone. This ability is helpful during global troubleshooting
discussions.

15.1.2. Procedure
Prerequisite:
You are logged into nShield Monitor.

Just for the duration of a special global collaboration work-

e session, a logged in user can choose a SELECTED time zone for
viewing Logs and Alarms on their browser connected to nShield
Monitor.

1. Navigate to either the Logs tab or the Alarms tab.

Denhibbaard Views = Repcrs = Conlicpration =

2. Go to the Date/Time drop down.

aDote/Time (GMT -10:00) Howal .
[[+] Severily  Mesioge
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3.

Select your preferred time zone.

Notes:

The setting applies to both Alarms and Logs tabs. That is, you only have to
select the time zone once.

ONLY the time zone displayed in these two tabs will be affected by this
selection (nShield Monitor displays on the other nShield Monitor tabs are NOT
affected).

The default time zone in Logs and Event pages are browser 'Local Time'
unless the Date/Time Format is set to UTC in User Profile, and in such case,
the default time zone is GMT.

The time zone change is NOT persisted across user logout/login. The time
zone change is temporary. The next time that you login, the time zone is reset
to the default 'Local Time' which is the default (or UTC if the Date/Time
Format is UTC in the login User Profile).

The Time Zone customization in Logs/Alarms pages does NOT affect
Date/Time in other WebUI pages, including Charts, Export Logs, and so on. All
other WebUI pages display Date/Time in 'Local Time' Time Zone (or UTC if the
Date/Time Format is UTC in the login User Profile).

15.2. Network test tools

Event logs provide additional information about security and operations issues.

The following networking test tools are available through the CLI to facilitate

nShield Monitor inter-networking tests.

Ping
RouteDump
TCPDump

Traceroute

To run the nShield Monitor Network test tools:

1.
2.
3.

Log into the CLI as an Administrator.
Enter the command: troubleshoot

Press Enter or Tab to display available options as follows:

nShield Montor > troubleshoot
ping routedump tcpdump traceroute
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nShield Monitor > troubleshoot

4, Type one of the four options to run the appropriate test tool.

15.3. Ping

Ping is a pass-fail continuity test that determines the accessibility of a target IP
address on an IP network. It sends ICMP echo request packets from the selected
nShield Monitor Management Interface to the specified target IP address and
waits for an ICMP response.

15.3.1. Using Ping

1. Log into the CLI as an Administrator.

2. Enter the command:

troubleshoot ping <Hostname or IP Address to ping>

3. Press Enter.

Ping output is displayed directly on the CLI screen. If the ping returns
successfully, the network statistics and properties display appear. If the ping
does not return, a failure message appears.

Example: Success case
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*******************.*****************************xsxsxsxsxsxs
PING:

PING 10.1.1.14 (10.1.1.14) from 10.1.2.122 eth0: 56(E84) bytes of data

€4 bytes from 10.1.1.14: icmp seg=l ttl=255 time=0.271 m=s

€4 bytes from 10.1.1.14: icmp seg=2 ttl=Z55 time=0.273 m=

€4 bytes from 10.1.1.14: icmp =2eg=3 ttl=Z55 time=0.319 m=

€4 bytes from 10.1.1.14: icmp seq=4 ttl=2535 time=0.ZET7 m=

€4 bytes from 10.1.1.14: icmp seq=5 ttl=2535 time=0.25% ms

€4 bytes from 10.1.1.14: icmp seg=& ttl=235 time=0.197 ms

€4 bytes from 10.1.1.14: icmp =seg=T7 ttl=255 time=0.257 m=

€4 bytes from 10.1.1.14: icmp seg=8 ttl=Z55 time=0.256 m=

--- 10.1.1.14 ping statistics ---

8 packets transmitted, 8 received, 0% packet loss, time 7000ms=

rct min/avg/max/mdev = 0.187/0.264/0.315/0.038 m=s

oA A A A A A A A A A A A A A A A A A A A A A A A A A A A A A A A A A A A A A A A A A A A A A A A A A A A A A

Example: Not Successful
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AR R R R AR R R R R R R R R R AR R R R R R R R R R R R R R R R R R R R R R R R R AR R R R
PING:
PING 10.1.1.131 (10.1.1.131) from 10.1.2.122 ethO: 56(84) bytes of cdata

From 10.1.2.122 icmp seg=l Destination Host Unreachakle

[ 3%]
I

[ 3%]
[ 3%]

From 10.1. icmp seg=2 Destination Host Unreachakle

%]
[

[
%]

From 10.1. icmp seqgq=3 Destination Host Unreachable

)
[

)
)

From 10.1. icmp seg=4 Destination Host Unreachable

)
[

)
)

From 10.1. icmp seq=5> Destipnation Host Unreachable

28]
I

%]
28]

From 10.1. icmp =zeq=6 Destination Host Unreachable

fud
[

fud
fud

From 10.1. icmp seq=7 Destination Host Unreachakle

)
[

fud
)

From 10.1. icmp zeg=8 Destination Host Unreachable
-=-10.1.1.131 ping =tatistics ---

8 packets transmizted, O receiwved, +8 errors, 100% packet loss, time 700

pipe 4

e e e e R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R AR R R R R R RRRRRR R

15.4. RouteDump

RouteDump displays routing information used by nShield Monitor.

15.4.1. Using RouteDump

1. Log into the CLI as an Administrator.
2. Enter the command: troubleshoot routedump

3. Press Enter.

The routing information for nShield Monitor is displayed on the screen.

Monitor v2.9.7 Install and User Guide 167/205



Chapter 15. Troubleshooting

R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R

ROUTEDUME @
default wia 10.1.1.20 dev eth0 proto static metric 1024
10.1.0.0/21 dev eth? proto kermel =cope link src 10.1.2.122
Fernel IP routing table

Destination Gateway Genmask Flags Metric ERe
U=ze Iface

default 10.1.1.20 0.0.0.0 oG 1024 d
0 ethd
10.1.0.0 0.0.0.0 255.255.248.0 1) d d
0 ethd

e e e e e e R R R R R R R R R R R R R R R R R R R R e R R R R R R R R R R R R R e R e e e R R R R R R R R R R R R R R

15.5. TCPDump

TCPDump is a common packet analyzer. It enables users to intercept and display
TCP/IP and other packets being transmitted/received over a network to which the
computer is attached.

Using the CLI commands tcpdump on and tcpdump off, the utility can be turned on
and off.

15.5.1. Using TCPDump

1. Log into the CLI as an Administrator.
2. Turn on TCPDump.

3. Enter the command:

troubleshoot tcpdump on

4. Press Enter.
The utility starts capturing.

Each Interface TCPDump capture generates a trace file. The TCPDump trace
file can only be exported as part of exporting debug logs.

6 Restarting the TCPDump capture overwrites any previously
captured data.
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15.6. Traceroute

Traceroute determines network response time, displays route (path) information
from an IP source to an IP destination address, and measures the associated
transit delays of packets across the network. It operates by sending a sequence of
ICMP packets from a specified source |IP address to a specified destination IP
address, and uses responses to determine the intermediate routers traversed.

15.6.1. Using Traceroute

1. Log into the CLI as an Administrator.

2. Enter the command:

troubleshoot traceroute <Hostname or IP Address>

3. Press Enter.

Traceroute output is displayed directly on the CLI. The last Traceroute
operation performed can also be exported as part of the debug logs.

o e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e R R R R R R R R R R R

It may take up to 450 =zecond=s to complete the operation.
Ctrl-c to =2top the process.
TRACEROUTE:

traceroute to 172.26.0.10 {(172.26.0.10), 30 hops max, &0 bytg
packets

1 10.1.1.20 (10.1.1.20) 0©0.730 mz 0.301 ms ©O.865 m=s

2 172.26.0.10 (172.26.0.10) 0.510 ms O0.52% m=s O0.527 ms

ke R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R

15.7. No monitoring data received
If no monitoring data is received or if a device is not reachable, verify that:

* SNMP is enabled
* SNMPv3 user is configured

e Utilization and health collection is enabled.
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16. nShield Monitor Alarm Conditions

nShield Monitor provides the following alert conditions for monitoring and

tracking system and device level conditions:

Alarm Condition

Device is added or removed

When the nShield Monitor
average CPU usage is higher
than 95%

nShield Monitor License Expiry

alerts

When the nShield Monitor
Memory is over 90% full

Alarm Severity Notes

Added: INFO

Deleted:
Warning

ERROR

WARNING

CRITICAL

EMERGENCY

ERROR

System Alarm - nShield Monitor

Alarm gets generated by nShield Monitor when a
device gets enrolled or deleted from the system.
Add operation will create an INFO alarm and

delete of enrolled device reported as WARNING.

System Alarm - nShield Monitor

This is a health alert for nShield Monitor, when
the average CPU usage is higher than 95%.
nShield Monitor will not shut down. Send debug
logs to your Support organization.

System Alarm - nShield Monitor

nShield Monitor will keep sending alerts with
different severity a few days before expiration.

A WARNING alert message will be sent out every
day from 23rd day to 28th day. A CRITICAL alert
will be sent out on 29th day and an EMERGENCY
alert will be sent out on 30th day. An Emergency
alert is the final alert before the evaluation
license expires.

User needs to install valid license at this point for
nShield Monitor to monitor the devices.

System Alarm - nShield Monitor

This Alarm gets generated when system memory
gets 90% full. At this point, nShield Monitor does
not stop monitoring or shut down. The system
will continue with normal operation.

Monitor v2.9.7 Install and User Guide

170/205



Chapter 16. nShield Monitor Alarm Conditions

Alarm Condition

When the nShield Monitor disk
is over 90% full

nShield Monitor Security
Related Alarm Warning when
Master key has not be
generated and Critical when
Master key is not loaded

nShield Monitor Security
Related Alarm

User: has enabled/disabled
Service

nShield Monitor Security
Related Alarm

The license features have been
changed for Device

Alarm Severity

ERROR

WARNING
CRITICAL

INFO

WARNING

CRITICAL

INFO

Notes

System Alarm - nShield Monitor

This Alarm gets generated when system disk
gets 90% full. At this point nShield Monitor does
not stop monitoring or shut down. The system
will continue with normal operation. Follow this
link to find disk size recommendations Server
Requirements.

Add storage space by expanding the virtual hard
disk.

Security Alarm - nShield Monitor

It is a security alarm regarding master key not
being generated or not being loaded. If key is
not generated a WARNING message and
CRITICAL when MK is not loaded. Administrator
needs to take appropriate action by configuring
the same on Security page.

Security Alarm - nShield Monitor

If SSH, WebUI or Open VMTool services are
enabled or disabled.

Security Alarm - nShield Monitor

It is a security alarm regarding master key not
being generated or not being loaded.

If the key is not generated a WARNING message
is generated and a CRITICAL message is
generated when a master key is not loaded.

The Administrator needs to take appropriate
action by configuring the same on the Security
page.

Device Alarm - nShield

There are optional feature licenses for the
nShield HSM. At a later date, when you require a
new feature, you can order it from Sales and
install the new License. Change in those featured
licenses are going to be monitored by nShield
Monitor and notified by an event.
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Alarm Condition Alarm Severity Notes

The nShield device temperature  WARNING /

change alerts CRITICAL
Hard Server failure in Client WARNING
Host

Module count is Zero for Client  WARNING
Host

The software base release INFO
updated, revision, build number,

core API version, performance

model update, crypto algorithm

host command update and

optional license update

Device Alarm - nShield

System reports device temperature change
WARNING message when exceeds lower
configured threshold value and CRITICAL above
upper threshold value.

Device Alarm - nShield

A WARNING message would be generated when
hard server program fails.

Follow Remote Administrator Client User Guide
for further investigation.

Device Alarm - nShield

When Client host discovers no nShields attached
to enrolled Client Host.

Follow up with nShield User Guide.
Device Alarm - nShield

This is an nShield monitored Event. Event is
logged for audit purposes. A Security World
software upgrade operation would update
revision, build number, core API versions and
optional licensing update information, and so on.
No action needed.
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Alarm Condition

License count exceeded

Device count license Exceed -
NOTIFICATION

Install new License - NOTIFICATION

Device count license exceeds for <N>
days - WARNING

Device count license exceeds for <0>
days - ALERT

Alarm Severity Notes

NOTIFICATION System Alarm - nShield Monitor

/ WARNIING /
ALERT /
CRITICAL

Client Host does not belong to a WARNING

security world

SoloXC fan speed down to zero CRITICAL

Power Supply failed for nShield WARNING

module

Number of nShield discovered

by nShield Monitor

INFO

When nShield Monitor detects more nShields
(connected to ClientHost) than the permitted
“nShield Monitor” License count, nShield Monitor
generates this event.

When the License count is exceeded, a new
license (with more HSM count) should be
installed within 30 days. If this does not occur,
ONLY Administrator privilege users of nShield
Monitor will be allowed to login.

Group Manager Privileged Users won'’t be
allowed to login to nShield Monitor.

After 30 days, nShield Monitor will still continue
to monitor the detected nShields in the
background. Once the new “nShield Monitor”
license with a sufficient HSM count is installed,
Group Manager Privileged Users are allowed to
login.

Device Alarm - nShield

When the Client host is not configured correctly
with correct security world information, and
enrolled for monitoring. WARNING message gets
generated. Refer to Remote Administrator Client
User Guide.

Device Alarm - nShield

This CRITICAL alarm generates when Fan speed
for Solo Down to zero or not functioning any
more. Refer to nToken Installation Guide if
needed.

Device Alarm - nShield

This WARNING alarm generates when power
supply to nShield module fails.

Refer to nToken Installation and Solo installation
guide if needed.

Device Alarm - nShield

nShield Monitor generates alarms when client
host start discovering nShield configured to it.
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Alarm Condition Alarm Severity Notes
HSM module hard failure CRITICAL Device Alarm - nShield

It’s an nShield/ClientHost module hard failure
event. Customer needs to investigate on Client
Host about module failure and refer to Remote
Administrator Client User guide suggest how to
restart it.

Device State changed to offline ALERT Device Alarm - nShield

An ALERT alarm is generated when the Device
State changes to offline.

Device State changed to online  NOTIFICATION Device Alarm - nShield

A NOTIFICATION alarm is generated when the
device state changes to online.

Device State changed to ALERT Device Alarm - nShield

unavailable
An ALERT alarm is generated when the device

state changes to unavailable.
Device State changed to secure NOTIFICATION Device Alarm - nShield

A NOTIFICATION alarm is generated when the
device state changes to unavailable.

Device information Modified NOTIFICATION System Alarm - nShield Monitor Enrolled device

nShield Monitor enrolled device information has
been modified. Device Details include Hostname,
HostIP, Description, Location; SNMP Details
include username, port, Authentication
algorithm/password or Privacy
algorithm/password or Group membership
information.

Device Monitoring WARNING Device Alarm - nShield Monitor Enrolled device

Enable/Disable
WARNING message gets generated when

administrator disables or enables monitoring
option for enrolled devices.
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Alarm Condition Alarm Severity Notes

Object Count Notification INFO / Device Alarm - nShield Monitor Enrolled device
WARNING /
CRITICAL WARNING and/or CRITICAL otifications are

raised if the object count of any HSM in a
defined group exceeds one of the thresholds for
a pre-configured period. INFO message gets
generated when the object count for that device
falls back under the lower threshold value for a
pre-configured period.

The alert indicates:

¢ The threshold value

* The HSM hostname and IP address (or the
HSM ESN if hostname and IP address are
not present)

e The group that the HSM belongs to.

SNMP Trap Notification NOTIFICATION Device Alarm - nShield Monitor Enrolled device
/ ALERT /
nShield Monitor generates alerts and
CRITICAL notifications when the SNMP TRAP state
changes.

ALERT when the state changes to offline or
unavailable.

NOTIFICATION when the state changes to
secure or online.

CRITICAL when the connection status is
unreachable.
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17. nShield Monitor Backup and Restore

To protect against data loss, nShield Monitor should be backed up using native
VMware capabilities for protecting virtual machines.

Both manual and scheduled backup operations can be used, as follows:

» After nShield Monitor is installed, setup and configured, a manual backup
should be completed.

» Before a nShield Monitor software upgrade is performed, a manual backup
should be completed.

* A scheduled backup program should also be setup to provide ongoing
protection against loss of monitored data collected.

For details of VMware virtual machine backup and restore capabilities please refer
to VMware the Virtual Machine Backup guide and the vSphere Virtual Machine
Administration manual.

Please also note the following:

* For your security, Master Key is not persisted in nShield Monitor - you must
remember the passwords used for establishment of the Master Key.

 Don’t invoke the nShield Monitor backup operation while a nShield Monitor
upgrade is in process.
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18. Deploying nShield Monitor

18.1. Centralized monitoring

When monitoring an estate of HSMs, it is recommended to keep all the data in as
few instances as possible. This may be subject to external requirements such as
network connectivity, regulatory control or other issues.

The best case scenarios are a single nShield Monitor instance that poll all HSMs in
an estate. This provides a complete set of statistics for all HSMs in the estate from
a single login. This is based on access rights and role/roles assigned within the
nShield Monitor server.

18.1.1. Single instance monitoring

By collecting statistics in a single window it allows views of all groups of HSMs
including events and alerts from a single browser when logged in as Administrator.

This configuration allows historical reporting for any and all HSMs in the estate as
needed, again based on assigned rights or roles.

There may be additional requirements when monitoring must be continuous. For
example, more than one instance of a central nShield Monitor virtual appliance is
required in order to ensure monitoring is continuous and non-stop.

18.2. nShield Monitor multi-instance

A single nShield Monitor virtual appliance is all that is required to monitor an HSM
estate. However, it is possible to utilize multiple nShield Monitor virtual appliances
simultaneously as insurance in case of an outage. By distributing nShield Monitor
virtual appliances across multiple locations, polling is maintained to all devices in
the event of a network outage, other than to a single site. It is possible to ensure
that, even during a single location network failure, only a minimal number of
devices will be unmonitored until the issue is resolved.

18.3. Distributed monitoring

There are cases where multiple monitors are required due. For example:
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* Network connectivity via firewalls
» Potential regulatory compliance requirements

* Scenarios where one or more central nShield Monitor virtual appliances
cannot poll specific HSM devices.

18.3.1. Multiple nShield Monitor instances

In this case, multiple regional or local nShield Monitor instances may be required in
order to provide coverage and continuous monitoring of HSM estates.

Even in this case, central distribution of alerts using SIEM or email services is
recommended. This enables a proactive notifications can be sent to the
appropriate person or persons responsible for a given nShield Monitor or specific
group of devices.

18.4. Deployment considerations

When looking into how to deploy nShield Monitor, there are some specific items
that need to be considered prior to implementation.

18.4.1. User access requirements

nShield Monitor has included provisions to address user access requirements by
providing the ability to limit which portions of HSM estates any given user can
view. This is done by only assigning a specific group or portion of the total
configured groups to a user with the group manager role assigned. These
requirements may affect both centralized and distributed configurations. A
thorough examination of the environment in question will need to be performed
prior to implementing nShield Monitor.

There may also be regional requirements for monitoring encryption devices. These
may require regional or local users to be the only authorized persons to access
specific portions of the estate due to geographic location.

18.4.2. Network connectivity

Multiple instances of nShield Monitor may be required on a per region or location
basis. This is mainly due to firewalling or other forms of limited network access to
the local HSM estates. In this case, individual nShield Monitor systems will have to
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be configured individually to achieve full coverage and notification of failures per
region or location.

18.4.3. Regulatory compliance requirements

nShield Monitor does not have any regulatory impact or requirements around it at
this time. However, due to potential regional requirements for the HSM estates. For
example, you may be required to have individual nShield Monitor servers deployed
regionally in order to access the management ports of the HSMs to be monitored.

A distributed model of nShield Monitor can still provide the ability to distribute
proactive alerts and event information to centralized tools. This can be based on
configuration at the virtual appliance or HSM group level.
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19. Residual Risk

19.1. User guidance

Deploying organizations should consider these guidelines for secure operation of
their systems.

19.2. Secure operation

This section highlights residual risks that are not completely covered by the
technical solution and that may require additional operational or procedural
controls.

Refer to Security Hardening: VMWare Infrastructure 3 (VMware
ESX 3.5 and VMware VirtualCenter 2.5) (

o http:/www.ymware.com) for recommendations for security
hardening VMware infrastructure, including virtual machines and

virtual machines files and settings.

Deploying organizations may wish to implement additional measures based on
their assessment and risk appetite.

19.3. Risks

e Malicious Host
e Misconfiguration

» Data Aggregation

Data Ex-filtration

19.4. Deployment and distribution

* Keys and for communication with clients and other Critical Security
Parameters (CSPs) such as TLS and SSH certificates are protected in software
only and are embedded on the virtual machine.

e Audit data accumulated from monitored clients is only protected by software

mechanisms on the virtual instance.

* Virtual machine instances must be managed. This includes auditing use and
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distribution of the virtual instances and controlling access to the host
machines.

* Cloning virtual machines with nShield Monitor is not recommended for new
deployments. A fresh installation via distribution of the OVA image and
reconfiguration is always recommended.

19.5. Secure configuration

The manual, Security Hardening: VMWare Infrastructure 3 (VMware ESX 3.5 and
VMware VirtualCenter 2.5), covers these measures in more depth.

They are repeated here since they are directly relevant to mitigating the outlined
risks to nShield Monitor Monitor and can be modified by user operating the virtual
machine.

* Secure virtual machines as you would secure physical servers. Antivirus, Anti
spyware, intrusion detection and other protection must be enabled for the
virtual machine. All security measures must be kept up to date including
applying appropriate patches.

» Disable Automatic Mounting of USB Devices. This measure is required to
prevent introduction of malware to the virtual environment and exfiltration of
data.

e Ensure Unauthorized Devices are Not Connected.
e Control Root Privileges.
e Disable Technical Support Mode.

* Disable Copy and Paste Operations Between the Guest Operating System and
Remote Console.

19.6. Host machine

Must be sanitized as per the deploying organizations policy. Best practices for OS
and application security controls are recommended on the host machine to
minimize the risks outlined above.
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20. Install OVA With VMware ESXi

20.1. Introduction

The nShield Monitor OVA can be installed on a VMware ESXi hypervisor including
the following versions:

* vSphere ESXi 6.0
* vSphere ESXi 6.5

Access to a DVD or the nShield Monitor OVA file from the machine that has the
vSphere software running is required for proper installation of the Virtual
Appliance.

It may be necessary to involve your vSphere management team

o if you plan to install this system in a corporate VMware
environment and you do not have access/authority to create and

manage virtual machines. Administrative rights are required.

The nShield Monitor OVA has been digitally signed with a
signature based on the SHA-256 algorithm. Legacy VMWare
software, such as the platform-native vCenter client, only

0 supports signatures based on the deprecated SHA-1 algorithm
and cannot directly deploy the nShield Monitor OVA.To deploy
nShield Monitor to VMWare ESXi 5.5 or later, use the vCenter
web client.

20.2. Install the nShield Monitor OVA

o ‘ Screen views are based upon vSphere ESXi 6.5.

Run the vSphere software.
1. Log into the web client.

The initial VMware page opens.
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Umer name VMware vCenter” Single Sign-On

Password:

The web client is ready to be deployed.

2. Select your version.

vmware: vSphere Web Client

~ Navigator E [ vcenter.cs.sv.us.thalesesec.com [ ) ‘F'J
d Back || Gettin. | Sum.. Monitor Confi. Permi.. g
o a =) <1
What is v(enter Server?
b [nSJ_ESX 5.5 vCenter Server allows you to manage
b [lnSJ_ESX_6.0 i muliple ESXNESX hosts and the virtual

machines on them. Because these
emvironments can grow very large, vCenfer
Sener provides useful management tools

[ like the abllity to erganize the hosts and virtual

tmS)_FESX 6.5

machines into dusters with vSphere DRS
andvSphere HA Multiple vCenter Server
systems can be managed by the vSphere
Web Cliernt so that their indiaduzl inventories
can be presented and managedunder one
“pane of gass”

AnyvCenler Senver systems for which you
have privileges and that have been registered
with the Leokup Service, or added manually
with the vCanter Regisiration Tosl in the
Administration section, will appear in your
inventory o the lefi.

Basic Tasks

7 Create a folder
fln Create Datacenter

3. Navigate to Deploy OVF Template.
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vmware* vSphere Web Client #=

Mavigator X

=l

A
m
[¥1]
(]
-

|
o |

k SJ_F" =

Actions - 5J ESX 55
» SJ_E ==
Add Host...
[ SJ_[
%] Mew Cluster..
Mew Folder [
Distributed Switch [
Mew Virtual Machine b

#8] New vApp from Library..

i Deploy OVF Template. .

Storage b

Edit Default WM Compatibility...

g2 Migrate Vs to Another Metwork...

Ll e T o

You will be prompted through the process:

|| Deploy OVF Template

| 1 Select template

2 Select name and location

3 Select a resource
4 Review details
5 Select storage

6 Ready to complete

4, Select template.

5. Enter the file location or select Browse and navigate to the location.
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| Deploy OVF Template

| 1 Select template Select template

Select an OVF template.
2 Select name and location

3 Select a resource Enter a URL to download and install the OVF package from theg
such as alocal hard drive, a network share, or a CO/OVD drive
4 Review details

5 Select storage (_JURL

G Ready to complete |

(=) Local file
| Browse... |

A Use multiple selection to select all the files associated

6. Select Next.

Hext Cancel

7. Select name and location.

Select name and location

+ 1 Select template
Enter a name for the OVF and select a deployment location.

2 Select name and location

3 Selectaresource Name | dev-2.1.0.0057-58-2017-06-25-20-59-03

4 Review details ) I —
Filter | Browse |

5 Select storage
Select a datacenter or folder.

6 Ready to complete

w (2] vcenter.cs sv.us.

b [l SJ_ESK_B.0
b [lg SJ_ESK 65

8. Select Next.

9. Select a resource (host).
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%21 Deploy OVF Template

Select a resource
Select where to run the deployed template.

" 1 Select template

' 2 Select name and location

3 Select a resource )
[ 3 selectaresource [N [‘Browse |

4 Review details

Select a host or cluster or resource pool orvapp.

5 Select storage
vSJ_ESK_E.E

b |3 esx-d.cssvus.
b [7 es-5.c55vus.

6 Ready to complete

[» [ esx-6.cs.svus.
b [7 esx-7.cssvus.
b |3 esx-8.cssvus.
b [7 esx-9.cs svus.

10. Select Next.

1. Review the details.

¥¢l Deploy OVF Template

Review details
WVerify the template details.

w 1 Select template
w' 2 Select name and location

w' 3 Selectaresource

Product
4 Review details :
Yersion
5 Accept license agreements Nl
el A Publisher & Mo certificate present
T Select networks TR e e 296 1 MB
& Ready to complete 2.6 GB (thin provisioned
Size on disk ( 4 ;

326.0 GB (thick provisioned)

12. Select Next.
13. Review the Agreement, (selecting Next to scroll through the Agreement).

14. Select Accept.
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#¢ Deploy OVF Template

Accept license agreements
Read and acceptthe license ag

w1 Select template

w2 Select name and location
" 3 Selecta resource

' 4 Review details

6 Select storage

7 Select networks

& Ready to complete

' Accept |

15. Select storage.

Monitor v2.9.7 Install and User Guide 187/205



Chapter 20. Install OVA With VMware ESXi

¥ Deploy OVF Template

Select storage
Select location to store the files for the deployed template.

w1 Select template

' 2 Select name and location

v 3 Selectaresource Selectvirtual disk format: | Thin provision
i [] Show datastores from Storage DRS clusters
w5 Accept license agreements

=

6 Select storage

[ Datastores | Datastore Clusters]
T Select networks

& Ready to complete

Mame Status
) B alma.build & Alert
(=) ] esx6-ds1 & Normal
i) B esxBdedicated-san & Mormal

16. Select Next.

17. Select your network.
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¥4 Deploy OVF Template

1 Select template

2 Select name and location
3 Select a resource

4 Review details

5 Accept license agreements

£ ¢ G ¢«

6 Select storage

7 Select networks

8 Ready to complete

Select networks
Select a destination network for each source network.

Source Network

CORF

IP Allocation Settings

IP protocol: 1Pwd

18. Select Next.

19. Review the configuration data.
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¥ Deploy OVF Template

+ 1 Select template Ready to complete

Review configuration data.
" 2 Select name and location
" 3 Selectaresource

Mame
" 4 Review details B SRS
" 5 Accept license agreements Download size
" 6 Select storage SR aaE
W T Select networks
Datacenter

*a & Ready to complete T

¢ Storage mapping 1

r Metwork mapping 1

¢ |IP allocation settings |Pvd, Static - Manual

20. Select Finish.
21. You can follow the status.

[z Recent Tasks
Ty
Task Name Target Status Initimtor
Deploy OVF template & -dev-2 = w% 0 VEPHERE L]
Import OVF package [l esx-b.cs.svus. L L < vsphere.locall

22. You are now ready to power on.

Monitor v2.9.7 Install and User Guide 190/205




Chapter 20. Install OVA With VMware ESXi

vmware: vSphere Web Client
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Havigator
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mitps.fecenter.cs.svius.thabesesec. coma 044 3 fvsphere-client T ospextensionld &3 0vsphere.co)

|@ B8 e
- [ veenter.ca swus
~ [qE) ESN 55
b [Eesn-4.033v0s
¥ (G esn5.cs svus
~ [F.esx-Bcs.avus

dk ES0SPT target-VI-Bild0003

dk AutomationCaash-hong-cemDS-Clone
08 CH_clone

4 chrig-alma-dane

& chrig-

B chiig«

P chris-gsm-0

B chris-dsm-5.3.1-0

P chris-test-2.0.0

P chris-test-2.0.0-0

B chris-wip-0
o &
P chu-clac-7.235
.ﬁﬁ.tku-DS-dern{l@1 017180
B cku-ova

I rlreaid Tanalame

¥ =
!1 1 CipherTrust-gey-2.1.0,0057-58-2017

Gatting 5. Summary ondor C::j

What is a Virfual Machine?

Avirlual maching is a software compuls
like a physical cormputed, ing an operal]
systern and applications. An operabng
system installed on & vrtual machina is
called a guest operaling system

Because everywirual machine is an isal
compuling envirenmaenl, you can uge v
machines as desklop or warkstation
environments, as testng environments,
consalidale server applications.

InwCenter Server, virual machines nun o

hasts or dusters. The same host can ry
many virlual machines.

Basic Tasks

¢ Power on the virtual machiy

20.3. Turn on the Virtual Machine

1. Click on the VM that you just created.
2. Select the Getting Started tab.

3. Select Power on the virtual machine.

B8 &
I

File Edt Wies Invenioey Admireshobion Plug-ims  Bdp

vome b g8 Dreeiory B[ ety

ShOhaDe P2y

= @ 1seiekid
Js]

et Frarstl - LOBUEENE- 185 1015 1808 b

EL0.0.02%8- 00

Winat is a Virtual Machine?

COMBONAETE SErveT SHHECATDNS

Ty wiflull mac hines

Basic Tasks

Semwrary | Remgurce Moostio

A virlual maching 5 a software compa
plrysical compuber, runs an aperating 4
apphcalions. An operang Sysiem nstd
e hine (S called 3 guest oparating Syl

Betause every vifual machine & an s
ETARONMENE, you Can use virlual mact
WOrKSEANON ENVIOHMEntS. &% beLing &

Wirbual mdchings. run on hosts. The o

B Power on Ui ViFtuial meshing

:'j.- Edif wirtual machime seitings

4, Allow five minutes for the virtual appliance to load.

Monitor v2.9.7

Install and User Guide

191/205



Chapter 20. Install OVA With VMware ESXi

20.4. Run the Virtual Machine

20.4.1. Unfamiliar with VMware ESXI

1.

Select the Console tab, if you are unfamiliar with VMware ESXi and cannot
determine the IP Address of the nShield Monitor VM that you just created:

il T Fured - LOGUSGM- 105 2015 100 1o B4 37

Semwrary | Rwvgurce Aoostios  Pedommancs  [veie  Corsole  Permigsicne

The login prompt displays.

Login to the system using the default user ID and password:

o Default user id: admin
o Default password: passwordl123

The system will prompt you to change the password.

Change the password to one that meets the same minimum requirements
those for a user on the nShield.

After the first login from the CLI, the system prompts you to start the CLI Setup
Wizard.

Entrust recommends using the WebUI set up wizard. If you would like to use the

WebUI for setup, then answer "no" to the prompt for starting the CLI setup wizard.

0 Entering the wrong password 3 or more times will lock the user
out of system and a re-install of OVA is required.
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SET THE DEFALLT USER'S PASSUIRI

ully conpleted zet wzer password

20.4.2. Familiar with VMware ESXI

If you can determine the IP address assigned to the new VM, record your new
password and IP address. Then, provide this information to the appropriate
personnel.

In most organizations the information technology or infrastructure group will
accomplish the setup of the OVA. However, the installation and operation of the
nShield Monitor Virtual Appliance will be performed by a different functional
group.

If you are to perform both tasks (nShield Monitor OVA install and nShield Monitor
setup), record your new password and the IP Address listed above.

Proceed to Setup Wizard for instructions on using the WebUI Setup Wizard for
setting up and configuring the nShield Monitor Virtual Appliance.
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21. Install OVA with VMware
Workstation/Player

21.1. Introduction

The nShield Monitor OVA can be installed on a VMware Workstation/Player
hypervisor including the following versions:

* VMware Player or Player Professional 6
 VMware Player or Player Professional 7
* VMware Workstation 11

* VMware Workstation 12.

o The VMware Workstation and Player installation must be local to
the machine nShield Monitor is being installed on.

The nShield Monitor virtual appliance does not have VMware
0 Tools installed. As a result, copy and paste operations are not
supported from the host or other guest OS to the virtual

appliance console.

You should ensure that the machine that you install nShield Monitor on runs 24 X7
throughout the duration. You may need to reboot at some point at which point
you will have to enter passwords to re-establish the master key.

Note: If you are going to be running nShield at full capacity with 500 devices, a
recommended precaution is to increase the 250GB disk in vCenter to 350GB after
deploying the OVA but before powering it on. Once the OVA has been powered on
the disk size cannot be changed.

21.2. Install the nShield Monitor OVA

Run the VMware Player or Workstation software.

o The steps that follow apply for both the VMware Player and the
VMware Workstation.

1. Select Open a Virtual Machine from the Home tab.
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Pli:.r:r - - L-il- J__"

Welcome to VMware Player

%' . Create a New Virtual Machine
1

| +". Create a new virtual machine, which will then be
T pdded to the top of your lbrary,

Open an existing wirtual machineg, which will then be
added to the top of your lbrary.

1 Open a Virtual Machine
f
—,w', Download a Virtual Appliance

| > Dovnigad a virtual appliance from the marke tplace,
Yiou can then open it im ViMware Player.

From the menu bar you can also select File (Alt + F) and
Open(Ctrl + O). On VMware Workstation, this is the first
option on the menu bar. For VMware Player, it is found under
e the Player drop down menu.

VMware Player and Workstation versions vary on the home
screen, so please refer to the documentation for the version

that you plan to use.

VMware Workstation

File Edit WView WM Tabs Help - | 0 = H

'ﬂ[ Home *

WORKSTATION 11

2. Select Open a Virtual Machine.

WORKSTATION 11

) O

Connect to a Connect to
Remote Server Vidware vCloud Air

=

Create a Mew
Virtual Machine

The Open Virtual Machine page opens.
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5| Open Virtual Machine

@U'I v Computer ¢ 05 (C) » Virtual Machines OVA Files §

Organize Mew folder

B Desktop “  Mame Date modified

3 Dropb
e mptan & 1.00.0300-111-2015-10-14-2...  10/14/2015 10:19 .

3. Select the OVA file to be installed.
4, Select Open.

The Import Virtual Machine dialog box opens.

Import Virtual Machine ﬁ

Store the new Virtual Machine

Provide a name and local storage path for the new virtual
machine.

Name for the new virtual machine:

-1.0.0.0200-111-2015-10-14-22-17-00

Storage path for the new virtual machine:

C:\Users\nvoratDocuments\Virtual Machines)
mport ) [ concel |

5. Enter a name and path for the VM to be stored.

6. Select Import.
The End User License Agreement (EULA) page opens.

7. Read the EULA.
8. Select Accept.

0 If you decline the EULA, you will be unable to proceed with
the installation.

The Import Progress page opens.
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VMware Workstation

Importing

Cancel

Once nShield Monitor is installed you will be looking at the nShield Monitor
VM (VMware Player) / VMware Workstation.

¢ W Mware Plu:,'Er

Fl.upqr - * - :'-:

1.0.0.0200-111-2015-10-14-22-17-00

-1.0.0.0300-111-2015
-10-14-22-17-00

State: Powered Off
05:  Cent0S 64-bit
Version: Workstation 9.0 virtual machine
RAM: 8GB

P Play virtual machine
Ly
o

Edit virtual machine settings
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[B) CipterTrust-1.0.0,0300-111 -2015-10-14-22-17-00 - Vitware Workstation
Eile Eda Yew VM Tats Help | b = ' = | B e

£ e 100080-111-...

1.0.0.0300-111-2015-10-14-22-17-00

P Fow
SJEGIE ¥
JuT
= Devices
- Bty aGh
B Proscesgaces 2

= Hard Disic (5050 2062

= Hard Disk 2 (SCS0) 16 G

SHard Disk ¥ (SCSN 250 GB

= Hard Disk & (5050 2068

== Hard Digk 5 (SCS0) 20 G2

Wi Metwork Adapter Eridged (Automatic
B Display At detect

= Deoription

After deployment of OVA is finished, the installation of the nShield Monitor

OVA is now complete.

9. On the VMware Player and Workstation screens, click the green right arrow

button to power on nShield Monitor.

Please allow five minutes for the Virtual Appliance to boot.

The login prompt displays.

21.3. Run the Virtual Machine

1. At the login prompt, enter the default user ID and password:

o Default user id: admin

- Default password: passwordl123

o The system will prompt you to change the password.

2. Change the password to one that meets the same minimum requirements

those for a user on the nShield.

3. Record your new password and the IP Address listed and provide information

to appropriate personnel.

After the first login from the CLI, the system prompts you to start the CLI Setup

Wizard.

It is recommended that you use the WebUI set up wizard. If you would like to use

the WebUI for setup, then answer "no"” to the prompt for starting the CLI setup

wizard.
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0 Entering the wrong password 3 or more times will lock the user
out of system and a re-install of OVA is required.

ers only All activitiesz may be nonitored and reported.
ACIM 0TS

mluy All activities may be ponitored and reported
ig Sum Oct 18 17:59:42 GHT 2615

HESHIRL

= ArE
th between & and 16

Start CLI Setup Hizard 7

In most organizations, the information technology or
infrastructure group will accomplish the setup of the OVA, while
the installation and operation of the nShield Monitor Virtual
o Appliance will be performed by a different functional group. If
you are to perform both tasks (nShield Monitor OVA install and
nShield Monitor setup), record your new password and the IP
Address listed above and proceed to Setup Wizard.

Monitor v2.9.7 Install and User Guide 199/205



Chapter 22. Create and Manage Hyper-V Virtual Machines in Hyper-V Core

22. Create and Manage Hyper-V Virtual

Machines in Hyper-V Core

22.1. Prerequisites for using nShield Monitor with
Hyper-V virtual machines

It is recommended to have at least 8 GB main memory when using Hyper-V

Manager with nShield Monitor. The following Hyper-V image files are required:

nShieldMonitor-2.7.0-1.
nShieldMonitor-2.7.0-2.
nShieldMonitor-2.7.0-3.
nShieldMonitor-2.7.0-4.
nShieldMonitor-2.7.0-5.

vhd

vhdx
vhdx
vhdx
vhdx

22.2. Install Hyper-V

With Windows Server Core installations, you can install Hyper-V using the

following applications:

* The legacy Hyper-V Manager.

e Windows Admin Center.

22.2.1. Install Hyper-V on Windows Server Core with PowerShell

At the PowerShell command prompt, run:

Install-WindowsFeature -Name Hyper-V -IncludeAllSubFeature -Restart

Windows Server Core will install the Hyper-V role and restart automatically.

22.2.2. Add the Hyper-V role using Windows Admin Center

1. Connect your Windows Admin Center Gateway Server to your Windows

Server Core installation.

2. In Windows Admin Server, select Server Manager > Roles and Features >

Install, then select Hyper-V.
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Windows Admin Center will calculate the dependencies of role and feature

installations and then prompt you to proceed with the installation, including
automatic reboot options.

3. When Windows Server has rebooted, check in Server Manager > Roles and
Features that the State for the Hyper-V role is Installed.

22.3. Configure a new virtual machine with Hyper-V

1. In Windows Admin Center, select Server Manager, then launch Hyper-V
Manager.

2. Select New > Virtual Machine.

The New Virtual Machine Wizard opens.

B8 Hyper-v Manager 3 New Virtual Machine Wizard X

File Action View Help
=75 3 -

% Hyper-¥ Manager
@ T——

Specify Name and Location

Before You Begin Choose a name and location for this virtual machine.

Spedify Mame and Location

The name is displayed in Hyper-V Manager. We recommend that you use a name that helps you easily
Specify Generation identify this virtual machine, such as the name of the guest operating system or workload.

MAssign Memory Name: |n5hieIdMonitor2?0|
Configure Networking

‘You can create a folder or use an existing folder to store the virtual machine. If you don't select a

Connect Virtual Hard Disk folder, the virtual machine is stored in the default folder configured for this server.
Installation Options D Store the virtual machine in a different location
Summary tion: |C:\ProgramData'Microsoft\Windows \Hyper-W\ Browse

< Previous Finish Cancel

Specify the Name and Location of the virtual machine, then select Next.
Select Generation 1, then select Next.

Set the RAM Size, then select Next.

Set the Connection to Default Switch, then select Next.

Attach the boot hard disk (VHD file) for nShield Monitor.

N O o b~ W
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§§ Hyper-V Manager

E3 New Virtual Machine Wizard X
File Action View Help|
&= znm 3 e Connect Virtual Hard Disk
% Hyper-V Manager
B«
Before You Begin A virtual machine requires storage so that you can install an operating system. You can specify the
Specify Name and Location storage now or configure it later by modifying the virtual machine’s properties.
Spedfy Generation () Create a virtual hard disk
Assign Memory Use this option to create a YHDX dynamically expanding virtual hard disk.
Configure Networking Mame: | mShieldMonitor270.vhdx
Connect Virtual Hard Disk P = y . -
C:\Users\Public\Documents\Hyper-v\yirtual Hard Disks), Browse...
Summary
127 GB (Maximum: 64 TB)
(@) Use an existing virtual hard disk
Use this option to attach an existing virtual hard disk, either VHD or VHDX format.
Location: UILDS \BUILDOUTPLTVMD) eldMonitor-2.7. Browse...
() Attach a virtual hard disk later
Use this option to skip this step now and attach an existing virtual hard disk later.
< Previous Finish Cancel
8. Select Next, then select Finish.
9. In the new machine, select Settings.
3 Hyper-V Manager — O X
File Action View Help
&= |7
% Hyper-V Manager Actions
- Virtual Machines
s 2 -
Mame State =
B nshieldMontor270 off = Quick Create...
Mew 3
[5  Import Virtual Machine...
| Hyper-V Settings...
hyp: g
EB virtual Switch Manager...
< o Virtual SAN Manager...
T wa Edit Disk...
Inspect Disk...
The selected | Stop Service
Remove Server
Refresh
View 4
ﬂ Help
nShieldMonitor270 -
nShieldMonitor270 9 Connect...
Created: Es settings...
Configuration Versior Start
Generation: E’ Checkpoint
Notes: B Move..
EE Export...
Eﬁ Rename...
Summary Memory  Networking E. Delete..

10. Select SCSI Controller, then add the remaining four hard drives of nShield

Monitor.
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22 Hyper-V Manager — [m| X
File Action View H

[
=

| nm HE

ﬁ Hyper-V Manager | Actions
Virtual Machines

_ -
Mame State

]
B nShieldMonitor270 off = Quick Create
Mew 4

Import Virtual Machine...
Hyper-V Settings...
Virtual Switch Manager...
Virtual SAN Manager...

Edit Disk...

Inspect Disk...

)l B B 35 @ P

The selected

=
=/

Stop Service

P
W

Remove Server

Refresh

e X

View 3
H Hep
[

Connect...

nShieldMonitor270

Created: Settings...

Configuration Versior
Generation:
Notes:

Start
Checkpoint
Move...
Export...
Rename...

Delete..,

oL e O

Summary Memory  Networking

a. Select Hard Drive, then select Add.
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E Settings for nShieldMonitor2 70 - X
nShieldMonitor270 ~ (]
# Hardware ~ | &l scscontroller
l" Add Hardware
O pios You can add hard drives to your SCSI controller or remove the SCSI controller from the
) wvirtual machine.
Boot from CD
. Security Click Add to add a new hard drive to this SCSI controller.
Key Storage Drive sabed
Wl Memory Shared Drive
4096 MB

L] Processor
1 Virtual processor
=] IDE Controller 0
= Hard Drive
nShieldManitor-2.7.0-1.vhd
=] IDE Controller 1
() DVD Drive
Maone

[H] Metwork Adapter
Default Switch

B coM1
Mone
& comz
Mone
[ Diskette Drive
Mone
# HManagement

MName

nShieldMonitor 270
D Integration Services
Some services offered
¥ Checkpoints
Standard
':'-':' Smart Paging File Location
C:\ProgramData\Microsoft\Win...

L

Add

You can configure & hard drive to use a virtual hard disk or a physical hard disk after
you attach the drive to the controller.

To remove the SCSI controller from this virtual machine, dick Remove. All virtual hard
disks attached to this controller will be removed but not deleted.

Remove

Apply

b. In the New Virtual Hard Disk Wizard, select Copy the contents of the
specified virtual hard disk, browse to the -2.vhdx file, and add it.

c. Back on the SCSI Controller page, select Apply.

d. Add the other three virtual hard disk files (-3.vhdx, -4.vhdx, and -5.vhdx),
repeating steps a-c for each of them.

All four virtual hard disk files added to the SCSI Controller:
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(3]

A Hardware

r Add Hardware
3 pros
Boot from CD
. Security
Key Storage Drive disabled
Wl Memory
4096 MB
u Processor
1 Virtual processor
= IDE Controller 0
= Hard Drive
nShieldMonitor-2.7.0-1.vhd
= IDE Controller 1
() DVD Drive
Mone

= &8 scsI Contraller

== Hard Drive
nShieldMonitor-2.7.0-2. vhdx

== Hard Drive
nShieldMonitor-2.7.0-3.vhdx

= Hard Drive
nShieldMonitor-2.7.0-4. vhdx

= Hard Drive
nShieldMenitor-2.7.0-5. vhdx

" Network Adapter
Default Switch
B ocom1
Mone
& comMz2
Mone

[ Diskette Drive
MNone

# Management

- Hard Drive

You can change how this virtual hard disk is attached to the virtual machine. If an
operating system is installed on this disk, changing the attachment might prevent the
virtual machine from starting.

Controller: Location:
SCSI Controller ~ | | 3 (in use) w
Media

You can compact, convert, expand, merge, reconnect or shrink a virtual hard disk
by editing the assodiated file. Spedfy the full path to the file.

(@) Virtual hard disk:
| C:\BUILDS \BUILDOUTPUTVMOK \nShieldMaonitor-2, 7.0-5. vhdx

Mewe Edit Inspect Browse. ..

o If the physical hard disk you want to use is not listed, make sure that the
disk is offline. Use Disk Management on the physical computer to manage
physical hard disks.

To remove the virtual hard disk, dick Remove, This disconnects the disk but does not
delete the assodated file.

Remave

Cancel Apply

1. From Hyper-V Manager, select Start and Connect to see the nShield Monitor
image running.
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