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Chapter 1. Introduction

1. Introduction

nShield® Monitor is a monitoring solution delivered in a virtual appliance environment.
Designed to be both cost-effective and scalable, it delivers the level of security assurance
expected of a Hardware Security Module (HSM) accessory supporting application.

Using a standard web-browser (Internet Explorer, Chrome (v 55.0) or Firefox), users con-

nect to the nShield Monitor server via HTTP(s) using a configured IP address or through a

user-friendly name. nShield Monitor provides a secure, authenticated connection allowing
easy access to all monitored information.

nShield Monitor provides the following features:

- Able to monitor of estates composed of the nShield HSMs and client hosts
+ Operates automatically in the background without human involvement

« Alerts users when investigation or intervention may be required

+ Provides information relevant to each user based upon role and groups

+ nShield Monitor provides the following benefits to an organization:

« Removes the need to pro-actively and regularly inspect each device to determine sta-
tus

« Suitable to operate in "dark" data centers or in environments where physical access to
devices is not possible

+ Rapid and automatic notification of potential security issues

- Ability to react rapidly to device hardware failures (e.g., a power supply unit)
+ Notification of unexpected changes to device configurations

« Immediate alerting of device overload

« General reporting of security, configuration, health and utilization of the estate of
devices to support audit requirements

After the initial network setup and installation, the virtualized nShield Monitor server moni-
tors HSMs and client hosts.

nShield Monitor provides a central repository of all information collected from your estate
of devices and monitors information directly from the HSMs including device utilization,
command information and HSM health. nShield Monitor also provides alarm and event notifi
cation (via syslog, SNMP, and email) as well as event logging and report generation from
predefined templates.
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Chapter 2. Requirements

2. Requirements

2.1. General Requirements
nShield Monitor is delivered in the following formats:

« Open Virtual Appliance (OVA)
+ Microsoft Hyper-V

Both formats include:

+ A 64-bit Linux-based OS
- Open VMware Tools (OVT)

By default, OVT service is DISABLED. A system administrator can
0 choose to ENABLE OVT from the CLI. For details, refer to Service Com-
mands.

2.1.1. Hypervisor Compatibility

The OVA can be installed on the following virtual platforms:

vSphere ESXi 6.0
vSphere ESXi 6.5
VMware Workstation 12
VMware Workstation 14

VMware Fusion 10

Oracle VirtualBox 6.0

The Hyper-V image can be installed on the following virtual platforms:

+ Microsoft Hyper-V

« Microsoft Azure

2.1.2. Server Requirements

+ Must support 64 bit OS
« CPU: 2 cores of 2.0GHz multicore CPU (can be increased as needed)

- Memory: 8GB dedicated memory for nShield Monitor (can be increased)
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Chapter 2. Requirements

« Network: Single network attached interface to bridged or physical network
Size on disk:

« Thin provisioned: 2.3 GB (OVA) / 3.3 GB (Hyper-V)
« Thick provisioned: 326.0 GB (OVA)

2.1.3. nShield Compatibility

nShield Monitor is compatible with the following nShield HSM models and software ver-
sions:

+ nShield Edge, Solo+, Solo XC, Connect+, and Connect XC
+ Security World software v12.40 and higher

2.2. Centralized Monitoring

When monitoring an estate of HSMs (i.e., more than one HSM), reduce duplicating data by
keeping your data in as few places as possible.

0 Multiple instances of your data may be required due to your organiza-
tion’s external requirements (e.g., due to regulatory issues, etc.).

2.3. Client Workstation

The client workstation is any Apple or Microsoft Windows workstation that has network con
nections to nShield Monitor and a supported browser (WebUI access) or SSH client (CLI
access) that can access nShield Monitor.

The client workstation can perform various configuration, administrative tasks or group man
agement tasks based upon defined roles.

2.4. Role Based Access

nShield Monitor supports role-based access. Each user role is associated with a predefined
set of tasks, ensuring that a user with a specific role can perform only those tasks that are
allowed by that role. For example, if a user is assigned the role of group manager, the user
cannot perform administrative tasks, such as creating users. Role-based access adds a level
of security to the configuration and administration of nShield Monitor.
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2.4.1. User Roles

The nShield Monitor role based administration model has the following role type:

- Auditor
- Administrator

« Group Manager

Users can be assigned to more that one role. For example, a user could be both am Adminis
tration and as a Group Manager. This user is then able to perform tasks related to both an
the administrator role and a group manager role.

For example, you could create users with the following combinations of permissions:

+ User #1: administrator and group permissions
« User #2: auditor only

« User #3: group manager only

The nShield Monitor Ul is role sensitive, and the pages displayed are dependent upon the
role of the user.

‘ User Mame ‘

‘ Password ‘

Forgot your password® Leg In

Figure 1.1: Login Prompts

2.4.1.1. Auditor

Auditors have complete visibility into nShield Monitor; however, they cannot modify any set
ting in nShield Monitor or on the HSMs.

o ‘ Auditors cannot be Administrators or Group Managers.
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The auditor role is for visibility purposes.

2.4.1.2. Administrator

Administrators are required to have sufficient knowledge of networks,

o various operating systems, and general system administration tasks

such as configuring IP addresses, backing up systems, and using the
console interface.

The Administrator is responsible for:

User management, including creating new users, and deleting users who do not have
any roles assigned to them

Assigning administrator or group manager roles to users
Network configuration

System configuration

Upgrading the system

License management

Security configuration

Group management

Event notification (syslog, SNMP and email) management

Enabling the Open VMware Tools Service

2.4.1.3. Group Manager

Group Managers are required to have sufficient knowledge and understanding of:

The importance of the data and devices that they manage
Corporate policies with respect to data dissemination

Corporate policies with respect to problem resolution

The Group manager is responsible for monitoring and understanding the following:

The command instruction usage

HSM utilization

HSM health

Event triggers in assigned groups

Event logging and report generation in assigned groups

Configuring event notification via email in assigned group
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2.5. Accessing the User Guide

Online Help is available to all user role types.

o ‘ While Online Help is enabled, you cannot perform any actions on the

GUL.

1. Log on as Administrator, Group Manager, or Auditor.

2. Locate the toggle switch in the upper right corner of the screen.

auditor | Systern Auditor |, Jan 11, 2017 2037 @

% Log Cut

3. Slide the toggle switch to the right.
Online Help is enabled.

Fields surrounded by a colored box contain help.

auditon | System Auditor ). Jan 11, 2017 2040 @

. Log Cut

4. Click a field to open the help text pop-up window.

Monitor v2.8.0 Install and User Guide
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I:::dminl [ Systermn Administr

User Profile

A description of the user roles assigned
to you is provided in parenthesis next
to your user name. Clicking your
usemame opens the profile information
page. You can edit the following
settings on this page:

- name

- description

- email

- password

- auto-logout duration by moving

the slider

Save or Cancel your changes.
You can change the date and time
formatting from the options in the drop-
down list:
= MNone (default): if you do not
select a format the default is
used: Month, DD, YYYY, HH:MM
= UTC
Month/Day/Year
Day/Month/Year
Custom: you can enter a custom
format in the text box provided,
use the example as a reference

L]

L]
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3. License Installation

3.1. Overview

nShield Monitor is shipped with an evaluation license. This license allows for the Virtual
Appliance to enroll and monitor up to eight devices for up to 30 days. After 30 days,the
product automatically stops device monitoring and restricts user access to the administra-

tor role only.
There are multiple license options available.

Contact nCipher Sales/Sales Support for prices and availability. Please
have the serial number of the deployed nShield Monitor available in

o order to obtain a license. The serial number can be found on the dash-
board page under the nShield Monitor Status tab.
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(N CIPHER A

Event List »

Users »

nShield Monitor Status ~

Serial Number : Tkig 7y 1P n7 5Y 9x 8X-kc IMLX O? ZzyD Ly F
Software version : 2.5.4 [build 0027)

Licenze : Evaluation, Remaining Doys: 27

Systermn Uptime 20 howrs, 27 minutes

Disk Space Used : 2%

services OK, running 18 of 18

3.2. Installing a License

1. Download the license, provided by nCipher, to the local machine that is currently being
used toaccess the nShield Monitor WebUI.

2. Log in as an Administrator.
3. Navigate to: Configuration > License

4. Click Choose File.
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Add License

hoose licensze file :

Choose Fle

5. Browse to the license file.
6. Click Open.

7. Click Install License.

The license installs and details are viewable under the Current License(s) tab:

Current License(s)

Licenze Category Llicenze Type Max No. of Devices Purchasze Order
Standard Device 200 S009
e In addition to choosing the file, it is also possible to copy and paste
the license code directly into the text box.

The Virtual Appliance is now ready to enroll and monitor devices up to the quantity of

devices licensed.
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4. Setup Wizard

4.1. Overview

nShield Monitor is delivered as an Open Virtual Appliance, OVA, format. The OVA includes a
64 bit Linux based OS. The nShield Monitor system can be accessed with a web browser.

Supported web browsers include:

- Firefox (Version 44 or higher)
- Internet Explorer (Version 11 or higher)

« Chrome (v 55.0)

4.2. Wizard

The initial setup of nShield Monitor upon first boot and login is done via a setup wizard. This
setup wizard can be run both from the WebUI or the Command Line Interface (CLI). It is rec
ommended that you use the WebUI Setup Wizard for initial setup of nShield Monitor.

o ‘ See nShield CLI Commands for details on how to setup using the CLI.

1. Access the Virtual Appliance from your Internet browser, go to:

https://XXX.XXX. X. XXX

(Use the IP address assigned in the CLI during the installation process.)

2. If the password was not changed during an initial OVA installation, via the CLI, enter
the default admin username and password.

3. Followed by a new password.
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Old Password :

New Password :

4. Click Change Password.

Once your password has changed (either using the CLI or the WebUI), the nShield Monitor
Setup Wizard loads.

o ‘ The Wizard prompts you through each tab.

1. Click Start.

The EULA page displays In order to continue to setup, you must accept the terms of
the End User license Agreement (EULA) provided with the Virtual Appliance. If you
decline the EULA, you will be automatically logged off.

2. Read through the entire EULA and then select | Accept.
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Decline | Accept

The Email Setup page displays.

+ Welcome Y EULA Ernail System Administrators Metweork Key Generation Date and Time

Ready to Setup

Set the Defaulft User's Email Address |

Email :
Confirm Email :

3. Enter the email associated with the default user (admin).

4. Enter the email a second time to confirm and then click Next Step.

The Create Administrators page opens.
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« Welcome W EULA « Email System Adminisfrators Metwaork Key Generafion

Date and Time Ready to Sefup

Create Administrators
Administrator One

User Mame :

Email :

Confirm Email :

| |
oo

User Name :

Email

Confirm Email :

4.2.1. Creating Administrators

nShield Monitor requires at least two administrators. During the setup,
the system prompts to create two new Administrators (in addition to

the default administrator which cannot be deleted during setup). The
9 best practice recommendation is to come back and delete the default
administrator, after you have successfully created your two official
administrators, as described in the procedure below.

1. Enter the User Name (e.g., Admin1) and Email (and confirm email) for each Administra
tor.
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2. Select Next Step.
A one time password is automatically sent to the both Administrator email addresses.

The Create Administrators page displays:

Create Administrators

User Name : User Name :
Email : Email :
Confirm Email : Confirm Email :

3. Complete the fields and then select Next Step.

The Network Settings page opens:

Monitor v2.8.0 Install and User Guide 15/284
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" Welcome " EULA " Emai " Systemn Adminisfrators Metwaork

Key Generatfion Date and Time Ready fo Setup

Network Setfings

IP Address :

| 10.1.7.124 |

Subnet Mask :

| 255.255.246.0 |

Gateway :

| 10.1.1.20 |

Hostname:;

| localhost |

Domain {optional) :

Primary DS [optional) :

Secondary DMS [opfional) :

Mail Host [optional) :

Chail Host Credentials (optional)

Mext Step
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4.3. Setting up the Network

To use nShield Monitor, you must setup a network.

0 Please do not change the following parameters without assistance from
your IT support/infrastructure organization.

- IP Address

+ Subnet

« Gateway

+ Hostname

+ Domain (optional)

« Primary DNS (optional)

- Secondary DNS (optional)
- Mail Host (optional)

+ Master Key Generation

Mail Host Credentials are optional. Should you select the Mail Host
e Credentials box, a window opens prompting for Mail Host User
Name and Mail Host Password.

1. On the Network Settings page, select Next Step.

=]

The Master Key Generation page opens.
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" Welcome " EULA « Email " Systemn Administrators ' Metwork

Fey Generation Dote and Time Ready fo Setup

Master Key Generation

Passphrase One

Passphrose :

Confirm Passphrase :

Passphrase Two

Passphrase @

Confirm Passphrase :

4.4, Master Key Generation

The master key consists of an AES256 wrapping key and an HMAC-SHA-512 hash key that
is used as the root of protection.

The master key is derived by using the two passphrases, using PBKDF2, that are input dur-
ing the wizard configuration after the first boot and after every reboot.

The master key is never stored in persistent storage.

Please note to record each passphrase in a secure location as you will re-enter them when
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nShield Monitor reboots.

1. Enter Passphrase One and Passphrase Two and then re-enter both for confirmation.

" K2y Genarafion Dote and Time Ready o Sefup

Master Key Generation

Passphrase One

Passphnrase :

(TTITYTT] o
Confirn Possphrass

(TTITYTT] o

Passphrase Two

Passphrase :

T Y] v
Confirn Passphrase

T Y] v

2. Record both phrases before continuing to the next step.

3. Select Next Step.

The Date/Time Settings page opens.

4.5. Date/Time

The Network Time Protocol (NTP) is an Internet standard protocol that synchronizes com-

Monitor v2.8.0 Install and User Guide
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puter clock times on your network. NTP servers transmit time to their client systems.

NTP Disable is the default setting. If you select NTP Enable, a new win-
o dow opens and you are prompted to enter the NTP Server Address(es).
You have the option of entering multiple servers, as long as you sepa-

rate the entries with commas.

" ey Genearafion Dote and Time rReady fo Sefup

Date/Time Settings

MIP Enable  «F MIP Disable

Time:

| 19:42

Date :

02/10/2017

Time fone &

W (GMT -05:00) Eastern Time [US & Canada) [V |

Mext Step

451. NTP Disabled

1. Select NTP Disable.

2. Enter Time, Date and Time Zone.
The default setting is:

GMT Greenwich Mean Time.
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3. Select Next Step.
The Ready to Setup page opens.

4. Continue to Ready to Setup.

452. NTP Enabled

If NTP is enabled, you must indicate the NTP server that you want to use in the NTP Server
Address field.

0 You can enter multiple servers, as long as you separate them using com

mas.

1. Use the drop down arrow to open the Time Zone drop down menu.
2. Select the appropriate Time Zone.

3. Select Next Step.

The Ready to Setup page opens.

4.6. Ready to Setup

1. Select Initialize.

The initialization status page opens and tracks the process.

Initializing System

Initialization Task Status Result

Generafing Master key v Master key generated an
Set Default User email address v Ernail changed CK.
Create user 'adminl’ 4 User created QK.

Assign System Administrator role to ‘"admini’ v Role assigned OK.
Create user 'admin' 4 User created OK.

Assign System Administrator role io "admin2' v Role assigned OK.
Setting Date/Time/NIP/Network values and rebooting [w]

nShield Monitor Reboots.
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4.7.Log In

1. Enter your User ID and Password.

‘ admin ‘

Forgot your password®

2. Select Log In.

The Master Key needs to be reloaded every time that nShield Monitor is rebooted.
After rebooting, you are prompted to enter the Master Key passphrase.

@ Master key has been generated, but has not been loaded. You must load the
Master key for monitoring operations.

™

3. Select the message to initiate the Master Key load.

The Master Key / SSL Certificate and the User Interface SSL/TLS Options windows

open.

4. Enter Passphrase One and Passphrase Two.

Master key

Fassphrase One
Passphrase - Passphrase -
BEEBEERD vf | BB EEN

Load Master key Desiroy Master key

5. Select Load Master Key.
The GUI session disconnects and the a pop-up reports:

Connection to nShield Monitor has been lost. If you have updated SSL Certificate,
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change the IP address or Hostname of nShield Monitor. You will need to open a new
browser window to correct address. Attempting to reconnect.

6. After the system reconnects, log back on to the system.

The system is now ready to use.
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5. Configuration Logged in as Administrator

5.1. Overview

After setting up nShield Monitor, Administrators can modify the system setup via the Con-
figuration tab.

o To see the options available to a Group Manager, see Configuration
Logged in as Group Manager.

The Administrator is able to set date and time, events, create groups, update licenses, con-
figure the network, reboot the system, set up security, perform upgrades, and set up users.

Logged on as an Administrator, the Configuration tab displays the following:
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Dashboard Views - Conﬁguru’ricE] Logs Alarms

Date/Time ‘

Events
Groups

License

Monitor Status » Mail Host

Network

edged Alarm Sum

Reboot

Security

Upgrade

Users

5.2. First Time Setup

In order to begin using nShield Monitor, several steps must be taken. These include:

« HSM configuration - verifying that the HSMs to be monitored are enabled for SNMP

Installing the appropriate nShield Monitor License
+ Creating groups and users in the nShield Monitor Virtual Appliance

+ Enrolling devices to appropriate groups

0 Please note that a device can be assigned to one group or to many
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separate groups.

+ Open firewall port settings

5.2.1. Configuring the nShield/Client Host

In order to properly manage your HSM estate with nShield Monitor, you must perform the
following on each device:

+ Enable SNMP and add SNMPv3 users
+ Enable the collection of utilization data
+ Set the period over which utilization statistics are to be collected to 60 seconds

- Enable the collection of health check counts
These tasks can be performed via the appropriate commands as follows:
« UTILCFG to set the period over which utilization statistics are to be collected.

0 ‘ Must be set for 60 seconds.

UTILENABLE to enable the collection of utilization data
- HEALTHENABLE to enable collection of health check counts

SNMP to enable provision of utilization and health check data via SNMP
+ SNMPADD to add an SNMP community or user

5.2.2. Configuring the nShield HSM

Refer to the SNMP V3 Agent for nShield Installation Guide and to the SNMPv3 Agent for
nShield User GuideV'3 User Guide for the steps to follow in order to properly configure the
nShield HSM.

5.2.3. Step 1: Create Groups

In order to begin monitoring, the first required item is to create groups that will contain the

monitored devices.

o ‘ You must be logged in as an Administrator.

1. Navigate to Configuration > Groups.

2. Select Add New Group.
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Group Management

Add Ne:.i Group

The Group Setup page opens.

Group Setup

New Group Mame :

Mew Group Description [optional) :

Cancel Changes

3. Enter the New Group Name along with an optional description.

4. Select Create Group.

o It is a best practice to never create more groups than the number
required to manage the number of devices that you have.

0 | nShield Monitor can support up to 32 groups.

5.2.4. Step 2: Configure the Group Manager Role

Once you have created your groups, you will need to configure one or more users with the
Group Manager role.

o This procedure also includes how to associate a Group Manager with a
group.

1. Navigate to: Configuration > Users.
2. The Manage Users page opens.

3. Select Create User.
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4. The Create a New User page opens.
5. Enter the new user data.

o You select the Auto-Logout Duration by sliding the circle to the
right to increase the length of time.

Auto-Logout Duration :

5 minutes

5 mi-w’f@s\ 50 minutes
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Create a New User

ser Mame ;

Full Mame [optional) :

Description [opfional) :

Erncil

Confirm Ennail :

Auto-Logout Duration :

5 minutes

5 minutes

Possword BExpirafion

Monthly v

Assign Role|s) for this User :

¥ MoRole  Administrator  Group Manoger  Auditor

Cancel Changes

&0 minutes
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6. Complete the open fields appropriately and under Assign Role(s) for this User, select
Group Manager.

7. The Assign User to Groups window opens.

Assign User to Groups
Click a group in either selection box to move it to the other one.
Any chonges made will not be saved unfil vou click the Save changes button.
Member of Availoble groups
Filter groups Filter groups:
Group 1
Group 2
Group 3
Create User Cancel Changes

8. Associate the user to groups by selecting the group name (e.g., Group 1).

9. When clicking on a Group name in the Available groups list, the group name moves to
the Member of list.
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Member of Available grou :]
Group 1 [added) Group 3
Group 2 [added]

10. Select Create User.

The User is created.

Back to Previous Fage

User Created. One-Time Passwaord 5 3EMWd bz

The one-time password is displayed on the screen and is emailed to the user.

5.2.5. Step 3: Group Manager Enroll Managed Entities to Groups
The Group Manager can add devices (i.e., enroll entities) to be monitored into the groups.
See Configuration Logged in as Group Manager.

A Group Manager can be configured to access one group, a subset of all the groups or all of

the groups in nShield Monitor.

Based on your current environment, the persons responsible for the day to day operations
of the monitored devices are usually the appropriate persons to assign to this role.

It is possible to assign a user to both Administrator and Group Manager
roles. In doing so, operations and functions of both user roles can be per
o formed. You should refer to your organization’s policy on whether a user
with multiple roles is allowed to exist within your security management
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‘ system.

5.3. Edit Profile page

The Edit Profile page is accessed by selecting (i.e., clicking on) your User ID located in the
top right corner of the page.

l ::ldminli System Administrator ), Jan 8, 2018 11:24:10 [GMT-10:00) @

. Log Out

From this page, you can perform the following actions:

Add a description

« Update the email address
« Change the password

+ Set the Auto-Log duration

- Select a custom date format

When you select a custom date format, the chosen format is associated with your user ID
giving each user the option of selecting their preferred format. Once the format has been
selected, it is consistently displayed in accordance with your selection.

The only date format that will not change is the date in the User ID line, as shown below:

admin | System Administrator ) JJan 8, 2018 11:24:10 [GMT -10:00] |@

. Log Out

o You can select the check box for Use Browser Timezone for Exporting
Events, based on your preference.

nShield Monitor keeps track of things like table column sort order, which
0 sections of a page are collapsed/expanded, chart settings, etc., as part

of your GUI Persistence Profile.

You are able to restore Custom Date/Time Format settings to the factory default through
the admin’s GUI Persistence Profile tab, Reset to GUI Default option.
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Reset fo GUI Default

5.3.1. Changing your Password and Email and set the Auto-Logout
Duration

1. Click on the <user name> on the upper right hand corner of main screen, (e.g., click on
admin).

admin [ System Administrator ), Jan 20, 2017 15:54 @

. Log Out

The Edit Profile window displays:

Edit admin’s Profile :

Full Name [optional) :

| Default System Administrator

Description [optional) :

| The default system administrator

Email :

| dashmytest@gmail.com

Change Password :

Auto-Logout Duration :

60 minutes
5 minutes 60 minutes

Cancel Changes
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2. To change the password:

Enter the old password in the Change Password field. As you type, the system will
prompt.

As prompted, enter the new password once, and then again, to confirm.
3. To change your email:

Enter the new email in the Email field.
4. The Auto-Logout Duration is set to 60 seconds by default.

Use the slide to adjust this setting.

5. Select Save User.

5.3.2. Formatting the Admin Date and Time

1. Select the Custom Date/Time Format drop down arrow.

admin’s Date/Time Formatting :

Custom Date/Time Format :

Mone (default) | v

yyyy-Mh-ddTHH:mm:ss.s587'

| Example:

[ Use Browser Timezone for Exporting Events

Save Date Format setting

The drop down menu opens.
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admin’s Date/Time Formatting :

Custom Date/Time Format :

utc
Month/Day/Year
Day/Month/Year

Custom Formnat 15¢.555 L'

[ Example: )

[] Use Browser Timezone for
Exporting Events

save Date Format sefting

2. Select your preferred format.

3. Select the Use Browser Timezone for Exporting Events check box to export
logs/alarms using the same Date/Time format as that displayed on the web page.

Date/Time on all web pages display in the format configured in the User Profile.
By default, exported logs/alarms show Date/Time in GMT format.

4. Select Save Date Format setting.

5.3.3. Resetting the Admin GUI Persistence Profile

nShield Monitor keeps track of things like table column sort order, which sections of a page

are collapsed/expanded, and chart settings, etc.

nShield Monitor also provides you with the means to reset Custom Date/Time Format set-

tings for your profile.

Selecting the Reset to Factory Default option does not affect nShield
o Monitor Configuration settings, but it does reset Custom Date/Time
Format settings in your profile.

To return to the default for the Date/Time format:
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1. Select Reset to GUI Default.

A confirmation message displays:

admin's GU| Persistence Profie & reset o Factory Default.

For more information, see Managed entities.

5.4. Configuration Tab tasks

The nShield Monitor main menu page contains a Configuration tab. This tab provides quick
links to individual pages. The following sections provide a brief discussion of actions avail-
able via the quick links.

0 For display purposes, the parameters displayed in this section are those
found on the Configuration tab for the Administrator user type.

5.41. Date/Time

Navigate to: Configuration > Date/Time.

The Date/Time Settings window opens.

5.4.1.1. Date/Time - NTP Disabled

Most operating systems, including Windows, OS X, Linux, have an option to automatically
synchronize the system clock periodically using a network time protocol (NTP) server. With
nShield Monitor, you can toggle this option between disabled (off) and enabled (on).

This allows either manual configuration or setting up an NTP server to adjust time as
needed.

1. Select NTP Disabled.
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Date/Time Settings

" NTP Disabled MTP Enabled

12/05/2018

Time Zone :

‘ [GMT -08:00) Pacific Time (Us & Canadal; Tijuana ﬂ ‘

Cancel Changes

2. Enter data appropriately and select your Time Zone from the drop down menu.

e The default Time Zone on nShield Monitor is GMT. Change it appro-
priately to match your organization’s Time Zone.

3. Select Save.

5.4.1.2. Date/Time - NTP Enabled

o | Changing date, time, or NTP options will reboot nShield Monitor.

If NTP is enabled, you must indicate the NTP server that you want to use in the NTP Server
Address field.

You can enter multiple servers, as long as you separate them using commas.

1. Select NTP Enabled.
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Date/Time Settings

MNTP Disabled " NTP Enabled

NTP Server Address|es) :

‘ O.us.pol.ntp.org v ‘

ime

‘ 14:57 ‘

Date :

Time Zone :

‘ (GMT -08:00) Pacific Time (US & Canada); Tijuana ﬂ ‘
save Cancel Changes

2. Enter the NTP Server Addresses (separated by commas).

3. Select the Time Zone drop down arrow to open your selections.

0 When NTP is enabled, the time and date field are already populated.
You are not able to change them.

The default setting is: GMT Greenwich Mean Time.
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MNTP Server Address|es) @

(GMT -11:00) Michway Island, Samoa A
(GMT -10:00) Hawaii
(GMT -09:00) Aloska (Anchorage)

GMT -08:00) FPacific Time (US & Canada): Tivana
(GMT -07:00) Mountain Time (US & Canada)
(GMT -07:00) Arizona (Phoenix); British Columibia (Fort 5t. John)

[GMT -07:00) Chihuvahua, La Paz, Mazatlan

(GMT -06:00) Central Time [(US & Canada)

(GMT -06:00) Saskafchewan (Regina)

(GMT -06:00) Mexico City, Guadalajara, Monterrey

(GMT -06:00) Managua

(GMT -06:00) Central America

(GMT -05:00) Eastern Time {US & Canada)

(GMT -05:00) Indiana {Indionapolis)

(GMT -05:00) Lima, Boegota, Quite. Panama City

(GMT -04:00) Atlantic Time (Canada)

(GMT -03:00) Sanficgo, Asuncion

(GMT -04:00) Caracas, La Paz

(GMT -03:30) Newfoundland (5t. John's)

(GMT -02:00) Brasilia, Sao Paulo, Montevideo

(GMT -02:00) Buenos Aires, Manaus, Georgetown, Paramaribo

(GMT -03:00) Greenland

(GMT -02:00) Mid-Atlantic

(GMT -01:00) Azores, Cape Verde lslands

(GMT +00:00) Greenwich Mean Time: Casablanca, Monrovia

(GMT +00:00) Greenwich Mean Time

(GMT +00:00) Greenwich Mean Time: London, Edinburgh, Dublin, Liskbon
(GMT +01:00) Paris, Rome, Madrid, Brussels, Amsterdam

(GMT +01:00) Berlin, Copenhagen, Oslo, Stockholm, Zurich, Vienna v

e = B = ]

4. Select your time zone.

The system prompts for confirmation:

Time Ione :

(GMT -08:00) Pacific Time [US & Canada): Tijuana E ‘

Mo, don't save

o ‘ Changing date, time or NTP options will reboot nShield Monitor.

5. Select Save.
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5.4.2. Events
nShield Monitor provides the capability for event notification via:

+ Syslog
« SNMP and SNMP trap receiver

« Email

Event Management

# Syslog  SMMP Email

o | nShield Monitor can support up to 5 Syslog/SNMP servers at a time.

Navigate to: Configuration > Events.

The Event Management page opens.

Event Management

« Syslog  SNMP Email

Add Syslog Server

Host or IP Port
Notification Policy: Remote Syslog
Policy Category Info Notification Warning Error Critical Alert Emergency
Monitor-Specific Security Events O | O O O O O
Device-Group Specific Events O O Il O O O O
Monitor-Specific General Events O O O O O O O

Save Seftings

5.4.2.1. Adding a Syslog Server

1. Navigate to: Configuration > Events > Syslog.
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Event Management

#Syslog  SMMP Email

Add 3yslog Server

Host or IF Port

2. Click Add Syslog Server.

Event Management

Port :

3. Enter the Host or IP of the syslog server.
4. Enter the Port number.
5. Click Save new Server.

6. Once the Syslog Server is configured, select the policy category and severity combina
tion that you would like reported to the Syslog Server.
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Notification Policy: Remote Syslog

Policy Category Info Nofification Warning Error Critical Alert Emergency

Monitor-Specific O O O O O O U]

Security Events

Device-Group O 0O B O ] ] ]

Specific Events

Monitor-Specific O O O O U O L]
General Events

Save Seftings

7. Select Save Settings.

5.4.2.2. Deleting a Syslog Server

1. Select the check box associated with the HP or IP address of the Syslog server to be
deleted.

Event Management

o Sydog  SMNMP Emnail

Add Syslog Server

Host or IF

l 10.1.7.1485

The Delete Server(s) tab activates.

2. Select Delete Server(s).

A confirmation page opens:
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Event Management

o Syslog  SMNMP Email

Add Syslog Servar Cancel Deleta Confirm Delele

Hast or IP

Notification Policy: Remote Syslog

Pelley Category Infe Hedificd
Maonitor-Specific Securty Evends <
Device-Group Specihc Events 2
Maonitor-Specific General Bvents -

3. Select Confirm Delete.

5.4.2.3. Download MIBs

1. Navigate to: Configuration > Events > SNMP.

2. Select Download MIBs. The system prompts with the option to Open, Save, or Cancel.

Event Management

Syslog  #*SHMP  Email

Downlood MIBs Add SMNMP Trapsink

Host or IF

3. Select your preference.

5.4.2.4. Support for n"CSNMP traps

The nShield Monitor user interface provides event notifications for supported nCipher
SNMP (nCSNMP) traps on the Dashboard, Logs and Alarms pages.
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+ Policies can be set about the notification level, for example warning or emergency, for
SNMP traps in general. These policies are managed by Administrators, Assign Notifica-
tion Policies for SNMP.

« Group Managers can associate these notification policies with device groups and trap
groups:
° Assign SNMP Notification Policies for Groups.
° Assign SNMP Notification Policies for Trap Groups.

The following SNMP traps are supported:

Trap ID Name Severity Trigger Event

hardserverAlert Hard Server Failure ERROR The nCipher host-side mod-
ule control software failed

hardserverUnAlert Hard Server NOTIFICATION The nCipher host-side mod-

Restart ule control software

restarted after a previous fail
ure event.

moduleAlert Module Failure ERROR The nCipher hardware failed.

moduleUnAlert Module Restart NOTIFICATION The nCipher hardware
restarted after a previous fail
ure event.

psuAlert PSU Failure ERROR The power supply to an
nShield Connect failed.

psuUnAlert PSU Restart NOTIFICATION The power supply to an
nShield Connect is now oper
ational, after a previous fail-
ure event.

fanfailureAlert Fan Failure ERROR The speed of an individual
fan on the nShield Connect
is zero.

fanfailureUnAlert Fan Restart NOTIFICATION Fan speed is now non-zero,
after a previous failure event.

memoryUsageHighAlert Memory Usage ERROR The HSM memory usage

High high threshold has been

reached.

memoryUsageOkAlert Memory Usage NOTIFICATION The memory usage is below

Normal

the HSM memory usage ok
threshold.
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5.4.2.4.1. Assign Notification Policies for SNMP

1. Sign in as Administrator.
2. Navigate to: Configuration > Events > SNMP.

3. Select your preferences for the Policy Categories.

Notification Policy: SNMP

Policy Info  Mofification Waming Emor Critical Alert Emergency
Category

Maonitor- o 0O O O O O O
Jpecific
Security Events

Device-Group [0 O O O O O O
Jpecific Events

Manifar- O O [ Od O [ O
Lpecific

General
Events

4. Select Save Settings.

5.4.2.4.2. Assign SNMP Trap Settings

o | The settings need to match the SNMP trap settings on the devices.

1. Log in as Administrator.

2. Navigate to: Configuration > Events > SNMP.

SNMP TRAP Receiver v2/v3 Credentials Setfings

SMMF TRAF Enabled: O

Save SHNMP Trap Setings

Delete SNMP Trap Setlings

3. Select the SNMP TRAP Enabled box. The SNMP Trap Setting page opens.
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SNMP TRAP Receiver v2/v3 Credentials Settings

SMMF TRAF Enabled:

Usernanme :
Fleqse enter a valid SHMP TRAF user name, Mininum & and
rnaxirnum 32 characters, no special characters are allowed.
Authenticaficn Algorithm :

EHA W
Authenticafion Possword -

Privacy Algorithrm :

AES-2546 W

Privacy Password :

SMMPw2 TRAP Enabled: [

4. Populate the following data fields: Username, Authentication Password, and Privacy
Password.
5. Select your Authentication Algorithm from the list.

6. Select your Privacy Algorithm from the list.

o ‘ Client Hosts only support AES.

7. By default, SNMP traps are supported only for SNMP v3. Therefore, option SNMPv2
Enabled is not enabled by default.

8. Select Save SNMP Trap Settings.

5.4.2.4.3. Configure SNMPv3 Traps on the SNMP Daemon

trapsess [SNMPCMD_ARGS] HOST defines the configuration for a trap. This is the only way to
define SNMPv3traps. SNMPCMD_ARGS are arguments that would be used for an equivalent
snmptrap command. So, for example to send a SNMPv3trap as USM user user1 with authen

Monitor v2.8.0 Install and User Guide 46/284



Chapter 5. Configuration Logged in as Administrator

tication and encryption, use -v3 -u user1 -1 priv. For example:

trapsess -v3 -u user1 -1 authpriv IP-address:port

To configure SNMPv3 traps on the SNMP daemon:

1. Navigate to the snmp folder:
° Linux: /opt/nfast/etc/snmp
> Windows: c:\program files\nCipher\nfast\etc\snmp
2. Stop the SNMP daemon:
° Linux: run /etc/init.d/nc_ncsnmpd stop
° Windows: via Services, the name of the service is nCipher SNMP Agent

3. Add the trapsess to the snmpd.conf file. Replace <userRW>, <userRO>, <trapre-
ceiverlP>, and port with your values.

trapsess -v3 -u <userRW> -1 authpriv <trapreceiverIP>:<port>
trapsess -v3 -u <userR0> -1 authNopriv <trapreceiverIP>:<port>

4. Restart the SNMP server:
° Linux: /etc/init.d/nc_ncsnmpd start

° Windows: via Services, the name of the service is nCipher SNMP Agent

5.4.2.4.4. Delete SNMP Trap Settings

1. Navigate to: Configuration > Events > SNMP > SNMP Trap Receiver v2/v3 Creden-
tials Settings.

SNMP TRAP Receiver v2/v3 Credentials Settings

SMMAF TRAF Enabled: O

Save SMMFP Trap Settings

Dealete SNMP Trap Credenfials Setfings

)

2. Select Delete SNMP Trap Credentials Settings. The system response confirms the
deletion.
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SNMP TRAP Receiver v2/v3 Credentials Settings

SMMF TRAF Enabled: O

Save SHMP Trap Seffings

SMMF Trap Credentials have been deleted T

5.4.2.4.5. Add SNMP Trapsink

1. Navigate to: Configuration > Events > SNMP > Add SNMP Trapsink.

Event Management

Syslog  #*SHMP | Emnail

Dowmicod MIBs Add Sr-u-.“lF'ﬁ::;:sink:

Host or IF

2. Two options are displayed, one for SNMP V2, and one for SNMP V3. By default, SNMP
V2 is selected, and the SNMP V2 settings are shown. To load the SNMP V3 settings,
select SNMP V3.
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Event Management

182

Community :
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Event Management

Configure the Trapsink:

For SNMP V2: Enter the Host or IP address of the SNMP device, the port number
(default: 162), and the community.

For SNMP V3: Enter the Host or IP address of the SNMP device, the port number, the
username, the authentication algorithm, the authentication password, the privacy algo-
rithm, and the privacy password.

3. Select Save new Trapsink.

5.4.2.4.6. Delete the SNMP trap
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1. Navigate to: Configuration > Events > SNMP
2. Select Delete Trapsink(s).

3. Select the appropriate SNMP trap to delete.
4. Select Save Settings.

5.4.2.5. Request email notification

1. Navigate to: Configuration > Events > Email.

Event Management

Sydog  SNMP  f Email

Email Nofification Enabled

Notification Policy: Email

Policy Category Info MNofification Warning Emor Crifical  Alert  Emergency

Monitor-Specific |0 O O O O O O
Security Events

Monifor-Specific 0O 2O O O O O O
General Events

Save Sefings

2. Select Email Notification Enabled.
3. Select the Policy Category and severity combination.

4. Select Save Settings.

5.4.3. Groups
Groups can be added, deleted and sorted.
1. Navigate to: Configuration > Groups.

The Group Management page opens.
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Group Management

Add New Group

q Search:

A Group Nome | Descripfion

Group 1 Unit test Group 1
Group 2 This is Group 2
Group 2 This is Group 3
Group &

Status

Managed by user. Devices enroclled.
Managed by user. Devices enroclled.
Managed by user. Devices enroclled.

Managed by user. Devices enroclled.

5.4.3.1. Add a New Group
1. Select Add New Group.

The Group Setup window opens.

Group Setup

MNew Group Mame :

Mew Group Description |opfional) -

P R ———
Cancel Changes

2. Enter a New Group Name and optionally, a description.

3. Select Create Group.

5.4.3.2. Delete Groups

You can only delete a group if its status is empty, i. e.,

- the group is not managed by another user

+ the group does not contain any enrolled devices

« there are no scheduled reports associated with this group.
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5.4.4. License
From the License tab, users can:

+ View general license data including license count
- Add licenses
« Install licenses

1. Navigate to: Configuration > License.

The System License page opens.

System License

Serial Numizer: Tkig 7y 1P n7 5Y 9x8X-kc PM LXK O ZzyD Ly Fo
Total Licensed Device Count: &

Used Licensed Device Count: & nShields

Unused Llicensed Device Count: Q

Curmrent License(s)

license Type Max No. of Devices Remaining Days

evaluation 3 29

Choose Boense file :

Choose Fle

Licernse Code :

=
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5.4.41. Add a License

1. Select Choose File.

Choose koense file

Choose Fle

License Code :

The file browser window opens:

=

| Computer

System Folder

4

b | Libraries
[» .. Documents MNetwork

System Folder

> b Music

F

[» &=L Pictures

) Adobe Acrobat 2017
3 g‘ Videos Shartcut
o 2.00 KB
b A Comnuter b A o ol .

File name:

2. Navigate to the file location and select the file.

3. Select Install License.

5.4.4.2. License Warning Banner

When the number of enrolled devices exceeds the maximum number of managed devices, a
warning banner displays on the top of the web page.

Monitor v2.8.0 Install and User Guide 54/284



Chapter 5. Configuration Logged in as Administrator

The highlighted message instructs you to reduce the number of managed devices.

5.4.5. Mail Host

From here you can configure your nShield Monitor's out going email address, i.e., your
"from" address,and you can send a test email.

o ‘ A mail host may be required in order to enable email.

1. Navigate to: Configuration > Mail Host.

The Email and Messaging page opens:

Email and Messaging

Mail Host (optional) :

L] Mail Host Credentials (optional)

. Enter your mail host.

. Enter your Email sender address.

. Select Save.

. Enter your Email ID for Sending Test Email.

. Select Send Test e-mail.

N O oo o w N

. Locate the test email in your email In-box.

5.4.6. Network

The base network configuration including IP address, subnet mask and default gateway can
all be changed via the Network Settings page.

Changing any one of these settings requires that you close your
browser and reconnect approximately 15 seconds after you save the

0 new settings. If you change the IP address, you will have to redirect your
web browser to the new IP address or host name.
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1. Navigate to: Configuration > Network.

The Network Settings page opens.

Network Settings

" DHCP

IP Address : Domain [optional) :

‘ 10.3.202.202 | ncipher.com

Subnet Mask: Primary DNS [optional) :

‘ 255.255.0.0 | | 10.3.110.104

Gateway: Secondary DNS [opfional) :
‘ 10.3.30.254 | |

Hostname:

‘ nshield-only |

Cancel Changes

2. Select your preference:

> Dynamic Host Configuration Protocol (DHCP) IP addressing or
° Static IP addressing

s

3. Select Save.

5.4.7. Reboot
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Users with System Administrator privileges are able to reboot the nShield Monitor virtual
appliance.

1. Navigate to: Configuration > Reboot.
The System Reboot page opens.
2. Select Reboot Now.
The system prompts for confirmation prior to initiating the reboot.

3. Select Yes, reboot now to continue the process.

5.4.8. Security

1. Navigate to: Configuration > Security.

The Security page opens.
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Master key

" Master key iz cumently loaded.

¥ Miaster key

S3L Certificate

«" View Cerificane f-Signed Cerfificare Senerate Cerificate Request

Country :

State :

City :
CompanyfCrganization :
Department :

Common Hame :

Ermil

lzsued To

Country

State :

ity :
Companyforganization :
Department :

Common Name :

Emnail -

valid From :

Vald To :

User Interface S5L/TLS Options

BAzzL w2
B zsL w3
e v
O wia
Onewvie

—

Denied Protocols:

Install Signed Cenificane

Change Pending Approwal:

B zsL w2
Bl zsL w3
F1s w1
Btz via

Onswvie
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Password Setfings

cbal Password Expiration :

Mionthly W

assword Reuse History Length -

B —
LIS

[Lost posswors

Miinirvrn Password Length :
I
Password Complexity -

M Lowercose Characters 1

O Uppercase Characters

M Mumbers | 1

O special Characters

5.4.8.1. Master Key

The master key consists of an AES256 wrapping key and an HMAC-SHA-512 hash key that

is used as the root of protection.

The master key is derived by using the two passphrases using PBKDF2, that are input during

the wizard configuration after the first boot and after every reboot.
The master key is never stored in persistent storage.

Two passphrases are required for generation of the key. Enter be entering each passphrase

twice.

o Please note to record each passphrase in a secure location as they are
required to be reentered when nShield Monitor is rebooted.

To destroy a Master Key:

o The Master Key can only be destroyed if all of the enrolled devices have
been deleted.

1. Select Destroy Master Key.
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Master key

+ Master key is curently loaded.

Destroy Master key

2. Select Yes, destroy it.

Master key

@ Destroying the Master Key will sfop the device monitoring, invalidate any user installed
33L cerificate, and device credentials.

Mo, don't destroy it Yes, destroy it

Please note that destroying the master key stops all device monitor

e ing and renders all device credentials invalid. The system must be
reset after this operation.

To generate a new master key, enter the two passphrases as before.

5.4.8.2. View the SSL Certificate

By viewing the current SSL certificate, the administrator can determine what type of certifi
cate is currently installed in the system.

By default, the system installs a self-signed SSL certificate with fixed values for common
name, country state, city, etc.
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SSL Certificate

+ \iew Cerlificate Generate 3=lf-Signed Cerfificate Generate Ceriificote Request

Install Signed Certificate

lssued By

Country - U3
State : A
City -

Company/Organization :

Departrmend -

Common Name :

Ennail :

Issued To

Country - us
State : CA
Cify

CompanyfCrganizaticn :
Departrnend -

Common Mame :

Email :

“alid From :

Valid To -

As a best practice, it is recommended that at least a new self-signed cer
tificate be generated using the appropriate values. The default SSL cer-
tificate is valid for 30 days.

5.4.8.3. Generate a Self-Signed Certificate

With a self-signed certificate, you can customize certificate information by entering infor-
mation that applies to your nShield Monitor deployment.

1. Select Generate Self-Signed Certificate.
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SSL Certificate

View Certificate » Generate Self-Signed Cerfificate

2. Enter the requested data to complete each field.

0 The default value for the field Certificate Validity in Days is 730
(i.e., 2 years).

SSL Certificate

Yiew Certificate " Generate Self-Signed Cerfificate

Install Signed Certificate

Country -

Generate Cerificate Request

| U3 - United Sates

Statef/Province -

City -

Company/Crganization

Common Name :

Murnber of Days Valid -

|:-'3::
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3. Select Generate Certificate.
This action requires restarting the web services so the new certificate can take effect.
You will need re-login into the WebUI.
The following message displays:

Self-Signed Certificate successfully created. System is restarting the web service,
please log in again.

5.4.8.4. Generate SSL Certificate Request

When a certificate must be signed by an organization’s own Certificate Authority (CA) or a
third party trusted CA, you must generate a ertificate signing request.

The only difference between the fields in a self-signed certificate and a

o certificate signing request are the number of days of validity which will
be determined by the signing CA.

1. Select Generate Certificate Request.

View Certificate Generate Sel-Signed Cerlificate " Generate Cerfificate Request

2. Enter the requested data to complete each field.
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SSL Certificate

Wiew Cerfificate Zenerafe Self-Signed Cerfificate +' Generate Cerfificate Request

Install Signed Certificate

Country -

| Us - United States [~ |

State/Province -

City -

Company/Organization :

Departrent :

Common Name :

3. Select Generate Certificate Request.

The system prompts you to save a file that you will provide to your PKI team or third
party CA provider to sign and return.

o ‘ Private keys are not exported as part of the signing request.

5.4.8.5. Install Signed SSL Certificate

Once your PKI team or third party CA provider returns your signed certificate, you will need
to install it in one of two fashions.
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It is recommended that you ensure that the returned signed certificate

includes the full chain of signers (e.g., nShield Monitor certificate, sign-

ing CA, root CA).

The chain should consist of at least two certificates nShield Monitor certificate and signing

CA) and as many as seven (includes nShield Monitor certificate, signing intermediate CA

and ntermediate CAs between signing CA and the root CA).

e If you receive the file via email be sure to save it to a location where you
can find it.

1. Select Install Signed Certificate.

SSL Certificate

Wiew Cerificate Generate Self-Signed Certificate Generate Cerificate Request

« Install Signed Cerfificate

Choose local file :

Choose Fle

showing the cerfificate file contents, you can also paste the cerfificate contents to the

window:

Install Certificate

2. Select Choose file and browse to locate the file that contains the signed certificate

and the associated signing chain.
3. Open the file and include the contents in the window.

4. Select Install Certificate. The signed certificate is installed.

5. Close your browser session (logout and close the tab) in order to connect using the

new certificate properly.
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0 ‘ You will be prompted to login again when you do so.

5.4.8.6. User Interface SSL/TLS Options

On this page, you can configure which protocols and cipher mechanisms nShield Monitor
accepts.

o This feature requires a quorum approval from a second administrator
before changes made by the first administrator can be applied.

+ By default, SSL v2 & v3, and TLS v1 protocols are disabled.
+ By default, the AES256-SHA cipher suite is disabled.

User Interface SSL/TLS Options

@ssLvz
@ssLva
@75 vl
OTLS w1l
OTLs 1.2

Disabled Cipher Suites:

AES256-3HA -
[ DHE-DSS-AES 1 28-CCM-SHAZSS

Ol DHE-DS3-AES 1 28-3HA254

[ DHE-D88-AES256-CCM-SHASES

[l DHE-DSS-AES254-3HAZES

[ DHE-RS A-AES 1 28-GCM-SHAZES

[ DHE-RS A-AES128-3HA254

] DHE-RE A-AES254-GCM-SHAZEL

[ DHE-RS A-AES254-3HAZ54

[ ECOH-ECDSA-AES 1 28-GCM-5H A254

O ECOH-ECDSA-AES 1 28-5HA2S54

[ ECDH-ECDEA-AEI254-CONM-SH 4354 -

Save Options

To change which protocols and cipher mechanisms are allowed:

1. Navigate to: Configuration > Security.
2. Select the protocols that the GUI server should deny.
3. Select Save Options.
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This generates a warning that lists the protocol option changes that require approval.

e There are protections that make sure at least one option is left
unchecked (which means unblocked).

4. When a quorum approval is pending, one of three actions can happen next:

° The first administrator can cancel the quorum request by selecting Cancel Change
and the system remains unchanged.

° The second administrator can deny the change by selecting Reject Change. This
generates a log message indicating that a change was denied.

° The second administrator can approve the change by electing Approve Change.
This generates a log message indicating that a change was approved, and the GUI

server is restarted.

5. Arestart is required for the new settings to take effect.

This is not a reboot, only a restart of the GUI server. However, any
users that are logged on are sent back to the login page. They will
need to log back in to the system.

5.4.8.7. Password Settings
1. Navigate to: Configuration > Security.
You may need to scroll down.
2. Set the parameters based on your organization’s security policy.

° Global Password Expiration
® Disable
" Never
® Monthly
® Quarterly
" Yearly
° Disallow Password Reuse History Length
® | ast password
® Last 2 passwords
® |Last <n> passwords (up to last 15 passwords)
° Minimum Password Length

° Password Complexity
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Password Setfings

cbal Password Expiration :

Mionthly W

assword Reuse History Length -

B —
LIS

[Lost posswors

Miinirvrn Password Length :
I
Password Complexity -

M Lowercose Characters 1

O Uppercase Characters

M Mumbers | 1

O special Characters

3. Select Save Password Settings.

5.4.9. Upgrade

nShield Monitor has the capability to be upgraded via a file provided by nCipher.

5.4.9.1. Upgrade from 1.1.X

o ‘ The same firmware upgrade file works for all your nShield Monitor appli-

ances. Additionally, the upgrade requires a password, or upgrade key.

The process to obtain an upgrade file for your virtual appliance follows.

1. Send an email to nCipher Support and request an upgrade.

Support forwards a firmware upgrade file (with a .cmf file extension) along with the

upgrade key password.

2. Save the .cmf file to a convenient location. You are now ready to apply the upgrade.

3. Navigate to:

Configuration > Upgrade
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The Upgrade System page opens:

From Verzion

2.5.4.0022

Upgrade System

Choose file to upload :

Select file for upload

Upgrade Key :

Automatically reboot after upgrade : [

Start Owver

Version History

This version of nShield Monitor is 2.5.4 {0029).

To Version Upgrade date/time

2.5.4.002% Fri Dec 07 2018 09:46:41 GMT-0800 [P3T)

4. Click Select file for upload.

5. Navigate to the upgrade file.

>

>

>

‘-.

.| Libraries

“. Documents
<. Music

=L Pictures

g Videos

!—| (@ q CD Drive (D)
o
4 Network Location (1)

. Support (TESFILESVRO1)
] __#' File folder

File name:

_—

- [Custom Files (*.cmf)

ComJ L

6. Select, and open the upgrade file that you just saved.
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7. Enter the password, provided by Support, under Upgrade Key.

At this point, you can choose to have the system automatically
reboot when the upgrade is complete by selecting Automatically
0 reboot after upgrade. Otherwise, you will need to manually trigger
a reboot once the upgrade process has completed. Either way, the

system must be rebooted to complete the upgrade process.

8. Select Automatically reboot after upgrade.

Automatically reboot after upgrade : [ I

If Automatically reboot after upgrade is not selected, you will
need to manually trigger a reboot once the upgrade process has

completed.

9. Select Upload and Perform Upgrade.

Start Over

s

The system displays progress meters to indicate the status.

Please do not navigate away from the Upload page during the
upload process. Should you navigate away, the upgrade automati-

cally cancels.

If the system does not automatically reboot, select Reboot Now button and then confirm

the action with a second click.

When the process completes, the system will either reboot automatically or you will need
to select Reboot Now button and then confirm the action with a second click.

o After the system reboots, the new software version is displayed on the
Dashboard page, in the nShield Monitor Status window.

5.4.10. Creating Users

o ‘ nShield Monitor can support up to 64 users.

e ‘ A user with no role is not allowed to login.
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o | After three failed login attempts, the account is locked

To unlock an account, select Forgot your Password on the login page. You will be emailed a
onetime password (OTP). The first time you log in with the OTP, the account is unlocked

and you are prompted to create a new password.

1. Navigate to: Configuration > Users.

The Manage Users page opens.

Manage Users

Create User

Q Search:

A Login |~ Full Nome

[
O | admin Default System
drninistrator
O odminl
O | odmin2
O | auditor
O group

Email

admi...

admi...

admi...

ag@aqa

aEa

Fassword

Expirafion

Newver

Newver

Newer

30 days

MNewver

Auta
Logout

1 hours

rninutes

rhinutes

30
rhinutes

1 hours

Assigned
Roles

System
Administrator

System
Administrator

System
Administrator

System Auditor

Group
Manager

2. Select Create User.

3. Complete the open fields appropriately.
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Create a New User

Liser Mame -

Full Name [optional] :

Description (opfional) :

Confirm Ennail

Auto-Logout Duration :

5 minutes
& ] ] o} 5} [} i s ] [] ]
5 minutes A0 rrinufes

Assign Role(s) for this User :

# Mo Role  Administrotor  Group Manoger  Auditor

— — £
Lancel Lnanges

When creating a user with the Group Manager role, available groups

must be assigned to the user.

At least one group must be assigned to all users assigned a Group

Manager role.
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Fassword Expirafion

Assign Role|s) for this User:

Mo Role  Administrator Group Manoger  «F Audifor

[ i S
Lancel Lnangss

4. After you have made your selections, select Create User.

5.4.11. Deleting Users
1. Navigate to: Configuration > Users.

The Manage Users page opens.
o | Only those users who have no role assigned can be deleted.
2. Select the Login ID associated with the user to be deleted. The Edit this user page

opens.

3. Under Assign Roles for this User, select No Role.

Azgign Role(s) for this User:

»" Mo Role  Adminisirator  Group Manager

Save User Cance=l Changes

4. Select Save User.

The Manage Users page opens.

5. Select the box associated with the user.
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Manage Users

Create User Delete User|s)

A Login ID

& ool
od

6. Select Delete User(s).
The system prompts requesting a confirmation of the deletion.

7. Confirm the deletion.
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6. Configuration Logged in as Group Manager

6.1. Overview

The Group Manager role is responsible for configuration of devices that are to be monitored
and the day to day monitoring of health and statistics down to an individual HSM device
level.

Group Managers are able to enroll devices, set group alarm thresholds, and configure group
event notifications via email.

6.2. Edit Profile page

Both the Administrator and the Group Manager are able to edit their own profiles.

The Edit Profile page is accessed by selecting (i.e., clicking on) your User ID located in the
top right corner of the page.

Group Maonagsr |, May 24, 20017 0457 @

. Log Ot

From this page, you can perform the following actions:

« Add a description

« Update the email address
+ Change the password

+ Set the Auto-Log duration

« Select a custom date format

o When selecting a custom date format, you can also select: Use Browser
Timezone for Exporting Events.
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Custom Date/Time Format :

None (default) v

vyyy-MM-ddTHH:mm:ss.sss'Z'

[ Example: )

[ Use Browser Timezone for Exporting Evenfs]

Save Date Format setting

When you select a custom date format, the chosen format is associated with your user ID

giving each user the option of selecting their preferred format. Once the format has been
selected, it is consistently displayed in accordance with your selection.

The only date format that will not change is the date in the User ID ling, as shown below:

group [ Group Manoger )| May 24, 2017 0457 | @

. Log Ot

+ Reset the GUI Persistence Profile.

6.3. Managed Entities

Logged on as a Group Manager, the Configuration tab displays the following:
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Configuration = Logs

Group Alarm Thresholds

Group Event Motification

Manoged Enfities

6.3.1. Enrolling Devices/Entities

To enroll a device/entity, you must be logged on as a Group Manager.
For enrolling a device you must configure SNMPV3 on the device with

0 an authentication algorithm and a privacy algorithm, and use the same
during device enrollment.

1. Navigate to: Configuration > Managed Entities.

Configuration - Logs

Group Alarm Thresholds

Group Event Motification

[Munoged Entities ]

The Manage Entity Settings page opens.

Managed Entity Settings

Enrcll Maanoged Entities

2. Select Enroll Managed Entities

The Entity Enrollment options are displayed.
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You can choose to enroll an entity one at a time or you can use a Batch file. The default
is set to enroll a Single Entity.

" Single Enfity  Batch

3. Select the Managed Entity Type from the drop down menu.

+ Single Entity  Batch

Device Details :

Managed Entity Type :
P ——
[Cient Hos %
M ——— «

4. Enter the details information into the appropriate fields, i.e., device details, SNMP

details, and Group Membership details.
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Entity Enrollment

« Single Enfity  Batch

Device Details : SMMP Details :

Managed Enfity Type - Username :
Client Host ey » |

Hostname/IP Address - Port -

| | | 161

Marne |optional) : Authenfication Algothm :

| | SHA ¥

Descrption {opfional) - Authentication Possword -

Location (optional) : Privacy Algorithmm - (Client hosts only support
AFES)

| | AFS b

Stats Timeout
Privacy Password :

E |

Adrnin Tinneout -

K |
Group Membership :
Member of Available Groups

| Filter groups: | | Filter groups: |

[ Manoged Groups N

v

o Both the Authentication Algorithm and the Privacy Algorithm
require a selection from a drop down.

0 ‘ Client hosts only support AES Privacy Algorithms.

5. Click Enroll Device to complete the enroliment process:

Monitor v2.8.0 Install and User Guide 79/284



Chapter 6. Configuration Logged in as Group Manager

Cancel Enroling

6. Select Yes, test connection to test the connection.
° If you would like to skip the test, select No, skip Test.
° If you would like to cancel the data that you just entered, select Cancel Changes.

° If you choose to test your connection and the test is successful are returned to
the Managed Entities page.

If you test the connection and the test is not successful, you
o will receive an error message. Correct the error condition and
re-enter the device information.

ATTENTION: Devices/entities can be assigned to multiple groups.

+ A device/entity can be assigned to groups not associated with the current manager

role; however, this is a one way function.

« In order to make changes or delete a device/entity in a group, the user must be a
Group Manager for that group.

+ A device/entity can be associated into multiple groups during enroliment.

« The same device/entity can be associated to more groups by editing the device.

ATTENTION: All HSMs being monitored must be configured to support SNMPv3 with
nShield Monitor.

6.3.2. Option: Enrolling using a Batch File

1. From the Entity Enroliment page, select Batch.

Single Enfity ~ «* Baich

The Entity Enrollment page opens.

0 ‘ To see a sample batch file, select Download Sample Batch Enroll
File.
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Entity Enrollment

Single Entity ~ #* Baich

Select a batch file o upload :

Choose Fle

Downlood Sample Batch Enroll File:

Cancel Enrcling

2. Select either Choose File or Download Sample Batch Enroll File.

° Enrolling multiple devices at one time requires a comma separated variable (CSV)

file containing all the device information and SNMP information.

° It is possible to create a file without passwords but you will need to still leave a

space where the passwords would go in the file.

Devices can be assigned to multiple groups. A device can be
assigned to groups not associated with the current manager
role; however, this is a one way function. In order to make

o changes or delete a device in a group, the user must be the

Group Manager. A device can be associated into multiple
groups during enroliment. The same device can be associated
to more groups by editing the device.

Device/Entity Batch Entry CSV Fields

CSV File Field Name
Group Name

Device Host name
Device IP address
Device Name
Description

Location

SNMP User Name

SNMP Authentication Algorithm

Notes

Required (string) [multiple groups in square brackets]
Optional if IP address present (string)

Optional if hostname present (IPv4 address - 123.45.67.89)
Optional (string)

Optional (string)

Optional (string - cannot use commas to separate city
from state)

Required (string)

Required (one of [MD5 SHA])
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CSV File Field Name Notes

SNMP Authentication Password Required (string)

SNMP Privacy Algorithm Required (one of [DES AES 3DES AES-192 AES-256])
SNMP Privacy Password Required (string)

SNMP Port Optional (string) default is 161

Device type Optional (string)

Admin Timeout Optional (string)

Stats Timeout Optional (string)

)

Each entity must be listed in a single row and all fields must be separated by com-

mas.

o

For the optional fields, if you do not want to specify a value, leave the field blank.
Both blank lines and comment lines are ignored.

° Example with all fields specified:

Group1, Devicel, 192.168.18.101, Device 1, Device description 1,Location
1,User1,SHA, authpassword1,DES, privacypassword1

° Example with optional fields not specified - Note that those field are left empty:

Group2,,192.168.18.102,Device 2, , ,User2,SHA,authpassword2,DES,privacypassword2

° Example with optional fields not specified - Note that those field are left empty:

Group2,,192.168.18.102,Device 2, , ,User2,SHA,authpassword2,DES,privacypassword2

3. After loading the batch file, select Enroll Devices.

Cancel Enrc 'r.:;||

4. Select Yes, test connection to test the connection.
° If you would like to skip the test, select No, skip Test.
° If you would like to cancel the data that you just entered, select Cancel Changes.

° |If you choose to test your connection and the test is successful, you are returned

to the Device Listing page.

o ‘ If you test the connection and the test is not successful, you
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will receive an error message. Correct the error condition and
re-enter the device information.

6.3.2.1. Deleting Enrolled Devices

You can only delete devices from groups that you have been assigned
the manager role. When a device is associated with multiple groups,
deleting a device from a group removes the association of the device
o from that group only. The device does not get deleted from other
groups that it is associated with. A device gets deleted from nShield
Monitor only when it does not have any association with any other
group.

1. Navigate to: Configuration > Managed Entities.

2. Select the check box next to the device to be deleted.

e Selecting the check box at the header level automatically selects all
the devices in the Group.

3. Select Delete <device>.

6.3.2.2. Editing Enrolled Devices
1. Single click on <device name> of the device to be edited.

The Edit Device Details page opens.
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W

Edit Device Detdails

Device Details :

Managed Enfity Type :

Hostname/IP Address -

| 1921658.19.255

| | 141

Marme {optional) -

| Vps-002

Descaption (opfional) -

SHNMP Details :

Usermame: :

| VpsUsSr

Fort :

Authenficaticn Algorithm :

SHA W

Authenticafion Possword -

| hY =5

Locatfion (optional) :

[ o=

Member of

Group Membership :

| FITE SO

Group 1

Group 2

Group 3

Save Changes

Cancs| Changes

Privacy Algorithm :

DES '

Privacy Posswond -

Axgilable Groups

Managed Groups

Crihver Groups
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The Group Membership window displays two assignments: Mem-
ber of and Available Group. You are able to toggle membership
between the two.

2. Enter the changes/make your selections.

3. Select Save Changes.

save Changes Cancsl Changes I

6.3.2.3. Starting and Stopping Device Monitoring
1. Navigate to: Configuration > Managed Entities.
The Managed Entity Setting page opens.

2. Select the box associated with the device to have monitoring started/stopped.

O A Name IF Address Monitoring Description Locafion

B | Fosalsw2cHl | 1921e80832 | [EENED
O | Foisal SW2CHZ | 192.158.17.141

New action buttons appear:

Ernrcll Manoged Enfities Stop Monifonng Clhent Hosts Delete Client Hosts

The Start Monitoring <device> is a toggle with Stop Monitoring
0 <device>. When the device is being monitored, the Stop Monitor
option is available. When the device is not being monitored, the

Start Monitor option is available.

3. Select the check box next to the device to stop/start monitoring.

e All selected devices must be either enrolled or unenrolled for the
button to be enabled.
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ST—r— r—

Q Search:

Q

reh:

LA
1]
%]

O A Device Name

i VES-003

4. Select <Stop> <Start> Monitoring <device/entity>.

6.4. Group Alarm Thresholds

The Group Manager role can view and set alarm thresholds.

manager [ Group Manager ) JFeb 22, 2018 8:01:27 (GMT-08:00) @

. Log Out

1. Navigate to: Configuration > Group Alarm Thresholds.

The Group Alarm Thresholds page opens:

Group Alarm Thresholds

Group n&hield n&hield n&hield nShield n&hield n&hield n&hield High
Name Warning Critical Peak Peak Object Object Object
Level Level Lewel Duration Cound Count Count
Warning Crifical Durafion
Level Level
nshisid 40 &F a9 15 minutes | 540 7500 15 minutes
Test

2. Select (i.e., click on) the Group that you would like to set.
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3. Utilize the slide bars to set the thresholds.

nshield

Utilization Overload

Alarm Enabled :
kA

Warning Lewvel :

0% 100%
Critical Lewvel :

677

0% 100%

Utilizafion Peak Event

Alarm Enabled :
b

Utilization Lewel :

3%

0% 100%
Curation [in minutes) -

nshield High Object Count

Alarm Enabled :
i)

Warning Lewel :

4. Continue to scroll down the screen.
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n3hield High Cbject Count

Alarm Enabled :

=

Worning Lewvel :

Critical Lewel :

7500

Duration [in minutes) ©

5

Sawe Thresholds Cancel changes

5. Set the values in the High Object Count fields based on your preferences.

6. Select Save Thresholds.

Save Thresholds Cancel changes

Alarms must be enabled to receive alerts and must be programmed for each group you wish
to see alerts for.

Utilization overload thresholds have two levels:

« The first level is a Warning Threshold used to generate a Warning Severity Event.

« The second level is Critical Threshold used to detect a Critical Severity Event.

When the group utilization overload alarm is enabled, and both thresholds are configured,
then every 10 minutes the alert detection will compute the last 10-minute nShield utilization
for each device in the group.

If the utilization is over the Critical Threshold, a critical event is generated; if it's less than
the Critical Threshold, but over the Warning Threshold, a warning event is generated. Other

wise, there is no alert event.

The Utilization Peak Event provides a warning level threshold if the utilization peaked above
a selected percentage during a pre-configured amount of time in minutes.
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Both sets of alerts are disabled by default.

6.5. Group Event Notification

The group manager role has the capability to view and set group event notification via

email.

1. Navigate to: Configuration > Group Event Notification.

Group Event Nofification

Group Email Info  Mofification Warning Ewor Crifical Alert Emergency
Name Enabled

2. Select the Group for notification.

Group Event Nofification

Group Email Info  Mofificg

The Notification Warning message displays.
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Group Event Notification : Group 1

[0 Email Nofification Enabled

Warming: Ernail Mofification i disatled.
Policy Category Info MNofificotion Waming Bror  Critical  Alet Emergency
Device-Group Specific o 0O O O O O O
Ewvenis

Save Policy Cancel changes

3. Select Email Notification Enabled.

Group Event Nofification : Group 1

Email Motification Enabled

FPolicy Category Info MNofification Warning Emor Crifical  Alert  Emergency

Device-Croup Specific M O O O O O O

Events L\}

Save Policy Cancel changes

4. Select the alert type.

5. Select Save Policy.

Group Event Notification : Group 1

& Email Nofification Enabled

Folicy Category Info MNofification Warning Emor Crifical  Alert  Emergency

Device-Group Specific M O O O O O O

Events I},

Save Policy Cancel changes

If a device is enrolled in multiple groups, the Group Manager receives

event notification emails for all groups to which the device is enrolled
and to which the manager has been assigned the Group Manager role.
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6.5.1. Assign SNMP Notification Policies for Groups

Group Managers manage which email addresses are sent notifications when a trap event
occurs in the device group. For instructions on how to enable notifications by trap groups,
see Assign SNMP Notification Policies for Trap Groups.

To assign Notification Policies for device groups:

1. Navigate to: Configuration > Group Trap Settings.

2. In the Group Name column, select the link of the device group for which you want to
configure email notifications.

Group Trap Event Notification

Group Name Email Enabled Info Nofification Wairning Error Crifical Alert Emergency

3. Select your preferences for the Group Trap Event policy categories and configure the
trap emails for the group.

Group Trap Event Notification : Group 1

O Email Notification Enabled
Warning: Email Nofification is disabled

Policy Category Info Nofification Warning Ermor Critical Alert Emergency

Device-Group Specific Events [= O 0 O [}

Save Policy Cancel changes

Add Trap Event Notification Emails

Add emails

Save Emails

a. To enable email notification, select the Enable Email Notification Enabled option.

b. To specify for which trap events to send email notifications, select the relevant
options.

c. Select Save Policy.
The Group Trap Event Notification page is displayed.

4. Configure the email notifications.

a. In the Group Name column, select the link of the group for which you want to con
figure email notifications.

b. Add the email addresses to which the notifications should be sent when a trap
event occurs. There is no limit on the number of emails that you can add to the list.
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c. Select Save Emails.

6.5.2. Assign SNMP Notification Policies for Trap Groups

Group Managers create, edit, and manage trap groups that contain traps and a list of email

addresses where notifications are sent when a trap event occurs.

For instructions on how to enable notifications by device groups, see Assign SNMP Notifica

tion Policies for Groups.
To assign notification policies for trap groups:
1. Navigate to: Configuration > Trap Settings.

The Trap Configuration page is displayed.

Traps Configuration

Group Name Dezeription (optional)

2. Select Add New Trap Group.

The Group Details page is displayed.
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Group Details

Group Name :

Description [opfional) :

Select the available traps to configure

Click a group in either selection box to move it to the other one.
Any changes made will not be saved until you click the Save changes button.

Cumrently Selected Awvailable Traps for configuration
Filter Trops: Filter Trops:
Fan Failure Fon Foiled Eror =
L o
Fan Restart ~on Restart Success
Hard Server Failure Hord Server Failed Erar
Hard Server Restart Hard Server Restart
JUCCESs
Memery Usage High Hich memory usage eror
Memory Usage Normal Memary usoge i less
than threshold
Admalelm il A d o) r. =l -
Add Trap Event Nofification Emails

Add emails

Create Group Cancel Changes

3. Enter a name for the new trap group.

4. Select traps from the list of Available traps. For traps supported in nShield Monitor,
see Support for N"CSNMP traps.

5. Add the email addresses to which the notifications should be sent when a trap event
occurs. There is no limit on the number of emails that you can add to the list.

6. Select Create Group.

The Trap Configuration page is displayed.
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/. Logs

The logging capability of nShield Monitor provides a view of all ongoing events that occur
in the system. Organizations can track all activities pertaining to their estate of HSMs and
clients, and pro-actively evaluate a preventative maintenance strategy.

@ CIFHER M Dashboard  Views - Reports = Configuration = Logs  Alarms

o ‘ The default sorting is by sequence number.

/.1. Logs available to Group Managers

When logged in as a Group Manager, the logs tab provides the ability to view, sort device
and filter group logs.

manager [ Group Manager | JFeb 22, 2018 8:01:27 [GMT-08:00) @

. Log Out
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" Device/Group Log

Q Search:
T
1D Date/Time Severity Message
4237 201705 | INFO | The connection status is now SNMP
TP 47147447 accessible for nShield module,
SenalNMurmiber: D2EC-DE0G-5D97 in
group: Group |
4934 | 201705 The connection status is now
23TI9- 44111247 unreachakle for Faisal SW2 CHI -
192.148.18.321n group: Group: 2
4235 | 201705 The connection status is now
23T19:46:11.1232 unreachakle for Faisal SW2 CH1 -
192.148.18.32 in group: Group 1
4234 | 201705 The connection status is now
23T19-44611.107L unreachakble for nshield module,
SenalNumiber: D2EC-DE0G-6D%7 in
group: Group 1
4233 2017-05 INFO | The connection status is now SNMP
23T19-44:11.0841 accessible for Foisal SW2 CHI -

192.148.18.32 in group: Group 2

r::-ws per page.
First Fage | « '

[
L8

w | Last Page

177 Total rows . Foge |1 | of 34.

Export Log [(CSW]

Logs can be exported via CSV format for further analysis.

/.2. Logs available to Administrators

When logged in as an Administrator, the Logs tab, on the main menu bar, provides the abil-
ity to view and sort system event logs, security logs and the ability to export the logs.
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admin [ Systerm Administrator ) Feb 22, 2018 8:04:25 [GAMT-08:00) @

. Log Out

" Systemn Event Log  Security Log

By default, the system sorts logs based on sequence. Clicking on the col
0 ored text (e.g., ID, Date/Time) toggles the order that the data is dis-
played.
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" System Event Log

4198

Seqarch:

Date/Time

200705

LM &62329 419F

20705

23T 4&2320.560

200705

ZaMa22:08.796L

200705

23N a21 02 3847

Export Log [C5V]

FD".I".I‘S CEr DOge.

First Page

/.3. Log Sorting

Z
EEEEE
=
Z

Securty Log

-

Export Support Data/Debug Logs

Message

Adrrinistrator admin has rejected an
3L opfion change.

Adrninistrator admin has requested
quorurn approval for an S5L oplion
change.

Administrator admin has rejecited an
33l opfion change.

Adrministrator admin has requested

quorurm approval for an 3351 option
change.

3 | n | Lost Page

2978 Total rows . Fage | 1 |-::-f 594,

Support Data/Debug Logs
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nShield Monitor provides the ability to filter logs by ID, date/time, severity, and message.

1. Click on the sort condition, e.g., Date/Time

" Device/Group Log

Q Search:
AlID Du'e,.-'@e Severity  Messoge
58 201704 m Group: "Group 37, User kory has enmclled device: Faisal CH 1A

26713:37:04.92572

59 2017-04- K}  Group: "Group 1", User kory has enrolled device: Faisal CH 2

The sorting icon displays as the content is sorted.

A Date/Time

20m7-04-
247133704 9571

2017-04-
28T15:8705.5701

2017-04-
24T13:37:05.68301

2017-04-
24T13:37:05.68321

2017-04-
287153707 4581

/.4. Log Functionality

o | You are logged in as Administrator.

admin [ Systemn Administrator ), Feb 22, 2018 8:04:26 [GMT -08:00) @

. Log Qut

7.4.1. System Event Log
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" Systemn Event Log  Security Log

The system event log provides events that correspond to non-security related system
events for nCipher Monitor.

o System Event log  Security Log

Q Search:

r

1D Date,/Time Severity Messoge

4199 | 201705 m Administrator admin has rejected an 351 opiion change.
23N &23:22. 4192

4198 | 2017-05- m drrinistrator admin has requested guorum approval for an
23T 425220 5801 33L opfion change.

4197 | 2017-05- I}  Administrator admin has rejected an 5L option change.
23N 62208 7947

41946 | 2017-05- m Administrator admin has requested quorum approval for an
23T 421023541 33L opfion change.

7.4.2. Security Log

System Eventlog  «*

The security log shows events that are related to system level security events. Events such
as master key password entry, master key destruction, certificate changes, and changes to
other system level security information are noted.

o | The default for sorting is by sequence number.
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System Event Log  «* Security Log

=} Search:

&lD Date/Time Severity Message

3 2017-04-26T1 3:20:55.4571 I}  User adminloggedin

4 2017-04-26T13:21:02.027F [ nFO | User admin has changed password.

5 0N 7-04-28T13:23:07 5427 m Master key generated by user: admin

& 20N7-04-26T1 3:23:07 7252 m Us=r admin has created new user: admin |

7 2017-04-26T13:23:08.3611 I}  Roles have changed for user: admin]
7.4.3. Device/Group Log

o | You are logged on as Group Manager.

manager [ Group Manager | JFeb 22, 2018 5:01:27 [GMT-08:00) @

. Log Cut

The device/group log lists events and alerts that relate to the groups for which a group man

ager has management rights.

" Device/Group Log

Group event entries are displayed in sequential order from newest to oldest.
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" Device/Group Log

Q Search:
Y
[} Date/Time Severity Message
109 201802 The monitoning status is now enable

2971 5:40:42 40427 192.158.18.101 in group, group] by

108 201802 The monitoing status is now disables
2971 5:40:38 40387 192.148.18.101 in group, group| by

104 | 2018-02- Error log count increased fo 864 for
227085504 5947 192.1468.18.101 in group: group

103 | 201802 Error log count increased fo 843 for
20704 43:03 4337 192.158.18.101 in group: group|

72 2018-02- Emor log count increased fo 862 for
21708 500,590 192.14658.158.101 in group: group|

FOWE [DSr DOge.

First Page --:' 2| 3| »| Last Page

37 Total rows .

Export Log [C5W]

7.4.4. Exporting a log.csv file

1. Select Export Log (CSV).

Export Log [(C5V]

The system prompts to open or save the logs.csv file.

2. Select Open. The log.csv file is imported into Microsoft Excel.
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f A RSB & D E F G

Time l heverity  Message

2017-01-0 INFO The connection status is now SNMP accessible for K
2017-01-0 INFO The connection status is now SNMP accessible for K
2017-01-0 INFO The connection status is now SNMP accessible for K
2017-01-0 qRITICAL The connection status is now unreachable for Kory
2[]1}'—[]1—[]}RITIEAL The connection status is now unreachable for Kory

B

° Logs can be exported in their entirety or filtered. This includes both actions on or
by a monitored system. They can also include changes in security of a given
device as needed such as a tamper, changes to device SNMP credentials, or the
addition of a new device. Changes in the device contact status are also displayed
in the group event log and on the alarms screen.

° The default for sorting is by sequence number.

° By default, the Time format is Date/Time in GMT format. Refer to Formatting the
Admin Date and Time for additional information regarding date formatting.

3. Save the Excel file, if needed.

7.4.5. Debug Log Export and Upload

A debug log export may be required to be given to Support for investigating issues. This log
will need to be exported which can take several minutes to generate and export. Once
exported it will need to be sent to Support.

The file does not contain any security information but does contain information related to
actions taken by nShield Monitor such as polling devices, system status events, and code

execution information.

The debug logs are a system for assisting in troubleshooting issues that may arise with the
virtual appliance during day-to-day operation. Logs are provided on a First in First out
(FIFO) basis, so if requested, the logs need to be exported as soon as possible after an issue
has occurred.

Only one user can export the debug log at a time, and only administrators and auditors have
the ability to perform this function.

The debug logs are not readable by users, and are to be sent to Support
for analysis. Exporting large debug files requires that the auto logout
value be set to 60 minutes.
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8. Dashboard

nShield Monitor provides a dashboard view when you first log on to the system.

This view provides a snapshot of what is occurring with your estate and provides invaluable
information for the day-to-day management of all your organization's HSMs.

The contents of the dashboard depends upon logon type:

- Logged on as Administrator.

@ CIFHER A Daoshboard WViews - Configuration = Logs Alarms

Event List »

nShield Monitor Status ,

Unacknowledged Alarm Summary »

- Logged in as Group Manager.
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@ CIPHER A Dashboard  Views -  Repors -  Configuration = Logs  Alams

Event List »

nShield Performance »

nShield Monitor Status ,

Unacknowledged Alarm Summary »

The following table summarizes the views based on log-on type:

Dashboard Views based on Log-on Type

Dashboard Views Administrator logon required Group Manager logon required
Event List X X
nShield Performance X
Users X
nShield Monitor Status X X
Unacknowledged Alarm Summary X X
The sections that follow examine each of the Dashboard Views (as iden-
0 tified in the table above).

8.1. Event List

1. Select the Event List expansion arrow.
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Event List -

| L || Most Recent Unacknowledged v |

4237

4254

4235

4234

4233

201705
ZITI9:47:14.7447

201705 CRITICAL
Z23ATI9:44:11.1247

HNF-05
N 4611.1232

2N 705
E3N9-446:11.107E

2705
Z3T19:46:11.084Z

The connection status is now SMMP acoesssible for
nshield module, SeralNumber: D2EC-Da03-5D97 in
group: Group 1

The connection status is now unreachakble for Faisal
W2 CHIT - 1921481832 in group: Group 2

The connection status is now unreachable for Faisal
W2 CHIT - 19201881832 in group: Group 1

The connection status is now unreachakble for nShisld
module, SeralMumber: D2EC-DE0S-SDP? in group:
Groug 1

The connection status is now SNMP acosssible for
Faisal 3W2 CH1 - 192.168.18.32 in group: Group 2

From this window, you can specify the number of events (default value is 5) displayed

and filter according to:

° Most Recent Unacknowledged (default value)

° Most Recent Events

> Alarm level (i.e., EMERGENCY ONLY, ALERT ONLY, etc.)

Event List ~

5 w

Maost Recent Events
EMERGENCY only
) ALERT only

2 CRIMICAL onily
ERREOR only
WARMNING only
MOTIFICATIOM onily
INFO onily

2. Select the drop down arrow to expand your choices for number of events displayed.
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Event List -

| CRIMZAL only bl |
2001 7-05 The connection status is now unreachable for Faisa
23T19:-44:11.1247 SW2 CHI - 192.148.18.32 in group: Group 2

4235 | 2017-05- The conneciion stafus i now unreachabls for Faisa
FATI9-44:011.1 232 SW2 CHT - 192.148.18.32 in group: Group |1

4234 | 2017-05- The connection status is now unreachable for nShisld

3. Select your preference.

4. Select the drop down arrow to expand your choices for event types.

Most Recent Unacknowiedged
Maost Recent Events
EMERGENCY only

ALERT only

ERECOR only |/\\§
WARNIMNG only
NOTIAICATION only

4236 | INFO only he connection status is now unreachable for Faisa
T 20 TT.T25L SW2 CHI - 192.145.18.32 in group: Group 2

4235 | 2017-05- The connection status is now unreachable for Faisa
ZIM9- 446111232 SW2 CH1 - 192.165.18.32in group: Group |1

5. Select your preference, e.g. CRITICAL only.

Event List ~

[s v v|

4736 | 2017-05 The connection status is now unreachable for Faisg
FATIF-44:011.1247 W2 CH1 - 192.1588.18.32 in group: Group 2

4235 | 705 The connection status is now unreachable for Faisa
AT 944111237 SW2 CH1 - 192.1458.18.32 in group: Group 1

4234 | 2017-05 The connection status i now unreachable for nshisld
2311944111072 module, SefalNurmber. D2EC-DE03-6099 in group:

Group 1

4225 | 2017-05- The connection stafus i now unreachakble for VRS-
23N 9046203 4287 004 - 19218820253 in group: Group 3

4227 | AN 705 The connection status is now unreachable for Vps-
23N 9046203 4207 006 - 192,148 20253 in group: Group |

6. Select the event by clicking on the event type.
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Event List -

| 3 ¥ || CRIMICAL onty A |

4234 | 2017-05- The connection status is now unreachable for Faisa
23N P-44:11.1247 SW2 CH1 - 122.1488.18.32 in group: Group 2

4235 | 2017-05- The connection status is now unreachable for Foisa
ZANNF 4460111237 SW2 CHI1 - 1922.148.18.32 in group: Group |
—— ———————————————————————

The Acknowledge Alarm page opens:

cemear  ACknowledge Alarm

Alarm Date/Time:

| 20017-05-23T19:44:11.1242 |

Alarm ICx

| AVWCIGCRVINMATUAL |

Alarm Message:

| The connection status i now unreachable for Faisal 3W2 CHI - 192.148.158.32 in group: Group 2

Acknowledgement Comments | Opficnal ):

Acknowledge Alarm Cancel

7. Enter Acknowledgment Comments, if needed.

8. Select Acknowledge Alarm.

o | Selecting Cancel returns you to the Dashboard.

8.2. nShield Performance

o | You are logged in as a Group Manager.

manager [ Group Manager ) JFeb 22, 2018 8:01:27 [GMT-0800) @

. Log Cut
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@ CIFHER F:y Dashboard Views = Feports - Cq

Event List »

nShield Performance »

nShield Monitor Status »

Unacknowledged Alarm Summary »

1. Select the nShield Performance expansion arrow. Two windows open:

° nShield Performance

° Top 5 Client Hosts by Command Count
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nShield Performance -~

nshield Commands Count, Last Hour

100

&0

- " — = %
]
-0~ mShield

40

Commands count

20

17:00 1710 17-20 1730 1740 17:50 18:00
£ mins
E ‘ Last Howr | = = & = ° . &

15 mins 1 min
Top 5 Client Hosts by Commands Count
Hame IP Address Security World Commands Count
1007212 10.1.7.212 cOF 67 d515fe84 1 9c387 7 Bed4c48cobaca 57 2fd 250

8.2.1. nShield Performance window
The performance window provides a customizable graph.

This section provides a basic overview on how to use the customization options. Refer to
Client Host Detail Page for greater detail.

8.2.1.1. Navigate to a Group’s Detail page

At any time, you can open a specific group’s Detail page. A color key on the right side of
the graph contains Group color line assignments, e.g., "nShield" group - circled in red above.
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nShield Perdformance -

nshield Commands Count, Last 24 Hours

40k

[ |
. |
g | I:.‘ lr'|1 |' i |. H’I{I |u l “I' 'i} f“t !Lll ||||
o Ll T T TR T o
10k
Y
ﬂ 20:00 B. Dac 04:00 0g:00 12:00 1600
o e " TR S

& houes

Clicking on Group 1's graph contents opens the Group Detail For: Group 1 page.

nshield Object Count, Last 7 Days

5
a
v
34
4
i)
£
o
2
0
5. Dac 12:00 6. Dec 12:00 7. Dac 12:00 B. Dac 12:00
15 mins
E | Last 7 Days | —o—o—-—o—o—'—o—o
2 days 15 mins

Refer to Group Details for a full description of the Group Details page.
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8.2.2. Top 5 Client Hosts by Commands Count

This window also contains a live count down until the next refresh. In the example below,
the data will refresh in 24 seconds.

Top 5 Client Hosts by Commands Count
 refreairin 20

Hame IP Address Security World Commands Count

1007212 10.1.7.212 cOF Sc¥ d5i5fed41 73877 8ed4c48cabacar SF2id 214

1. Select an entry in the name list to navigate to additional windows of data.

The detail page opens.

Client Host Detail for: 10.1.7.212

IP Address/Host Name @ "10.1.7.212"

Performance »

Health »

Applcations with Active Connection to Hardserver »

Secunty World Info »

nshield HSMs »

nshield Card Sets »

nshield Keys »

2. Select (i.e., click on) the Performance expansion arrow.
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Client Host Detail for : 10.1.7.212

IP Address/Host Name : "10.1.7.212"

10.1.7.212 Command Count, 2018-11-28T18:21:51.2151Z - 2018-12-08T18:21:51.2151Z =

300

250 " s e W A e s e
- o T - il o e,
-— \ Tl
"_-." |
200
=
E
a
2
w
T 150
g
E
E
a
“ 100
=0
0
16:00 20:00 B.Dsc 04:00 08:00 12:00 16:00

E | KI'I&-II-EEIT'IE:'.'-!'I:.EI.'.'-!IS'II-KI'IE.-'IE-IET'IE: [1_24]|:| m

2018-11-28T18:21:51.2151Z | 2018-12-08T15:21:51.21512

The Start Date and End Date selection boxes appear when the custom date option is
selected.

3. Scroll down and click on the Health expansion arrow.
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Client Host Detail for : 10.1.7.212

IP Address/Host Mame : "10.1.7.212"

Performance »

Health -

Mortoring [nnaieo
Stotus
Hardserver Status: m

Number Of H5Ms: &

Applicafions With Active Connectlion Te Hardserver: 11

Meodules Failed:

Hardserver Version: 124000

Hardserver Port: FO04

Hardserver Upfime: 28 Days : 22 Houwrs - 21 Minutes : 14 Seconds

4. Scroll down and click on the Applications with Active Connection to Hardserver

expansion arrow.

Applications with Actiwve Connecfion fo Hardserver -

a Search: = m

Connecfion Uptime Command Reply Remote P Process Process Total Objed
Number Count Count Address 1D Name Count
3 28 Diays : 23 Hours ; 21 a 0.0.0.0 ] o |

Minutes : 14 Beconds

11 98 Days - 23 Hours : 21
Minutes : 02 Seconds

B 0.0.0.0 ] llegocy]
12 78 Days : 23 Hours @ 21
Minutes : 02 Seconds

12 P8 Days - 23 Hours @ 21
Minutes : 02 Seconds

a
B 0.0.00 o legocy] o |
B 0.0.00 ] legocy] [0 |
[0 o]

15 78 Days - 23 Hours : 21
Minutes : 02 3econds

0.0.00 o legooy]

5. Scroll down and click on the Security World Info expansion arrow.
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Secunty World Info -

Security World Name: 767 d5fEfedd | PoIBFT e ddcd4dcabacarf 572fd
Security World State:

hashKNSO: cOF 6T d5iEfel4 1723877 Bald4c4dcabocaf 5921
hashKM: 111d3dbf3fo3412e2d44837 %71 P41 4baa 1 342123

6. Scroll down and click on the nShield HSMs expansion arrow.

nshield H3Ms -
Q Search:

Seral No. Type Mode
0305-02E0-DF4T COMNECTXC [ FaILED |
2B05-02E0-0F47 CONNECT XC [ FalLED |
£455-T4B4-30FF CONNECT
SF79-74BF-4298 COMNECT
B54A-31C9-T3F2 COMNECT

Commands Last Hr.

7. Scroll down and click on the nShield Card Sets expansion arrow.

nshield Card sets -

a Search:

et Name Client Host Count Generafien Time
cmocOl 1 201 4-09-16T23:47:30.47300
ocl 1 2014-03-18T1 871207122
oc? 1 2014-03-15T23:07:15. 7152

8. Scroll down and click on the nShield Keys expansion arrow.
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nshield Keys +

Q Search: Add
Key ldenfifier/Name Key Hash Key Application = Chlient
Name Hosts
2043514328050k 378247 1290PeTabFidER] B0 Oe2dod 27 diddar 4045 80P 40142122231 808 ambad
Sffc27 L6017 47 2c80403d 251 Seafe53cPédaid- 1f3c2f6231f8fel7b2bi lecd 1 454451 bBleca2d? embed
COO00000
Bfd31735720b3b47 obe 1 4527 ecdbed87 dbaffess 427ce]182a07a5bfcbl8Bes4fP551eds1f1812317 | embed
il F3838cc | Fboa?3Fd SPDiSAFT 4FBE207 1 bdBedif simple
2 odbfdfo4 ] 771 548227 3432384560007 4708ddes | simple
o ‘ At any time, you can select Back to Previous Page.

8.3. Users

6 ‘ You are logged in as an Administrator.

admin | System Administrator )

@ CIPHER A  Dashboard Views -  Configuration =  Logs

Event List »

nShield Monitor Status ,

Unacknowledged Alarm Summary »

1. Click the Users expansion arrow.

2. Select the drop down arrow to open the filtering options.
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| S l

Cmiline admin System Administrator 2018-12-08T15:44:57 45571
Cfline uper System Administrator, Group Monoger 2018-12-07T14:55:48 55481
Cfliine adl System Administrator
Cfline ad3 System Administrator

3. Select your preferred view. Filters include:
° System Administrators
° Group Managers
° System Auditors
° Last 5 login
° Locked Out

The display reflects your selected filter option.

8.4. nShield Monitor Status

o | You are logged in as an Administrator.

1. Select the nShield Monitor Status expansion arrow.
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Event List »

nShield Monitor Status -

Serial Mumber : Teig 7y 1P n7F &Y P d¥-kc PML{ O IzyD Ly Fb
Software version - 2.5.4 [build 0029)

Lzense : BEvaluation, Remaining Days: 27

System Uptime - 1 day. 1 hour

Disk Jpoce Used : 2%

Services : O, anning 18 of 18

Unacknowledged Alarm Summary »

The status data is displayed.

8.5. Unacknowledged Alarm Summary

o ‘ You are logged in as an Administrator.

1. Scroll down, if needed, and select the nUnacknowledged Alarm Summary expansion

arrow.
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Event List »

nShield Monitor Status »

Unacknowledged Alarm Summary ~

EMERGENCY - 0
ALERT :
CRITICAL -

=] [=]

L=

%]

2. Select the alarm type, e.g., click on CRITICAL. The Current Unacknowledged Alarms
detail page opens.

Cumrent Unacknowledged Alarms

O Dwate Time Severity Message

O 2018-12- Master key has been generated but not loaoded. You must lood master key for monitoring
OFT12:47:48 4T 451 cperaficns

O 201812 Master key hos been generated but not looded. You must load master key for monitoring
04T13:30:246.30262 operafions

3. Select the alarm for acknowledgment.
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Current Unacknowledged Alarms

a Search:

Acknowledgement Comments | Opfional ):

[ Acknowledge Alamn ]:c el

] DateTime Severity Message

v} 018-12- Master key hos been generated but not loaded. You must lood master key for monitoring
7T 2474847451 operctions

O 2018-12- Master key has been generated but not loaded. You must load master key for monitoring
04T13:30:24.30261 cperations

FONWS DEF DOgEe. Frst Page |« n | Last Page 2 Total rows . Page \:I of 1.

4. Enter Acknowledgment Comments, if needed.

5. Select Acknowledge Alarm.

From the Current Unacknowledged Alarms window, you can also

0 click on the severity type (e.g., click on CRITICAL), to open the

Acknowledge Alarm window.

crmear Ack

Alarm DatefTime:

| 2018-12-07T1 2:47:48 4T 437 |

A My
Aarm L

| AWelyF Lz3MLgex- oD |

Alarm Message:

Master key has been generated but not loaded. You must load master key for monitoring operations

Acknowledgement Comments | Optional ]:

Acknowledge Alamn
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9. Views

User login type determines which options are displayed.

9.1. Logged in as Administrator
1. Navigate to:

Views > Groups > Group List

Views - Configuration - Logs Al

H Groups ' Group List

The Group Summary page opens.

| =

Group Summary

a Search:
A Group Name nihield Owverlood Alarm nihield Client Hosts Descripfion
' [ DisasLED | (3 [1]a]s] 0 0
10 [oisasueo ] oo 0 1
- [ DisasLeD | 1 [2]2] 0 0
3 [ DisABLED | ooo 0 o
‘ [oisasie] 0 0

On this page, you can sort the display order of the Group Name column and the
Description column.

Refer to View > Group > Group List for additional information on Administrator options
under Group List.

9.2. Logged in as Group Manager

Logged on as Group Manager provides the following navigational options:
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%, Reports =

I Groups r
HEMs 4
Client Hosts ¥
Eeys k
Card Sets 4

Security Worlds #

9.2.1. View > Groups
View Groups drop down has three destinations:

« Group List. Refer to View > Group > Group List, for additional information on Group
Manager options under Group List.

+ HSMs By Group
+ Client Hosts By Group

Vigws =

Groups k HOUR ]
H3Ms By Group

s

ent Hosts By Group
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View > Groups > Group List

Group Summary page

Navigational links:

Group Name > Group Detail page

Alarm count > Current Unacknowledged Alarms page
nShield > HSMs By Group page

Client Hosts > HSMs By Group page

View > Group > HSMs By Group
Group <n> There are <n> nShields in this group page

Expand the pane:

nShield HSMs

Navigational links:

Serial No. > HSM Detail page

Alarm count > Current Unacknowledged Alarms page
Security World > Security World Detail page

Client Host Count > Client Hosts By HSM page

View > Group > Client Hosts By Group
Group <n> There are <n> client host(s) in this group page

Expand the pane:

Navigational links:

Mame > Client Host Detail page

HSM count > HSMs By Client Host page
Alarm count > Unacknowledged Alarms page

Security World > Security World Detail page

9.2.2.View > HSMs

View HSMs drop down has two destinations:

« HSM List

+ Client Hosts By HSM
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Vigws =

Cliant Hosts By Hahd

View > HSMs > HSM List

HSM Summary page
nShield HSMs
Navigational links:
Serial No. > HSM Detaill page
Alarm count > Current Unacknowledged Alarms page
Security World > Security World Detail page
Client Host(s) count > Client Hosts By HSM page
View > HSMs > Client Hosts By HSMs

There are <n> client host(s) in this nShield page
Expand the pane:
Navigational links:
MName > Client Host Detail page
HSMs count > HSMs By Client Host page
Alarm count > Current Unacknowledged Alarms page

Security World > Security World Detail page

9.2.3. View > Client Hosts

View Client Hosts has two destinations:

+ Client Host List
« HSMs By Client Hosts
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Wiews =

View > Client Hosts > Client Hosts List

Client Host Summary page
Mavigational links:
Mame > Client Host Detail page
HSMs count = HSMs By Client Host page
Alarm count = Unacknowledged Alarms page
Security World > Security World Detall page
View > Client Hosts > HSMs By Client Hosts

There are <n> nShield(s) in this client host page
Expand the pane:
Navigational links:
Serial No. = HSM Detaill page
Alarm count = Current Unacknowledged Alarm page
Security World > Security World Detail page
Client Host(s) count > Client Hosts By HSM page

9.2.4. View > Keys
View Keys has two destinations:

- Key List
 Client Hosts By Key
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Views - Reports - Configuration -
Groups ’
H3Ms 4

‘ Client Hosts ’
k.eys P Key List
Card dets 4 Client Hosts By Key

Security Worlds #

View > Keys > Key List

Key Summary page
Navigational links:
Key Name/ldentifier = Key Detall page
Client Hosts = Client Hosts By Key page
View > Keys > Client Hosts By Key

Key Summary page
There are <n> client host(s) with this key page
Expand the pane:
Navigational links:
Name > Client Host Detail page
HSMs > HSMs by Client Host page
Alarm count > Current Unacknowledged Alarms page

Security World > Security World Detail page

9.2.5. View > Card Sets

View Card Sets has two destinations:
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+ Card Set List
+ Client Hosts By Card Set

Views = Reporis = Configuration = _l

Groups H

Client Hosts By Caord Set

View > Card Sets > Card Set List

Card Set Summary page
Navigational links:
Set Name > Card Set Detail page
Client Host count > Client Hosts By Card Set page
View > Card Sets > Client Hosts By Card Set

There are <n> client host(s) with this cardset page
Expand the pane:
Navigational links:
Name > Client Host Detail page
HSMs > HSMs By Client Host page
Alarm count = Current Unacknowledged Alarms page

Security World > Security World Detail page

9.2.6. View > Security Worlds

View Security Worlds has five destinations:

Monitor v2.8.0 Install and User Guide 126/284



Chapter 9. Views

Security World List
HSMs By Security World

Client Hosts By Security World

Keys By Security World
Card Sets By Security World

Views =
Groups r
HEM3s ¥
Zlient Hosts b
Feys b

Card Sets g

Secunty Worlds ¢

H3Ms By Secunty World

Chent Hosts By Securty World

Fal

evs By Security World

Card S5ets By Securty Warld
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View > Security Worlds > Security World List

Security World Summary page
Navigational links:
Name = Security World Detail page
HashKNSO = Security World Detail page
Client Hosts count = Client Hosts By Securnty World page
nShield count > HSMs By Secunty World page
View > Security Worlds > HSMs By Security World

There are <n> nShields in this security world page
Expand the pane:
Navigational links:
Serial No. = HSM Detall page
Alarm count = Current Unacknowledged Alarms page
Client Host(s) count = Client Hosts By HSM page

View > Security Worlds > Client Hosts By Security World

There are <n> client host(s) in this security world page
Expand the pane:

Navigational links:

Name = Client Host Detail page

H5Ms count > HSMs By Client Host page

Alarm count = Unacknowledged Alarms page

View > Security Worlds > Keys By Security World

There are <n> keys(s) in this security world page
Expand the pane:
Navigational links:
Key Name/ldentifier = Key Detail page
Chient Hosts count = Client Hosts By Key page
View > Security Worlds > Card Sets By Security World

There are <n> card set(s) in this security world page
Expand the pane:
Navigational links:

Set Name > Card Set Detail page

Client Hosts count = Client Hosts By Card Set page
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9.3. View > Group > Group List

From the View tab, whether logged in as an Administrator or as a Group Manager (or Audi-
tor), you are able to navigate to the Group List page.

The Group List page provides a group summary listing of groups configured in the virtual
appliance as well as utilization information, host command information, and overload, alarm

information, and a column for descriptive information.

e When logged on as a Group Manager, you can navigate through the
View menu to acknowledge alarms.

The options provided in the View drop down menu is directly tied to your logon.

« Administrator
« Group Manager

- Auditor

The Auditor has the same views (i.e., menu drop downs) as the Group Manager; however,
the auditor has no ability to perform any actions. For example, an Auditor can not acknowl-
edge alarms or enter comments, etc.

9.3.1. Group List > Group Summary - Administrator

The Group Summary page provides an easy to use view that updates every 60 seconds as
information is polled.

1. Navigate to:
Views > Groups > Group List
The Group Summary page opens.

o When logged in as an Administrator, you can only view all groups.
You can not perform any other actions on these groups.
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Q, Search:

A Group Name

Group Summary

n3hield Overload

Alarm

nShield

o

0

o

Croup Liste®

Client Hosts

o]

o]

HSMs By Group

Client Hosts By Group

Descrpfion

As an Administrator, you are able to sort the data displayed.

Black column headers indicate that the contents of the column can

not be sorted while blue column headers indicate that the contents

of the column can be sorted.

Group Summary

Q Search:

v GroUp Name

nahiald

3

~— /

n5hield Overlood

Alarm

nShield

0

i3

Client Hosts

o

1

o

Descripfion

2. Toggle the sort, if needed.

3. Hover over an alarm total in the Alarm column to view the severity pop-up.
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Group Summary

Q Search:
¥ Group Name nShield Overood Alarm nShield Client Hosts Descripfion
@ aa| : 1
i [ DisasLED | cri o b
3 [ Disasteo | (1 [l o 0
2 DisasLeD | (1 [2]2] 0 0
o Z

9.3.2. Group List > Group Summary - Group Manager
When logged in as Group Manager, all groups assigned to you are listed.
1. Navigate to:

Views > Groups > Group List

Dashboard Views - Fepors - Configuration - Lo

¥ Group List
y. ’ H3Ms E‘,ﬁu;s

| Client Hosts 4 Client Hosts By Group

keys 4

Card 3ets ]

Security Worlds ¢

The Group Summary page opens.

Monitor v2.8.0 Install and User Guide 131/284



Chapter 9. Views

Group Summary

Group Listy?

H5Ms By Group

Client Hostz By Group

(o} Search: m
¥ Group Name nShield Owverload Alarm nShield Client Hosts Descripfion
Test Vp3 m 0 ]
nShisid 0% | 25 [#]2]30 s 1
E [ pisasieD | aoD g o
2 [ Disasiep | (1 [2]2] o o
9.3.3. Group Summary page - Navigation options
The Group Summary contains three navigation points.
Selecting any one of the following opens a new page:
+ A specific Group Name
¥ Group Name nShield Overload Alarm nShield Client Hosts Descripfion
[oisasieo | 0 0
0 | 45 [#]2]30 6 1

The Group Detail page opens.

Group Detail For : Test VpS

nshield H5Ms »

Back to Previous Page

+ A specific Alarm
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¥ Group Name n¥hield Overlood Algrm nShield Clhient Hosts Descriplion

Test Vps [ DisaBLED | 0 ]

nSkhisid [ 0= | %um 5 1
4 [ pisamieD | Criti g L

: [ Disastep | ann

(=]
(=]

The Current Unacknowledged Alarms page opens.

Cumrent Unacknowledged Alarms

o

Severity: CRMCAL G JEEREEE

Date Mime Sewverity Messoge

2018-12-08T10:09:16.71 61 The connection status is now unrecchakle for nShield module, 10.1.3.78 in group: nShisld
2018-12-08T10:09:156.7161 The connection status is now unreachakble for nShield module, 10.1.3.72 in group: nShiald
2018-12-08T10:07:16.71 61 The connection status is now unrecchable for 10.1.7.212 - 10.1.7.212 in group: nEhield

2018-12-08T10:09:14.9162 The connecfion status is now unreochoble for nShisld module, 10.1.3.77 in group: nShisld

DDDIED

2018-12-08T10:05:14.51 &I The conneciion status is now unreachable for n3hield moedule, 10.1.3.71 in group: nShieid

rcm-s per page. First Page | & n 2| 3| | Laost Page 45 Total rows . Page | | of 5.

Acknowledgement Comments | Optional )

Acknowledge Alamn Cancel

You can acknowledge the alarm by checking the box to open the Acknowledge Alarm

page.

A specific entity
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Group Summary

'O. Search:

A Group Name nShield Overload Alarm
DisAsLeD | (s [a]a]s]

o DisAsLED | 1 ]1]

2 Disasteo | 1 [2]2]

2 [ Disasteo | oon

4 [ Disasteo |

néhield

o

=]

=]

Client Hosts

Descripfion

The Client Hosts By Group page opens.

Client Hosts By Group

a

Search:

10 ~ There are 1 client host(s) in this group.

a, Search:

Name Monitoring Hordserver ‘Commands H3Ms  Alarm
Status Last Hr.

ol s, R unchiown JRl o aoa

A Last
Update

HEMs
Failed

Securilby

Llocafion | World

jocation

9.3.3.1. Alarms Acknowledgment Views
1. Navigate to:

View > Groups > Group List
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Dashloard Views - Feports - Configuration - L

¥ Group List
2" HSMs E-}llllg o
| Client Hosts ~ * Client Hosts By Group
Keys W
Card Sets "

Securty Worlds ¥

The Group Summary page opens.

Group Summary

Q Search:
& Group Name nshield Overload Alarm nshield Client Hosts Descripfion
 CisasLED 8 oo 0 0
[oisaseo | oo 0 |
: [ DisasLeD | 1 [2]2] 0 0
: [ DisasLeD | ooo 0 0
: [oisasieo ° 0

2. Select (i.e., click) any number in the Alarm column.

3. After Current Unacknowledged Alarms page opens, optionally enter a comment and
then select Acknowledge Alarm.
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Current Unacknowledged Alarms

Date Time

O & o O

FOWE pEF page.

Q searcr:

Severity

2018-12-04T1£:09:10.9102
2013-12-04T1£:07:50.7 502

2018-12-05T14:34: 28 34281 CRITICAL

Message

The connection stotus is now unreachalkle f
The connection status is now unreachakble f

The connection stotus is now unreachalkle f

First P i ¥ Azt Poos
rtpage |« [ | Lost poce

vhnowledgement Comments | Sptional ):

Acknoaedge Alam

or testestdevice? - 172148114113 0in group: 1
or festdevice] - 192.168.122.121 in group: 1

or 192.1568.17.188 - 1¥2.1&5.17.188 in group: 1

3 Total rows . Page | 1 of 1.

20717-01-20T17-24:54. 24547

FT0004:59 6591

FTI908:16.616L

TT16:35:47 33471

ITT4:42:4% 42471

Date /Time
1%
EI"\} 2017-01-1
O 2017-01-1
O 2017-01-1
O 2017-01-1

r:m.-'s Dr Doge.

Acknowledgement Comments | Opticnal )

Severity

CRITICAL

CRITICAL

Acknowledge Alarm Cancel

Message

The conneg
The conneg
The conneg
The conneg

The conned

First Poge

Selecting multiple boxes allows you to simultaneously acknowledge

multiple alarms.

If you click directly on the Alarm Severity, i.e., directly on CRITICAL,

the Acknowledge Alarm page opens.
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Severity

CRITICAY

)

CRITICAL

CRITICAL
CRITICAL

CRITICAL

cemeat  ACknowledge Alarm

Alarrmn DatefTirme:

| 2017-05-24T1 5:08:37 4611 |

Alarrm ICx

| ANWT SGCHCRVIcMATZEH |

Alarm Messoge:

| The connechion status i now unreachable for nghield mody

Acknowledge Alam Canos]

4. Enter comments (optionally) and then select Acknowledge Alarm.

9.3.3.2. Navigating to the Group Detail page
1. To get to the Group Detail page, navigate to:
View > Groups > Group List

The Group Summary page opens.
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Group Liste®  HEMs By Group  Client Hosts By Group
Group Summary
12 zearch: Add
" payshield payshield payshield nShield Alarm poyshield nshield cClient
Group | Ulilization Host oOwverlood  Owerload Hosts | Descripfion
Naome Command
cor o @ B (@ @O0 - « 2 unitres
1 Croup 1
o= G2 B G moa| o s 0 mes
Croup 2
o O3 B @ oom| s o 1| s
3 Croup 3

2. From the Group Name column, select Group <n>.

Group Detail For: 1

Client Hosts »

nshield H3Ms »

9.3.3.3. Filtering Group Detail - Group Average, Top 10, or Custom

Each window on the Group Detail page, i.e.,.Client Hosts, nShield HSMs, can be filtered
based on Group Average, Top 10, or based on a Custom list of devices.

Example: Filtering a Utilization Chart based on:

Group Average, Top 10, or Custom list of devices

T | ot ] oo

Client Hosts »

nshield HSMs »

Each of these views shows the average of the data collected for the interval period
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selected (5 minutes, 15 minutes, etc.).

Line colors in the chart are used to designate a specific device. Click on
e the items in the color index, (e.g., specifically on "MAX", and/or on
"Group 1") to toggle the display options.

nShield Monitor can provide the maximum data point that occurred in a

selected interval period. The utilization chart provides a red line to show
e a maximum data point as well as a time stamp to show when that maxi-
mum utilization occurred.

+ Select the drop down arrow on the time period bar to modify the time period being
viewed.

o ‘ The Custom Range selections are in the UTC time zone.

+ Use the sliding mechanism to change the intervals.

5 mins
E ‘ Last Hour ‘ ° ™ -

15 mins 1 min

Example of Custom:
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Group Detail For: 10

Sroup Average

Customize the Dewvice list

Click o device in either selection box to move it 1o the other one.
Any changes made will not take effect unri{vcu click the Apply button. I

iglected devices Available devices

testdevicel

10 nShield Commands Count, Last Hour

. Select (i.e, click on a device) in the selection box to move it from one box to the other.
« Select Apply to confirm the change.
+ Select Close to return the to Group Detail page.

+ Select the expansion arrow to open a Group Detail page, as needed.

Monitor v2.8.0 Install and User Guide 140/284



Chapter 9. Views

Client Hosts =

Group 1 Command Count, Last Hour

125k
— L
100k

7ik

S0k

Commands count

23k

ok
1415 14:20 14:45 15:00

Q Search: m

Commands Alarm Security World

MNaome | Last Hr. Description
Faisal 88 c076c7d5T5fe841 9c38778e34c48cabact
CH2
Faisal | [ 17 [ 28 ] 5¢ |
W2
CH1

0 ‘ Each graph can be printed or exported in CSV.
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=

Frirt chart
Dowmnlood CEW

9.3.3.4. Group Detail page - Client Hosts
The Client Hosts window displays:

« Graphed command count based on command count per time block:

Lot 24 Hours

Last 7 Days
L=t 30 Days
<ustom Range
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Group Detail For: 10

Customize the Device st

Click o device in sither pelection box to mowve it to the other one.
Any changes mode will nof foke effect until you click the Apply button.

Sxlected devices Available devices

testdevicel

e co-- |
ot

10 n5hield Commands Count, Last 24 Hours

5 mins
E | L | —o—o—o—o—o—o—o—o—o
& hours 5 mins

Q S=orch: . m

Commonds Lost Hr. Alorm & Dexcripfion Secwrity World

testdevice] n ﬂnﬂ descinption
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+ Clicking on the device name opens the Client Host Detail page for that device.

9.3.3.5. Client Host Detail page - Overview

Select the expansion arrow to open the windows.

Client Host Detdail for : Faisal CH 2

IP Address/Host Mame : "10.1.7.212"

Performance »

Health »

Applications with Active Connectfion to Hardserver »

Security World Info »

n3hield H3Ms »

nshield Card Sets »

nshield Keys »

9.3.3.6. Client Host - Performance window
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Faisal CH 2 Command Count, Last Hour

400k
a L |
L 2 \\

200k \
1 ,
g ",
W
n
T 200k
L)
E
E
[+]
(%]

100k

Ok
n 17-10 17:15 17:20 17:25
5 mins
H | Last Hour | — - - ._o » ®

15 mins 1 min

9.3.3.7. Client Host - Health window

Monitoring: m

siaus:

Hordserver Status: m

Number Of HEMs: 3

Applications With Acfive Connection To Hardserver: 7

Modules Failed:

Hordserver Version: 2921

Hardserver Pork: POD4

Hardserver Uplime: 48 Days - 13 Hours © 34 Minutes : 08 Seconds

9.3.3.8. Client Host - Applications with Active Connection window
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Apphcotions with Active Connection to Hardserver -
Q search: m

Connection Upfime Command Reply Remote Frocess | Process Total
Number Count Couwnt IF Address 1D Hame Object
Count

3 &5 Days : 153 [ 0 | 1467495531 RN o

Hours : 348
Minutes : 04
Zaconds

4 45 Days : 13 [ 0 | [ o | 0.0.0.0 o [legacy]
Hours - 346
Minutes - 08
Eacond:s

5 &5 Days: 13 [ o | [ o] 0.0.0.0 o llegacy]
Howrs - 34
Minutes : 08
Zaconds

+ Click on the blue columns to reverse the sort order, based on preference.

- Select (i.e., click on) a specific Connection Number to open a the connection’s Applica

tion Details page.
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Application Details for :

Application Connection Mumber - "3"

Connection Number: 0 Drarys - 00 Howrs : 00 Minutes : 05 2econds
Uptime: AD2444T

Command Count: ﬂ

Reply Count:

Remote IF Address: 0.0.0.0

Process |D: o

Frocess Name:

Total Object Count:

o] Search:

Serial Type Mode monitoring module Object Count

6757 AE4-30FF CONNECT OPERATIONAL [ EnABLED | o |
SFFR-T4BF-42FE COMMECT OFERATIONAL Exa ﬂ

+ Select a specific Serial number to open the HSM Detail page.
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SM Detail for : 6699-74B4-30FF

Managed By Group(s) : "Group 1, Group 2" IP Address - "10.1.371"

Performance »

Configuration »

Health »

Secunty World Info »

Chent Hosts »

Apphcations with Active Connecthion to Hardserver »

9.3.3.9. Client Host - Security World Info window

Secunty World Info -

Security World Name: cO76cTd55feE4 1 36T 7B l4cdBoabacar srefid
security world State:

hashkNSO: cOT&cTdSf5feBd 17 o367 TEe34c4Boabacar 57 2fd
hashkm: 111d3df3fc341 2223557 efTR 1761 4Da01 362126

+ Select the Security World identifier to open the Security World Detail page.
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Security World Detail For : c076c7dS

Edit Security Word Mame

Health »

Security World Quorum »

Client Hosts »

nihield H5Ms »

Keys »

Card Sets »

9.3.3.10. Client Host - nShield HSMs window

nihield H5Ms -
Q, search: Add
Sernial No. Type Mode Commands Last Hr.
£&75-T 4B4-30FF CONMECT OFERATIOMAL
AFPR-TABF-42FE CONMECT OPFERATIOMAL [ 5025 |

+ Select a specific Serial Number to open the HSM Detail page.

Monitor v2.8.0 Install and User Guide

149/284



Chapter 9. Views

SM Detail for : 9FC4-3000-53C9

Managed By Group(s) : "Group 3®  Senal Mumber - "?FCé

Performance »

Configuration »

Health »

Secunty World Info »

Clhent Hosts »

Apphcations with Active Connection to Hardserver »

9.3.3.11. Client Host - nShield Card Sets window

nihield Card Sets -

Q search: Add

et Name Client Host Count Generation Time
cmocdl 2 201 56-07-146T23:47:30 45301
[+ o3| = 2015605 15TIE 171217 12T

- Select a specific Set Name to open the Card Set Detail page.
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Card Set Detail for : ffoc]

Guorum Count (k):
Tolal Number Of Cards[M]): 2
Timeouf : 4]

Generation Time : 201 5-05-24T19206: 116112

Secunty World Info »

nihield Keys Protected By This Card 5=t »

Clhent Hosts »

9.3.3.12. Client Host - nShield Keys window

nihield Keys -

Q Zearch: m

Key Applicafion Client

Fey identifier/ Mame Key Hash
Name Hosis

sHcar 558017 4720804030251 Seafe53cpsdaid 1facofaes1fefe0rbabld 1 ecd] 454551 0EBeca2d2 embed 3
Bfd51973572003047abe ] 45eFecdbeddTdbarfess | 42PcelB2a0fosoTcol3ses4irs551eds1f131ea17 embed 3

1 7388cc | Tboca?37dsrdissf7 4f5E207 1 bd8adff simnphe 3

fiz bdiofofod 19715482029 3082564 560007 4P a3ddes simple 3

- Select a specific Key Identifier/Name to open the Key Detail page.
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Edit Key Mame

Key Application Name -

Key Identifier/Mame :

Key Hash :

Key Protecfion :

Key Recovery -

Time Limit :

Fre-authenficafion Use Time Limit :
Generating Module ESN :

Frotecting Cardset Hash :

Secunty World Info »

Clhent Hosts »

Key Detail for : &6ffc2/5560117472c8b4a3d2515eafe

embed

&ffic27 55801747 2c50403d
1facefaz31 fafe 0FDSDS1 E\:‘]
MODULE
EMABLED
]

]

Hot availabie

9.4. Additional Views available to the Group Manager

The View drop down menu provides several additional options that are not offered to the

Administrator, i.e.,

« Groups

« HSMs

- Client Hosts

+ Keys

- Card Sets

« Security Worlds

group | Group Manager |, Jan 05, 2017 1920 @

. Log Out
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Wiews = er:nrl
Groups b
HiMz b
Client Hosts b
Feys *
Coard Sets ’

Secunty Waorlds *

9.4.1. Groups
1. Navigate to:

View > Groups > Client Hosts By Group

Wiews = Reports - Configuration -

Groups k Group List

HEMs= L HEMs By Group

Client Hosts b Client Hosts By Group
L

2. Select Client Hosts By Groups.

The Client Hosts By Groups page opens.
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Client Hosts By Group

o

q Zearch
i Maoniforing Hardserver
Name shatus
CH 2
Wz
Faisa UMREACHARLE
Wz
£

TOWVE par page.

Commands
Last Hr.

in this group.

HiMs  Alarm

Last

Update | Location

Cument

Cumant

Group 2 There are 2 client host(s) in this group.

Security World

3 Total rowvs .

The Client Hosts By Group page contains three navigation points. Selecting any one of the

following opens a new page;

+ A specific device name

The Client Host Detail page opens.
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Client Host Detail for : Faisal CH 2

IP Address/Host MName - "10.1.7 212"

Perfformance »

Health »

Applications with Active Connection to Hardserver »

Secunty World Info »

nshield H3Ms »

nihield Card Sets »

nihield Keys »

+ A specific Alarm

The Current Unacknowledged Alarms page opens.

Current Unacknowledged Alarms

Q severty: CRIMCAL E JEEEEGN

Date/Time severity Message

O 2017-01-31T01:25:34 477 CRITICAL The connection stafus B now unreachable l

O 2017-01-10721:15:13.550T CRITICAL The connection stafus B now unreachable

+ A specific Security World
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Security World
cc?éc?ﬁﬁaﬁq 19387 782 34c 43cabacar 5P 2id

cOFdc7dmsie841PcIBT 7aa 340 48cabocar 57 2fd

The Security World Detail page opens.

Security World Detail For : cO076c/7daf5fed41

Edit Security World Name

Health »

Security World Quorumm »

Client Hosts »

n3hield H3Ms »

Keys »

Card Setfs »

9.4.2. View > HSMs > HSM List

1. Navigate to:

Views > HSMs > HSM List

Monitor v2.8.0 Install and User Guide 156/284



Chapter 9. Views

Wiews = Feports = Configuration =

Groups b
H3Ms k| HSM List '{F_”}

Client Hosts b Client Hosts By H3M
Feyvs 4

Cord Sets 4

Securty Waorlds *

payshield Host Comnj

2. Select HSM List.

The HSMs Summary page opens.

9.4.2.1. HSM Summary Page

With the HSM Summary page open, you can toggle between views by
o selecting Client Hosts by HSM. See the upper right hand corner of the
screen.

HEM Liste®

Client Hosts By HSM

H3M Summary

< Rk = m

A Seriol Mo lType I Mode= Monitoring Commands Last Alarms S=curity Warld Ch=nt Host Lo=i
Objecis] Hr. (=) Update
P

capsozecmear conmzs | |NEEER a (1] o7 §cTdEHEFaE419 28776 14gdbcabacaTSiid | 1 Curent
bl

zosozEc-Deay, conmzs  |NEEEY enaecen il o | a [+ [1] <07 ScTdSH5teE41 9o 287784 cdbraba o Mg Curent
xc

4899-T4B4-20FF | CONMECT [ 14 ] EID BB | -074<7d5i5i=841902877804cdicabacal 552 | 1 Cumrent

4F99-TABF-4296 | CONMECT [ 14] BB | -07:c7d55i28419c3577Be2dcdbcabaca? 5926 | | Curent

BS4A-51CE- CONHECT [ | [+ [0} D7 T d5i5teB41 987 TR M cdBoabacal S92d | 1 Cument

73F2

Colored font indicates that filtering is available. Additionally, you can select individual
devices to open new windows.

Examples:
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—
H3M Detail for : 0305-02E0-D947

Managed By Group|s) : "nShisid” IP Address - "10.1.3.78"

Performan ze »

Configurc fion »

Healt 1 »

Secunty Worlc Info »

S
Chient He sfs »

Applications with Active Connection to Hart server

Security World Detail For : c076c/7d5t5fe8419c38778e34c48cabaca7592fd

Heal th »

Security Worlc Quorum »
Clien Hosis »

nshield H3Ms »

=N

Carc | Sets »
———

9.4.2.2. Navigation Example - nShield HSMs window
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nShield HSMs

Type Mode Moniforing & Commands  Alarms = Securihy World Chent Lost

Serial Objects | Last Hr. Host  Updats
No. (5}

F48C- | CONNECT EI g B | -orscrdstsiess19c38778e34c43cabacal 5926 | 2 Curen
E2CE-

FFCE | SOLO EI 8 [ 4391 | 0T 4cTdSfEfald] Pe38778e4c48cabocol 572fd | 1 Curren/
3000-

ol

o Blue icons and blue text indicate action available, e.g., selecting a spe-
cific Security World, opens the Security World Summary page.

Examples follow:

Security World

cFScFdEfsfadd] ?C%@EES4:"—ECQEGCD?5?HC§

. Select the Security World identifier. The Security World Detail page opens.

Security World Detail For : c076c7d

Edit Security World Name

Secunty World Guorum »

Chent Hosts »

n3hield HSMs »

Keys »

Caord Sets »

- Select Edit Security World Name to edit the name:
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Edit Security Word Name

| cO76cT7d55Me8419c387 783 4c48c0bacaT 5721 | ﬁ

Clear

- Enter the new name and select Save.

0 ‘ Select Clear to close this dialog box without saving an edit.

« Health window

Generation Time: 2016-01-29T00:00:00.000Z

Generating Module ESN: BEAA-B1CR-TIR2

hashkKMSOx <07 6cTd5iEfel419c3877 a3 4c48c0boca7 572
haashikM: 111d3dbf3fc341 2e2d 5377l P41 4boa 1 3462128

+ Security World Quorum window
Securty World Quorum -

KNSO Quorum 1
Total Number Of Admin Cards 3
Module Reprogramming (KM) Quorem 1
Recovery (KR) Quorum 1
Passphrase Recovery (KF) Guorum 1
NVRAM Authorizafion (KNV) Quorum 1
RTC Auvthorizafion (KRTC) Guorum 1
SEE Debugging Authorization (KDSEE) Quorem 1

Foreign-Token Auvthorization (KFTP) QGuorum 1

- Client Hosts window
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Client Hosts =
q, Search: m

Name Hardserver Status Commands Last Hr.
Faigal CH 1 [ RUNNING | [ 8724 |

Faig? CH2 [ RunNING | [ 13083 |

Faisal SW2 CH1 [ RUNNING |

- Select the client host name to open the Client Host Detail page.

Client Host Detail for : Faisal CH 1

IP Address/Host Mame - "10.1.7.1547

Performance »

Health »

Applhcatons with Active Connection to Hardserver »

Secunty World Info »

n3hield HSMs »

nihield Card Sets »

nihisld Keys »

« nShield HSMs window
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Q Search:

Serial No. Type Mode Lood
F4BC-B3CE-3EDP COMNECT OPERATIONAL 6337
5¢Ce-3000.63C5 s0L0
£679-T4B4-20FF CONNECT [ oPERATIONAL |
£FP9-74BF-4278 CONNECT [ operATIONAL | [ 1947492 |

- Select a Serial No. (e.g., click F48C-82C8-3ED9) to open the HSM Detail page.

Tl

HSM Detail for : F48C-82C8-3ED9
Managed By Group(s) : "Group 1. Group 3° IP Address - "10.1_3.70"

Performance »

Configuration »

Health »

Secunty World Info »

Chent Hosts »

Apphcations with Active Connection to Hardserver »

9.4.3. View > HSMs > Client Hosts by HSM
1. Navigate to:
Views > HSMs > Client Hosts by HSM
The Client Host by HSM page opens.

2. When hovering over the text turns the text blue, click to expand.
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A details window opens:

HSM List  Client Hosts By HSMw”

Client Hosts By HSM
R Search:

PFC6-3000-0001 ~ There are 1 client hosts(s) with this nShield.

Q Search:

A Name Menitoring Hardserver Commands Last HSMs  Alarm Last Update Security World HSMs=

Status Hr. Location Failed
Kory [ RUNNING | [0 ] 5 [ 41 [2]1 [ 45 RIPaE home Security world False
Simulator 20T17:21:29.7371 one

This detail window has 4 navigation links as summarized in the following table.

Links on the Details window

Clicking Opens this page Notes

Name See Client Host Detail page

HSMs count nShield HSMs page. The nShield HSMs page also con-
This page lists all the HSMs by Ser- tains a link under the Security World
ial Number column. Clicking on the Security

World identifier opens the Security
World Detail page.

Alarm Current Unacknowledged Alarm Select the box associated with the
(hover over the colored alarm total alarm to open the Acknowledge
box in the Alarm column, then click.) Alarm window.

Security World (name or Security World Detail page.

HashKNSO)

9.4.3.1. Client Host Detail page

Select the expansion arrows to open additional windows.
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Client Host Detail for : Faisal CH 2

IP Address/Host Name - "10.1.7.212"

Performance »

Health »

Apphcations with Active Connection to Hardserver »

Secunty World Info »

nShield H3Ms »

nihield Card Sets »

nihigld Keys »

Performance window:

Performance -

Faisal CH 2 Command Count, Last 30 Days

S0k

&0k

40k

Commands count

P

ok
n E. Miar 12 Mar 20. Mar 27. Mar

H | Last 30 Dioys |

1 houwr

1 houwr

Health window:
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mMonitoring:

Shotus:

Hardserver Shatus:

Humber Of HSMs:

Applicofions with Active Connection To Hardserver:
mModules Failed:

Hardserver Version:

Hardserver Pork:

Hardserver Upfime:

5
T
i |

#0002

48 Days © 17 Howrs : 47 Minutes : 57 Beconds

Applications with Active Connection to Hardserver window:

Applications with Active Connection to Hardserver -

a search: A
" Upfime Command Reply Remote Frocess  Tofal Object
Connecfion Count Count 1P Frocess = Name Count
Number Address ]

3 ssoay=:17 | B 173857543 [QTRsTs) o Mot available
Hours - 48
Minutes : 57
Zeconds

4 ssoay=:17 | B 0 | 0.0.0.0 o =l Hot ovoiloble
Hours : 42
Minutes - 57
Zeconds

s soay:=:17 | B 0 | 0.0.0.0 o (==l Hotb ovoiloble
Hours © 47
Minutes : 57
Seconds

£ 4B Days 1 17 n n 0.0.0.0 o o=t Ml Wb ovoiloble
Hours © 47
Minutes : 57
Zaconds

72581 36 Days - 23 HMATEAT2 0ATEATY 0.:0.0.0 i Hol ovailable
Hours : 27
Minutes : 57
e

Security World Info window:

Monitor v2.8.0 Install and User Guide

165/284



Chapter 9. Views

Secunty World Info -

Security World Name: 07 &o7d5f5fesd 1 PoEETTEeS4ciBoaobaca7 seefd
Security World state:
hashKMSO: cO7 soTasisfesd 1 PoBETTEeS4cABCOD OCaT SR
hashKm: 11133dbfifc3412=2d437e97e1 746140001 362128
9 Clicking on the Security World identifier (e.g, cO76cd....), opens the
Security World Detail page.

nShield HSMs window:

Q Search:

Serial No. Type Mode Commands Last Hr.

F4BC-3ECE-3E0F COMNECT | OPERATIONAL |

nShield Card Sets window:
nihield Card Sets -
q seqarch:
et Mame Client Host Cownf Generation Time
cmocOl 2 201 &-0F-1 8T23: 4730 47501
| 3 2O1&0F15TIE T 120712
oo2 3 201 &0F15T2307 157158
o ‘ Selecting a set name, opens the Card Set Detail page.

Card Set Detail page:
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Card Set Detail for ;: cmoc0]

Health »

Secunty World Info »

nihield Keys Protected By This Card 52t »

Client Hosts »

Select the expansion arrows to open additional windows.

nShield Keys window:

nShield Keys -~
qQ tearch:

Key identifier/Mame Key Hash Key applicafion Client
Hame Hosts
@{.‘4 72cB0403d251 Seaf@ 1f3czféz31{8fe07 D303 1 2ca 45445 1 DBBRCcO2O2 embed @
Efd31735F 2003047 abel 45eTecabedd7anarfess | 427cel8200f0507cD0BS44IP5510d4111810317 embed 3
il 73Bscc 1 7pcafaraseal Salf7 88207 cl oodeaff simpie 3
ff2 banfafad 197154820 203052384 580007 40080088 | Simpie 3
ffa 150343004307081 SOPOQITACOS44DEI2CH1PCEAS | SiMpe 3

This window has two navigational links.

Selecting the Key Identifier opens the Key Detail page:

Key Detail for : 6ffc275560117472c8t

Edit Key Mame

Health »

Secunty World Info »

Client Hosts »

Selecting the Client Hosts number opens the Client Hosts By Key page.
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Client Hosts By Key

MNarne: 6Fc2755601f747 20804034251 SeafesdaFidaid @ Search:

6ffc2/75560117472c6b4a3d2515eafebdc?é4etd - There are 3 client hosi(s)
with this key.

Q Search:
i Monitoring  Hordserver  Commands  HSMs — Alarm Loust Securiy World
MName Status Last Hr. Update Locafion
E-S I ensnien [l kunninc Il 6729 | 2 B Cumenit 07T d5f5iad4] Fo3aT78el
== EnanieD Ml RUNNING | 3 BO Cument cO74cT S5 feB419c387 703
ricl | (B OIS EXEE] - 1158 | 1184 JReTESNY C074cT A5t 5feB41 903877823

9.4.3.2. Navigating to the Security World Detail page

1. Select a Security World name.

Security World

Security World Detail page opens.
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Security World Detail For : cO76c/7d5t5fe

Edit Security World Hame

Secunty World Quorum »

Chent Hosts »

n3hield HiMsz »

Keys »

Cord Sets »

2. Select the Health expansion arrow.

Health -
Generafion Time: 301 &-01-2FTO0:0000.00T
Generafing Module ESN: BSSA-B1CR-FIFR
hoshKMsO: cO7 éc7dsfsfedd 1 o3BT TEeS4cdEoobacar 572fd
hashkm: 11103dbf3fc341 222043727721 741 40O 1342125

3. Select the Security World Quorum expansion arrow.

Secunty World Quorum -

KN30 Guorum 1
Total Number OF Admin Cards 3
Module Reprogramming [KM) Guorum 1
Recovery [KR) Guarum 1
Passphrase Recovery (KF) Guorum 1
NVRAM Authorization (ENV) Quarum 1
RTC Authorizotion [KRTC) Guorum 1
SEE Debugging Authorizafion (KDSEE) Guaorum 1

Foreign-Token Avthorizafien (KFTP) @uorem 1

4. Select Client Hosts
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Chent Hosts =

Q search:
Mame Hardserver Shatus Commands Last Hr.
Faisal CH 1 | RUNNING | 8741
Faisal BWZ CH1 [ RUNNING | [ o]

The Client Hosts window has one navigational link.
5. Select a name from the Name column (e.g., click on Faisal CH 1)

The Client Host Detail page opens:

Client Host Detail for : Faisal CH 1

IP Address/Host Name - "10.1.7.1.54"

Performance »

Health »

Apphcations with Active Connecthion to Hardserver »

Secunty World Info »

n3hield HiMs »

nihield Card Sets »

nihield Keys »

9.4.4. View > Keys

9.4.41. Key > Key List
1. Navigate to:

Views > Keys
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Wiews =

Groups

HiMs

Keys

Cord 3ets

Client Hosts

Reports -

|

Securty Waorlds *

Configuration -

Key List
O

Client Hosts By Key

2. Select Key List.

The Key Summary page opens.

Key Summary

Q Search:

Key Name/Identifier ¥ Key Hash Eey Applicafion Name Client Hosts
mycintlkeyl fe0i8eedldbidbadcéfPEaddecccPbd4bdb 10 smple 3
fraining faD234587eacd] 1 e4cD4féféal2bB5921 77 4babe simple 3
nirc e37802af?a2eR 5ceafidiabb ] ded 1 10533cPHisa simple 3
fisimpleffocs e3580bas b 1alds] de3070daeeIRsarrdibarase smple
flkeydmpleaug242014 cc1380E8c17b133c5bef83a 1 PP239Pae2s] PedBs simple
The Key Summary page has two navigation links:
> Key Name/Identifier
° Client Hosts
3. Select a Key Name to open the Key Detail for page.
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Ley Detail for : mycintlkeyl

Edit Key Mame

Health »

Security World Info »

Client Hosts »

o Should you need to Edit the Key Name, Select Edit Key Name,
rename the key and then select Save.

4. Select the expansion arrows to open the windows.

Blue font indicates that the text is a link. Click on the blue text to
0 drill deeper (e.g., click on Faisal CH 1to open the Client Host Detail
for: Faisal CH1 page.)

Health:
.
Key Application Name : smple
Key Identifier : mycint ey
Key Hash : fo00B=et0dbidbadcéfPPEaideccc22Pbd4edb 10
Key Frotection : MODULE
Eey Recovery : EMABLED
Time: Limit : 0
Pre-authenficafion Use Time Limit : 0
Generating Module ESN : Mot availakle
Protecting Cardset Hash :

Security World Info:
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Securty World Info -

Security World Name: COF ST ALfofeld19038778e34c48cabacar 592id

Security World States

hashKNSO: cO7scTd5fofel419c38778e34c48cabocar 57 2fd

hashKM: 111d3dbf3fc34] 2e2d637e9721941 4banl 362125
Client Hosts:

Client Hosts -

Q Search:

Name Hardserver Status Command Last Hr.
Foisal CH 1

Foisal CH 2 [eunninc | [ c200015 |
Faisal SW2 CHI

9.4.4.2. Keys > Client Hosts By Key

Views = Reports = Configuration -

Groups 4

H3Ms b

Client Hosts b

Keys b Fey List

Cord Sets * Client Hosts By Key

b

Secunty Worlds *

1. Select Client Hosts By Key.

The Client Hosts By Key page opens.
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Client Hosts By Key

Q Search:

Q Search:

A Monitoring  Hardserver Commands  HSMs = Alarm Last
Name Status Last Hr. Update
roiol | [T | (XIS 2 @  Curent
CHI1

rovo | (D OIS = ¢ @B o
CH2

Location

Key List

Security World

Client Hosts By Keyw*

2. When hovering over the text turns the text blue, click to expand.

3. Select a device.

& Monitoring  Hardserver  Commands HSMs = Alarm
Name Status Laist Hr.

L

Fill 4175843 3
D D BEX (1 [2]

[

CH2
BN cricoico J unninc | . oo
W2
CH1

Last
Update
Current

Current

Current

Locafion

Security World
c7 57558419

The Client Host Detail page opens.
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Client Host Detail for : Faisal CH 1

IP Address/Host Mame : "10.1.7.154"

Performance »

Health »

Applications with Active Connection to Hardserver »

Security World Info »

nshield HSMs »

nshield Card Sefs »

n3hield Keys »

4. Select the expansion arrows to open the windows.

Performance:
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Faisal CH 1 Command Count, Last Hour

E00k
300k

e

400k —

200k \
200k \

100k

Ok
19:20 15%:35 18:40 19:45
5 mins
H ‘ entiionn ‘ —n—a—a—n—o e o

Commands count

15 mins 1 min

Health:
et

Menitoring:

status: [avar_swwr

Hardserver Status:

Number OF HSMs: 2

Applications With Acfive Connecfion To Hardserver: 5

Modules Failed: [ TRUE |

Hardserver Version: 2921

Hardserver Port: 2004

Hardserver Upfime: 45 Days - 20 Howrs : 49 Minutes - 18 Seconds

Applications with Active Connection to Hardserver:
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Applications with Active Connection to Hardserver -

Q Search: m
A Upfime Command Reply Remote Process Name Total Object
Connectfion Count Count IP Process Count
Number Address 1D
5000 (@ 0000 |0
Hours - 49
Minutes - 18
Seconds
5 4sDoys:20 [ (o] 0000 0 legocy)
Hours - 48
hMinutes - 45
Seconds
w7se  4ioop:ol (EEOEY  EEEEES 0000 o
Howurs : 03
Minutes - 14
S

Security World Info:

Security World Info ~

Security World Name: cOFSCTdofofedd ] PoadiTéed4cdBoabacar S92id
Securty World sate:

hashKNSO: cO7scifdsfofedd | Poci8i7EeddcdBoabacar 572d
hashkEM: 111d3dbf3fc34] 2e2d 63729721941 4baal 362125

nShield HSMs

nShield HSMs -
Q Search: m

Serial No. Type Mode Commands Last Hr.
9FOE-3000-53C9 s0L0 (4572

F48C-82C8-3ED7 COMNECT

nShield Card Sets:
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nshield Card Sefs -

Q Zearch:
Set Name Client Host Count
ffoc] 1
ocl 3
ool 3

Generafion Time

2015-08-24T19:08:1 18112

2601 5NENFN2N2E

2015603-15123:07:157152

nShield Keys:

nShield Keys =

Q Search: m
Key ldeniifier/Name Key Hash Key Client
Applicafion = Hosis
Name
&ffc275540117472c8b403425) Seafe53cPsdafd 1f3cPa231fafe07b3b3 | ecd ] 454645 bAleca?d? embed 3
5fd3193592003b47abe] 45e7ecdbedsTdnariess | 429ce1820000507cb058244/95512d41f1812317 | embed 3
1 7384cc ) TboaPard5Pdisafi7 4f88207 ol bdBedff simple 3
ff2 bdbfdfad] 9715452c29508238454b007 49a8ddes | simple 3
ffa 14084d0bs30908 1 daPaa374c05440832cb 1 7808 | simple 3
9.4.5. Card Sets
1. Navigate to:
Views > Card Sets
9.4.5.1. View > Card Set > List
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WViews = Reports - Configuration - Lg

Groups 4 |

Client Hosts k

FEys b

Cord 5ets 4 Card Set List

W

Secunty Worlds * Client Hosts By Card et

1. Select Card Set List.

The Card Set Summary page opens.

Card 5et Liste*  Client Hosts By Card Set

Card Set Summary

Q Search:

¥ St Name Client Host Count
oc2 3

oc] 3

2. Select a Set Name to open a specific Card Set Detail page.
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d Set Detail for : oc2

Health »

Security World Info »

nshield Keys Protected By This Card Set »

Client Hosts »

3. Select the expansion arrow to open the windows.

Health:
Health =
hashELTL: Slaaléc4a7?clibs?éc2oidi48dcd4] foc24f804a
Guorem Count (k): 1

Total Number Of Cards{N): 1
Timeout : 0

Generatfion Time : 2 &05-15123:07:15.7152

Security World Info:

Security World Info -

Security World Name: 7 507 d5i5feB41 9c387 782340 480cnboca 7 592d
securty World sgte

hashKNSO: c7 4c7d5i5ieB41 9387 7 Se34c4B8onbaca7 59 2d
hashkKM: 111d3dbf3fca4] 2824637 2F721 74140001 362128

nShield Keys Protected By This Card Set:

n3hield Keys Protected By This Card Set -

O Ther= ars no keys to display.
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0 ‘ When there are no keys to display, the system indicates such.

Client Hosts:

Client Hosts -

qQ Search:

Naome Hardserver Status Command Last Hr.
Foical CH 1 [xunninG

Foisal CH 2 [ cunninG
Faisl SW2 CHI [runninG

9.4.52. View > Card Sets > Client Hosts By Card Set

Views = Reparts - Configuration = Lcl

coves [

Client Hosts 4
Feys 4

Cord 5ets 4 Card Set List

Securty Waorlds # Clhent Hosts By Card Set

W

1. Select Client Hosts By Card Set.

The Client Hosts By Card Set page opens.
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Client Hosts By Card Set

cmocO01 » There are 2 client host(s) with this cardset.

ffocl » There are 1 client host(s) with this cardset.

ocl » There are 3 client host(s) with this cardset.

oc2» There are 3 client host(s) with this cardset.

2. When hovering over the text turns the text blue, click to expand.

m

Client Hosts By Card Set

Q Search:

cmoc01 ~ There are 2 client host(s) with this cardset.

Q Search:
A Monitoring  Hordserver  Commands  HSMs = Alarm Last Security World HSMs
Name Status Last Hr. Update Locafion Failed
Faisal m m 3 nn Current cO74cTd5f5fe8419c38778234c48cabaca? 592fd | False
CH2
Faisal [ running [l 1310417 A B curent c076c7d5f5fe8419038778234c48c0bacar592fd | False

3. Continue to click on the blue text to drill deeper.

For example, clicking on the Security World identifier opens the Security World Detail

page:
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Security World Detail For : c076c/d5f5fe841

Edit Security World Name

Health »

Security World QGuorum »

Client Hosts »

nshield H3Ms »

Keys »

Card Sets »

9.4.6. Security Worlds

9.4.6.1. Views > Security Worlds > Security World List
1. Navigate to:

Views > Security Worlds > Security World List
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Wiews = Reports - Configuration - Logs
Groups k |
Client Hosts b
Keys ¥
Card 3ets r
Secunty Waorlds * Secu World List
Sevel  HShis By Security World
E Client Hosts By Secunty Waorld

2. Select Security World List.

The Security World Summary page opens.

Security World Summary

L= Search:
& Home HoshKHED Client nShield Generofion Time Generafing
Hosts Module ESN
ar 2841 PcIETTE= 24 aboc c =4 ST 7Ee34c4E afse2id | 2 BS8A-B108-
3. Click on the blue text to drill deeper.
¥ Name HashKNSOr

For example, clicking on the Security World HashKNSO opens the Security World

Detail page.
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Security World Detail For : c0/7é6c/7dafafei

Edit Securty Word Name

Health »

Security World Quorum »

Client Hosts »

n3hield HiMs »

Card Sets »

4. Click on the expansion arrows to open additional windows.

9.4.6.2. Security Worlds > HSMs By Security World
1. Navigate to:

Security Worlds > HSMs By Security World
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Wiews = Reports - Configuration - Logs
Groups k
H3Ms L
Ky ¥
Cord Sets ¥

Secunty Worlds ¥ Secunty Word List

Client Hosts By Securty Waorld

2. Select HSMs By Security World.

The HSMs By Security World page opens.
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HSMs By Security World

c0/76c/d5t5fed419c38/7/78e34c48cabaca/592fd -~ There are 4
nShield(s) in this security world.

nshield H5Ms

& Type Mode Monitoring Commands Alarms | Client  Last
Serial Objects  Last Hr. Host Update
No. (s)

6699~ CONNECT Cenasieo Jll 10] BB > cumen
74B4-

30FF

699 CONNECT Ex=3 @ OO 2 o
74BF-

4798

3. When hovering over the text turns the text blue, click to expand.

nshield H5Ms

'y Type Mode Monitoring Commands Alarms  Client Last

Senal Objects  Last Hr. Host Update,
No. (s)

8699 | CONNECT (enasieo il 0] BB coren
FAR4-

6F99- | CONNECT I m oD 2 o

4. Select a Serial Number to open the HSM Detail page.
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HSM Detail for : 6699-74B4-30FF

Managed By Group|(s] : "Group 1, Group 2" IF Address

Performance »

Configuration »

Health »

Security World Info »

Client Hosts »

Applications with Active Connection to Hardserver »

5. Select the expansion arrows to open additional windows.

9.4.6.3. Security Worlds > Client Hosts By Security World
1. Navigate to:

Security Worlds > Client Hosts By Security World
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Wiews = Reports - Configuration - Logs
Groups b
H3Ms L
Client Hosts L

Keys ¥ _

, bup 3" IP Address:™

Cord lets
Securty Worlds ¥ Secunty World List
H5Msz By Securty World

Client Hosts By Securty Waorld

1 0

The Client Hosts By Security World page opens.

2. When hovering over the text, the font turns blue, click to expand.

Client Hosts By Security World

The page expands:
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Client Hosts By Security World

c0/76c/d5fofe8419c38/78e34c46cabaca/592fd ~ There are 3
client host(s) in this security world.

Q, Search:

Name Monitoring = Hardserver Commands HSMs  Alarm Last A H5Ms
Status Last Hr. Updaie Lecation | Faoiled

Foisal CH [cunnin | 5 EE Curen Folse

Faisal l‘lﬂ"l"l li'“ B 2 nn Current False

SW2 CHI

aisal CH m m 2 n Current True

The blue font indicates that there are two links on this page, i.e., data in the name col-
umn, and count total in the HSMs column.

3. Select a specific Name, e.g., click on Faisal CH 2.

The Client Host Detail for: Faisal CH 2 page opens.
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Client Host Detail for : Faisal CH 1

IP Address/Host Name - "1001 7.154"

Performance »

Health »

Applications with Active Connection to Hardserver »

Secunty World Info »

n3hield HiMsz »

nihield Card Sets »

nShield Keys »

4. Select the expansion arrows to open additional windows.
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Chent Host Detail for - Faisal CH 2

IP Addrecs/Host Mame :"10.1.7 212

I Perfomance -

12k

Cammuards courk

-

Ll Mlar  Riar Ll Llar

Maontiong:

Slabus:

Hordsenver Shahes

Humbsar Of HEMS:

Appdications Wi Acfive Cormaction To Hardsareer
Maodokss Falie-d:

Hordsenver Varsion:

Hordsenver Port:

Hordsener Uptime:

Faisal CH 2 Command Count, Last 30 Days

e e 2w e

Dl
n o3& 5 26 #.  LAp @.Apr Ao T.Apr mApr 1. 1& 18 7. I8
-

[-1- 3

T2

S04

3% Days : 1€ Hours © 17 Minudas © 54 Seconds
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Applications with Active Connection fo Hardsenver -

Conneclion Uptime

39 Dows
Minutas

4 37 Dons
Minutats

5 37 Dorgs
Minuhas

& 37 Dovs
Minutas

150417 13 Deorgs
Minutas

Sty Woekd Manme:
Sacurtty Workd Stosa:

hashiNE0:

Sarial Mo.
E4TF-TARL-IOFF

SPFF-TABF-4278

F4EC-E2C8-3E07

: 1&Houms : 17
: B4 Baconck

D 1&Howms : 17
: B4 Sgconch

o1& Hows 17
54 Zaconch

:1&Hous 2 17
: B4 Sgoonch

1 15 Hours : X0
: 57 Saconcs

I sCToal S84 Pe 38T TER 344 BoabnCoT 572

1112300 He24] JeLITe7Te 1741 4ban i 243123

Typst
COMNECT
COMNECT

OOMMECT

Regly Remate IF
Counk Address

[ @ ] DO

Moda

First Foge: :-I:: Last Fope:

[ 1] Home: Cound
a

o [eg=cy] D

o Y - |

o [egocy] D
a

Todal Objec

7 Todal m.FE:JGII:l ot
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nEhield Card Sefts -

(2] Sk m

Sat Hame Cllant Hast Cound Genenation Time:

ool I 30 &-05-1 SE2457 30,0000
oo 3 20 &03-1 ST R:1T12.000
ool 3 2016031 ST2307:1 50000

e DEf DOgE. First Foge: | & I 5 | Lost Foge 3 Todn rvas . Fﬂ:;lGII:I el

nEhield Keys «

o Seorch: m

Kay Ideniifler/Home Eay Hosh Ezy Applicotian Client
Hams: Hasls

Efe2T 5501 47 2eEbdn 30T E ] SanfaS3oFidald e MR DF B AR | erd] 455451 BB nSn ek 3

Efd31 7357300347 obel 43eTecobedErdbaass | 4290a18200%0 SbTebO80as 4755 1ada11181a317 et 3

i TABSco | T o 3T ISRt S ST #188207C | oS ottt Srgie 3

2 Edeieind 571 548200982000 SAnTDT AR NSNS | SmEia 3

3 1 E08L00bE3TF0E] doRondr4clC44bEmTobIFoBod | dreia 3

=]

5. Continue to click on the blue text to drill deeper.

9.4.6.4. Security Worlds > Keys By Security World
1. Navigate to:

Security Worlds > Keys By Security World
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Security Worlds *

F AT LI

Wisws - Reports - Configuration - Logs
Groups ¥

HiMs L

Client Hosts b _
Keys *

Cord Sets ¥

Secunty World List

H3Ms By Securnty Waorld

Cliznt Hosts By Security Warldg

Keys By Secunty World

Card Sets By Securty Waorld

The Keys By Security World page opens.

Keys By Security World

c076c/d5f5fe8419c38778e34c48cabaca/5%92fd ~ There are 15 key(s) in this

security world.

Q Search:

A Key Name/ldentifier Key Hash Key Applicafion Clent
Name Hosts
Gifc27 556011747 2084030251 Seafe 530 édafd 11326231 f8iel7b3b3 1 ecd1 4565651 bE8ecald2 embed 3
8id31935920b3b47abel 4beFecdbeds/dbariess | 429ce18200P05b7 cb088e64i95512db11181 2317 embed 3
ff F3B6cc | 7oca?37 d5Paissliy 4188207 ¢ bdBedit smple 3
ff2 bdbfdfad] $715482c29808238456b007 4%a8ddee | simple 3
Both the Key Name/Identifier and the Client Host columns contain
0 blue font. Blue font indicates an active link. For example purposes,
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the following step selects the Key Name/Identifier.

2. Select the Key Name/Identifier.

4 Key Name/Identifier K

&ffc27 554017 47 2c8b403d251 SeafeS3cisdefd 1

Bf&ﬁ'-?35£3m54?cbel45&?&Cdbedr3?dbﬂ?f&55 4

The Key Detail page opens.
Ley Detail for : 6ffc2755601f/4/72c8b4a3d

Edit Key Mame

Health »

Securty World Info »

Client Hosts »

3. Select the expansion arrows to open additional windows.
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Health ~

Key Applicafion Name : embed

Key ldenfifier : &ffc2755801 1747 2cBb403d251 Seafe5acPidefd
Key Hash: 1f3c2f46231 fafelfo3bd] ecd | 456651 b83eca2d2
Key Protection : MODULE

Eey Recovery : EMARLED

Time: Limit : 0

Pre-authenficafion Use Time 4]
Limnit :

Generating Module ESN : Mot availabls

Protecting Cardset Hash :

Security World Info ~

Security World Name: cOF éc/d5f5fedd] Poib/ T6eddc4dcaobacal 5721d

Securiy Worid e

hashENSO: cl7 6c7d5fsfeds] Poddi/8eddc4Boabaca? 572

hashEM: 11 1d3dbf3fc341 282463729721 741 4000 3621 28

Client Hosts -
Q Zearch: m

Name Hardserver Status Command Last Hr.

Faisal CH 1 [ RUNNING | [ 8334 |
Faial CH2
Faisal W2 CHI [ RuNNING | [ 1510280 |

4. Continue to click on the blue text to drill deeper.

9.4.6.5. Security Worlds > Card Sets By Security World
1. Navigate to:

View > Security Worlds > Card Sets By Security World
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Wiews = Reports = Configuration - Logs
Groups b
H3Ms b
Leys *
Card jets ’

Securnty Worlds ¥ Secunty Word List
H5Ms By Security World
Client Hosts By Secunty Waorld
Kevs By Securnty Word

Card Sets By Securty Warla

W

The Card Sets By Security World page opens.
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Card Sets By Security World

Q Search: m

c076c7d5f5fe8419c38778e34c48cabaca/ 592fd
~ There are 4 card set(s) in this security world.

Q Search: m

A Set Nome Client Host Count
cmocO] 2
fioc] 1
ocl 3
oc? 3

2. Select a Set Name to open the Card Set Detail page.

Card Set Detail for : cmocO1

Health »

Security World Info »

nShield Keys Protected By This Card Sat »

Client Hosts »

3. Select the expansion arrows to open the windows.
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rd Set Detail for : cmoc0]

Hedalth

hashELTL: 141 7ef7258bbb2e1 b30045fcadfi dfé292b24644
Cuorem Count (k): 1
Total Number Of Cards{N): 2

Timeout : 0

Generation Time : 201 509-14T23:49:30 49307

Security World Info =

Security World Name: cO7 47 d5f5feB41 9387782 34c48cabacal 59 Hd

Secuity Word tate
hashENSO: cO74cTdofsfeld] 9el8778eld4c4Boobacarl 592id

hashEM: 111d3dbf3fcdd] 2e2dé637e?7e1941 4baal 362123

nshield Keys Protected By This Card Set -

® There are no keys fo display.

Client Hosts ~

Name Hardserver Status Command Last Hr.
Foisal CH 2 (13032
Foisal SW2 CHI 5727121

4. Select the Client Host Count (from the Card Sets By Security World page).
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Card Sets By Security World

c0/6c/d5tbfe84192c38/7/8e34c46cabaca/592id
~ There are 4 card set(s) in this security world.

Q Search:

A 5t Name Client Host Count

The Client Hosts By Card Set page opens.

Client Hosts By Card Set

Q Search: |

cmoc01 ~ There are 2 client host(s) with this cardset.

Q Search:

A Monitoring  Haordserver Commands HSMs = Alarm Last Security World HSMs
Name Status Last Hr. Update Locafion Failed
Faisal [ running [ 13053 | 3 BB curent c076c 7558419038778 34c48cabaca7592fd | False
CH2

Faisal [ RUNNING | 2 aEB curent c076c7d5i5eB419C38778e34c48cabaca7s92fd | False
swz2

CHI

5. Select Name to open the Client Host Detail page.
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Client Host Detail for : Faisal CH 2

IP Address/Host Mame : "10.1.7.212"

Performance »

Health »

Applications with Active Connection to Hardserver »

Security World Info »

n3hield H3Ms »

nShield Card Sets »

nihield Keys »

6. Select the expansion arrows to open the windows.
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10. Reports

With nShield Monitor, you can create pre-generated reports and send them to a PDF file or
export them to a CSV file. These reports can provide valuable information pertaining to a
specific HSM or group in near real time. You can also schedule a report to periodically track
a group or a specific HSM over time.

With the Reports feature you can track device utilization and loading trends, as well as
cross HSM (details per HSM as selected).

10.1. Generating Reports
1. Navigate to: Reports > Generate Reports

The Generate Report page opens.

Generate Report

Groups and Devices -

Cancel Changes

2. Select the Groups and Devices drop down arrow.

The down menu opens.
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Generate Report

Groups and Devices -~

Select a Group :

Test Vps
1

2

3

4

10

3

%

rt type :

ot Device Report

] Cancel Changes

3. Select a Group. (In the example above, the Group is titled "nShield".)

The Group Report and Device Report options display.

10.1.1. Group Report

1. Select Group Report

Follow this link to see the Device Report menus/options: Device
Report.

Monitor v2.8.0 Install and User Guide

204/284



Chapter 10. Reports

Generate Report

Groups and Devices -

select a Group :

Shioid 1%

select a report type :

Group Report  Device Report

Cancel Changes

The Generate Report page opens.
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Generate Report

Groups and Devices -~

Select a Group :

nshield W

Select areport type :

Group Report #  Device Report

U (optional) Show Top 10 Devices.

Report Configuration ~

Utilization and Loading Trends Opfions -

Cancel Changes

2. Optionally, select Show Top 10 Devices to limit the report to the top 10 devices.

Select a report type -

Group Report #Ff  Device Report

M [opfional) Show Top 10 Devices.

o ‘ You may need to scroll down the screen to access the expansion

arrows.

3. Select the Report Configuration expansion arrows.

The Report Configuration window opens.
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Generate Report

Groups and Devices -

Selecta Group -

slect arsport type :

Group Report »*  Device Report

[optional) Show Top 10 Devices.

Report Configuration -

Enter the report name : Select arsport type : Select an output format -
| | | Utilization and Loading Trends v
Select a delivery method : Select a report ofientafion |

® Portrait O Landscape

4. Enter a report name.

5. Expand the drop down arrows and use the radio button to set your report’s specifica-

tions.
6. Scroll to the Utilization and Loading Trends Options window.

7. Expand the drop down arrow.
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Utilization and Loading Trends Opfions -~

Client Host Options

High Command Ceount Threshold :

78 ‘

Low Command Count Threshold :
B

nShield Options

High Command Count Threshold :

75 ‘
Low Command Count Threshold :
ENN

High Object Count Threshold :

75 ‘
Low Object Count Threshold :

EN

Cancel Changes

8. Modify the default settings, based on preference.

9. Select Generate Report.

10.1.2. Device Report

1. Select Device Report.
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Generate

select a Group :

nihield

Group Report

Client Hosts

Report

Groups and Devices -

select areport type.:

Device Report v

vicer rt, select a device fype :
For a device report, select a device type

nshields

Report Configuration -~

Cancel Changes

2. Select a device type.
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For a device report, select a device type :

Client Hosts nshields

)

Report Configuration -

Caoncel Changes

o To see the flow for device type Client Hosts, go to: Device report
for Client Hosts.

The device selection window opens.
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Groups and Devices -

Group Report  Device Report «*

For a device report, select a device type -

Client Hosts  nShields «

Click a device in either selection box to move it to the other one.
Q Search:
Selected Devices Available Devices

Remaining Devices: 15

0305-02E0-D947 (10.1.3.78) (CONNECT XC)

2805-02E0-D947 (10.1.3.77) (CONNECT XC)
6699-74B4-30FF (10.1.3.77) (CONNECT)
GF99-74BF-429E (10.1.3.72) (CONNECT)

B56A-81C9-73F2 (10.1.5.49) (CONNECT)

F48C-82C8-3ED? (10.1.3.70) (CONNECT)

Report Configuration -

Loading Trends Options -

3. Select, by single clicking, the devices from the Available Devices window for inclusion
in your report.

0 The click will toggle the device between the Selected Devices win-
dow and the Available Devices window.

The selected device moves to the Selected Devices window.

Monitor v2.8.0 Install and User Guide 211/284



Chapter 10. Reports

Client Hosts

Remaining

nShisids «*

Click a device in either selection box to move it fo the other one.

Q Search:

Selected Devices

Devices: 14

[added)

[DSGS-GEED-D?-‘-!? (10.1.3.78) (CONNECT XC) ]

Report

Configuration -

Loading Trends Opftions -

Available Devices

Asc W

2805-02E0-D947 (10.1.3.77) (CONNECT XC)

6699-74B4-30FF (10.1.3.71) (CONNECT)

GF99-7ABF-4298 (10.1.3.72) (CONNECT)

B56A-B1CY-73F2 (10.1.5.4%) (CONNECT)

F48C-B2C8-3EDY (10.1.3.70) (CONNECT)

You may need to scroll down to access the expansion arrows for

additional views.

4. Select the expansion arrow to open the Report Configuration window.
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Report Configuration -~

Enter the report name :

select areport type :

Loading Trends v

select an output format :

PDF Vv

Select a delivery method :

save fo Fle v

Select a report crientation :
® Portrait O Landscape

Select a schedule :

Dne-Timse v

select a fime/date range .

Last 24 Hours W

5. Enter the report name and select the drop down arrows to display additional selec-

tions.
6. Select your preferences.

7. Select the expansion arrow to open the Utilization and Loading Trends Options win-

dow.
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Loading Trends Opfions -~

nShield Opfions

High Command Count Threshold :

75 ‘
Low Command Count Threshold :
EN

High Object Count Threshold :

73 ‘
Low Object Count Threshold :

R

Cancel Changes

8. Set your preferences.

9. Select Generate Report.

10.1.3. Device report for Client Hosts

1. Navigate to: Generate Report > Groups and Devices > Device Report > Client Hosts
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select a Group :

nshield

Generate Report

Groups and Devices ~

select areport type :

Group Report

Device Report ¥

Client Hosts

For a device report, select a device type :

nshields

The Client Host Cross-HSM device report supports 2,500 nShield

keys, i.e., the report limits the number of keys to 2,500 even if there

are more keys on the client host.

2. Select, by single clicking, the devices in the Available Devices window to move the

device into the Selected Devices window.
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Select a report type :

Group Report Device Report ¢

For a device report, select a device fype :

Client Hosis #f  nShields

Click a device in either selection box to move it to the other one.

Q Search:

Selected Devices Avdilable Devices

Remaining Devices: 15 Serigl V] | ‘ Asc W ‘
Y

|
[ {10.1.7.212)

Report Configuration -~

e The click will toggle the device between the Selected Devices win-
dow and the Available Devices window.

o You may need to scroll down to access the expansion arrows for

additional views.

3. Select the expansion arrows to open the Report Configuration window.
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Report Configuration -

Enter the report name :

select a report type :

Loading Trends v

select an output format :

PDF Vv

Select a delivery method :

Save to File W

Select a report orientation :
@® Portrait O Landscape

Select a schedule :

One-Time %

select g fime/date range :

Last 24 Hours W

Loading Trends Opfions -

4. Enter a report name and select the drop down arrows to display additional selections

(i.e., choices).
5. Select your preferences.

6. Select the expansion arrow to open the Loading Trends Options window.
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Loading Trends Options -

Client Host Options

High Command Count Thresheold -

75

Cancel Changes

7. Set your thresholds.

8. Select Generate Report.

10.2. Scheduled Reports

1. Navigate to: Reports > Scheduled Reports

Reports - Configura

| Zenerate Reports l

Scheduled Reports

T

The Scheduled Reports page opens.

2. Select the report name.
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Scheduled Reports

Q Search:
O ry Group  Last Run Next Run File
Enabled Name Frequency Type
| v CH-R nshield  2018-12- 2018-12- HOURLY PDF rd
\ 11T18:00:00.00Z 11719:00:00.00Z
| ¥ ch-uit nshield | 2018-12- 2018-12- HOURLY PDF rd
11T18:00:00.00Z 11719:00:00.00Z
(| ¥ devl nShield 2018-12- 2018-12- HGURLY PDF #
11T18:00:00.00Z 11719:00:00.00Z
O [ garpl nShield 2018-12- 2018-12- HOURLY FPDF #
11T18:00:00.00Z 1171%:00:00.00Z
The report page opens.
Q Search:
O A Ran At Download Type Status
O 2018-12-04T19:00:00.00Z Download Report PDF SUCCESS
O 2018-12-04T20:00:00.00Z Download Report PDF SUCCESS
O 2018-12-04121:00:00.00Z Download Report PDF SUCCESS
O 2018-12-04122:00:00.00Z Download Report PDF SUCCESS
[} 2018-12-04723:00:00.00Z PDF FAILED |[No active devices found for this report)
[1 2018 12-.08T00-00-00 Q07 PDE EANED (Mo active devicae fonind for this renaort!]

10.2.1. Downloading Individual Reports

The report page also provides download links.
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Q Search:

Ol A Ran At Download Type Status
] 2018-12-04T19:00:00.00Z Download Report FDF SUCCESS
] 2018-12-04720:00:00.00Z Cownload Report FDF SUCCESS
] 2018-12-04721:00:00.007 Download Report FDF SUCCESS

1. Select Download Report.

The system prompts:

170104180001+0000--1.PDF (68.5 KB) 10.1.7.124

Open Save = Cancel

2. Select Open or Save.

When Save is selected, the system prompts:

The 170104180001 +0000--1 (1).PDF download has completed.

Open i Open folder View downloads

3. Select your preference.

10.2.2. Downloading Reports in Bulk
Selecting Bulk Download uses a toggle:

1. Select the check box of the first report to download.
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The Bulk Download and Delete Report tabs activate as soon as you have selected a
report.

Bulk Download Delete Report(s)

Q Search:

@ A Ran At Download Type Status

[ 2018-12-04T19:00:00.00Z Download Report FDF SUCCESS

[ 2018-12-04720:00:00.00Z Download Report FOF SUCCESS

[+ 7018-12-04721:00:00.00Z Download Report FOF SUCCESS

vl 2018-12-04722:00:00.00Z Download Report POF SUCCESS
—

[ 1 2018-12-04723:00:00.00Z PDE FAILED (Mo active 4
o To activate the Select All feature, select the box at the header. This

check box can also be used to clear you selections.

0 Conversely, you can click specific check boxes to customize the

download. The check box selection can be toggled.

2. Select Bulk Download to initiate the download.

The system prompts with (example):

2017-02-13T20_21 18.959Z Sample gro....zip (238 KE) 10.1.7.124

Open Save - Cancel

3. Select your preference.

10.2.3. Deleting Reports

1. Select the report(s) to be deleted.
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Delete Report(s)

Q Search:

A Ran At

2018-12-04719:00:00.00Z

2018-12-04720:00:00.00Z

2018-12-04721:00:00.001

2018-12-04122:00:00.007

2018-12-04723:00:00.007

0 (€| Q| 0O |’ O

2018 12 08TO0-00-00 007

Once the check box is selected the Delete Report(s) option activates.
2. Select Delete Report(s).

The system prompts for confirmation.

Download All Confirm Delete

Q Search:

3. Select Confirm Delete.
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11. Alarms

11.1. General Description

Alarms events must be acknowledged before they can be cleared. Until an alarm is acknowl|
edged it remains reported in the alarm totals.

For example:

Alarm

Alarms can be monitored actively and historically.

Active alarms (unacknowledged alarms) appear on the main menu by clicking on the icon
that looks like an exclamation.

% Dashboaord Wiews = Reports - Configuration = Lo

When there are any active alarms, this icon changes color to indicate the highest alarm
active.

Select the Alarms tab, in the main menu, to view Alarm History.

Alarms can always be exported, by selecting Export Alarm History (CSV) from the Alarm His
tory page.

11.2. Acknowledging Alarms in Bulk

1. From any Alarm count column, select (i.e., click on) the alarm total.
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Alarm

Viarning

The Current Unacknowledged Alarms page opens.

2. Select all the alarms that you want to acknowledge.

Current Unacknowledged Alarms

Date Time Severity
200 7-0N-Z3T A 4111 7182 | WARNING
200 7-0N-23T 41117152 m
201 7-01-23T20 41117112 m
201 7-01-23T 003618 4591 m

200 7-01-23T 038184887 | WARNING

?E]

3. Select Acknowledge Alarm.

Acknowledge Alarm Cancel

)

11.3. Acknowledging an Alarm (individual basis)
1. Navigate to: Alarms > Alarm History
The Alarm History page opens.

2. Select (i.e., single click) on the alarms severity level.
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The Acknowledgment Alarm page opens.

iFel AcCknowledge Alarm

Alarm Date/Time:

‘ 2017-03-15T15:05:35.5352 ‘

Alarm 1D:

‘ AvVriglbgxH-kyRY2QB6g ‘

Alarm Message:

‘ The connection status is now SNMP accessible for Enhanced payShie

Acknowledgement Comments | Optional ):

Aclknowledge Alarm Cance

3. Enter any Acknowledgment Comments in, if needed.

4. Select Acknowledge Alarm.
The Alarm History page opens.

5. Select Export Alarm History (CSV). The file can now be saved or opened.
The system prompts asking if you would prefer to Open or Save the .csv file.

6. Select your preference.

Open Save =
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12. nShield CLI Commands

12.1. GUI initialization

Upon the startup of the nShield Monitor Virtual Appliance, the CLI will wait for the GUI to
finish initializing (at the first boot and every reboot). This operation can take up to 60 sec-
onds. If GUl initialization is not completed by then, the user is logged out and asked to log
back in later.

12.2. Setting Password

If you are using the One Time Password (OTP), you will be asked to change it after logging
in and before accessing any of the CLI operations.

You are prompted with the following password requirements:

+ Length should be between eight and sixteen characters
« Should contain at least two capital letters

+ Should contain at least two lower case letter,

+ Should contain at least two digits

+ Should contain at least two special characters

1. Enter the old password.

2. Enter the new password.

The new password is checked for the requirements above and com
pared with the old password. If it fails to comply with the require-

o ments or if the new password is the same as the old one, the user is
prompted with the associated error and/or the requirements and is

directed back to step 2.

3. Enter the password confirmation.
The only check that is performed is whether the two passwords match.
If it fails, it will prompt the error and start from step 2 above.

If it is successful, you will proceed to the CLI commands of the wizard.

12.3. Master key status
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After the setup wizard has run and the mandated passwords have been entered, a status
message for the master key is prompted if the master key needs to be reloaded, or gener-
ated and loaded.

12.4. CLI Setup Wizard

12.4.1. Log in

1. Connect to the IP address.

2. Login as administrator.

£ 10.1.7.161 - PuTTY
-

login as: adminl

The CLI Setup Wizard initializes at the first boot. It will only initialize if the entire wizard
setup has not yet run, or if the following steps of the wizard failed: Set User Email, or Cre-
ate Administrators.

The wizard prompts you to perform the following operations:

+ Set the user's email

+ Create two administrators

+ Configure the network

« Configure the date and time

+ Set two passwords for system key

Once the user logs in, the CLI verifies if the Virtual Machine (VM) has an IP address. If it
does, it will prompt the user with the IP address and the URL to launch the wizard from a

web browser.

If the Virtual Machine (VM) does not have an IP address, the CLI will
prompt the user to set the static network configuration before running

o the Wizard. Until the IP address is set, the user will not be able to run the
Wizard.

12.5. Welcome
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1. Select y to start the CLI Setup Wizard.

0 ‘ Select n if you need to exit and logout.

12.6. EULA

The EULA is displayed one page at a time.

1. Navigate the EULA:

. Scroll up and down the page using up and down arrows
. Select Enter to scroll down the page

. Enter q to quit EULA at any time

. Scroll all the way down the page, which will automatically closes the EULA

o o1 B~ o w N

. Select y to agree to the terms of the EULA.

o ‘ Select n if your need to exit and logout (after 5 seconds).

The system prompts to set the default user email.

12.7. Set User's Email

SET THE DEFAULT USER'S EMATL

The requirements for an email address are:

+ Alphanumeric characters and < - or _ or .>@<alphanumeric characters and < - or .>

« The two parts before and after the "@" cannot start or end with a non-alphanumeric

character.
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- The email cannot contain successive dots, dashes or underscores.

1. Enter your email address.

2. Re-enter your email address to confirm.

The system prompts to create your Administrators.

12.8. Create Administrators

CREATE ADMINISTRATORS

1. Enter the User Name for Administrator One.
2. Enter the first administrator's email address; verify that the email address is valid.

3. Enter the first administrator's email address confirmation; verify that the email
addresses match.

4. Repeat steps 1through 3 above to create second administrator.

Once the administrators are created, the system prompts for network configuration.

12.9. Configure Network

el oo~ oo oo oo

IUelcome lEULAIEmail ISystem Admins| =Network= |Key Genera
NETUWORK SETTING

configuration ..: dhcp
ip :192.168.17.197

netmask - 5 .255.248 .0

gateway : 192.168.16.20
hostname : localhost
primary DNS : 192.168.17.79
secondary DNS ..: 192.168.17.80
domain name : localdomain
interftface.......: etho

The wizard will show the current network configuration.
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1. Select the network configuration.

IWelcome |EULAIEmail ISystem Admins| *Network= |Key Generationl

NETUWORK SETTING

configuration ..: dhcp
ip : 192.168.17.197
- 1.295.248.0
gateway - 168.16.20
hostname : localhost
primary DNS : 192.168.17.79
secondary DNS ..: 168.17.80
domain name ....: localdomain
interface.......: ethO

Select the type of network configuration.
1) DHCF

Z) Static

3) Keep the current configuration

Type number corresponding to configuration type:

2. If DHCP, enter:

° hostname (optional)
° mail host (optional)

° Interface (optional)

3. If Static, enter:

Interface can be skipped by pressing enter (system defaults to
ethO).

° hostname (mandatory)

° |P (mandatory)

° netmask (mandatory)

° gateway (mandatory)

> domain (optional)

° primary DNS (optional)

° secondary DNS (optional)
° mail host (optional)

° Interface (optional)
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0 Interface can be skipped by pressing enter (system defaults to
eth0).

4. To Keep the current configuration, enter: mail host(optional)

The system continues with Master Key Generation and prompts you to create Passphrase
One.

12.10. Generate System Key
1. Enter Passphrase One and then re-enter to confirm.
The system prompts for Passphrase Two.

2. Enter Passphrase Two and then re-enter to confirm.

The system prompts to configure date and time.

12.11. Configure Date & Time
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ATE/TIME SETTI

1. Choose between NTP and NTP Disable (manual configuration).
° Enter 1 or 2 based on your preference:

° Enter: 1 for dynamic configuration (NTP enabled)
Follow the prompts to complete the configuration.

2. Enter servers (this is only optional if a server is already configured, otherwise this is
mandatory).
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° Check for server regular expression.

° Select timezone (optional)

e Each parameter is checked. If a failure occurs, you are prompted to re-
enter the parameter

1. Enter 2 for manual configuration (NTP disabled)

DATE-TINE SETTINGS

ntp enabled

datestime ! Mon 2017-05-01 18:29:43 GNT
timezone

day light saving status..: n-a

elect type of date and time configuration.
1) NTP (dynamic configuration)

J Hanually configure date, time and timezone.

nter number corresponding to configuration type: 2

ate (optiomall: [Y¥YYYY-MHM-DDI

2. Follow the prompts to complete the configuration:

11) Mountain Time

Mountain Time
Pacific

° Enter date (optional)
° Enter time (optional)

° Select timezone (optional)

0 Each parameter is checked. If a failure occurs, you are prompted to re-
enter the parameter.
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The system now prompts for initialization.

12.12. Initialize

Welcome |EULA|Email

1. Select y to start performing all operations.
0 ‘ Select n if you need to log out.
The initialization process is performed in the following order:

« Generate and load master key.

- Set user's email (if this fails, it will log out after five seconds).

- Create administrators (if this fails, it will log out after five seconds).
+ Set mailhost.

« Configure network.

+ Set NTP (on/off). Configure date, time and timezone and/or NTP servers.
If the date-time configuration is successful, a reboot is triggered.
You can log back in and restart the wizard if:

- |nitialization failed

0 - Initialization was interrupted before setting Date/Time and Net-
work

+ You logged out before initialization.

12.13. CLI Commands

Monitor v2.8.0 Install and User Guide 234/284



Chapter 12. nShield CLI Commands

netmask Eateway

network

timezone
Set-nip-state

SEt-5ErVErS
traceroute

troubleshoot

power-off
reset-config

master-key

emailqueus

upgradepky

12.14. Network commands
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Action Show current network configuration.

Input > network show

Output Mode (dhcp or static)

IP address
Metmask

Gateway

Host Name
Primary DNS IP
Secondary DNS IP
Comain Name
Mail Host (if any)
Interface (if any)

Action Configure dynamic network.

Input > network configure dhcp hostname

<hcstname> interfacename <interface>

Details Hostname is optional. Interface is optional.

Action Configure static network.

Input > network configure static hostname
<hocstname> ip <ip> netmask <netmask> gateway
<gateway> interfacename <interface>

Details All parameters are mandatory. Interface is optional.
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Action | Add/overwrite DNS parameters.

Input » network configure dns add domain
<dcmain name> primary <primary dns> secondary <secondary
dns> interfacename <interface>

Details | Commands to set domain name and primary DNS/secondary DNS can be
performed separately or together in one command.

Only prompt for secondary if primary is entered to ensure that primary DNS is not
left blank.

Interfacename is optional

Action Remove DNS parameters.

Input > network configure dns remove domain
<dcmain name> primary <primary dns> secondary <secondary
dns> interfacename <interface>

Details | Commands to remove domain name and primary DNS/secondary DNS can be
performed separately or together in one command.

Only prompt for primary if secondary is entered to ensure that primary DNS is not
left blank.

If the domain name is removed, it will be replaced by « localdomain »
Interface name is optional.

12.15. Date-time commands

Date-time configuration triggers system reboot if configuration has succeeded.

Action | Show date and time configuration.

Input > date-time show

Output | NTP enabled : <ves/no=
Date/time

Timezone

Day light saving status : <yes/noz

NTP server list (if any)
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Action | Switch NTP on or off.

Input > date-time configqure ntp set-ntp-state
<on/off>

Details | set-ntp-state is mandatory. Set it to « on * to enable NTP and set it to
« off » to disable NTP.
If enabled, NTP will try synchronizing with NTP servers. If it fails, it will
remain disabled.
Mote: check with « date-time show » command if any servers were
configured.

Action | Set NIP servers.

Input > date-time configure ntp set—3servers <“list
cf servera”»

Details | This command removes all previous servers (if any) sets the new list of
SEervers.
In CLI, provide the list of servers between double guotes. If there is only
one server then there is no need for quotes.
Examples :
date-time configure ntp set-servers us.pool.ntp.org
date-time configure ntp set-servers "us.pool.ntp.org time.nist.gov”

Action | Configure date and time manually.

Input > date-time configure manual date <dater time
<time> timezone <gelect from list>

Details | NTP has to be disabled to perform this operation.

Commands to set date, time and timezone can be performed separately or
together in one command.

12.16. System Commands

Action | Power-off the system.

Input > gystem power—-off
Details | This operation can take up to 60 seconds.
Action | Reboot the system.

Input > ayatem reboot
Details | This operation can take up to 60 seconds.
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Action | Reset the system to factory settings.
Input > aystem reset-config
Details | Stop database services.
Remove data.
This operation can take up to 60 seconds.
Action | Show summary of system information.
Input > ay3tem Jummary
Details | SSH state indicates only the user’s configuration for SSH through the
CLI (=« service ssh enable/disable » command.)
« ‘enable”; if user configured SSH using « service ssh enable »
« ‘disable’; if user configured S5H using « service ssh disable =
Output | Serial Number
Software Version
System Uptime
Disk Usage
Services status
License
Type : Evaluation/Product.
If evaluation then show remaining days.
Uparade history (if any)
S55H state
Web UI state
Action | Belcad Master Hey.
Input > gystem master-key relcad
Details | Reload master key when master key is generated but not loaded.
Master key has to be reloaded after each reboot.
Action | Show current state of debug.
Input > ayatem debug show
Details | Show current state of debug
Action | Enable logging of debug message
Input > ayatem debug confiigure set—debug-state on
Details | Enable debug logging
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Action

Disable logging of debug message

Input

> gystem debug configure set—debug-state off

Details

Disable debug logging

12.17. Email Queue Commands

Action
Input

Output

Action
Input

Output

Show the out standing emails queued up in the system

> gayatem emailqueue 3tatus

EMAIL QUEUE SUMMARY

Pending mail requests ... I nn

Purge system email queue

> ay3stem emailgqueus purge

EMAIL QUEUE PURGE STATUS

Mail purge status ... .. . SUCCesS

12.18. Troubleshooting Commands

Action | Fing host name or IP addreas

Input > troublesheoot ping <ip address/hostnames>

Action | Tracercute host name cor IP address

Input > troubleshoot tracercute <ip
address,/ho3tname>

Details | This operation may take up to 450seconds (7.5min)

Action | Show routing tables.

Input » troublesheoot routedump

Action | Dump traffic on the network to a file.

Input » troubleshoot topdump <on/off>

Details | The file is overwritten everytime tcpdump is turned on.
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Action Export debug logs through SCP.

Input > troubleshoot export logs server <IPx»
ugername <name> deat dir <destination path> port
<optional port number:>

Optional | port and debug db date are optional parameters
Details | This command is used to export debug logs using SCP. The users should
have valid access to SCP server with username and deatinaticn directory.
Port number is optional and the default SCP port would be used if not
provided.

User is pormpted to enter correct password after executing the command.

12.19. Service Commands

Action | Enable/Disable SSH.

Input > gervice 33h <enable/disable>

Details | By default, it is disabled as well as after each reboot.

Action | Enable/Disable webUI.

Input > gervice webll <enable/disable>

Action | Enable/Disable OVT

Input > gervice open—-vm-tools enable
This will enable Qpen VMware Toocls. Proceed? [v/n]

CLI access is restricted to Administrator accounts only. Manager

o accounts cannot access the CLI. A proper error message will be dis-
played.
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13. Licensing

13.1. Introduction
The nShield Monitor Virtual Appliance offers several license options as listed below.
License Options

Order Code Description

nShield Monitor monitoring software licenses for installation onto customer-supplied workstation or PC.

NT-SW-V2S nShield Monitor software license - single
NT-SW-V2D nShield Monitor software license - dual
NT-SW-V2E nShield Monitor software license - Enterprise
NT-LIC-ADD50 Adds additional 50 endpoints

nShield (endpoints) to be monitored. A maximum of 500 endpoints per monitoring software license is avail-

able.

NT-LIC-ADD5 nShield Monitor endpoint license — 5 additional

NT-LIC-ADD10 nShield Monitor endpoint license — 10 additional

NT-LIC-ADD20 nShield Monitor endpoint license — 20 additional

NT-LIC-ADD50 nShield Monitor endpoint license — 50 additional

NT-LIC-ENTERPRISE nShield Monitor endpoint license — Enterprise (500 endpoints valid for NTM

2.5 and later, 300 endpoints for NTM 2.4.1 and earlier)

Post-installation upgrades

NT-DVD-V2 nShield Monitor installation image on DVD
NT-LICU-S2D Upgrade from single to dual license
NT-LICU-S2E Upgrade from single to Enterprise license
NT-LICU-D2E Upgrade from dual to Enterprise license
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14. Enterprise Firewall Settings

If the nShield Monitor appliance is separated from any of its services (for example, NTP,

DNS, SMTP server) or endpoints (for example, users devices) by a firewall, you must config-

ure the firewall to allow passage of the appropriate IP protocols.

The table in this section lists the ports that, at a minimum, you must configure to support

connectivity.

Protocol Transport
Echo1 N/A

SSH TCP/UDP
HTTPS TCP

DNS TCP/UDP
NTP UDP
SNMP UDP
SNMP UDP
System Log UDP
SMTP TCP

FTP TCP
HTTP TCP/UDP
Echo Reply

Echo Request

Port Configurations

Port

N/A

22

443

53

123

161

162

514

25

21

80

Direction

Both

Inbound

Both

Outbound

Outbound

Outbound

Outbound

Outbound

Outbound

Both

Outbound

Both

Both

Description
Echo/ICMP Pings

nShield Monitor Remote Console Man-
agement

nShield Monitor Web Ul & firmware
upgrade

nShield Monitor Web Ul & firmware
upgrade DNS

nShield Monitor utilization of Network
Time Protocol

Monitoring devices via SNMPV3
SNMPV3 Notification

Remote system log alerts

nShield Monitor sending email alerts

nShield Monitor firmware upgrade
option

nShield Monitor firmware upgrade
option

ICMP Response (code 0)

ICMP Request (code 8)
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15. Troubleshooting

This appendix describes nShield Monitor troubleshooting information.

15.1. Global Troubleshooting Enhancement feature

15.1.1. Overview

HSMs, nShield Monitor (NM) Servers, and nShield Monitor users can be globally dispersed
crossing multiple time zones. nShield Monitor stores all collected HSM events in Greenwich
Mean Time (also referred to as nShield Monitor Server time). Users who remotely log into
nShield Monitor see NM information displayed in the local time zone of their browser.

The Global Troubleshooting Enhancement feature allows users, logged into nShield Monitor
from various time zones around the world, to select and view nShield Monitor Log and
Alarms in a common agreed upon Timezone. This ability is helpful during global trou-
bleshooting discussions.

15.1.2. Procedure

Prerequisite:
You are logged into nShield Monitor.

Just for the duration of a special global collaboration work-session, a
logged in user can choose a SELECTED time zone for viewing Logs and
Alarms on their browser connected to nShield Monitor.

1. Navigate to either the Logs tab or the Alarms tab.

Denhibsoard Views = Reporty = Conlicpuration =

2. Go to the Date/Time drop down.

aDote/Tme (GMT -10:00) Howall "
[[+] Severily  Meiioge

3. Select your preferred time zone.

Notes:
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- The setting applies to both Alarms and Logs tabs (i.e., you only have to select the time
zone once).

« ONLY the time zone displayed in these two tabs will be affected by this selection
(nShield Monitor displays on the other nShield Monitor tabs are NOT affected).

« The default time zone in Logs and Event pages are browser 'Local Time' unless the
Date/Time Format is set to UTC in User Profile, and in such case, the default time zone
is GMT.

« The time zone change is NOT persisted across user logout/login. The time zone change
is temporary. The next time that you login, the time zone is reset to the default 'Local
Time' which is the default (or UTC if the Date/Time Format is UTC in the login User Pro-
file).

« The Time Zone customization in Logs/Alarms pages does NOT affect Date/Time in
other WebUI pages, including Charts, Export Logs, etc. All other WebUI pages display
Date/Time in 'Local Time' Time Zone (or UTC if the Date/Time Format is UTC in the
login User Profile).

15.2. Network test tools

Event logs provide additional information about security and operations issues.

The following networking test tools are available through the CLI to facilitate nShield Moni-
tor inter-networking tests.

+ Ping
+ RouteDump
« TCPDump

« Traceroute
To run the nShield Monitor Network test tools:

1. Log into the CLI as an Administrator.

2. Enter the command: troubleshoot

3. Press Enter or Tab to display available options as follows:
nShield Montor > troubleshoot

ping routedump tcpdump traceroute
nShield Monitor > troubleshoot

4. Type one of the four options to run the appropriate test tool.
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15.3. Ping

Ping is a pass-fail continuity test that determines the accessibility of a target IP address on

an IP network. It sends ICMP echo request packets from the selected nShield Monitor Man-

agement Interface to the specified target IP address and waits for an ICMP response.

15.3.1. Using Ping

1. Log into the CLI as an Administrator.

2. Enter the command:

troubleshoot ping <Hostname or IP Address to ping>

3. Press Enter.

Ping output is displayed directly on the CLI screen. If the ping returns successfully, the

network statistics and properties display appear. If the ping does not return, a failure

message appears.

Example: Success case

PING:

PING 10.1.1.14 (10.1.1.14) from 10
64 bytes from 10.1.1.14: icmp seg=l
64 bytez from 10.1.1.14: icmp seg=2
64 bytes from 10.1.1.14: icmp seqg=3
64 bytes from 10.1.1.14: icmp seqg=4
64 bytes from 10.1.1.14: icmp =seg=5
64 bytes from 10.1.1.14: icmp =seg=é
64 bytez from 10.1.1.14: icmp zeg=7
64 bytez from 10.1.1.14: icmp seqg=3
--—-—10.1.1.14 ping statistics --—-

8 packets transmitted, & received,
rtt min/avg/max/mdev = 0.187/0.264/

L.1.2.122 eth0: 56(84)

ttl=255 time=0.
ttl=255 time=0.
ttl=255 time=0.
ttl=255 time=0.
ttl=255 time=0.
ttl=255 time=0.
ttl=255 time=0.

ttl=255 time=0.

0% packet lozs,

0.315%/0.038 ms

e e R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R CRRCRRRCROR RO R ROR

271 m=

273 m=

315 m=

287 m=

258 m=

187 m=

257 m=

256 m=

time 7000ms=

e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e R R e e e e e e R R R R R R R R

bytes of data
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Example: Not Successful

AR R R R R AR R R R AR R R R R R R AR R R R R R R R R R R R R R R R R R R R R R R R R R R R R R
PING:
PING 10.1.1.131 {10.1.1.131) from 10.1.2.122 ethO: S5&(84) bytes of catal

From 10.1.2.122 icmp zeg=l Destination Host Unreachable

From 10.1.2.122 icmp =seqgq=2 Destination Host Unreachable
From 10.1.2.122 icmp =seqg=3 Destination Host Unreachakble
From 10.1.2.122 icmp seg=4 Destination Host Unreachable
From 10.1.2.122 icmp =zeg=S5 Destination Host Unreachable
From 10.1.2.122 icmp zeg=é Destination Host Unreachable
From 10.1.2.122 icmp seq=7 Destination Host Unreachable
From 10.1.2.122 icmp seg=8% Destination Host Unreachakle
——— 10.1.1.131 ping statistics —-—-

8 packets tranami-ted, 0 receiwved, +8 error=, 100% packet lo=sz, time 700

pipe 4

o e e e e e e R e R e o e e o R R R R R R R R R R R R R R R R R R R R R R R R R R

15.4. RouteDump

RouteDump displays routing information used by nShield Monitor.

15.4.1. Using RouteDump

1. Log into the CLI as an Administrator.
2. Enter the command: troubleshoot routedump

3. Press Enter.

The routing information for nShield Monitor is displayed on the screen.
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R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R

ROUTEDUME @
default wia 10.1.1.20 dev eth0 proto static metric 1024
10.1.0.0/21 dev eth? proto kermel =cope link src 10.1.2.122
Fernel IP routing table

Destination Gateway Genmask Flags Metric ERe
U=ze Iface

default 10.1.1.20 0.0.0.0 oG 1024 d
0 ethd
10.1.0.0 0.0.0.0 255.255.248.0 1) d d
0 ethd

e e e e e e R R R R R R R R R R R R R R R R R R R R e R R R R R R R R R R R R R e R e e e R R R R R R R R R R R R R R

15.5. TCPDump

TCPDump is a common packet analyzer that allows the user to intercept and display TCP/IP
and other packets being transmitted or received over a network to which the computer is
attached.

Using the CLI commands tcpdump on and tcpdump off, the utility can be turned on and off.

15.5.1. Using TCPDump

1. Log into the CLI as an Administrator.
2. Turn on TCPDump.

3. Enter the command:

troubleshoot tcpdump on

4. Press Enter.
The utility starts capturing.

Each Interface TCPDump capture generates a trace file. The TCPDump trace file can
only be exported as part of exporting debug logs.

e Restarting the TCPDump capture overwrites any previously cap-
tured data.
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15.6. Traceroute

Traceroute determines network response time, displays route (path) information from an IP
source to an IP destination address, and measures the associated transit delays of packets
across the network. It operates by sending a sequence of ICMP packets from a specified
source IP address to a specified destination IP address, and uses responses to determine
the intermediate routers traversed.

15.6.1. Using Traceroute

1. Log into the CLI as an Administrator.

2. Enter the command:
troubleshoot traceroute <Hostname or IP Address>

3. Press Enter.

Traceroute output is displayed directly on the CLI. The last Traceroute operation per-
formed can also be exported as part of the debug logs.

o e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e R R R R R R R R R R R

It may take up to 450 =zecond=s to complete the operation.
Ctrl-c to =2top the process.
TRACEROUTE:

traceroute to 172.26.0.10 {(172.26.0.10), 30 hops max, &0 bytg
packets

1 10.1.1.20 (10.1.1.20) 0©0.730 mz 0.301 ms ©O.865 m=s

2 172.26.0.10 (172.26.0.10) 0.510 ms O0.52% m=s O0.527 ms

ke R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R R

15.7. No Monitoring Data Received
If no Monitoring Data is received or if a device is not reachable, verify that:

+ SNMP is enabled
+ SNMPv3 user is configured

- Utilization and health collection is enabled.
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16. nShield Monitor Alarm Conditions

nShield Monitor provides the following alert conditions for monitoring and tracking system

and device level conditions:

Alarm Condition

Device is added or removed

When the nShield Monitor average
CPU usage is higher than 95%

nShield Monitor License Expiry

alerts

When the nShield Monitor Memory
is over 90% full

When the nShield Monitor disk is
over 90% full

Alarm Severity

Added: INFO

Deleted:
Warning

ERROR

WARNING
CRITICAL

EMERGENCY

ERROR

ERROR

Notes
System Alarm - nShield Monitor

Alarm gets generated by nShield Monitor when a
device gets enrolled or deleted from the system. Add
operation will create an INFO alarm and delete of
enrolled device reported as WARNING.

System Alarm - nShield Monitor

This is a health alert for nShield Monitor, when the
average CPU usage is higher than 95%. nShield Moni-
tor will not shut down. Send debug logs to your Sup-
port organization.

System Alarm - nShield Monitor

nShield Monitor will keep sending alerts with different
severity a few days before expiration.

A WARNING alert message will be sent out every day
from 23rd day to 28th day. CRITICAL alert will be sent
out on 29th day and EMERGENCY alert will be sent
out on 30th day. Emergency alert is the final alert
before the evaluation license expires.

User needs to install valid license at this point for
nShield Monitor to monitor the devices.

System Alarm - nShield Monitor

This Alarm gets generated when system memory gets
90% full. At this point, nShield Monitor does not stop
monitoring or shut down. The system will continue
with normal operation.

System Alarm - nShield Monitor

This Alarm gets generated when system disk gets 90%
full. At this point nShield Monitor does not stop moni-

toring or shut down. The system will continue with nor
mal operation. Follow this link to find disk size recom-

mendations Server Requirements.

Add storage space by expanding the virtual hard disk.
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Alarm Condition

nShield Monitor Security Related
Alarm Warning when Master key
has not be generated and Critical
when Master key is not loaded

nShield Monitor Security Related
Alarm

User: has enabled/disabled Service

nShield Monitor Security Related
Alarm

The license features have been
changed for Device

The nShield device temperature
change alerts

Hard Server failure in Client Host

Alarm Severity

WARNING CRITI

CAL

INFO

WARNING

CRITICAL

INFO

WARNING /
CRITICAL

WARNING

Notes
Security Alarm - nShield Monitor

It is a security alarm regarding master key not being
generated or not being loaded. If key is not generated
a WARNING message and CRITICAL when MKiis not
loaded. Administrator needs to take appropriate
action by configuring the same on Security page.

Security Alarm - nShield Monitor

If SSH, WebUI or Open VMTool services are enabled
or disabled.

Security Alarm - nShield Monitor

It is a security alarm regarding master key not being
generated or not being loaded.

If the key is not generated a WARNING message is
generated and a CRITICAL message is generated
when a master key is not loaded.

The Administrator needs to take appropriate action by
configuring the same on the Security page.

Device Alarm - nShield

There are optional feature licenses for the nShield
HSM. At a later date, when you require a new feature,
you can order it from Sales and install the new
License. Change in those featured licenses are going
to be monitored by nShield Monitor and notified by an
event.

Device Alarm - nShield

System reports device temperature change WARN-
ING message when exceeds lower configured thresh-
old value and CRITICAL above upper threshold value.

Device Alarm - nShield

A WARNING message would be generated when hard
server program fails.

Follow Remote Administrator Client User Guide for fur
ther investigation.
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Alarm Condition

Module count is Zero for Client
Host

The software base release updated,
revision, build number, core API ver
sion, performance model update,
crypto algorithm host command
update and optional license update

License count exceeded

Device count license Exceed -
NOTIFICATION

Install new License - NOTIFICATION

Device count license exceeds for <N>
days - WARNING

Device count license exceeds for <@>
days - ALERT

Client Host does not belong to a
security world

SoloXC fan speed down to zero

Alarm Severity

WARNING

INFO

NOTIFICATION /
WARNIING /
ALERT / CRITI-
CAL

WARNING

CRITICAL

Notes
Device Alarm - nShield

When Client host discovers no nShields attached to
enrolled Client Host.

Follow up with nShield User Guide.
Device Alarm - nShield

This is an nShield monitored Event. Event is logged for
audit purposes. A Security World software upgrade
operation would update revision, build number, core
API versions and optional licensing update information
etc. No action needed.

System Alarm - nShield Monitor

When nShield Monitor detects more nShields (con-
nected to ClientHost) than the permitted “nShield
Monitor” License count, nShield Monitor generates
this event.

When the License count is exceeded, and if a new
license (with more HSM count) is not installed after 30
days, ONLY Administrator privilege users of nShield
Monitor will be allowed to login.

Group Manager Privileged Users won't be allowed to
login to nShield Monitor.

After 30 days, nShield Monitor will still continue to
monitor the detected nShields in the background.
Once the new “nShield Monitor” license with a suffi-
cient HSM count is installed, Group Manager Privi-
leged Users are allowed to login.

Device Alarm — nShield

When the Client host is not configured correctly with
correct security world information, and enrolled for
monitoring. WARNING message gets generated. Refer
to Remote Administrator Client User Guide.

Device Alarm - nShield

This CRITICAL alarm generates when Fan speed for
Solo Down to zero or not functioning any more. Refer
to nToken Installation Guide if needed.
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Alarm Condition Alarm Severity

Power Supply failed for nShield WARNING
module

Number of nShield discovered by  INFO

nShield Monitor

HSM module hard failure CRITICAL
Device State changed to offline ALERT

Device State changed to online NOTIFICATION
Device State changed to unavail- ALERT

able

Device State changed to secure NOTIFICATION
Device information Modified NOTIFICATION

Notes
Device Alarm - nShield

This WARNING alarm generates when power supply
to nShield module fails.

Refer to nToken Installation and Solo installation guide
if needed.

Device Alarm - nShield

nShield Monitor generates alarms when client host
start discovering nShield configured to it.

Device Alarm - nShield

It's an nShield/ClientHost module hard failure event.
Customer needs to investigate on Client Host about
module failure and refer to Remote Administrator
Client User guide suggest how to restart it.

Device Alarm - nShield

An ALERT alarm is generated when the Device State
changes to offline.

Device Alarm - nShield

A NOTIFICATION alarm is generated when the device
state changes to online.

Device Alarm - nShield

An ALERT alarm is generated when the device state
changes to unavailable.

Device Alarm - nShield

A NOTIFICATION alarm is generated when the device
state changes to unavailable.

System Alarm - nShield Monitor Enrolled device

nShield Monitor enrolled device information has been
modified. Device Details include Hostname, HostIP,
Description, Location; SNMP Details include user-
name, port, Authentication algorithm/password or Pri-
vacy algorithm/password or Group membership infor-
mation.
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Alarm Condition Alarm Severity

Device Monitoring Enable/Disable  WARNING
Object Count Notification INFO / WARN-
ING / CRITICAL

SNMP Trap Notification NOTIFICATION /

ALERT /

CRITICAL

Notes
Device Alarm - nShield Monitor Enrolled device

WARNING message gets generated when administra-
tor disables or enables monitoring option for enrolled
devices.

Device Alarm - nShield Monitor Enrolled device

WARNING and/or CRITICAL otifications are raised if
the object count of any HSM in a defined group
exceeds one of the thresholds for a pre-configured
period. INFO message gets generated when the
object count for that device falls back under the lower
threshold value for a pre-configured period.

The alert indicates the threshold value, the HSM host-
name and IP address or the HSM ESN (if hostname
and IP address are not present) and the group that the
HSM belongs to.

Device Alarm - nShield Monitor Enrolled device

nShield Monitor generates alerts and notifications
when the SNMP TRAP state changes.

ALERT when the state changes to offline or unavail-
able.

NOTIFICATION when the state changes to secure or
online.

CRITICAL when the connection status is unreachable.
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17. nShield Monitor Backup and Restore

To protect against data loss, nShield Monitor should be backed up using native VMware
capabilities for protecting virtual machines.

Both manual and scheduled backup operations can be used, as follows:

+ After nShield Monitor is installed, setup and configured, a manual backup should be
completed.

+ Before a nShield Monitor software upgrade is performed, a manual backup should be
completed.

+ A scheduled backup program should also be setup to provide ongoing protection
against loss of monitored data collected.

For details of VMware virtual machine backup and restore capabilities please refer to
VMware the Virtual Machine Backup guide and the vSphere Virtual Machine Administration
manual.

Please also note the following:

« For your security, Master Key is not persisted in nShield Monitor - you must remember
the passwords used for establishment of the Master Key.

« Don't invoke the nShield Monitor backup operation while a nShield Monitor upgrade is
in process.
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18. Deploying nShield Monitor

18.1. Centralized Monitoring

When monitoring an estate of HSMs, it is recommended to keep all the data in as few
instances as allowed by external requirements such as network connectivity, regulatory or
other issues.

The best case scenarios are a single nShield Monitor instance that poll all HSMs in an estate.
This provides for a complete set of statistics for all HSMs in the estate from a single login
based on access rights and role or roles assigned within the nShield Monitor server.

18.1.1. Single Instance Monitoring

By collecting statistics in a single window it allows views of all groups of HSMs including
events and alerts from a single browser when logged in as Administrator.

This configuration allows historical reporting for any and all HSMs in the estate as needed,
again based on assigned rights or roles.

There may be additional requirements when monitoring must be continuous such that more
than one instance of a central nShield Monitor virtual appliance is required in order to
ensure monitoring is continuous and non-stop.

18.2. nShield Monitor Multi-Instance

While a single nShield Monitor virtual appliance is all that is required to monitor an HSM
estate, it is possible to utilize multiple nShield Monitor virtual appliances simultaneously as
insurance in case of an outage. By having more than one nShield Monitor virtual appliance
distributed across multiple locations, it is possible to ensure that even in the event of a net-
work outage other than to a single site, polling is maintained to all devices. In fact, it is possi
ble to ensure that even in the event of a single location network failure, at most, only a mini
mal number of devices will lose the ability to be monitored until such time as the issue is
resolved.

18.3. Distributed Monitoring

There are cases where multiple monitors are required due to one or more reasons ranging

from network connectivity via firewalls, potential regulatory compliance requirements or
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some other reason where one or more central nShield Monitor virtual appliances cannot poll
specific HSM devices.

18.3.1. Multiple nShield Monitor Instances

In this case, multiple regional or local nShield Monitor instances may be required in order to
provide coverage and continuous monitoring of HSM estates.

Even in this case, it is still recommended that a central distribution of alerts using SIEM or
email services so that proactive notifications can be sent to the appropriate person or per-
sons responsible for a given nShield Monitor or specific group of devices.

18.4. Deployment Considerations

When looking into how to deploy nShield Monitor, there are some specific items that need
to be considered prior to implementation.

18.4.1. User Access Requirements

nShield Monitor has included provisions to address user access requirements by providing
the ability to limit which portions of HSM estates any given user can view. This is done by
only assigning a specific group or portion of the total configured groups to a user with the
group manager role assigned. These requirements may affect both centralized and distrib-
uted configurations and a thorough examination of the environment in question will need to
be performed prior to implementing nShield Monitor.

There may also be regional requirements for monitoring encryption devices that require
regional or local users to be the only authorized persons to access specific portions of the
estate due to geographic location.

18.4.2. Network Connectivity

Multiple instances of nShield Monitor may be required on a per region or location basis. This
is mainly due to firewalling or other forms of limited network access to the local HSM
estates. In this case, individual nShield Monitor systems will have to be configured individu-
ally to achieve full coverage and notification of failures per region or location.

18.4.3. Regulatory Compliance Requirements
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nShield Monitor does not have any regulatory impact or requirements around it at this time.
However, due to potential regional requirements for the HSM estates, you may be required
to have individual nShield Monitor servers deployed regionally in order to access the man-
agement ports of the HSMs to be monitored.

To this end, a distributed model of nShield Monitor can still provide the ability to distribute
proactive alerts and event information to centralized tools based on configuration at the vir
tual appliance or HSM group level.
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19. Residual Risk

19.1. User Guidance

Deploying organizations should consider these guidelines for secure operation of their sys-

tems.

19.2. Secure Operation

This section highlights residual risks that are not completely covered by the technical solu-
tion and that may require additional operational or procedural controls.

Refer to Security Hardening: VMWare Infrastructure 3 (VMware ESX 3.5
and VMware VirtualCenter 2.5) (http://www.vmware.com) for recom-

0 mendations for security hardening VMware infrastructure, including vir-
tual machines and virtual machines files and settings.

Deploying organizations may wish to implement additional measures based on their assess-
ment and risk appetite.

19.3. Risks

+ Malicious Host
+ Misconfiguration
- Data Aggregation

- Data Ex-filtration

19.4. Deployment and Distribution

« Keys and for communication with clients and other Critical Security Parameters (CSPs)
such as TLS and SSH certificates are protected in software only and are embedded on
the virtual machine.

+ Audit data accumulated from monitored clients is only protected by software mecha-
nisms on the virtual instance.

- Virtual machine instances must be managed carefully (including auditing use and distri
bution of the virtual instances and controlling access to the host machines).

+ Cloning virtual machines with nShield Monitor is not recommended for new deploy-
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ments (a fresh installation via distribution of the OVA image and reconfiguration is
always recommended).

19.5. Secure Configuration

The manual, Security Hardening: VMWare Infrastructure 3 (VMware ESX 3.5 and VMware
VirtualCenter 2.5), covers these measures in more depth.

They are repeated here since they are directly relevant to mitigating the outlined risks to
nShield Monitor Monitor and can be modified by user operating the virtual machine.

« Secure virtual machines as you would secure physical servers. Anti-Virus, Anti spyware,
intrusion detection and other protection must be enabled for the virtual machine. All
security measures must be kept up to date including applying appropriate patches.

+ Disable Automatic Mounting of USB Devices. This measure is required to prevent intro-
duction of malware to the virtual environment and exfiltration of data.

+ Ensure Unauthorized Devices are Not Connected.
- Strictly Control Root Privileges.
« Disable Technical Support Mode.

+ Disable Copy and Paste Operations Between the Guest Operating System and Remote
Console.

19.6. Host Machine

Must be sanitized as per the deploying organizations policy. Best practices for OS and appli
cation security controls are recommended on the host machine to minimize the risks out-
lined above.

Monitor v2.8.0 Install and User Guide 260/284



Chapter 20. Install OVA With VMware ESXi

20. Install OVA With VMware ESXi

20.1. Introduction

The nShield Monitor OVA can be installed on a VMware ESXi hypervisor including the follow
ing versions:

« vSphere ESXi 6.0
« vSphere ESXi 6.5

For installation of the VMware ESXi hypervisor it may be necessary to involve your vSphere
management team if you plan to install this system in a corporate VMware environment and
you do not have access/authority to create and manage virtual machines (administrative
rights will be required).

It will be required to have access to a DVD or the nShield Monitor OVA file from the
machine that has the vSphere software running for proper installation of the Virtual Appli-
ance.

The nShield Monitor OVA has been digitally signed with a signature
based on the SHA-256 algorithm. Legacy VMWare software, such as

the platform-native vCenter client, only supports signatures based on
o the deprecated SHA-1 algorithm and cannot directly deploy the nShield
Monitor OVA.To deploy nShield Monitor to VMWare ESXi 5.5 or later,
use the vCenter web client.

20.2. Install the nShield Monitor OVA

o ‘ Screen views are based upon vSphere ESXi 6.5.

Run the vSphere software.
1. Log into the web client.

The initial VMware page opens.
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Umer name VMware vCenter” Single Sign-On

Password:

The web client is ready to be deployed.

2. Select your version.

vmware: vSphere Web Client

~ Navigator E [ vcenter.cs.sv.us.thalesesec.com [ ) ‘F'J
d Back || Gettin. | Sum.. Monitor Confi. Permi.. g
o a =) <1
What is v(enter Server?
b [nSJ_ESX 5.5 vCenter Server allows you to manage
b [lnSJ_ESX_6.0 i muliple ESXNESX hosts and the virtual

machines on them. Because these
emvironments can grow very large, vCenfer
Sener provides useful management tools

[ like the abllity to erganize the hosts and virtual

tmS)_FESX 6.5

machines into dusters with vSphere DRS
andvSphere HA Multiple vCenter Server
systems can be managed by the vSphere
Web Cliernt so that their indiaduzl inventories
can be presented and managedunder one
“pane of gass”

AnyvCenler Senver systems for which you
have privileges and that have been registered
with the Leokup Service, or added manually
with the vCanter Regisiration Tosl in the
Administration section, will appear in your
inventory o the lefi.

Basic Tasks

7 Create a folder
fln Create Datacenter

3. Navigate to Deploy OVF Template.
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vmware* vSphere Web Client #=

Mavigator X

=l

A
m

[¥1]

(]

-

|
o |

k SJ_F" =

Actions - 5J ESX 55
» SJ_E ==
Add Host...
[ SJ_[
%] Mew Cluster..
Mew Folder [
Distributed Switch [
Mew Virtual Machine b

#8] New vApp from Library..

i Deploy OVF Template. .

Storage b

Edit Default WM Compatibility...

g2 Migrate Vs to Another Metwork...

Ll e T o

You will be prompted through the process:

|| Deploy OVF Template

| 1 Select template

2 Select name and location

3 Select a resource
4 Review details
5 Select storage

6 Ready to complete

4. Select template.

5. Enter the file location or select Browse and navigate to the location.
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| Deploy OVF Template

| 1 Select template Select template

Select an OVF template.
2 Select name and location

3 Select a resource Enter a URL to download and install the OVF package from theg
such as alocal hard drive, a network share, or a CO/OVD drive
4 Review details

5 Select storage (_JURL

G Ready to complete |

(=) Local file
| Browse... |

A Use multiple selection to select all the files associated

6. Select Next.

Hext Cancel

7. Select name and location.

Select name and location

+ 1 Select template
Enter a name for the OVF and select a deployment location.

2 Select name and location

3 Selectaresource Name | dev-2.1.0.0057-58-2017-06-25-20-59-03

4 Review details ) I —
Filter | Browse |

5 Select storage
Select a datacenter or folder.

6 Ready to complete

w (2] vcenter.cs sv.us.

b [l SJ_ESK_B.0
b [lg SJ_ESK 65

8. Select Next.

9. Select a resource (i.e., host).
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%21 Deploy OVF Template

Select a resource
Select where to run the deployed template.

" 1 Select template

' 2 Select name and location

3 Select a resource )
[ 3 selectaresource [N [‘Browse |

4 Review details

Select a host or cluster or resource pool orvapp.

5 Select storage
vSJ_ESK_E.E

b |3 esx-d.cssvus.
b [7 es-5.c55vus.

6 Ready to complete

[» [ esx-6.cs.svus.
b [7 esx-7.cssvus.
b |3 esx-8.cssvus.
b [7 esx-9.cs svus.

10. Select Next.

11. Review the details.

¥¢l Deploy OVF Template

Review details
WVerify the template details.

w 1 Select template
w' 2 Select name and location

w' 3 Selectaresource

Product
4 Review details :
Yersion
5 Accept license agreements Nl
el A Publisher & Mo certificate present
T Select networks TR e e 296 1 MB
& Ready to complete 2.6 GB (thin provisioned
Size on disk ( 4 ;

326.0 GB (thick provisioned)

12. Select Next.
13. Review the Agreement, (selecting Next to scroll through the Agreement).

14. Select Accept.
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#¢ Deploy OVF Template

Accept license agreements
Read and acceptthe license ag

w1 Select template

w2 Select name and location
" 3 Selecta resource

' 4 Review details

6 Select storage

7 Select networks

& Ready to complete

' Accept |

15. Select storage.
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¥ Deploy OVF Template

Select storage
Select location to store the files for the deployed template.

w1 Select template

' 2 Select name and location

v 3 Selectaresource Selectvirtual disk format: | Thin provision
i [] Show datastores from Storage DRS clusters
w5 Accept license agreements

=

6 Select storage

[ Datastores | Datastore Clusters]
T Select networks

& Ready to complete

Mame Status
) B alma.build & Alert
(=) ] esx6-ds1 & Normal
i) B esxBdedicated-san & Mormal

16. Select Next.

17. Select your network.
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¥4 Deploy OVF Template

1 Select template

2 Select name and location
3 Select a resource

4 Review details

5 Accept license agreements

£ ¢ G ¢«

6 Select storage

7 Select networks

8 Ready to complete

Select networks
Select a destination network for each source network.

Source Network

CORF

IP Allocation Settings

IP protocol: 1Pwd

18. Select Next.

19. Review the configuration data.
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¥ Deploy OVF Template

+ 1 Select template Ready to complete
Review configuration data.
" 2 Select name and location
" 3 Selectaresource
Mame
" 4 Review details B SRS
" & Accept license agreements Download size
" 6 Select storage SR aaE
W T Select networks
Datacenter

4 & Ready to complete Resource

¢ Storage mapping 1
r Metwork mapping 1
¢ |IP allocation settings |Pvd, Static - Manual
20. Select Finish.
21. You can follow the status.
[z Recent Tasks
[5-
Task Name Target Status Initimtor
Dieplay OVF template th -dey-2 = w% 0 VEPHERE L
Import OVF package [l esx-b.cs.svus. L L < vsphere.locall

22. You are now ready to power on.
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vmware: vSphere Web Client  #=

{" el 1 mitps.fecenter.cs.svius.thabesesec. coma 044 3 fvsphere-client T ospextensionld &3 0vsphere.co)

Havigator

8 | @ B8 @
- [ veenter.ca swus
= [5) ESH 55
b [Eesn-4.033v0s
¥ (G esn5.cs svus
~ [F.esx-Bcs.avus
dk ES0SPT target-VI-Bild0003
dk AutomationCaash-hong-cemDS-Clone
L CH_clone
4 chrig-alma-dane
& chrig-
5 chiig
B chiig-gsm-0
B chris-dsm-5.3.1-0
B chrisdest-2.0.0
8 chris-test-2.0.0-0
8 chris-wip-0

i o
B chu-ctac-7 238
(9 cku-D3-dema@10.1.7.180
B cku-owa

I rlreaid Tanalame

. —
2l & ﬂnr-errmav-z.i.u.uusr-ﬂ-zwj

Gatting 5. Summary Monfdor Co

What is a Virfual Machine?

Avirlual maching is a software compuls
like a physical cormputed, ing an operal]
systern and applications. An operabng
system installed on & vrtual machina is
called a guest operaling system

Because everywirual machine is an isal
compuling envirenmaenl, you can uge v
machines as desklop or warkstation
environments, as testng environments,
consalidale server applications.

InwCenter Server, virual machines nun o

hasts or dusters. The same host can ry
many virlual machines.

Basic Tasks

¢ Power on the virtual machiy

20.3. Turn on the Virtual Machine

1. Click on the VM that you just created.

2. Select the Getting Started tab.

3. Select Power on the virtual machine.

File Gdt Wiew Invenioey Admenisiotion Plug-ins Balp
ﬁ u iy rome b g8 tremtoey B Sty
NS DG P

B} R Copleer sl - LOOSI- 185 2015 1908 b
: LA AT

Semwrary | Remgurce Moostio

Winat is a Virtual Machine?

A virlual maching 5 a software compa
plrysical compuber, runs an aperating 4
apphcalions. An operang Sysiem nstd
e hine (S called 3 guest oparating Syl

Because every virlual machine & an S
ETRONMEnL, you can use virlual mack
WOrKALEION ENvFOnments, &5 MEing &
COMBONAETE SErveT SHHECATDNS

Wirual ma hines, run on hosts. The 8
Ty wiflull mac hines

Basic Tasks
B Pawer on thie vifual meching

:'j.- Edif wirtual machime seitings

4. Allow five minutes for the virtual appliance to load.
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20.4. Run the Virtual Machine

20.4.1. Unfamiliar with VMware ESXI

1.

Select the Console tab, if you are unfamiliar with VMware ESXi and cannot determine
the IP Address of the nShield Monitor VM that you just created:

il T Fured - LOGUSGM- 105 2015 100 1o B4 37

Semwrary | Rwvgurce Aoostios  Pedommancs  [veie  Corsole  Permigsicne

. The login prompt displays.

. Login to the system using the default user ID and password:

° Default user id: admin
° Default password: password123

The system will prompt you to change the password.

. Change the password to one that meets the same minimum requirements those for a

user on the nShield.

After the first login from the CLI, the system prompts you to start the CLI Setup Wizard.

nCipher recommends using the WebUI set up wizard. If you would like to use the WebUI for

setup, then answer "no" to the prompt for starting the CLI setup wizard.

0 Entering the wrong password 3 or more times will lock the user out of
system and a re-install of OVA is required.
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SET THE DEFALLT USER'S PASSUIRI

ully conpleted zet wzer password

20.4.2. Familiar with VMware ESXI

If you are familiar with VMware ESXi and can determine the IP address assigned to the new
VM, record your new password and the IP Address listed, and provide information to the
appropriate personnel.

In most organizations the information technology or infrastructure group will accomplish
the setup of the OVA, while the installation and operation of the nShield Monitor Virtual

Appliance will be performed by a different functional group.

If you are to perform both tasks (nShield Monitor OVA install and nShield Monitor setup),

record your new password and the IP Address listed above.

Proceed to Setup Wizard for instructions on using the WebUI Setup Wizard for setting up
and configuring the nShield Monitor Virtual Appliance.
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21. Install OVA with VMware
Workstation/Player

21.1. Introduction

The nShield Monitor OVA can be installed on a VMware Workstation/Player hypervisor
including the following versions:

« VMware Player or Player Professional 6
« VMware Player or Player Professional 7
+ VMware Workstation 11

« VMware Workstation 12.

o The VMware Workstation and Player installation must be local to the
machine nShield Monitor is being installed on.

Please be aware that the nShield Monitor virtual appliance does not have VMware Tools
installed; thus copy and paste operations are not supported from the host or other guest
OS to the virtual appliance console.

You should ensure that the machine that you install nShield Monitor on runs 24X7 through-
out the duration. You may need to reboot at some point at which point you will have to
enter passwords to re-establish the master key.

Note: If you are going to be running nShield at full capacity with 500 devices, a recom-
mended precaution is to increase the 250GB disk in vCenter to 350GB after deploying the
OVA but before powering it on. Once the OVA has been powered on the disk size cannot
be changed.

21.2. Install the nShield Monitor OVA

Run the VMware Player or Workstation software.

0 The steps that follow apply for both the VMware Player and the VMware
Workstation.

1. Select Open a Virtual Machine from the Home tab.
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Pli:.r:r - - L-il- J__"

Welcome to VMware Player

%' . Create a New Virtual Machine
1

| +". Create a new virtual machine, which will then be
T pdded to the top of your lbrary,

Open an existing wirtual machineg, which will then be
added to the top of your lbrary.

1 Open a Virtual Machine
f
—,w', Download a Virtual Appliance

| > Dovnigad a virtual appliance from the marke tplace,
Yiou can then open it im ViMware Player.

From the menu bar you can also select File (Alt + F) and Open (Ctrl
+ O). On VMware Workstation, this is the first option on the menu
bar. For VMware Player, it is found under the Player drop down

e menu.

VMware Player and Workstation versions vary on the home screen,
so please refer to the documentation for the version that you plan

to use.

VMware Workstation

File Edit WView WM Tabs Help - | 0 = H

'ﬂ[ Home *

WORKSTATION 11

2. Select Open a Virtual Machine.

WORKSTATION 11

) O

Connect to a Connect to
Remote Server Vidware vCloud Air

=

Create a Mew
Virtual Machine

The Open Virtual Machine page opens.
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5| Open Virtual Machine

@U'I v Computer ¢ 05 (C) » Virtual Machines OVA Files

Organize Mew folder

B Desktop “  Mame Date modified

3 Dropb
e mptan & 1.00.0300-111-2015-10-14-2...  10/14/2015 10:19 .

3. Select the OVA file to be installed.
4. Select Open.

The Import Virtual Machine dialog box opens.

Import Virtual Machine ﬁ

Store the new Virtual Machine

Provide a name and local storage path for the new virtual
machine.

Name for the new virtual machine:

-1.0.0.0200-111-2015-10-14-22-17-00

Storage path for the new virtual machine:

C:\Users\nvoratDocuments\Virtual Machines)
mport ) [ concel |

5. Enter a name and path for the VM to be stored.
6. Select Import.

The End User License Agreement (EULA) page opens.

7. Read the EULA.
8. Select Accept.

0 If you decline the EULA, you will be unable to proceed with the
installation.

The Import Progress page opens.

Monitor v2.8.0 Install and User Guide 275/284



Chapter 21. Install OVA with VMware Workstation/Player

VMware Workstation

Importing

Cancel

Once nShield Monitor is installed you will be looking at the nShield Monitor VM
(VMware Player) / VMware Workstation.

¢ W Mware Plu:,'Er

Fl.upqr - * - :'-:

1.0.0.0200-111-2015-10-14-22-17-00

-1.0.0.0300-111-2015
-10-14-22-17-00

State: Powered Off
05:  Cent0S 64-bit
Version: Workstation 9.0 virtual machine
RAM: 8GB

P Play virtual machine
Ly
o

Edit virtual machine settings

Monitor v2.8.0 Install and User Guide 276/284



Chapter 21. Install OVA with VMware Workstation/Player

[B) CipterTrust-1.0.0,0300-111 -2015-10-14-22-17-00 - Vitware Workstation
Eile Eda Yew VM Tats Help | b = ' = | B e

£ e 100080-111-...

1.0.0.0300-111-2015-10-14-22-17-00

P Fow
SJEGIE ¥
JuT
= Devices
- Bty aGh
B Proscesgaces 2

= Hard Disic (5050 2062

= Hard Disk 2 (SCS0) 16 G

SHard Disk ¥ (SCSN 250 GB

= Hard Disk & (5050 2068

== Hard Digk 5 (SCS0) 20 G2

Wi Metwork Adapter Eridged (Automatic
B Display At detect

= Deoription

After deployment of OVA is finished, the installation of the nShield Monitor OVA is
now complete.

9. On the VMware Player and Workstation screens, click the green right arrow button to
power on nShield Monitor.

Please allow five minutes for the Virtual Appliance to boot.

The login prompt displays.

21.3. Run the Virtual Machine

1. At the login prompt, enter the default user ID and password:
° Default user id: admin
° Default password: password123
° The system will prompt you to change the password.

2. Change the password to one that meets the same minimum requirements those for a
user on the nShield.

3. Record your new password and the IP Address listed and provide information to appro
priate personnel.

After the first login from the CLI, the system prompts you to start the CLI Setup Wizard.

It is recommended that you use the WebUI set up wizard. If you would like to use the
WebUI for setup, then answer "no" to the prompt for starting the CLI setup wizard.

o Entering the wrong password 3 or more times will lock the user out of
system and a re-install of OVA is required.
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1l activitiesz may be nonitored and reported.

SET THE DEFALLT USER'S PASSUIRI

Fort HEB

| sl loomes |EULAIERail |Systen fdming |INetuvork [Key Generat jon | Date-Ti

Setup Wizard

This wizard will guide you through setting up the initial users

Start CLI Setup Wizard 7 [ym]

In most organizations, the information technology or infrastructure
group will accomplish the setup of the OVA, while the installation and

o operation of the nShield Monitor Virtual Appliance will be performed by

a different functional group. If you are to perform both tasks (nShield
Monitor OVA install and nShield Monitor setup), record your new pass-
word and the IP Address listed above and proceed to Setup Wizard.
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22. Create and Manage Hyper-V Virtual
Machines in Hyper-V Core

22.1. Prerequisites for Using nShield Monitor with Hyper-V
Virtual Machines

It is recommended to have at least 8 GB main memory when using Hyper-V Manager with
nShield Monitor. The following Hyper-V image files are required:

- nShieldMonitor-2.7.06-1.vhd

- nShieldMonitor-2.7.0-2.vhdx
+ nShieldMonitor-2.7.0-3.vhdx
« nShieldMonitor-2.7.0-4.vhdx
+ nShieldMonitor-2.7.0-5.vhdx

22.2. Install Hyper-V

With Windows Server Core installations, you can install Hyper-V using the following applica
tions:

« The legacy Hyper-V Manager.

« Windows Admin Center.

22.2.1. Install Hyper-V on Windows Server Core with PowerShell

At the PowerShell command prompt, run:

Install-WindowsFeature -Name Hyper-V -IncludeAllSubFeature -Restart

Windows Server Core will install the Hyper-V role and restart automatically.

22.2.2. Add the Hyper-V Role Using Windows Admin Center

1. Connect your Windows Admin Center Gateway Server to your Windows Server Core
installation.

2. In Windows Admin Server, select Server Manager > Roles and Features > Install, then
select Hyper-V.
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Windows Admin Center will calculate the dependencies of role and feature installations
and then prompt you to proceed with the installation, including automatic reboot
options.

3. When Windows Server has rebooted, check in Server Manager > Roles and Features
that the State for the Hyper-V role is Installed.

22.3. Configure a New Virtual Machine with Hyper-V

1. In Windows Admin Center, select Server Manager, then launch Hyper-V Manager.

2. Select New > Virtual Machine.

The New Virtual Machine Wizard opens.

ij Hyper-V Manager 3 New Virtual Machine Wizard x

File Action View Help|
=55 -

% Hyper-V Manager
T

Specify Name and Location

Before You Begin Choose a name and location for this virtual machine.

Spedify Name and Location

The name is displayed in Hyper-V Manager. We recommend that you use a name that helps you easily

Specify Generation identify this virtual machine, such as the name of the guest operating system or workload.
Assign Memory Name: |n5hieldMonihor2?0|
Configure Netwarking You can create a folder or use an existing folder to store the virtual machine. If you don't select a
Connect Virtual Hard Disk folder, the virtual machine is stored in the default folder configured for this server.
Installation Options [ store the virtual machine in a different location
Summary Location: | C:\ProgramDataMicrosoft\Windows \Hyper-v\ Brow

< Previous Finish Cancel

3. Specify the Name and Location of the virtual machine, then select Next.
4. Select Generation 1, then select Next.

5. Set the RAM Size, then select Next.

6. Set the Connection to Default Switch, then select Next.

7. Attach the boot hard disk (VHD file) for nShield Monitor.
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§§ Hyper-V Manager

E3 New Virtual Machine Wizard X
File Action View Help|
&= znm 3 e Connect Virtual Hard Disk
% Hyper-V Manager
i
Before You Begin A virtual machine requires storage so that you can install an operating system. You can specify the
Specify Name and Location storage now or configure it later by modifying the virtual machine’s properties.
Spedfy Generation () Create a virtual hard disk
Assign Memory Use this option to create a YHDX dynamically expanding virtual hard disk.
Configure Networking Mame: | mShieldMonitor270.vhdx
nnect Virtual Hard D C:\Users\Public\Documents\Hyper-V\virtual Hard Disks), Browse...
Summary
Size 127 GB (Maximum: 64 TB)
(@) Use an existing virtual hard disk
Use this option to attach an existing virtual hard disk, either VHD or VHDX format.
Location: UILDS\BUILDOUTPUTVMD Browse...
() Attach a virtual hard disk later
Use this option to skip this step now and attach an existing virtual hard disk later.
< Previous Wt > Finish Cancel
8. Select Next, then select Finish.
9. In the new machine, select Settings.
3 Hyper-V Manager — O X
File Action View Help
e zE H
% Hyper-V Manager Actions
- Virtual Machines
s 2 -
Mame State =
B nshieldMonitor270 off = Quick Create...
Mew 3
[5  Import Virtual Machine...
Hyper-V Settings...
EB virtual Switch Manager...
< o Virtual SAN Manager...
T wa Edit Disk...
5 Inspect Disk...
The selected | W Stop Service
¥ Remove Server
) Refresh
View 4
ﬂ Help
nShieldMonitor270 -
nShieldMonitor270 9 Connect...
Created: Es settings...
Configuration Versior Start
Generation: E’ Checkpoint
Notes: B Move..
EE Export...
Eﬁ Rename...
Summary Memory  Networking E. Delete..

10. Select SCSI Controller, then add the remaining four hard drives of nShield Monitor.
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22 Hyper-V Manager — [m| X
File Action View H

[
=

| nm HE

E Hyper-V Manager | Actions
Virtual Machines

_ -
Mame State

]
B nShieldMonitor270 off = Quick Create
Mew 4

Import Virtual Machine...

Hyper-V Settings...

R

Virtual Switch Manager...
Virtual SAN Manager...

Edit Disk...

Inspect Disk...

g
i
) Ba BB

The selected

=
=/

Stop Service

P
W

Remove Server

e X

Refresh
View 4

H Hep
[

Connect...

nShieldMonitor270

Created: Settings...

Configuration Versior
Generation:
Notes:

Start
Checkpoint
Move...
Export...

Rename...

oL e O

Summary Memory  Networking Delete...

a. Select Hard Drive, then select Add.
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E Settings for nShieldMonitor2 70 - X
nShieldMonitor270 ~ (]
# Hardware ~ | &l scscontroller
l" Add Hardware

You can add hard drives to your SCSI controller or remove the SCSI controller from the

3 oS

Boot from CD wvirtual machine.
. Security Click Add to add a new hard drive to this SCSI controller.

Key Storage Drive sabed
Wl Memory Shared Drive

4096 MB

L] Processor
1 Virtual processor
=] IDE Controller 0
= Hard Drive
nShieldManitor-2.7.0-1.vhd

Add

You can configure & hard drive to use a virtual hard disk or a physical hard disk after
you attach the drive to the controller.

=] IDE Controller 1
() DVD Drive
Mone

To remove the SCSI controller from this virtual machine, dick Remove. All virtual hard

Ty—— disks attached to this controller will be removed but not deleted.
& scsI Controller

[H] Network Adapter Remave
Default Switch —
B coM1
Mone
& comz
Mone

[ Diskette Drive
MNone

# HManagement

MName
nShieldMonitor 270

D Integration Services
Some services offered

¥ Checkpoints
Standard

':'-':' Smart Paging File Location
C:\ProgramDataMicrosoft\Win...

e

b. In the New Virtual Hard Disk Wizard, select Copy the contents of the specified
virtual hard disk, browse to the -2.vhdx file, and add it.

c. Back on the SCSI Controller page, select Apply.

d. Add the other three virtual hard disk files (-3.vhdx, -4.vhdx, and -5.vhdx), repeat-
ing steps a-c for each of them.

All four virtual hard disk files added to the SCSI Controller:
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ﬁ Settings for nShieldMonitor2 70

nShieldMonitor2 70

(3]

A Hardware

r Add Hardware
3 pros
Boot from CD
. Security
Key Storage Drive disabled
Wl Memory
4096 MB
u Processor
1 Virtual processor
= IDE Controller 0
= Hard Drive
nShieldMonitor-2.7.0-1.vhd
= IDE Controller 1
() DVD Drive
Mone

= &8 scsI Contraller

== Hard Drive
nShieldMonitor-2.7.0-2. vhdx

== Hard Drive
nShieldMonitor-2.7.0-3.vhdx

= Hard Drive
nShieldMonitor-2.7.0-4. vhdx

= Hard Drive
nShieldMenitor-2.7.0-5. vhdx

" Network Adapter
Default Switch
B ocom1
Mone
& comMz2
Mone

[ Diskette Drive
MNone

# Management

- Hard Drive

You can change how this virtual hard disk is attached to the virtual machine. If an
operating system is installed on this disk, changing the attachment might prevent the
virtual machine from starting.

Controller: Location:
SCSI Controller ~ | | 3 (in use) w
Media

You can compact, convert, expand, merge, reconnect or shrink a virtual hard disk
by editing the assodiated file. Spedfy the full path to the file.

(@) Virtual hard disk:
| C:\BUILDS \BUILDOUTPUTVMOK \nShieldMaonitor-2, 7.0-5. vhdx

Mewe Edit Inspect Browse. ..

o If the physical hard disk you want to use is not listed, make sure that the
disk is offline. Use Disk Management on the physical computer to manage
physical hard disks.

To remove the virtual hard disk, dick Remove, This disconnects the disk but does not
delete the assodated file.

Remave

Gance

1. From Hyper-V Manager, select Start and Connect to see the nShield Monitor image

running.

Monitor v2.8.0 Install and User Guide

284/284




	nShield Monitor: Monitor v2.8.0 Install and User Guide
	Table of Contents
	1. Introduction
	2. Requirements
	2.1. General Requirements
	2.1.1. Hypervisor Compatibility
	2.1.2. Server Requirements
	2.1.3. nShield Compatibility

	2.2. Centralized Monitoring
	2.3. Client Workstation
	2.4. Role Based Access
	2.4.1. User Roles

	2.5. Accessing the User Guide

	3. License Installation
	3.1. Overview
	3.2. Installing a License

	4. Setup Wizard
	4.1. Overview
	4.2. Wizard
	4.2.1. Creating Administrators

	4.3. Setting up the Network
	4.4. Master Key Generation
	4.5. Date/Time
	4.5.1. NTP Disabled
	4.5.2. NTP Enabled

	4.6. Ready to Setup
	4.7. Log In

	5. Configuration Logged in as Administrator
	5.1. Overview
	5.2. First Time Setup
	5.2.1. Configuring the nShield/Client Host
	5.2.2. Configuring the nShield HSM
	5.2.3. Step 1: Create Groups
	5.2.4. Step 2: Configure the Group Manager Role
	5.2.5. Step 3: Group Manager Enroll Managed Entities to Groups

	5.3. Edit Profile page
	5.3.1. Changing your Password and Email and set the Auto-Logout Duration
	5.3.2. Formatting the Admin Date and Time
	5.3.3. Resetting the Admin GUI Persistence Profile

	5.4. Configuration Tab tasks
	5.4.1. Date/Time
	5.4.2. Events
	5.4.3. Groups
	5.4.4. License
	5.4.5. Mail Host
	5.4.6. Network
	5.4.7. Reboot
	5.4.8. Security
	5.4.9. Upgrade
	5.4.10. Creating Users
	5.4.11. Deleting Users


	6. Configuration Logged in as Group Manager
	6.1. Overview
	6.2. Edit Profile page
	6.3. Managed Entities
	6.3.1. Enrolling Devices/Entities
	6.3.2. Option: Enrolling using a Batch File

	6.4. Group Alarm Thresholds
	6.5. Group Event Notification
	6.5.1. Assign SNMP Notification Policies for Groups
	6.5.2. Assign SNMP Notification Policies for Trap Groups


	7. Logs
	7.1. Logs available to Group Managers
	7.2. Logs available to Administrators
	7.3. Log Sorting
	7.4. Log Functionality
	7.4.1. System Event Log
	7.4.2. Security Log
	7.4.3. Device/Group Log
	7.4.4. Exporting a log.csv file
	7.4.5. Debug Log Export and Upload


	8. Dashboard
	8.1. Event List
	8.2. nShield Performance
	8.2.1. nShield Performance window
	8.2.2. Top 5 Client Hosts by Commands Count

	8.3. Users
	8.4. nShield Monitor Status
	8.5. Unacknowledged Alarm Summary

	9. Views
	9.1. Logged in as Administrator
	9.2. Logged in as Group Manager
	9.2.1. View > Groups
	9.2.2. View > HSMs
	9.2.3. View > Client Hosts
	9.2.4. View > Keys
	9.2.5. View > Card Sets
	9.2.6. View > Security Worlds

	9.3. View > Group > Group List
	9.3.1. Group List > Group Summary - Administrator
	9.3.2. Group List > Group Summary - Group Manager
	9.3.3. Group Summary page - Navigation options

	9.4. Additional Views available to the Group Manager
	9.4.1. Groups
	9.4.2. View > HSMs > HSM List
	9.4.3. View > HSMs > Client Hosts by HSM
	9.4.4. View > Keys
	9.4.5. Card Sets
	9.4.6. Security Worlds


	10. Reports
	10.1. Generating Reports
	10.1.1. Group Report
	10.1.2. Device Report
	10.1.3. Device report for Client Hosts

	10.2. Scheduled Reports
	10.2.1. Downloading Individual Reports
	10.2.2. Downloading Reports in Bulk
	10.2.3. Deleting Reports


	11. Alarms
	11.1. General Description
	11.2. Acknowledging Alarms in Bulk
	11.3. Acknowledging an Alarm (individual basis)

	12. nShield CLI Commands
	12.1. GUI initialization
	12.2. Setting Password
	12.3. Master key status
	12.4. CLI Setup Wizard
	12.4.1. Log in

	12.5. Welcome
	12.6. EULA
	12.7. Set User's Email
	12.8. Create Administrators
	12.9. Configure Network
	12.10. Generate System Key
	12.11. Configure Date & Time
	12.12. Initialize
	12.13. CLI Commands
	12.14. Network commands
	12.15. Date-time commands
	12.16. System Commands
	12.17. Email Queue Commands
	12.18. Troubleshooting Commands
	12.19. Service Commands

	13. Licensing
	13.1. Introduction

	14. Enterprise Firewall Settings
	15. Troubleshooting
	15.1. Global Troubleshooting Enhancement feature
	15.1.1. Overview
	15.1.2. Procedure

	15.2. Network test tools
	15.3. Ping
	15.3.1. Using Ping

	15.4. RouteDump
	15.4.1. Using RouteDump

	15.5. TCPDump
	15.5.1. Using TCPDump

	15.6. Traceroute
	15.6.1. Using Traceroute

	15.7. No Monitoring Data Received

	16. nShield Monitor Alarm Conditions
	17. nShield Monitor Backup and Restore
	18. Deploying nShield Monitor
	18.1. Centralized Monitoring
	18.1.1. Single Instance Monitoring

	18.2. nShield Monitor Multi-Instance
	18.3. Distributed Monitoring
	18.3.1. Multiple nShield Monitor Instances

	18.4. Deployment Considerations
	18.4.1. User Access Requirements
	18.4.2. Network Connectivity
	18.4.3. Regulatory Compliance Requirements


	19. Residual Risk
	19.1. User Guidance
	19.2. Secure Operation
	19.3. Risks
	19.4. Deployment and Distribution
	19.5. Secure Configuration
	19.6. Host Machine

	20. Install OVA With VMware ESXi
	20.1. Introduction
	20.2. Install the nShield Monitor OVA
	20.3. Turn on the Virtual Machine
	20.4. Run the Virtual Machine
	20.4.1. Unfamiliar with VMware ESXI
	20.4.2. Familiar with VMware ESXI


	21. Install OVA with VMware Workstation/Player
	21.1. Introduction
	21.2. Install the nShield Monitor OVA
	21.3. Run the Virtual Machine

	22. Create and Manage Hyper-V Virtual Machines in Hyper-V Core
	22.1. Prerequisites for Using nShield Monitor with Hyper-V Virtual Machines
	22.2. Install Hyper-V
	22.2.1. Install Hyper-V on Windows Server Core with PowerShell
	22.2.2. Add the Hyper-V Role Using Windows Admin Center

	22.3. Configure a New Virtual Machine with Hyper-V


